Forums » Support

Back To Topics

Direct connection to SBRICK Plus

    • 4 posts
    December 19, 2018 9:38 PM CET

    Issue solved.

    You just have to use --char-write-req instead of --char-write

     

    • 4 posts
    December 19, 2018 8:54 PM CET

    Checked the SBRICK using the windows driver tool. Everything is working fine.

    I also tried a USB Bluetooth dongle. It is also not working using gatttool.

    I use Raspbian GNU/Linux 9 (stretch)


    This post was edited by Heiko Klein at December 19, 2018 9:15 PM CET
    • 4 posts
    December 18, 2018 11:34 PM CET

    I tried to connect to SBRICK Plus using gatttool on linux.

    Connection is possible and HW and Firmware version can be read out.

    But while trying to use handle 0x001a and char-write with value 010000FE no response on the SBRICK.

    gatttool with prameter "characteristics" shows that the handler is right with 0x001a.

    Has the protocol changed for SBRICK plus compared to SBRICK?

    How can I control the SBRICK PLUS via gatttool?

    Thanks in advance

    Heiko