Forums » Support

Back To Topics

BBC Microbit connection issues

    • 340 posts
    July 17, 2019 2:36 PM CEST

    Great to hear that it worked! :)

    It is so interesting that your daughter works with SBrick and Microbit.

    It would be wonderful if we can create a short video about she's findings. If you are on it please write me directly to

    Thank you!

    • 6 posts
    July 17, 2019 1:25 PM CEST

    Hello, thankyou,

    The extra space before Berry, is apart of the sbrick block in makecode, not me, so can't be changed. But it got me thinking so I went into the sbrick for scratch app on the desktop and checked the name. The sbrick had 2 spacebar characters after its name. So I changed the name to be exactly "Berry" and the code works. Yay!!! I do feel a little silly that it was something so simple. My daughter had programmed something in scratch x but the code was a little buggy. If the connection was lost we had to close down all the software and restart the computer to establish a connection again in Scratch for sbrick app.

    The Microsoft MakeCode software works beautifully. 

    Thanks for you help. 

    Cheers Juliet

    • 340 posts
    July 16, 2019 12:35 PM CEST

    I also see an extra space on the connect function. " Berry" I think the correct will be the "Berry"

    • 340 posts
    July 16, 2019 12:34 PM CEST

    So the SBrick's name and the name in the project code is the same. Perfect.

    What is the firmware version on the SBrick currently?

    The connection initiated by the SBrick to the microbit. If the sbrick powers up then it search first for a microbit who want to connect to the SBrick by the name. If it is OK the SBrick connects to the microbit.

    Your code seems fine. Please turn on the microbit first, then it will wait for the SBrick connection. Also important that if some other app (like the SBrick app) connected to the SBrick the SBrick will not connect to the microbit.

    • 6 posts
    July 16, 2019 12:24 PM CEST

    Its my 9 year old daughter's project. She built a monster/cat/animal? thing that poos lego balls on command. The mechanics of the lego technic is working fine, when controlled by the phone app. So its not that the lego is stopping the code running. She named the sbrick Berry. I thought that may be the problem but the name Berry comes up when we connect the sbrick to the sbrick scratch driver and for my phone. I did try the generic sbrick and Sbrick. I though it might be the microbit but we have a few of them and none of them worked. Also the microbit connects to scratch3 just fine. 


    • 340 posts
    July 16, 2019 11:38 AM CEST

    Can you take a screenshot from your code?

    • 6 posts
    July 15, 2019 11:18 PM CEST

    Sorry I mean no pairing required. I also tried just works pairing. But both didn't work.

    • 6 posts
    July 15, 2019 11:15 PM CEST


    I can't establish a connection between the sbrick and the microbit. I thought that maybe it was because the sbrick or microbit was connecting to something else so I turned off bluetooth on all devices except microbit and sbrick. I have no pairing selected in makecode. I am just running a simple code to test connection. On start, show image (a cross), - establish connection to sbrick. On sbrick connected, show image (a tick). Firmware's updated. I thought that maybe I was using the wrong name for the sbrick- I have tried lots of different names - none of them work. I am at a bit of a loss as to what to try next. 


    • 340 posts
    July 15, 2019 3:50 PM CEST

    Yes it is working. Can you describe the problem in more detail?

    • 6 posts
    July 13, 2019 7:21 AM CEST

    Is is possible to do? I can't find a single working project on the internet that has a sbrick connected to a bbc microbit?

    • 6 posts
    July 13, 2019 6:57 AM CEST

    Hello I am having trouble connecting a BBC microbit to the sbrick. I have followed the instructions given in the lessons from the Vengit website and it is not working. I have tried updating the firmware on both the sbrick and the microbit. Has anyone managed to connect a microbit to and sbrick?