Forums » Support

Back To Topics

2 m motors on one sbrick port are only buzzing

    • 3 posts
    September 28, 2021 2:14 PM CEST

    Hi SBrick Team,

     

    are there any "idiots" guide to handle the PF M motors in the meanwhile? Any easy way to influence the PWM frequency?

    Any advise would be very helpfull. My goal is to connect 4 M Motors on one SBrick Port.

    THX.

     

    BTW: HW Version 5, FW 26


    This post was edited by Thomas Hess at September 28, 2021 2:16 PM CEST
    • 326 posts
    March 9, 2020 2:30 PM CET

    M motors are pretty strange. Lego IR sometimes also can handle that.

    We work on support to adjust the PWM frequency in SBrick. It "can be" solve the problem, but it can hurt other motors at the same time, because the PWM frequency can be changed on ALL port at once, but not separately.

    • 3 posts
    March 9, 2020 12:02 PM CET

    No news from my side. 2m motors on one port dont work.

  • March 9, 2020 10:55 AM CET

    I have the same issue. I tried with different m-motors and different sbricks.

    It doesn't work.

    Are there any news on this?

    • 13 posts
    February 19, 2020 10:22 PM CET

    I ahve had the same problem this week. i changed the M motors to new motors, and that solved the problem. I had the problem with both IR PF, and Sbrick, so i am convinced that the issue lies within the M motor.

     

    • 1 posts
    February 13, 2020 8:11 AM CET

    I have the same problem with two M motors. Two XL motors on one channel no problem. A M motor and a L motor works as well.

    When I put the two M motors to a LEGO battery box they run, but not on one S Brick channel.

    • 3 posts
    February 5, 2020 7:49 AM CET

    Is there any support from the sbrick support team? I wrote mails and here, but no response.

    Did i miss something - is sbrick a dead end?

    • 3 posts
    February 2, 2020 12:28 PM CET

    As the title says, 2 m motors on one sbrick port are only buzzing. New sbricks, new motors and cables.

    Changed to other new sbricks, cables and motors - the same, only buzzing.

    changed to 1 m and 1 l motor, everything is okay.

    Firmware 25, android, sbrick 4.6.3

    Doeas anybody have the same issue, or a solution, please?