Forums » Support

Back To Topics

Not pairing with Bluetooth

    • 306 posts
    March 30, 2021 12:56 PM CEST
    Emanuele Ajroldi said:

    I'm unable to pair my sbrick (purchased in the year 2016 and years ago paired to an old Galaxy S5).

    Now I have a Samsung Galaxy 7, I have installed the latest version of SBrick v4.7 Update 1.

    I don't know the SBrick firmware version because I can't connect.

    If I scan the bluetooth units, the phone sees SBrick but when I try to pair the message appears: pairing refused by sbrick.

    Any suggestion?

     

    Hi,

    First, you don't need to pair with the OS.

    Please check your location service settings. You need to enable it globally and for the SBrick app too. This is needed by Android to enable BLE for the application. (we don't collect your location data)

     

  • March 28, 2021 6:03 PM CEST

    I'm unable to pair my sbrick (purchased in the year 2016 and years ago paired to an old Galaxy S5).

    Now I have a Samsung Galaxy 7, I have installed the latest version of SBrick v4.7 Update 1.

    I don't know the SBrick firmware version because I can't connect.

    If I scan the bluetooth units, the phone sees SBrick but when I try to pair the message appears: pairing refused by sbrick.

    Any suggestion?

    • 306 posts
    January 20, 2021 8:16 PM CET

    Hi, This is fixed now. If you restart the app, the app will receive updates.

    • 3 posts
    January 8, 2021 5:17 PM CET

     Hi Lénárd

     

    Here is the screenshot:

    This gamepad and also a newly created remote control in personal profile works, but this message keeps popping up...

    • 306 posts
    January 8, 2021 4:53 PM CET

    huh, sounds bad NormB. So you can connect and play with the SBricks, but still receiving this message?

    Can you please take a screen shot?

    • 3 posts
    January 8, 2021 8:50 AM CET

    I got it working with the standard Gamepad with buttons v3.3, but the app keeps giving the message "The BLE needs the location services, please enable it, if you have not done so!"

    Pretty enoying...

    • 3 posts
    January 7, 2021 8:46 PM CET

    Hi

    Same here with Samsung Galaxy S7.
    Location services in the app is active but app keeps giving the message "The BLE needs the location services, please enable it, if you have not done so!"

    Location method is set to "battery saving" (as pposed to "high precision" or "only phone".

    Thanks for replying.

    • 306 posts
    December 21, 2020 11:50 AM CET

    Hi,

     

    You not need to pair the SBrick. Please enable location services for the SBrick app then use SBrick directly in the SBrick app.

    • 1 posts
    December 7, 2020 7:34 PM CET

    i'm not able to connect my Motorolla G5+ phone, android 8.1.0 to my s brick. When I try and pair them with bluetooth I get the message "Pairing rejected by SBrick".

    Can anyone help?