Forums » Support

Back To Topics

Designer problems

    • 28 posts
    March 13, 2015 2:52 PM CET

    "Omni 2" created and downloads and attaches fine.

    What I was trying to do can't actually be done at the moment.  I can see a this being very useful, so could you please look into adding it:

    I have a moc with 4 wheels, each wheel has a motor therefore each wheel is connected to a port on the brick.  I wanted to add another slider that would be attached to all ports, in effect a very simple forwards and backwards moving all 4 wheels in one direction.  In the app at present you can only assign a single port to a single control.  Would it be better to look at this from the other direction and assign a port to a control?  Or multiple ports to a control?  Yes, you can set all ports on the brick to a single control, but then you can't do anything else.

    I realise you could potentiallly end up with opposing commands on a port so there would have to be some logic to make sure this couldn't happen.

    Please let me know what you think.

    • 28 posts
    March 13, 2015 2:40 PM CET

    Hi folks, one for the development team here.

    Earlier today I created a profile with 4 sliders.  I downloaded and tested with complete success.

    I then wanted to add another slider, I made the changes on the site and saved the changes, I then downloaded 'Updated' the profile on my phone, at which point the app crashed.

    I repeatedly tried to attach the updated profile to the moc with the same results, crashed every time.  I deleted the moc and tried to attach the profile with the same results.  So there must be a bug somewhere with the app reading the profile.  I have left the profile in place so you can have a look at it.  "Omni Wheels".  I will try to create another.

    There is one other things that I think is wrong.  You can name the controls in the designer, but you don't see the names in the brick setup on the phone.

    I'm using an up to date Iphone 6 with the latest released sbrick app, I still haven't had a link to the test flight release.