Forums » Support

Back To Topics

SBrick no longer works

    • 2 posts
    November 14, 2015 4:06 PM CET

    I would like to thank the entire SBrick team.

    They just replaced my broken SBrick. The only issue was that the shipping company lost the first one they sent, otherwise I would have had it within 2 weeks.

    I hope my old broken SBrick will help the SBrick team to improve future models.

    I'm so excited to start useing my new SBrick!

    • 164 posts
    September 17, 2015 12:16 PM CEST

    Hi Miles,

    Plese contact us at It seems your SBrick defective.
    But don't worry, you'll get a new one.

    Sorry for the inconvenience.

    • 2 posts
    September 16, 2015 11:55 PM CEST

    I have the same issue. I got my SBrick about a month ago, and it worked wonderfully. Today, I tried to use my SBrick, and it didn't work. I was using it normally with a regular battery pack and some M-Motors and LED lamps. I tested the battery pack, the motors, and the lights seperately and they all work fine. My phone (iPhone 4s) cannot find the SBrick. When I turn the battery on,connected to the SBrick, the SBrick's light does not flash. I have tried various combinations of battery packs and cables, but no luck.

    Is the SBrick broken, or can it be fixed? Can someone help me?

    • 164 posts
    June 5, 2015 4:51 PM CEST

    Dear Erik,

    It is seems to us your SBrick defective. Plese contact us at
    You'll get a new SBrick.

    Sorry for the inconvenience.

    • 4 posts
    June 5, 2015 1:05 PM CEST
    I have a similar problem. Sbrick used to work normally but since doing the OTA software update the Sbricks LED keeps blinking in a one second interval. Phone (Galaxy s3 mini) connects, app opens, I can add a profile but that's it. Can't operate brick, port tester doesn't react at all. Tried updating again 4 times but Sbrick just keeps blinking. Is the brick dead or can I do anything at this point?
  • April 13, 2015 1:58 PM CEST

    I would like to thank Tamas and all SBrick's Team. 

    Tamas solved my problem very quickly replacing my Sbrick: i just received the new one.

    I hope that my old SBrick will help the Team to improve this project.


    I'm so happy to start again my playing session with Sbrick :)

    • 164 posts
    March 24, 2015 12:02 PM CET

    Dear Nico,

    Please contact us at, you will get a new SBrick.
    Sorry for the inconvenience.

  • March 24, 2015 10:00 AM CET

    A few days ago I was using my SBrick normally with a battery pack and a PF-M with the app onm my phone. Today I tried to connect again through the app and through but it cant find the Sbrick. nRF Master Control cant find the Sbrick too. Motor and battery box function properly without Sbrick.

    Can anyone help me?