Forums » Support

Back To Topics

sbrick plus & tilt sensor problems

  • January 15, 2018 10:51 PM CET

      Hi everybody. I still haven't found a way using my sbrick+ with windows 7. But... after experimenting with various Linux distro's i succeeded with OpenSuse leap 42.3 64bit.  I downloaded S2bot app from Picaxe (S2Bot App for Linux 64-bit  )  following their instructions i extracted to a folder on my Desktop. From the cmd line cd to this new folder and run ./scratch-hardware-helper, this opened the app with message "No adaptor found" and in terminal "] Failed to open serial port: FILE_ERROR_ACCESS_DENIED" ,after that i tried running "./scratch-hardware-helper" as root and the app opened, found my sbrick+ and i was able to test both motors and sensors. But when i tried to save "New scratch template" i got "Unable to create io-slave. Cannot talk to klauncher: Not connected to D-Bus server". I managed to avoid the error by executing the following command "export $(dbus-launch)". Finally i installed chrome that supports shockwave flash needed by online scratch. I hope this will be somehow helpful.

  • December 26, 2017 1:30 AM CET

    Hi again. I managed to use my Sbrick+ with scratch using native S2Bot program V0.1.0. but this does not support sensors. Is there a known issue with the S2Bot App version? How can i make use off my tilt sensor?

  • December 25, 2017 12:29 AM CET

        Hi everybody. I just got my self an SBrick plus & a tilt sensor and i am trying to get them to work but with limited success. I use a windows 7 laptop with BLED112 and s2bot V0.8.1, every time i scan for devices my SBrick is detected and initialized but at least half the times after i close the detection window i get SBrick is not connected. Even when i get "sbrick is connected" voltage and temp readings stop refreshing after a few seconds and after that all test features are inoperative. In scratch i have the green dot stating "sbrick is connected" but never managed to run any program. If any of these make any sense to you please advise me.

        I also use a samsung A5. I have no problem connecting and i tested successfully all outputs, input from tilt sensor, led. I also updated firmware to v.20. I didn't manage to create a profile to use the tilt sensor, i would appreciated very much if you could provide me a simple example profile that demonstrates sensor interaction.