Forums » Support

Back To Topics

SBrick firmware upgrade

    • 164 posts
    • 3 posts
    July 7, 2015 8:10 AM CEST

    Hi Casper,

    It's a drag and drop thing, but it doesn't like to be on tablets... you should try designing profiles on a PC or laptop.


    also the wiki page may help you:

    • 4 posts
    July 7, 2015 6:58 AM CEST

    I have now updated all three SBricks, the led is on all the time and the when clicking identify brick it flashes.

    The trick for me was to disconnect all motors etc. And use the safe update method.

    My next problem is to design an interface, I cannot figure out how to place controls in the android app.

    I am using a Samsung Galaxy ProTab 8.4 LTE.

    • 1 posts
    July 6, 2015 11:08 PM CEST


    I have the same problem. First I updated at safe speed with 3 motors attached (worked fine last time), and it seems to go fine, but the led stays on the whole time. After I got confirmation thet download was complete I restarted bluetooth and connected to the sbrick again: Brick is correctly found be the android app, but the led is alwasy on and I get no response from the brick.

    I tried again with only one XL attached at risky speed. The motor runs as wild, and the led seems somehow dimmer, like its flashing to fast for me to see. The update somehow seems to take even longer to complete... Still not done... Will update after download is completed.

    Download is complete. Same resault... Trying again with safe speed.

    Which output was the motor connected to and what motor was used?


    I tried to connect to the brick with my girlfriends phone and version 0.8 of the app. Everything works, and the led of the sbrick is responding correctly. It seems the update is working ok, but version 1.6.1 of the app for Android is broken...


    Update: I tried with version 1.5 and 1.6 as well, but still same problem...


    I'm using a Sony Xperia Z3.



    This post was edited by Espen Danielsen at July 7, 2015 12:19 AM CEST
    • 4 posts
    June 28, 2015 11:41 PM CEST

    Tried updating again and for some unknown reason it actually managed to complete the safe mode update and it did not ask me to update it again.

    Now the led on the brick is permantly on, when asked to identify brick it flashes.

    I will try the two other bricks tomorrow



    • 10 posts
    June 28, 2015 11:21 PM CEST

    It does show versions somewhere. 

    • 4 posts
    June 28, 2015 11:18 PM CEST

    I installed sbrick on a mini iPad and I vas able to control the sbrick without updating it first.

    I had the option to upgrade but it did not seems to make any changes.

    It would be nice if it showed what version was on the brick and what version it should be updated to.


    • 10 posts
    June 28, 2015 11:13 PM CEST

    It's definitely the Android app. I borrowed an iPhone, which was able to connect to and control the Sbrick. Android still discovers but cannot connect.

    • 4 posts
    June 28, 2015 11:09 PM CEST

    I have just bought 3 sbricks, using samsung galaxy tabpro 8.4 lte to control them.

    However, the sbrick app requires that the brick gets new firmware, updating in any of the three modes ended successfully, but it still requires the brick to be updated.

    Just updated the app, but still the same problem, except that safe stops randomly and fast ended successfully, but it still requires the brick to be updated.


  • June 22, 2015 10:03 AM CEST

    For me, it was not the motor attached, but more the change from Android to iOS and then back. Crazy story.... I am happy to have given you some ideas and that your sBricks are working fine now :-)




    • 3 posts
    June 21, 2015 4:22 PM CEST

    Whel that's awsome support :) tried it one more time while writing the update, and the silly thing works!

    it seems attaching a motor might have been a magic fix after all :)

    • 3 posts
    June 21, 2015 4:15 PM CEST

    I have two Sbricks, one updated fine, but the second doesn't.

    I have tried the update on risky safe and average but it doesn't mather. it sais update is succesfull, but after that the LED stays off and next time the app finds it it just wants to update again.

    since the LED stays off I don't think the update gets completed correctly...

    I tried attaching a motor while updating, but it doesn't spin and I don't see a blinking LED during update (with or without the motor)

    The only device I have with android 4.4 is a samsung tab4 10.1. the app crashes a lot, but since update worked for the other I don't see why the second wouldn't.


    Any suggestions are much appreciated

  • June 8, 2015 7:53 AM CEST

    V1.5 of the Android SBrick app did it for me somehow! In the new OTA section I chose "safe" as the flashing method, which still had a motor connected to port D spin like crazy whie flashing, but it led to a blinkind LED during the flash process. Afterwards I disconnected the SBrick and turned Bluetooth on my Sony Z3 Tablet Compact off. Turned everything one, and - no dice, neither the blinkind LED identify feature nor the port tester worked. 

    Next, I got so frustrated that I installed the SBrick app for iOS on my Ipad Air 2, and BAM! The SBrick was found and it worked. I repeated the process with my other non-working SBrick, and it also worked. Since then, interestingly both are now also working from Android.

    So, what is this iOS 'cure'? Is the BT stack in those bricks somehow stuck in talking to the internals, and a new device connection resets it? We cannot know, but hopefully someone at Vengit can use this info to look into it so that others do not run into this trap.

    A happy user of 4 SBricks now ;-) 

  • June 6, 2015 8:54 AM CEST

    Thanks for posting,


    at least I know I am not alone ;-) I have emailed the guys from Vengit as well, let's see whats happening. At least I have two out of four SBricks working, so I can play around. This is no excuse for the teething troubles that are now more like a long time pain, though ...

    • 10 posts
    June 6, 2015 8:37 AM CEST

    I have the same problem. App wanted me to update the brick firmware. I started the update on "safe" speed, then backed out and used "average". That seemed to complete successfully. Now the LED is solidly lit all the time, the SBrick is discoverable, but I cannot connect to it. Back on the shelf it goes.

    Phone: Moto G, Android 5.0.2, SBrick app 1.5, SBrick hardware 4.0.

    This post was edited by bachaddict . at June 6, 2015 8:39 AM CEST
  • June 1, 2015 8:11 AM CEST



    I have four SBricks, two of them were immediately unpacked and used to various success, so they got a couple of firmware upgradres over the first weeks after release. After having to stop Lego in general for a couple of weeks, I have now connected them again successfully with my Android Tablet and subsequently upgraded to the latest firmware without problems, they work very nicely with my Sony Xperia Tab Z3 Compact ;-) 

    Then I unpacked my other two ones and they were found by the tablet and upgraded (LED was not blinking during the process; I associated this behaviour with the initial LED behaviour that was a bit strange). After the app confirmed successful flash, the SBricks are not working. Reenabling bluetooth, rebooting the tab and of course rebooting the Bricks is not successful. The Bricks can be found in the app, but neither LED identification or port checking works (LED stays on, no movement on connected motors). The first two units that were in-between updated continue to work nicely. Strangely, when I try to re-flash the nonworking pair via the OTA functionality in the app, a motor connected to port D spins wildly while the app reports flashing progress, but actually nothing else seems to happen as the LED does not flash.

    I suspect something was done in some of the older firmware upgrades that is missing from the ones that were from the initial run and that never got updated until now. How can I fix this? As I said the bricks can still be found via bluetooth, so not all is lost I guess...





    This post was edited by Tobias Knostmann at June 1, 2015 8:14 AM CEST