Forums » Support

Back To Topics

SBrick Market working?

    • 17 posts
    December 24, 2014 8:20 PM CET

    Everything works fine on the Port Tester other than the OTA which is coming soon apparently. All 4 ports work. Just the Control Profiles which don't work.

    Downloaded the app to day from the Google Play Store. Version is: 0.0.20 apparently. There doesn't seem to be a way to find the version no. within the App itself.


    What is the home page within the app meant to do? It appears blank with no options to do anything.


    • 340 posts
    December 24, 2014 8:09 PM CET
    Of course all ports needs to be work on the brick. What is your SBrick app's version number? Do you tried the port tester function?
    • 17 posts
    December 24, 2014 8:04 PM CET

    I was planning on intergrating it with 42030 tomorrow, but I think I am going to scratch that plan.

    • 17 posts
    December 24, 2014 8:01 PM CET

    I have 4 motors connected to it at the moment, to see if anything comes out of any port at all via control profile input. It is currently 1x Servo, 1x XL, 1x L and 1x M.

    I initially tried it with 2, trying all the different port combinations, but nothing.

    I get nothing from any of them. All ports work via the SBrick test bit.


    To be honest, if you just had 1 control that actually worked on Android which allowed you to use a servo and motor, I think that would keep a lot of people happy for now. A lot of people just want to use it as a remote for their RC LEGO car.

    • 340 posts
    December 24, 2014 7:53 PM CET

    Can you change the power source switch to the other side and try agan to drive the SBrick ports?

    • 17 posts
    December 24, 2014 7:50 PM CET

    So basically, if you aren't iPhone, you aren't in luck at the moment?

    • 340 posts
    December 24, 2014 7:46 PM CET

    You will can create your own profile with the Profile Designer service. This service is still in development. Our plans is to open for a public testing in december.

    @Zoltan Tüskés: please help to Toku with the Android app.


    • 17 posts
    December 24, 2014 7:40 PM CET

    Well, for some reason, the Profile Market appeared and I downloaded the 2 steering wheel and game pad ones.


    Do they actually work though? e.g. I added each one to a seperate profile and tested each one. Nothing out of any ports.

    Game Pad 2 is the one I want to use, but nothing.


    If these don't work, how are we meant to use the SBrick as there doesn't seem to be any means to create your own profiles?

    • 340 posts
    December 24, 2014 7:29 PM CET

    Hi, The Profile Market is not working in the current Android release.

    Our applications still in a very alpha stage, we have a big bug report queue and of course many features is missing yet.

    We have some rest in the holidays then we work hard to improve the application, the controls and the profiles. Big updates coming in January!

    • 17 posts
    December 24, 2014 7:22 PM CET

    Using the Android App on Galaxy S4 via Wi-fi for net.

    Click on the Market bit and all I get is a spinning icon. Is it meant to go to a web page or something?


    I can browse the net etc. via the phone, so the internet works on it.