Forums » Support

Back To Topics

Technical questions

    • 159 posts
    November 23, 2018 2:42 PM CET

    Hi Derek,

    unfortunately you can't combine the current on the different pins. You can feed at most 3 amps into SBrick, othervise you risk melting the plastic around the metal contacts.

    It is _technically_ possible to drive SBrick with a LiPo pack, but please only do this if you know what you're doing. There is no fuse in SBrick, and a short circuit with a LiPo pack can drive dozens of amps through it potentially causing fire or even an explosion.

    LEGO battery packs come with proper current limiting, LiPo packs usually don't.

    • 4 posts
    October 4, 2018 3:57 PM CEST

    Hi,

    As the Wiki says,

    Absolute maximum continuous current intake from "0" and "9V" pins: 3A Maximum continuous current intake from C1-C2 (using old, or 9V power supplies): 2A

     

    Can I just use 0 and 9V pin to connect power like Li-Po Battery??

    Or Connect 4pins will be batter for current intake 3+2A? and cause more powerful output also?

     

    Thanks!

  • August 23, 2017 11:20 AM CEST

    [blockquote]Tamás Fábián said:

    First of all, there's no need to worry.

    Both the SBrick and the IR receiver drives the motors with PWM or Pulse Width Modulated voltage.

    Both devices work by turning the voltage on and off once in about every thousandth of a second, so in each cycle the motor is on for some time, and off for some. The more the motor is on, the more torque and power it can deliver.

    Certain parts of a motor can vibrate, and give off a tweeting sound that is the loudest when the motor is driven with 50% duty cycle e.g. it is on for 50% of the time.

    We did our best to support LEGO's M motor, and we did great, since we can drive more M motors per channel than the IR can, and the overall current carrying capacity of the SBrick is much higher than the same figure in case of the IR receiver.

    This alsomeans that SBrick might turn on the motors more quickly than the IR recever, and therefore the noise might me louder.

    Moreover, the IR receiver only applies PWM duty cycles other than 0 and 100% (where there's no noise, but this is the case with SBrick too) if you use it with a 8879 remote.

    Additionally, SBrick can utilize 255 PWM levels. The first 20-30 levels are not really useful with PF motors, since they won't even start. At these levels, there is no motor noise to cover the beeping. Once the motors are running at a reasonable rate, their noise usually masks the tweeting.

    If you're really annoyed by the noise, I can do a few experiments to either lower the PWM frequency (lower sounds are harder to radiate, and are masked better by the motors), or increase it (with a bit of luck, above the ~20 KHz limit of the human ear). Since this can affect power efficiency (higher the frequency, higher the switching loss, there's more heat), such parameter should be allow tweaking (let the user to override it).

    (Hm, I've looked at the code, and the lowest frequency is about 490Hz, the highest is well above 100KHz. DRV8833's rise and fall time is 160 & 180ns, so it might be able to work at that frequency.)

    [/blockquote]

     

    I know this is an old topic but I think is possible to do something to improve the "sound problem": take a look to this.

    If they did it, so maybe you can do it as well: sounds like a software (firmware) thing! :)

    I really hope to see those functionalities implemented in SBrick!!! ^_^

    • 313 posts
    April 11, 2017 10:13 AM CEST

    [blockquote]Troy Johnston said: How do I edit my user profile's picture? I know there is supposed to be a button that says "edit profile picture" or something like that, but I can't seem to find it.[/blockquote]

     

    Dear Troy, 

    There will be a "My profile" menu on top of the page. Click on it. 

    Than you will see an "Edit my profile" function (under your image.)

    And finally find "Edit my Photo", on the right side of the page. 

    I hope this will help you. :) 

    If you need any further help, just let us know! 

    Have a nice day,

    Balint
    SBrick Team

    • 4 posts
    April 11, 2017 2:56 AM CEST
    How do I edit my user profile's picture? I know there is supposed to be a button that says "edit profile picture" or something like that, but I can't seem to find it.
    • 313 posts
    July 22, 2016 9:27 PM CEST

    [blockquote]Trevor Lien said:

    How can I search the forums?

    I know that I can use an external engine, like Google, but it is very difficult to find previous answers to even the most common questions.

    [/blockquote]

     

    Hello Trevor! 

    Please find "Forum" in the upper menu. 
    Than click on "search" (without any words.), and you will see filters, and then set "everything" instead "forum topics". 

    For the previous question, you can quote more questions together also, if you copy the exact question with the "blockquote" commands. 

    I hope i could helped to you, if you have further questions feel free to ask. 

    Best wishes, 
    Balint Mezei
    SBrick Team 

    • 6 posts
    July 22, 2016 6:48 PM CEST

    How can I search the forums?

    I know that I can use an external engine, like Google, but it is very difficult to find previous answers to even the most common questions.

    • 6 posts
    July 22, 2016 6:46 PM CEST

    How can I reply to someone's specific comment?

    I Know that I can quote them, but they would have to read every single comment forever in order to see that I am talking to them and would never get the answer to their question.

    • 9 posts
    July 2, 2016 11:48 AM CEST

    [blockquote]Balint Mezei said:

    [blockquote]Johan vd Pluijm said:

    How can I post more than one picture in one post?

     

    [/blockquote]

     

    Hello! 

    If you choose the "albums" option (top of the page), there you can create your own album with more than one picture. :)

    I hope i could helped to you. 

    Best wishes, 

    Balint Mezei - SBrick Team

    [/blockquote]

    Thanks!

    • 313 posts
    July 2, 2016 11:36 AM CEST

    [blockquote]Johan vd Pluijm said:

    How can I post more than one picture in one post?

     

    [/blockquote]

     

    Hello! 

    If you choose the "albums" option (top of the page), there you can create your own album with more than one picture. :)

    I hope i could helped to you. 

    Best wishes, 

    Balint Mezei - SBrick Team

    • 9 posts
    July 2, 2016 10:16 AM CEST

    How can I post more than one picture in one post?

     

    • 4 posts
    June 10, 2016 3:16 PM CEST
    Thanks!
    • 313 posts
    June 10, 2016 2:02 PM CEST

    [blockquote]Alexander WIssing said:

    Hello there

    ive tested the sbrick and it fails in too many areas 

    my 4 sbricks is updated to version 8 i have tested them before and after update whit samsung tablet, sony ericson phone and iphone 6 allmost same result sadly its hard to tell the small diffemce cos of connection unstability 

    my test setup : each sbrick has its own lego battery and is connected on channel A too a Lego PF XL motor

    Here comes the weird part.. "under" sbricks own app >meny >SBricks all 4 sbrick works fine on all channels    

    but when i try to set all 4 sbricks to run on same slider or split them up to each channel and slider they fail.. so sad 

    i want 4x4 or 6x6 rock crawler whit a motor to each wheel on 2 or 3 diffent sbricks

    and some mechanic funtions on my crawler.. 

    but my dreams are broken..  reason i want too split the PF motor load on 2 or 3 brick is my concern of the thermo swith in lego batteries when crawling up somthing by 4x4

    XL PF Lego motors and less worriers about connecting all 4x4 or 6x6 whit extension wires

     

    all this is allso tested whit only 2 sbricks whit better result but still fails to many times 

    its just to unstable if you consider the promises and specialy the prices

    allso the range up too 50m is naive if you want i a make video while testing

      ^I could how ever use the sbrick to remote controll the Lego Ir controllers built to the chassie in a line to controlle 4 or 6. 8. XL PF motors

    i just thinks its is insane to reroute remote controlling in that way.. seriously stand up!

    regards Alexander

    [/blockquote]

    Hello Alexander!

    We contacted you via e-mail.

    Sorry for the late reply.

    Thanks!

    Balint Mezei - SBrick Team

    • 313 posts
    June 10, 2016 10:13 AM CEST

    [blockquote]Troy Johnston said: How warm should the SBrick be when operating? [/blockquote]


    Hello! 

    Here you can find every technical informations about SBrick. 

    https://social.sbrick.com/store/product/9/sbrick (At the bottom of the page.) 

    The operating temperature rate is between -20°C - 80°C. 

    I hope i could helped to you!

    Regards, 

    Balint Mezei - SBrick Team 

    • 4 posts
    June 9, 2016 10:31 PM CEST
    How warm should the SBrick be when operating?
  • June 7, 2016 7:39 PM CEST

    Hello there

    ive tested the sbrick and it fails in too many areas 

    my 4 sbricks is updated to version 8 i have tested them before and after update whit samsung tablet, sony ericson phone and iphone 6 allmost same result sadly its hard to tell the small diffemce cos of connection unstability 

    my test setup : each sbrick has its own lego battery and is connected on channel A too a Lego PF XL motor

    Here comes the weird part.. "under" sbricks own app >meny >SBricks all 4 sbrick works fine on all channels    

    but when i try to set all 4 sbricks to run on same slider or split them up to each channel and slider they fail.. so sad 

    i want 4x4 or 6x6 rock crawler whit a motor to each wheel on 2 or 3 diffent sbricks

    and some mechanic funtions on my crawler.. 

    but my dreams are broken..  reason i want too split the PF motor load on 2 or 3 brick is my concern of the thermo swith in lego batteries when crawling up somthing by 4x4

    XL PF Lego motors and less worriers about connecting all 4x4 or 6x6 whit extension wires

     

    all this is allso tested whit only 2 sbricks whit better result but still fails to many times 

    its just to unstable if you consider the promises and specialy the prices

    allso the range up too 50m is naive if you want i a make video while testing

      ^I could how ever use the sbrick to remote controll the Lego Ir controllers built to the chassie in a line to controlle 4 or 6. 8. XL PF motors

    i just thinks its is insane to reroute remote controlling in that way.. seriously stand up!

    regards Alexander


    This post was edited by Alexander WIssing at June 7, 2016 8:39 PM CEST
    • 313 posts
    May 2, 2016 2:18 AM CEST

    [blockquote]Moz . said:

    How do I search the forums? I'm sure my questions aren't new, but I don't really want to spend hours reading every post to find the answers. Search from outside using duck doesn't seem to work.

    So:

    - how do I use the app if I don't have internet access on my phone? It seems to run with the "guest" user, but I can't work out how to associate a brick to a profile. When I press "remote control profiles" I get "unable to fetch the profiles". If the app is only usable with an internet connection that seems really badly broken.

    - why do I still have to restart the app and the brick after a firmware update? The app doesn't say I need to, it just doesn't re-connect to the brick until I do. It's better than having to reboot the phone or turn off bluetooth like I used to have to, but it's still poor. At the very least the app should *say* something if it needs that.

    - is it possible to have two sbricks controlled from one screen yet?

    - does the profile designer work? More importantly, is it ever going to work on a phone without internet access? If not, how do I side-load profiles so I can actually control an sbrick?

    [/blockquote]


    Hello! 


    To download a profile from the profile market, you need internet access, but if you once downloaded it, after that to activate it, you won't need internet connection. 

    For the question why do you need to restart the phone after the fw update, i can only ask you later. I forwarded the question to the competent person. :) 

    Yes, it is possible to control 2 sbrick from one screen, and the profile designer works. :) 

    If you have any further questions, feel free to ask.

    Regards, 

    Balint Mezei - SBrick Team 

    • 4 posts
    May 1, 2016 5:15 AM CEST

    How do I search the forums? I'm sure my questions aren't new, but I don't really want to spend hours reading every post to find the answers. Search from outside using duck doesn't seem to work.

    So:

    - how do I use the app if I don't have internet access on my phone? It seems to run with the "guest" user, but I can't work out how to associate a brick to a profile. When I press "remote control profiles" I get "unable to fetch the profiles". If the app is only usable with an internet connection that seems really badly broken.

    - why do I still have to restart the app and the brick after a firmware update? The app doesn't say I need to, it just doesn't re-connect to the brick until I do. It's better than having to reboot the phone or turn off bluetooth like I used to have to, but it's still poor. At the very least the app should *say* something if it needs that.

    - is it possible to have two sbricks controlled from one screen yet?

    - does the profile designer work? More importantly, is it ever going to work on a phone without internet access? If not, how do I side-load profiles so I can actually control an sbrick?

    • 313 posts
    April 28, 2016 2:10 AM CEST

    [blockquote]Scott Roys said:

    Thanks for looking into that profile. I did use the s-brick for a few minutes to run a train and discovered another less then desirable a feature that caused me to just use the Lego PF IR controller for the rest of the weekend. The annoying thing was that the train would stop as soon as the phone would go to screen lock feature from a short period of not receiving inputs. I want to be able to get my trains running and then stick my phone in my pocket and have the train keep running while the phone "goes to sleep". Is this possible? It's not convenient to have to constantly wake up the phone up to keep the train moving.  

     

    Thanks, Scott

    [/blockquote]

     

    Hello Scott! 

    We fixed the profile, download it again please. You can stop the train with the "stop" and "coast" button too. It has the same chanel name with the slider too. 

    In the view of the "goes to sleep" function, it is an interesting idea, thank you for sharing this with us. :)
    We try to figure it out how would it become available in the future. 

    Regards, 

    Balint Mezei - SBrick Team 

    • 313 posts
    April 27, 2016 3:08 PM CEST

    [blockquote]wh wh said:

    Upload according to the size requirements and format, display upload success, but the gallery can not find the uploaded pictures

    [/blockquote]

    Hello! 



    For us uploading pictures  work perfectly. Where did you try to upload the files? What kind of web browser do you use? 

    Regards, 



    Balint Mezei - SBrick Team 

    • 1 posts
    April 27, 2016 1:50 PM CEST

    Upload according to the size requirements and format, display upload success, but the gallery can not find the uploaded pictures

    • 3 posts
    April 26, 2016 1:24 AM CEST

    Thanks for looking into that profile. I did use the s-brick for a few minutes to run a train and discovered another less then desirable a feature that caused me to just use the Lego PF IR controller for the rest of the weekend. The annoying thing was that the train would stop as soon as the phone would go to screen lock feature from a short period of not receiving inputs. I want to be able to get my trains running and then stick my phone in my pocket and have the train keep running while the phone "goes to sleep". Is this possible? It's not convenient to have to constantly wake up the phone up to keep the train moving.  

     

    Thanks, Scott

    • 313 posts
    April 23, 2016 1:20 PM CEST

    [blockquote]Scott Roys said:

    I've got v1.6 so I do not think that is the problem. The problem is that I think I should be able to assign more then one function to each port. Right now, I can assign Port "C" (for example) to only "Drive" and not "Drive, "stop", and "coast" like I think I should be able to.

    I have not educated myself to creating my own control panel but maybe I could figure it out that way. 

    [/blockquote]

    Hello! 

    We are fixing this profile as soon as possible. We ask for some patience. :) 

    Regards, 


    Balint Mezei - SBrick Team 


    This post was edited by Balint Mezei at April 23, 2016 1:21 PM CEST
    • 3 posts
    April 20, 2016 1:09 AM CEST

    I've got v1.6 so I do not think that is the problem. The problem is that I think I should be able to assign more then one function to each port. Right now, I can assign Port "C" (for example) to only "Drive" and not "Drive, "stop", and "coast" like I think I should be able to.

    I have not educated myself to creating my own control panel but maybe I could figure it out that way. 

  • April 20, 2016 12:52 AM CEST

    [blockquote]Scott Roys said:

    Sorry for the repeat but I got no reply posting this in it's own thread.

    I've got an s-brick in my Horizon Express train and am using the publical available Horizon Express profile to run it. I've got 2 lego train motors that are hooked up to ports "C" and "D" with "D" inverted. The ports are assigned to the "Drive" slider and which works very well. The control panel also has two additional buttons on it which are "coast" and "stop". I would like each motor to be able to do all three funtions but I havent been able to figure out how. Right now the only sure way to stop is to exit out of the control panel as it is dificult to get the drive slider exactly centered so that it is truely off. Is this possible?

    Thanks, Scott 

    [/blockquote]

    Version 1.5 of the Horizon Express profile was messed up by Profile Designer (the infamous 'rename interface element' bug), but there is a new version 1.6 that should work, I think.