Forums » Support

Back To Topics

Technical questions

    • 272 posts
    May 11, 2020 1:08 PM CEST
    Kristóf Csillag said:

    Dear all,

    Could someone please advise me about what is the currently recommended / official way for talking to an SBrick using Python?

    Thank you.

     

    Hi Kristóf,

     

    We don't have official python sdk yet.

    But we have open protocol, so you can start here: https://social.sbrick.com/custom/The_SBrick_BLE_Protocol.pdf

    And here is an example for SBrick projects in python: https://github.com/BensonHsu/SBrick-Framework

  • May 11, 2020 8:41 AM CEST

    Dear all,

    Could someone please advise me about what is the currently recommended / official way for talking to an SBrick using Python?

    Thank you.

     

    • 272 posts
    April 3, 2020 5:19 PM CEST
    Borderlands said:
    Jörg said:

    Hello,

    can anyone advise with the following issue:

    One of my SBricks worked fine in a custom built rough terrain crane just until yesterday when it stopped working.

    Attaching the brick to the battery pack, the green LED did not turn on. In the app I can see the brick but under a different name. It shows up as "OTA_12", however , I originally named the brick "SBrick1". So the name somehow got lost. The battery symbol shows just one orange bar and the voltage status reports "0.00 Volt".

    I did verify the battery pack with another brick, the battery pack is completely full. I did check the cables as well, all working well with the other brick. I updated the firmware but this did not change anything.

    Any idea, what is going on with that SBrick? It looks and feels very dead.

    Thanks!

    i got the same problem i can't fix it

    OTA_12 means the SBrick ready to receive a firmware update. So the current firmware hurt somehow. :(

    Can you try to force the update with this software? https://play.google.com/store/apps/details?id=com.vengit.blecontrol&hl=en

    • 1 posts
    April 3, 2020 4:33 PM CEST
    Jörg said:

    Hello,

    can anyone advise with the following issue:

    One of my SBricks worked fine in a custom built rough terrain crane just until yesterday when it stopped working.

    Attaching the brick to the battery pack, the green LED did not turn on. In the app I can see the brick but under a different name. It shows up as "OTA_12", however , I originally named the brick "SBrick1". So the name somehow got lost. The battery symbol shows just one orange bar and the voltage status reports "0.00 Volt".

    I did verify the battery pack with another brick, the battery pack is completely full. I did check the cables as well, all working well with the other brick. I updated the firmware but this did not change anything.

    Any idea, what is going on with that SBrick? It looks and feels very dead.

    Thanks!

    i got the same problem i can't fix it

    • 2 posts
    February 5, 2020 8:07 PM CET

    Update on my allegedly broken SBrick: issue is solved (for now).

    Although I tried updating the firmware a couple of days ago without any success, the firmware update today worked and the SBrick is back functioning.

    Weird behavior, but for now I am glad.

    • 2 posts
    February 1, 2020 4:46 PM CET

    Hello,

    can anyone advise with the following issue:

    One of my SBricks worked fine in a custom built rough terrain crane just until yesterday when it stopped working.

    Attaching the brick to the battery pack, the green LED did not turn on. In the app I can see the brick but under a different name. It shows up as "OTA_12", however , I originally named the brick "SBrick1". So the name somehow got lost. The battery symbol shows just one orange bar and the voltage status reports "0.00 Volt".

    I did verify the battery pack with another brick, the battery pack is completely full. I did check the cables as well, all working well with the other brick. I updated the firmware but this did not change anything.

    Any idea, what is going on with that SBrick? It looks and feels very dead.

    Thanks!

    • 15 posts
    November 27, 2019 9:47 PM CET
    great, cant wait for the sbrick3 :-)
    • 272 posts
    November 27, 2019 9:44 PM CET
    Hmm.. i don’t know in this times, they make interesting and great tech products, but it seems they need more UX expert :) hmm... like us.. but great news here, we..finally..grow. So we can do more with our current and next technology. Please follow our crowdfunding news ;) back to the topic, i will check that id i can get one.
    • 15 posts
    November 27, 2019 9:37 PM CET
    hi :-), well, it is a google product, should be a bestseller
    • 272 posts
    November 27, 2019 9:35 PM CET
    Hi Lars! :)

    Haven’t seen this controller yet. I will check the specs. Do you think it will be a best seller?
    I’ve seen the game streaming service and i’m not convince about that.
    • 15 posts
    November 27, 2019 9:29 PM CET
    hello, do you plan to add dupport for the google stadia controller?
    • 272 posts
    October 25, 2019 2:59 PM CEST
    Hambone said:

    Is it possible to detect a particular train passing by a motion sensor with the current Sbrick technology? Ultimately, I want to use a color sensor with trains having a few different colored bricks as unique identifiers to do the job, however, not sure when the ev3 sensor adapter will be available.  Has anyone out there tried something similar using the current Sbrick technology?

     

     

    You can use WeDo 1.0 proximity sensor for that. It has no color sensing unfortunately.

     

    • 38 posts
    October 23, 2019 11:30 PM CEST
    Hambone said:

    Is it possible to detect a particular train passing by a motion sensor with the current Sbrick technology? Ultimately, I want to use a color sensor with trains having a few different colored bricks as unique identifiers to do the job, however, not sure when the ev3 sensor adapter will be available.  Has anyone out there tried something similar using the current Sbrick technology?

    You have a SBRICK plus, the newer version of SBRICK is only capable to work with sensor technic?

    • 14 posts
    October 23, 2019 9:21 AM CEST

    Is it possible to detect a particular train passing by a motion sensor with the current Sbrick technology? Ultimately, I want to use a color sensor with trains having a few different colored bricks as unique identifiers to do the job, however, not sure when the ev3 sensor adapter will be available.  Has anyone out there tried something similar using the current Sbrick technology?

    • 38 posts
    August 31, 2019 9:17 PM CEST
    Judah Herman said:
    I’m making an RC tank and I’m trying to control both steering and drive with one joystick. How do I do this?
    A joystick has 2 movements, X-Axis and Y-Axis. You are steering with chains? 1 chains has to move slower then the other?

     

    • 1 posts
    August 30, 2019 9:35 PM CEST
    I’m making an RC tank and I’m trying to control both steering and drive with one joystick. How do I do this?
    • 272 posts
    July 4, 2019 9:33 PM CEST
    It is an itereating project if you ask for this feature. :)
    Yes, you can, but not with the SBrick app, you must try the new one. It is currently on provate beta. Please write to the beta@sbrick.com for the access. ;)
  • July 4, 2019 9:12 PM CEST

    Hello,

    is it possible to run two motors on one SBricks simultaneously with a ratio?

    I would like to control one motor with a slider and the second motor should run with 60% of the first motor. So if I put the slider to 100%, the first motor should run at full speed, the second one at 60%. If I reduce the slider to 40%, the first motor should run at a speed of 40%, the second at 24%. And if I put the slider on -50%, the first motor should drive backwards at 50% speed, the second one also backwards at 30% speed.

    Kind Regards

    Ludger

    • 272 posts
    February 11, 2019 9:07 PM CET
    Roman R said:

    Hi,

    Is it possible to control two SBricks from one Android phone simultaneously? I'm going to motorize one complex model which would require more than four channels one sbrick provides, swo two sbricks would be installed into one model.

    Thank you.

     

    Hi,

    Yes, of course. :)

    • 1 posts
    February 11, 2019 11:13 AM CET

    Hi,

    Is it possible to control two SBricks from one Android phone simultaneously? I'm going to motorize one complex model which would require more than four channels one sbrick provides, swo two sbricks would be installed into one model.

    Thank you.

     

    • 272 posts
    January 30, 2019 2:18 PM CET
    Jaap Technic said:

    Is it possible to programm the Sbrick some way so i can make warning lights?

    Like something i have made on my Mercedes Actros. Just to get rid of the old 9v flashing lights.

    Maybe it is possible with an add-in in the app which makes it possible to choose between a set of different light patterns.

     

    you can do this with using "sequences" in profile designer.

    • 2 posts
    January 28, 2019 7:10 PM CET
    Lénárd Pásztor said:
    Ilya Rodionov said:

    Few days ago I probably forgot the battery box switch open. Yesterday the battery box light did not lighted up. The batteries were fully discharged (I guess because of the sbrick’s Bluetooth operation). I changed the batteries and the battery box led works (I also tested the battery box with a motor – It was OK).

     

    But the sbrick does not respond . No led working and cannot be found from my Android app.

     

    Do you have any idea of what it might be happened or have you faced this before ?  is there a possibility of sbrick failure because I forgot it open and worked for many hours ?

     

    Can you send back the SBrick to the following addres? The problem is really interesting, we want to check the hardware. Of course we send you a replacement for free.

    Address is:

    Tamas Fabian

    Kurbli Kft.

    1143 Budapest

    Gizella ut 42-44

    Thanks for your reply, I will send you my sbrik soon and I will wait for a replacement in responselaughing

    • 272 posts
    January 28, 2019 11:13 AM CET
    Ilya Rodionov said:

    Few days ago I probably forgot the battery box switch open. Yesterday the battery box light did not lighted up. The batteries were fully discharged (I guess because of the sbrick’s Bluetooth operation). I changed the batteries and the battery box led works (I also tested the battery box with a motor – It was OK).

     

    But the sbrick does not respond . No led working and cannot be found from my Android app.

     

    Do you have any idea of what it might be happened or have you faced this before ?  is there a possibility of sbrick failure because I forgot it open and worked for many hours ?

     

    Can you send back the SBrick to the following addres? The problem is really interesting, we want to check the hardware. Of course we send you a replacement for free.

    Address is:

    Tamas Fabian

    Kurbli Kft.

    1143 Budapest

    Gizella ut 42-44

    • 2 posts
    January 25, 2019 7:44 PM CET

    Few days ago I probably forgot the battery box switch open. Yesterday the battery box light did not lighted up. The batteries were fully discharged (I guess because of the sbrick’s Bluetooth operation). I changed the batteries and the battery box led works (I also tested the battery box with a motor – It was OK).

     

    But the sbrick does not respond . No led working and cannot be found from my Android app.

     

    Do you have any idea of what it might be happened or have you faced this before ?  is there a possibility of sbrick failure because I forgot it open and worked for many hours ?

    • 171 posts
    January 24, 2019 3:03 PM CET

    Hello Grzegorz,

    what do you mean by "frame format"? Could you please re-phrase the question?

    Grzegorz Bladocha said:

    When connecting with another bluetooth + arduino module to enable channel A which frame format
    send?