Forums » Support

Back To Topics

Firmware Update: How long should it take???

    • 1 posts
    January 13, 2017 9:31 PM CET

    hello, i had te same problem and i resolved it! just restart your phone, open your app and power on your sbrick. i use a samsung s4.

    scuse me for poor english!

    • 6 posts
    November 22, 2015 6:51 PM CET

    Does anyone know if update is supposed to work with Android yet?


    Interface is different; no blue bars.


    Agreed- it would be great if they had put in some kind of user feedback on things like status, connection, and progress.

    • 57 posts
    January 8, 2015 2:53 AM CET

    I agree with you about the convinience to be able to see the fw version number available in each SBrick!


    In the present case it is to know, because before fw upgrade:

    - LED ID: normally off / Identify function: LED on

    After upgrade:

    - LED ID: normally on / Identify function: LED blinking


    As stated here in the forum, at Android one can use Nordic Semiconductor nRF Master Control Panel to read the firmware version.

  • January 8, 2015 2:34 AM CET

    Ok, seems my iPhone 5s did stall the update...

    Turned the power off to the brick, tried again, same issue. Update status stops at about 98% and stays there. 

    Moved to my iPhone 5, did the same thing, and the progressbar moved to 100%, and showed a 'success' message. Took about 3 minuts!


    1: It seems like the SBrick app does not test if the BT connection is working as expected, when doing this.

    2: It would be Very nice to be able to see the FW version on the brick, so you have a small idea if the brick got updated or not! ;-)

    This post was edited by Jakob Peterhänsel at January 8, 2015 7:10 PM CET
    • 57 posts
    January 8, 2015 2:28 AM CET

    I didn't measure the time but I upgraded 3 of them about 1hour ago... :)

    It took something about 1min each and you should follow the progress from a blue bar in the phone screen.
    After the firmware is fully uploaded into SBrick, it reboots and flashes the firmware in the SBrick rom. It takes about 5 seconds and lef flashes quite fast during this period.


    Although for the 2nd and 3rd SBricks that I tried the upgraded it didn't start for sometime (it was obviously too much).

    Since the critical part is the final one when it flashes the rom, I was not affraid to disconnect SBrick in the middle, power it down and restart the fw upgrade procedure.

    The 2nd time it ran always fine and fast. :)

  • January 8, 2015 12:49 AM CET

    Hi All,

    Could someone tell how long the FW update should take?

    Mine has been working for 50+ minutes... !

    What happens if I power the brick off & on? (Should I get the power supply to the LEGO PF battery?)