Forums » Support

Back To Topics

Technical questions

    • 10 posts
    July 2, 2016 10:16 AM CEST

    How can I post more than one picture in one post?

     

    • 4 posts
    June 10, 2016 3:16 PM CEST
    Thanks!
    • 310 posts
    June 10, 2016 2:02 PM CEST

    [blockquote]Alexander WIssing said:

    Hello there

    ive tested the sbrick and it fails in too many areas 

    my 4 sbricks is updated to version 8 i have tested them before and after update whit samsung tablet, sony ericson phone and iphone 6 allmost same result sadly its hard to tell the small diffemce cos of connection unstability 

    my test setup : each sbrick has its own lego battery and is connected on channel A too a Lego PF XL motor

    Here comes the weird part.. "under" sbricks own app >meny >SBricks all 4 sbrick works fine on all channels    

    but when i try to set all 4 sbricks to run on same slider or split them up to each channel and slider they fail.. so sad 

    i want 4x4 or 6x6 rock crawler whit a motor to each wheel on 2 or 3 diffent sbricks

    and some mechanic funtions on my crawler.. 

    but my dreams are broken..  reason i want too split the PF motor load on 2 or 3 brick is my concern of the thermo swith in lego batteries when crawling up somthing by 4x4

    XL PF Lego motors and less worriers about connecting all 4x4 or 6x6 whit extension wires

     

    all this is allso tested whit only 2 sbricks whit better result but still fails to many times 

    its just to unstable if you consider the promises and specialy the prices

    allso the range up too 50m is naive if you want i a make video while testing

      ^I could how ever use the sbrick to remote controll the Lego Ir controllers built to the chassie in a line to controlle 4 or 6. 8. XL PF motors

    i just thinks its is insane to reroute remote controlling in that way.. seriously stand up!

    regards Alexander

    [/blockquote]

    Hello Alexander!

    We contacted you via e-mail.

    Sorry for the late reply.

    Thanks!

    Balint Mezei - SBrick Team

    • 310 posts
    June 10, 2016 10:13 AM CEST

    [blockquote]Troy Johnston said: How warm should the SBrick be when operating? [/blockquote]


    Hello! 

    Here you can find every technical informations about SBrick. 

    https://social.sbrick.com/store/product/9/sbrick (At the bottom of the page.) 

    The operating temperature rate is between -20°C - 80°C. 

    I hope i could helped to you!

    Regards, 

    Balint Mezei - SBrick Team 

    • 4 posts
    June 9, 2016 10:31 PM CEST
    How warm should the SBrick be when operating?
  • June 7, 2016 7:39 PM CEST

    Hello there

    ive tested the sbrick and it fails in too many areas 

    my 4 sbricks is updated to version 8 i have tested them before and after update whit samsung tablet, sony ericson phone and iphone 6 allmost same result sadly its hard to tell the small diffemce cos of connection unstability 

    my test setup : each sbrick has its own lego battery and is connected on channel A too a Lego PF XL motor

    Here comes the weird part.. "under" sbricks own app >meny >SBricks all 4 sbrick works fine on all channels    

    but when i try to set all 4 sbricks to run on same slider or split them up to each channel and slider they fail.. so sad 

    i want 4x4 or 6x6 rock crawler whit a motor to each wheel on 2 or 3 diffent sbricks

    and some mechanic funtions on my crawler.. 

    but my dreams are broken..  reason i want too split the PF motor load on 2 or 3 brick is my concern of the thermo swith in lego batteries when crawling up somthing by 4x4

    XL PF Lego motors and less worriers about connecting all 4x4 or 6x6 whit extension wires

     

    all this is allso tested whit only 2 sbricks whit better result but still fails to many times 

    its just to unstable if you consider the promises and specialy the prices

    allso the range up too 50m is naive if you want i a make video while testing

      ^I could how ever use the sbrick to remote controll the Lego Ir controllers built to the chassie in a line to controlle 4 or 6. 8. XL PF motors

    i just thinks its is insane to reroute remote controlling in that way.. seriously stand up!

    regards Alexander


    This post was edited by Alexander WIssing at June 7, 2016 8:39 PM CEST
    • 310 posts
    May 2, 2016 2:18 AM CEST

    [blockquote]Moz . said:

    How do I search the forums? I'm sure my questions aren't new, but I don't really want to spend hours reading every post to find the answers. Search from outside using duck doesn't seem to work.

    So:

    - how do I use the app if I don't have internet access on my phone? It seems to run with the "guest" user, but I can't work out how to associate a brick to a profile. When I press "remote control profiles" I get "unable to fetch the profiles". If the app is only usable with an internet connection that seems really badly broken.

    - why do I still have to restart the app and the brick after a firmware update? The app doesn't say I need to, it just doesn't re-connect to the brick until I do. It's better than having to reboot the phone or turn off bluetooth like I used to have to, but it's still poor. At the very least the app should *say* something if it needs that.

    - is it possible to have two sbricks controlled from one screen yet?

    - does the profile designer work? More importantly, is it ever going to work on a phone without internet access? If not, how do I side-load profiles so I can actually control an sbrick?

    [/blockquote]


    Hello! 


    To download a profile from the profile market, you need internet access, but if you once downloaded it, after that to activate it, you won't need internet connection. 

    For the question why do you need to restart the phone after the fw update, i can only ask you later. I forwarded the question to the competent person. :) 

    Yes, it is possible to control 2 sbrick from one screen, and the profile designer works. :) 

    If you have any further questions, feel free to ask.

    Regards, 

    Balint Mezei - SBrick Team 

    • 4 posts
    May 1, 2016 5:15 AM CEST

    How do I search the forums? I'm sure my questions aren't new, but I don't really want to spend hours reading every post to find the answers. Search from outside using duck doesn't seem to work.

    So:

    - how do I use the app if I don't have internet access on my phone? It seems to run with the "guest" user, but I can't work out how to associate a brick to a profile. When I press "remote control profiles" I get "unable to fetch the profiles". If the app is only usable with an internet connection that seems really badly broken.

    - why do I still have to restart the app and the brick after a firmware update? The app doesn't say I need to, it just doesn't re-connect to the brick until I do. It's better than having to reboot the phone or turn off bluetooth like I used to have to, but it's still poor. At the very least the app should *say* something if it needs that.

    - is it possible to have two sbricks controlled from one screen yet?

    - does the profile designer work? More importantly, is it ever going to work on a phone without internet access? If not, how do I side-load profiles so I can actually control an sbrick?

    • 310 posts
    April 28, 2016 2:10 AM CEST

    [blockquote]Scott Roys said:

    Thanks for looking into that profile. I did use the s-brick for a few minutes to run a train and discovered another less then desirable a feature that caused me to just use the Lego PF IR controller for the rest of the weekend. The annoying thing was that the train would stop as soon as the phone would go to screen lock feature from a short period of not receiving inputs. I want to be able to get my trains running and then stick my phone in my pocket and have the train keep running while the phone "goes to sleep". Is this possible? It's not convenient to have to constantly wake up the phone up to keep the train moving.  

     

    Thanks, Scott

    [/blockquote]

     

    Hello Scott! 

    We fixed the profile, download it again please. You can stop the train with the "stop" and "coast" button too. It has the same chanel name with the slider too. 

    In the view of the "goes to sleep" function, it is an interesting idea, thank you for sharing this with us. :)
    We try to figure it out how would it become available in the future. 

    Regards, 

    Balint Mezei - SBrick Team 

    • 310 posts
    April 27, 2016 3:08 PM CEST

    [blockquote]wh wh said:

    Upload according to the size requirements and format, display upload success, but the gallery can not find the uploaded pictures

    [/blockquote]

    Hello! 



    For us uploading pictures  work perfectly. Where did you try to upload the files? What kind of web browser do you use? 

    Regards, 



    Balint Mezei - SBrick Team 

    • 1 posts
    April 27, 2016 1:50 PM CEST

    Upload according to the size requirements and format, display upload success, but the gallery can not find the uploaded pictures

    • 3 posts
    April 26, 2016 1:24 AM CEST

    Thanks for looking into that profile. I did use the s-brick for a few minutes to run a train and discovered another less then desirable a feature that caused me to just use the Lego PF IR controller for the rest of the weekend. The annoying thing was that the train would stop as soon as the phone would go to screen lock feature from a short period of not receiving inputs. I want to be able to get my trains running and then stick my phone in my pocket and have the train keep running while the phone "goes to sleep". Is this possible? It's not convenient to have to constantly wake up the phone up to keep the train moving.  

     

    Thanks, Scott

    • 310 posts
    April 23, 2016 1:20 PM CEST

    [blockquote]Scott Roys said:

    I've got v1.6 so I do not think that is the problem. The problem is that I think I should be able to assign more then one function to each port. Right now, I can assign Port "C" (for example) to only "Drive" and not "Drive, "stop", and "coast" like I think I should be able to.

    I have not educated myself to creating my own control panel but maybe I could figure it out that way. 

    [/blockquote]

    Hello! 

    We are fixing this profile as soon as possible. We ask for some patience. :) 

    Regards, 


    Balint Mezei - SBrick Team 


    This post was edited by Balint Mezei at April 23, 2016 1:21 PM CEST
    • 3 posts
    April 20, 2016 1:09 AM CEST

    I've got v1.6 so I do not think that is the problem. The problem is that I think I should be able to assign more then one function to each port. Right now, I can assign Port "C" (for example) to only "Drive" and not "Drive, "stop", and "coast" like I think I should be able to.

    I have not educated myself to creating my own control panel but maybe I could figure it out that way. 

  • April 20, 2016 12:52 AM CEST

    [blockquote]Scott Roys said:

    Sorry for the repeat but I got no reply posting this in it's own thread.

    I've got an s-brick in my Horizon Express train and am using the publical available Horizon Express profile to run it. I've got 2 lego train motors that are hooked up to ports "C" and "D" with "D" inverted. The ports are assigned to the "Drive" slider and which works very well. The control panel also has two additional buttons on it which are "coast" and "stop". I would like each motor to be able to do all three funtions but I havent been able to figure out how. Right now the only sure way to stop is to exit out of the control panel as it is dificult to get the drive slider exactly centered so that it is truely off. Is this possible?

    Thanks, Scott 

    [/blockquote]

    Version 1.5 of the Horizon Express profile was messed up by Profile Designer (the infamous 'rename interface element' bug), but there is a new version 1.6 that should work, I think.

    • 3 posts
    April 19, 2016 11:25 PM CEST

    Sorry for the repeat but I got no reply posting this in it's own thread.

    I've got an s-brick in my Horizon Express train and am using the publical available Horizon Express profile to run it. I've got 2 lego train motors that are hooked up to ports "C" and "D" with "D" inverted. The ports are assigned to the "Drive" slider and which works very well. The control panel also has two additional buttons on it which are "coast" and "stop". I would like each motor to be able to do all three funtions but I havent been able to figure out how. Right now the only sure way to stop is to exit out of the control panel as it is dificult to get the drive slider exactly centered so that it is truely off. Is this possible?

    Thanks, Scott 

    • 87 posts
    February 18, 2016 1:23 AM CET

    Hi. It's safe to use 9V with the SBrick. I've used LEGO old 9V batteries cases (both 1xPP3 type and 6xAA type), just need to use a PF cable as an adapter because old 9V plug is not compatible with SBrick PF-type plug.

    If you're going to control just a M-motor, a PP3 battery works but doesn't last long, 6xAA is better.

  • February 18, 2016 1:16 AM CET

    Is there any chance that running an SBrick with a 9v battery might cause it to short out or cause thermal shut down? I've been poking around the forum a bit to see if I can find an answer. I'm less worried about the voltage because it seems like a 9v battery is well within the operating peramaters of the SBrick. I guess my question is; is it likely that using a 9v battery to power the Sbrick and a Power Functions M-motor would cause enough resistance to bring the peak amps up to around or above 3amps to cause damage to the SBrick or motor ICs?

    • 164 posts
    February 1, 2016 12:31 PM CET

    [blockquote]lars bosman said:

    Hi

    If I'm going to SBricks on my SBrick app it says: "The platform/hardware doesn't support..." What does it mean and what can I do to connect to my SBrick??

    [/blockquote]

    What kind of device do you have? 

    • 1 posts
    January 30, 2016 8:54 AM CET

    Hi

    If I'm going to SBricks on my SBrick app it says: "The platform/hardware doesn't support..." What does it mean and what can I do to connect to my SBrick??

    • 164 posts
    November 16, 2015 5:28 PM CET

    Hi Nick,

    It's a know bug in the iOS apllication, but our developers already fixed it. ;) The new fixed application will be available in the Appstore soon.

    You can use your own background in the Profile Designer. Just choose a background, edit it with paint or photoshop as you want and uplodat it ;)

    • 10 posts
    November 14, 2015 6:42 PM CET
    How about taking pictures in the ios app somewhere i can't connect to my photoalbum or camera on the ipad mini is it a wrong setting or is it somewhere in the app i can't really find the problem and it would be nice to have the original pictures by the original models
    And in the profile designer are some possibilitys to add some skins ass arrows,hook and lightbulb or flashing lightbulb to put next to your sliders and joysticks like the one for the 42009 crane
    At the moment i run a rebuild 42042 and its stil under construction id really would like it that i can put the right simbolics next to the determined slider,switch or joystick specially with a lot more functions it would be handy grtz nick
    • 212 posts
    October 19, 2015 3:38 PM CEST

    [blockquote]Henrik Therkildsen said:

    How many XL motors would it be possible to connect to a single sbrick?
    hHve 4 XL morotr that I would like to control at the same time. Would I need one or two sbricks for that?

    [/blockquote]

    You can use one SBrick for that, but the current limit of the LEGO power source may degrade the power of the motors. Alternatively you can use custom LiPo or you can hack the battery box..

    http://www.eurobricks.com/forum/index.php?showtopic=74919

  • October 19, 2015 3:23 PM CEST

    How many XL motors would it be possible to connect to a single sbrick?
    hHve 4 XL morotr that I would like to control at the same time. Would I need one or two sbricks for that?

  • September 10, 2015 10:43 AM CEST
    Hi, You can use LIPO 11.1V! It's powerful and light. Perfect balance :)