Forums » Support

Back To Topics

SBrick Android App

    • 164 posts
    September 28, 2015 9:28 AM CEST

    Does not matter when did you restart your phone :)

    Please download this simple control application? Does it work on your phone? Can you control the SBrick with this application?

    • 32 posts
    September 27, 2015 6:30 PM CEST
    [blockquote]Tamas Misik said:

    Dear Makar,

    Did you restart your phone after the firmware update? 

    [/blockquote] Hi Tamas Thanks for the advice! I did restart but not straight after updating. I updated about 2 weeks ago. Sorry to bother you, Makar
    • 3 posts
    September 27, 2015 6:05 PM CEST

    The firmware was updated on both SBricks with an IPad Mini.  So my android device was not involved in that process.

    • 164 posts
    September 27, 2015 1:09 PM CEST

    Dear Makar,

    Did you restart your phone after the firmware update? 

    This post was edited by Tamas Misik at September 27, 2015 1:09 PM CEST
    • 32 posts
    September 27, 2015 1:06 PM CEST
    So I installed it updated the sbrick firmware and it keeps saying 'error couldn't connect to sbrick it may have powered down or gotten out of range'
    I have a galaxy a5 and am really looking forward to a working app with no errors bugs or lag
    I got two sbricks for my birthday and will not be happy if it turns out being a waste of money
    • 99 posts
    September 23, 2015 5:45 PM CEST

    Hi Tamas,

    My phone is a Sony Xperia M4, Lollipop 5.0

    The tablet is a Galaxy Note 10.1, Kit-Kat 4.4.2

    Both devices have the same behavior with 1.7 :(


    • 164 posts
    September 23, 2015 1:58 PM CEST

    Hi Marc,

    The 1.7 verison was just a really small update in the android application. This isn't the new version.
    Our developers working on a tottaly new application which will be available soon :)

    But thanks for the bugreport. I don't see the main buttons on my phone (LG G3, lollipop) when I open a profil. What kind of devices do you have exactly? 

    • 99 posts
    September 22, 2015 11:49 PM CEST

    Hi all,

    I have upgraded both my phone (Lollipop) and  my tablet (KitKat) to v1.7. Just a short indoor test tonight, should be able to test outdoor this week-end (depending on the weather!).

    You guys forgot something when the app switches to full screen mode (i.e. when you launch a profile) : it's a real full screen until you touch the screen, then the top notification bar and the three Android main buttons come back. The bar and buttons should be deactivated, that's why we have the close button in the profiles, right ?


    • 178 posts
    September 22, 2015 4:29 PM CEST

    Chris, first of all, try the SBrick Simple Conrtol application. Tell me how's it going with that.

    However, if you've paired the SBricks, and then made the phone to forget them, you probably won't be able to connect to them again from the same device until you do a successful OTA update to firmware version 4.4 with a different device.

    Please try to acquire a different Androidphone, install SBrick Simple Control from the Play Store, connect to the SBricks and do OTA Update on them one by one.

    NEVER unpair a paired SBrick that has a firmware version less than 4.4. It can cause the SBrick and the phone to work together. This is beacause the old firmware stores certain information about paired devices, and this can interfere with future connections. Firmware 4.4 solves this problem.

    The phenomenon is described on this wiki page:

    • 3 posts
    September 22, 2015 2:22 AM CEST

    I am not sure that pairing first helped any.  As I was not able see the either SBrick in the App.  Once I told the phone to forget the Sbricks in the bluetooth settings, I was able to discover the Sbricks (line showing image and MAC address). However, I was not able to connect to them.  Received this error message: "Could not connect to Sbrick. It might have been powered down or gotten out of range."

    I am currently running SBrick App 1.7 Dated 9/17/2015 on a Motorola Droid Turbo (XT1254) with Android 5.1 standard non-rooted OS.


    This post was edited by Chris Henning at September 22, 2015 2:27 AM CEST
    • 178 posts
    September 21, 2015 10:15 AM CEST

    bachaddict: thank you for the feedback, yes we've also found that pairing can improve the situation, especially with Android 5.0.

    Marc, Chris: we've released bugfixes to the official SBrick application, please update your apps and see if there's any improvement. If there's no change, try the "SBrick Simple Control" application, it uses the BLE engine of the new application still in development.

    • 10 posts
    September 21, 2015 9:32 AM CEST

    My Android stopped working with the Sbrick a few months ago, until I recently tried pairing it with the Sbrick before connecting. 

    It's worth a try!

    • 3 posts
    September 20, 2015 4:01 PM CEST


    I have two SBricks via for my support the SBrick Kickstarter campaign.  When receivd them, I added one of them to my technic creations, I was very disappointed the interface on both the IPad and Android apps.  So much so that I threw both SBricks back in the box.  

    Today,  I found them again.  So I decided to see if things have improved.

    Using my Ipad Mini and Motorola Droid Turbo, I updated the SBrick software.  Using the IPad I was able to update the firmware on each of SBricks.  IPad interface is still outdated and not very intuitive. 

    The Andoird App is no better if not worst.  I can find the SBrick but I cannot connect to the SBrick, which mean I cannot test it any further right now. 

    It appears both of apps have been updated resently, which is great to see development is progressing.  

    Once I have played with both apps more, I will post more.  

    • 99 posts
    September 19, 2015 11:50 AM CEST

    [blockquote]Tamas Misik said:

    Our developers has rewrote the whole application...


    Excellent :)

    It's sometimes the best solution. v1 teaches a lot, to include the traps and mistakes to be avoided, then comes a time when you say "that's how we should have done it".

    Let's wait a bit, so, I'm sure it'll be worth waiting!


    • 164 posts
    September 18, 2015 4:56 PM CEST

    Hi Marc,

    The new application will be available wtihin 1-2 weeks. Our developers has rewrote the whole application... So far the results are very promising, but we still need to test a few things before the release ;)

    • 99 posts
    September 17, 2015 11:24 PM CEST

    Hi guys,

    It's been a while since we didn't get a new release... You have certainly worked on that during last summer and we are looking forward to testing a new version :)

    • 178 posts
    September 3, 2015 3:38 PM CEST

    Thank you, I'll try to figure out something.

    • 10 posts
    September 3, 2015 8:19 AM CEST

    I hadn't tried pairing before. After pairing the update got to 4200 bytes before failing. However, control finally worked.

    It was an iPhone 5, not sure on iOS version.

    • 178 posts
    September 2, 2015 3:32 PM CEST

    bachaddict: try to pair your Android device with the SBrick (but DO NOT unpair), and then try Simple Control again.

    What is your iOS version by the way?

    • 10 posts
    September 2, 2015 11:15 AM CEST
    Well this is great. The iPhone runs through the update, the Sbrick flashes its light, but the version stays 4.3.
    • 178 posts
    September 1, 2015 3:21 PM CEST

    Matej, thank you, good news.

    Indeed, sometimes (e.g. with certain phone vendors and OS versions) it is required to pair the SBricks to work properly.

    • 10 posts
    August 31, 2015 10:50 AM CEST

    I've had the same issue for months, over several updates - Sbrick visible, but no control at all. Sbrick Simple Remote finally gave me a clue when doing OTA  - it fails at 2400 bytes (tried 3 times). That means the main app's OTA was also failing, but never reporting it. Firmware 4.3, App 1.6.1, Simple app 2.3, Android 5.0.2 on 2013 Moto G.


    I will borrow an iPhone this week and see if I can get 4.4 on the brick.

    • 95 posts
    August 30, 2015 9:25 AM CEST

    Do you know when next version will be available (no update since 2 monthes)

    I am waiting for button bug fix (the motor is always turning in the same direction)

    Thank you



    • 99 posts
    August 28, 2015 10:22 PM CEST

    [blockquote]Tamás Fábián said:

    Thank you Marc! Could you please tell us what phone/table did you use, and what Android version do you have? Thanks!


    Sorry for my late reply, Tamas: got back to work this week :(

    I made the OTA firmware update with my Galaxy Note 10.1 LTE, Kit-Kat 4.4.2, Rooted

    • 5 posts
    August 28, 2015 7:27 PM CEST

    [blockquote]Tamás Fábián said:

    Oh! Sorry, I see you did. :)

    You can control BOTH SBricks separately, but not TOGETHER?

    If one of the CANNOT be controlled ALONE, then please see the steps linked above.

    If one of them CANNOT be controlled TOGETHER with the other, than we probably have a bug that is platform dependent. I'll try to figure out how does that happen.


    Thank you!


    Hi Tamás, sorry for late response. at first I was not able to control second S_Brick with OPO anyway.

    BUT now I can control boath S-Brick (alone and together) with OPO.

    After your last answer I try again steps described in the wiki page. I was switch on the BT and in application manager close all what looks like processes. Then restart device. did not help. I did it one more time but after restart I connect S-Brick in BT menu and after that I can control also second S Brick and also Update run smoothly.

    Before I connect S-Brick only at beginning, I think this is the key. Connect S-bric in BT menu and then open app every time.

    result is OPO, CM 12, Andriod 5.0,2 - all works fine.

    thx for your patience and advices.