Forums » Support

Back To Topics

Sbrick Plus notifications

    • 4 posts
    January 26, 2017 11:26 AM CET

    I have a similar question. I have the first SBrick, not the plus, and want to get notifications about battery and temperature.

    I have one SBrick with firmware 4.8. There I can send 0100 to handle 0x001b and I get notifications.

    On my other SBrick with firmeware 4.17 this does not work. Yesterday I upgraded to 4.18 but it is the same. I tried your suggestion and tried handle 0x001e that is the quick drive characteristic. Then I got this printout: "Notification handle = 0x001e value: 02 04 00 05 06 88 48 c9 58" but no notifications. I also tried to set the periodic voltage notifications with 2e0809, but I get no notifications.

    I have also tried this on a version 5.1 SBrick and that works like the 4.8 and notifications is working.

     

    Is it possible to get battery and voltage notifications on firmware 4.18?

    • 169 posts
    January 25, 2017 3:31 PM CET

    Hello Owen,

    you need to subscribe to notifications on the "quick drive" characteristic (489a6ae0-c1ab-4c9c-bdb2-11d373c1b7fb).

    Let me know wether this solves your problem or not.

    Cheers,

    Tamas

    • 2 posts
    January 25, 2017 11:41 AM CET

    Any news on this issue?

     

    Thanks,

     

    Owen

    • 310 posts
    January 15, 2017 12:55 AM CET

    [blockquote]Owen Dunn said:

    I'm trying to use the SBrick Plus from Linux, speaking the BLE protocol documented at https://social.sbrick.com/wiki/view/pageId/11/slug/the-sbrick-ble-protocol.

    I can use it as an ordinary SBrick to drive motors just fine, but I can't get it to send me notifications about the state of sensors, voltage, or temperature.

    I think I should be able to turn on notifications by sending 2c00 and then 2e00 to the Remote Control Characteristic to turn on periodic notifications of C1 on port 0.  Maybe (or maybe not) I need also to send to handle 0x001b 0300 to turn on notifications.

    However, I don't see any notifications.  What am I doing wrong?  Are notifications the right way to read sensor data from the SBrick Plus or is one supposed just to loop round sending the 0f Query ADC command?

    [/blockquote]

    Hello, 

    I have forwarded your question to the competent person! 

    Soon we will get back to you! 

    Regards, 

    Balint
    SBrick Team

    • 2 posts
    January 14, 2017 3:58 PM CET

    I'm trying to use the SBrick Plus from Linux, speaking the BLE protocol documented at https://social.sbrick.com/wiki/view/pageId/11/slug/the-sbrick-ble-protocol.

    I can use it as an ordinary SBrick to drive motors just fine, but I can't get it to send me notifications about the state of sensors, voltage, or temperature.

    I think I should be able to turn on notifications by sending 2c00 and then 2e00 to the Remote Control Characteristic to turn on periodic notifications of C1 on port 0.  Maybe (or maybe not) I need also to send to handle 0x001b 0300 to turn on notifications.

    However, I don't see any notifications.  What am I doing wrong?  Are notifications the right way to read sensor data from the SBrick Plus or is one supposed just to loop round sending the 0f Query ADC command?