Forums » Support

Back To Topics

SBrick iOS App

    • 4 posts
    February 10, 2015 4:08 PM CET

    I cant inverse my Motors in the App 3.6 Version. Using Iphone 6 with latest iOS. All in all, the Steering is inverse now and really confusing while using my Trial Truck... .^^ Please fix that. Thx.

    • 3 posts
    February 10, 2015 3:55 AM CET

    The more I try to fix it, the worse it gets.  3rd gen iPad, iOS 8.1.3.  When I first installed I could update firmware, visit the marketplace, apply profiles, but I could not change the picture for a model and any attempt to actually use a model just showed a blank background with no controls.  Port tester works.  Now deleted app, rebooted device, and reinstalled.  Now there are NO profiles (not even joystick or gamepad) and marketplace is completely empty.  Therefore I can't do anything at all.



    • 21 posts
    February 9, 2015 10:02 PM CET

    Tested SBRICK 3.6 on ipad mini (iOS 8.1.2)


    • app crashes on log-in but after re-start of app I am logged in.


    • cannot add background image. Menu offers me Camera or Photo library, but neither actually take me to Camera or Photo library!


    • successfully uploaded own profile (hurrah!). Which worked (double hurrah!!)


    More feedback to follow.


    Thanks so far.


    • 2 posts
    February 9, 2015 7:52 PM CET

    Tested SBrick App 3.6 on iPhone 5C (iOS 8.1.3)

    -SBrick crashes at Login. I restart my iphone, it's OK.

    -application crash when I add a new official LEGO set. It work when i add MOC.

    -my Private Profiles works, but public profiles will crash the app.


    For the Profile Designer :

    -not delete a profile

    -how to create a beautiful interface as the presentation Kickstarter "7939, 60052 Cargo Trains and SBrick" :

    -missing items such as headlights, turn signals, emergency stop ...

    • 11 posts
    February 9, 2015 12:26 PM CET

    Tested SBrick App 3.6 on iPhone 6 iOS 8.1.3:
    -app crashes at Login, after restart I seem to be logged in
    -I downloaded my profile from the market (there are now 4 profiles available: gamepad II, joystick & sliders, gamepad with buttons and my profile: Unimog U400; each in personal and public area)
    -when I try to add my profile to the moc the app crashes
    -the other profiles can be added to the moc

    I tried it again with a new profile:
    -this time I could add the profile and use it for steering
    -inverting channels doesn't work
    -there is no way to delete a profile or even reload an updated profile, I always have to delete and reinstall the whole app

    This post was edited by Philip Dreffkorn at February 9, 2015 3:51 PM CET
    • 28 posts
    February 9, 2015 11:31 AM CET

    I've just tried in the latest beta build 3.6(158), and had the same issue again.

    But then changed my password to remove an '&' and it was then accepted, though the app now crashes, but when you reload, you are actually logged in.

    I'm just compiling my feedback to the team with other issues.

    PS. 2 bricks ordered, and awaiting delivery, but assume my issues are not 'lack of bricks' related.

    • 5 posts
    February 9, 2015 11:01 AM CET

    [blockquote]Kalvis Rautseps said:

    When I click ≡ button there is a big reg button "LOGIN" when I write password and e-mail corectly it throws me out of the app.

    Any one else has this same think?



    I have the same problem....

    (iPhone 6 Plus with iOS 8.1.3)

    This post was edited by Beat Germann at February 9, 2015 11:02 AM CET
    • 28 posts
    February 6, 2015 9:34 PM CET

    [blockquote]Kalvis Rautseps said:

    When I click ≡ button there is a big reg button "LOGIN" when I write password and e-mail corectly it throws me out of the app.

    Any one else has this same think?


    Mine always says invalid email/password, so not sure what you are supposed to do, to login?

    • 4 posts
    February 6, 2015 7:51 PM CET

    When I click ≡ button there is a big reg button "LOGIN" when I write password and e-mail corectly it throws me out of the app.

    Any one else has this same think?

    • 13 posts
    January 30, 2015 7:10 PM CET

    [blockquote]Vassilis Aggelakos said:

    I upgraded the brick firmware from my iOS app (iphone 4S - iOS 7.1) and now the brick cannot start my motor.

    The brick is discoverable from the app so I believe is not dead though. I tried to switch off and turn on again with no luck.



    I had the same Problem with a few of my SBricks. I solved the Problem that way:

    - delete the SBrick APP

    - turn BlueTooth of

    - install the SBrick APP new.

    - turn BlueTooth on

    - Start the APP

    - Use the [≡] button in the upper left corner

    - tap on "Bricks"

    - now start the power for the SBrick

    - you will see a SBrick in the list

    - tap on the SBrick

    - I think the Sbrick wont' have any name (SmartBrick's name)

    - tap in the array and write a Name. To start without "&" or " " (space) would be a good idea. You can overwrite the name later.

    IMPORTANT: Be sure to complete your name with the "Return"-Button

    - tap on "Port tester"

    - wait a little moment until the "Connecting to bricks"-writing disappears (a few seconds)

    - now use the sliders an your brick should work

    Good luck!






    • 11 posts
    January 28, 2015 6:39 AM CET
    This was only related to the range of the SBrick. The description and Videos show a working a SBrick over much longer distances.

    I like the SBrick and its advantages. But this is one of the points that needs improvement. When it works fine I will order four more of them.
    • 10 posts
    January 27, 2015 11:46 PM CET
    Well, apart from being able to use your phone
    • 11 posts
    January 27, 2015 4:22 PM CET
    I have problems with the range too. Indoors I get a range of about 8m. This is also the limit of the IR Receivers at dark conditions. So there is almost no advantage when using SBrick.
    • 10 posts
    January 27, 2015 8:34 AM CET
    • 10 posts
    January 27, 2015 8:33 AM CET
    I have only two issues with the sbrick; 1 the app is scaled for the iPhone 5 and i have an iPhone 4s hoping there will be a version for the 4s. 2. The rang of my sbrick is only about 12 meters, little more than ir but a long way off 100m promised in the website. I hope you can find a fix to these problems
    Thanks Caoimhin
    • 23 posts
    January 26, 2015 9:29 PM CET

    Unfortunately, I'm experiencing a lot of connection problems lately. The App promps "Could't discover all bricks" a lot when trying to open a profile, causing the profile not to open. The weird thing is, all bricks respond to the port tester in the "Bricks" menu, so it looks like it's something in the App

    It also occurs in the port-assignment screen where you assign different fuctions of the profile to the ports of the bricks. And when I hit the Port-tester button there, sometimes the app crashes. This happens specifically with the brick that the app is having trouble to connect to.

    It mainly happens to mostly to one of the V4 prototypes I have. It does have updated firmware though. 

    This post was edited by Jurgen Krooshoop at January 26, 2015 9:44 PM CET
    • 4 posts
    January 22, 2015 11:06 PM CET

    I fixed my problem from earlier! The problem, which is posted somewhere above on this thread, was that the control profiles were invisible. I was still ues controls like joysticks, but was unable to see them. I fixed this by deleting and re-downloading the SBrick IOS app. It worked perfectly from then on! Hope this helps someone else who has this problem!

    • 21 posts
    January 22, 2015 10:33 PM CET


    I have just posted a short video of my LEGO Particle Accelerator working with my SBrick! Hurrah!

    Having to use the Port tester since I just need a simple forward/backward slider bar for variable speed control. Will await profile editor and make such a thing once it becomes available.

    Still no success with selecting a photo. Neither the 'Camera' nor 'Photo Library' buttons respond when trying to select a source for the image.

    Never mind...


    • 1 posts
    January 22, 2015 9:02 PM CET
    Hey everybody,

    I finally got to trying out my SBricks and I'm very much looking forward to playing around with it.

    Good work guys!

    Just one thing bothers me a little on the iOS app. It's scaled to the size of the iPhone 5 and upward, but on my iPhone 4s there is always something cut off on one side or the other. Can you try to have the app working "universal" for all iPhone screen sizes? It would be highly appreciated!

    Other than that I love SBrick already!

    By the way turning off Bluetooth seems to be the main trick... worked for me as well!

    • 36 posts
    January 22, 2015 4:37 PM CET
    Hi Conor,
    I can use my iPad2 (OS 8.1.2) with no such issues re loading custom pictures ot taking camera shots.
    What OS do you run?
    RST button means reset, it moves the corresponding slider to a neutral position, not sending signals to the controlled channel.
    Sliders should be driving the associated channel: up and down directions. Did you check, whether you have associated any control functions to the relevant channel in the profile? If there are no values selected (eg. Acceleration, Lighting, Index,etc..), the slider will not do anything.
    I hope it helps,
    Peter (BrickPower)
    • 21 posts
    January 22, 2015 2:23 PM CET

    Thanks, Philip.

    Does Port Tester just give on/off options, or do I use the sliders? and what does 'RST' mean? Is it supposed to be a button that responds to your touch? Mine don't...

    On my Ipad I CANNOT choose the pictures, no response from ither 'Camera' or 'Gallery' options.


    Any other advice from other users, please?



    • 11 posts
    January 22, 2015 1:52 PM CET
    You don't even need a profile. Tap the button at the top left of the start screen. There you choose "Bricks". Then connect to the SBrick and use the port tester. This should give you the options until the profile designer is available.

    The LED doesn't need to be activated.
    On my iPhone 6 I can choose background pictures.
    • 21 posts
    January 22, 2015 10:33 AM CET


    just connected to SBrick (after 4 or 5 attempts).

    Can I please ask:


    Do I need to have 'Indicator LED' switched 'ON' for SBrick to work?

    How do I add custom image to profile? When I select 'Camera' or 'Photo' there is no response from the app (Ipad Mini ios 8.1). Is this feature enabled?

    How do I make a custom profile to drive a single motor? I only want to vary the speed of a motor, and not have the joystick/control 'spring' back to zero when released. All i want it a simple 'power' slider. Is there such a simple profile, or do I have to wait until the profile editor is released before I can create one?


    Many thanks in advance.



    • 11 posts
    January 20, 2015 5:55 PM CET

    I have another Problem: when I start the App and choose a profile after a few days my phone can't find my SBrick. I have to delete the SBrick from the profile an add it again.

    iPhone 6, iOS 8.1.2, actual SBrick App and firmware

    • 11 posts
    January 17, 2015 5:23 PM CET
    Try to delete and reinstall the app from the App Store.