Forums » Support

Back To Topics

SBrick iOS App

    • 2 posts
    December 29, 2014 10:12 AM CET

    I have tested iphone 6 and ipad air2 (both IOS 8.1.2) and both can connect with my SBrick.

    Same experience about the bug (PF motor stop once the slider is at max. pos) from me.

    • 4 posts
    December 28, 2014 3:51 PM CET

    As Sebastian quotes

    [blockquote]sebastian madsen said: Hi.... i have an iPad air 2 With 8.1.2 iOS... But my iPad Can't find my Sbrick Wien i try to connect it... Then it's telling me that i have to wait for Bluetooth....[/blockquote]

    I have the same problem. Bleutooth cannot find the SBrick

    I posted this message on the Android part of the forum

    [blockquote]Yesterday I resived my SBrick.

    After powering on the SBrick the manual says the LED should turn on. I did not... I though is my SBRick broken.

    But after 2 times re-installing the App my Samsung S5 I was able to operate the SBrick.

    I found that the LED is working if your turn it on in the Manage Brick menu (identify led).

    I installed the SBrick on my 41999 and only profile Gamepad 2 was working, except the speed control was working reverse.

    I don't know who to reverse the output controls.

    The Joystick does not work at all and the steering profiles do not react very well.

    Gamepad 1 does not work at all, sometimes the app stoppes. Test 2 only shows 1 slider. So I probably have to re-install the app again..

    I also installed the SBrick app on our IPAD (software 6.1.3.) and IPOD but both cannot find the SBrick....[/blockquote]

    Is this related to the IPAD version (its an IPAD 2 software 6.1.3.)?



  • December 27, 2014 7:37 PM CET
    Hi.... i have an iPad air 2 With 8.1.2 iOS... But my iPad Can't find my Sbrick Wien i try to connect it... Then it's telling me that i have to wait for Bluetooth....
    • 57 posts
    December 27, 2014 5:06 PM CET

    The motor stop when slider reaches the maximum is a problem from the latest SW version confirmed by SBrick team in this forum. It will be fixed in the next version.

    This post was edited by Fernando Correia at December 27, 2014 5:06 PM CET
    • 1 posts
    December 27, 2014 4:03 PM CET

    Same problem here, app works ok untill you put one of The sliders to max, then motor stops. With The porttester The same, motors stop when sliders are at max.
    • 11 posts
    December 27, 2014 3:44 PM CET


    I got my SBrick today and have problems too. The LED of the SBrick can't be activated and the motor stops when I go with a channel up to maximum power, while the other motors keep running. Also the LEGO LED lights turn off when the slider is at maximum.

    I tested the SBrick with different batteryboxes (AA and AAA) and different cables. I think it is a software problem.


    The OTA function also doesn't work. The App crashes each time.


    Tested on iPhone 6 and iOS 8.1.2 

    • 1 posts
    December 26, 2014 12:37 PM CET



    've got my sBrick right in time for xmas, thx.

    I'm eager to write my own app to communicate with the brick. Is there any lib/api I can use provided or planned by u guys? Couldn't find any so far.




    • 2 posts
    December 25, 2014 7:45 PM CET

    Hi everyone,

    SBrick works perfectly unless when I hit the maximum power, all the motors shut down suddenly. Think this is a software problem (I have tried with a default battery box and with a battery from LEGO (8878) -- have the same bug).

    iPhone 4S

    iOS 6.1.3

    • 4 posts
    December 25, 2014 9:52 AM CET
    <--- little stupid

    Hav forgotten to asign the profile funktions to the different ports. ;-)

    Thanks, Tobias Fuchs
  • December 24, 2014 2:56 PM CET


    i second Conchas ost from Dec. 22nd. I got an SBrick yesterday and put in my 42030. However i could not make it run from the iPad app since no profile was in the market. I tried it again today with my iPhone 4S, and there is a profile for it. This makes it rather complicated. The profiles should be independent from controller platform.

    The second thing i ran into was the fact, that the function that once you hit the maximum power (slider to up most point) the motor stops. On the iPad app i could change this when creating a new profile, but i was not able to do this for a profile from the market (maybe i was to stupid to find it again).

    3rd issue: Creating a profile for more than 2 function didn't work on the iPad. i could add a joystick an a slider but making it work idependently was not possible. Is there a tutorial?

    So far for now - i should be able to explore the sBrick during the next days.

    Merry Christmas to all of you!


    • 57 posts
    December 24, 2014 2:28 PM CET

    Version 3.2 (15) / iPhone 5 / iOS 8.1.2


    This might be not a specific iOS problem, even if it is really a problem.
    But it is quite inconvinient at the minimum.

    I'm using SBrick prototypes v3 and v4.1.
    Recently I started to notice that connection to v4 is very hard to obatin when I start to work with my SBricks.
    After sometime I realized that usually when working with these I've my iPhone 5 and Android Tablet nearby. So I found that v4 keeps connected on the tablet and iPhone can't connect to it. The same does not happen with v3 which connects to iPhone promptly.

    The only solution I found to solve this, is to switch BT off in the tablet, so that I can have both SBricks on my iPhone and I can work with them.
    This might be related with some firmware differences between both.
    And I've not yet upgraded SBricks firmware via OTA, with the latest app version available on TestFlight. I'm afraid to lose them before the postman arrive with the definitive versions here...

    Other behaviors I found:

    - Very occasionally it gets not possible to connect to SBricks anymore. The only way I found to solve this is to kill SBrick app, swith BT off at iPhone, switch it back on and then launch the app again.

    - After sometime use, the connection is also prone to get lost quite often. Although reconnection is possible to do manually (doesn't reconnect automatically), to have better stability and longer connection periods I must kill app and swith BT off/on.

  • December 24, 2014 1:47 PM CET

    @Christian K. Check if you have set your ports in the profile settings menu correctly.

    • 4 posts
    December 23, 2014 9:36 PM CET

    I have a strange problem with my SBrick

    I can connect to it and the port tester is working.

    But if i load a profile (e.g. Gamepad 1 or 2) no motor is moving.

    Tried it on iPhone 6 and iPad Air. Have the same problem on both devices.

    • 57 posts
    December 22, 2014 10:47 PM CET

    Version 3.2 (15)
    iPhone 5
    iOS 8.1.2

    Had difficulties to connect one of my SBricks. Maybe because it was also connected to the Android app.But also the other one was, and it connected to iPhone app easily. Had to shutdown power off Android tablet (turnig BT off might have worked also).
    After this did not experienced anymore connection issues to the second SBrick (v4 prototype).
    Besides this issue SBrick connection seems a lot more stable in this version.


    I've in the market several profiles you made for me (3 for 8043, 2 for 8275).
    It was one for iPad Mini and another for iPhone 5. The 3rd for 8043, I think it was a correction that ended in a ne profile. I can't test with iPad Mini anymore.
    Since the names are identical this is quite confusing and testing is sometimes about trial and error to find the right profile.

    When I get the iPad Mini profiles by mistake, they are too large and can't close them. Need to kill SBrick app to recover control.
    Some do not show anything on screen anymore.

    I believe you should rethink the profile management concept.
    Better if can also have the same profile running on multiple devices, making it screen independent. Some automatic rescaling if possible/doable.
    Wonder how it will work when we get profile designer and thousands of users (yes, I said thousands :D) adding new profiles to the market everyday.
    Maybe they are available per user and only some pulished to everyone if the user so decides. Anyway they will grow "too much" to be easily manageable

    Also something that should be easy and fast to implement. Display the app version somewhere from the home menu.
    Just to make sure we easily know the version we are actually using.

    • 178 posts
    December 8, 2014 1:20 PM CET

    Hello Enrico,

    1-2) Official sets: yes, it's quite inconvenient and it doesn't make a lot of sense right now. This function will be replaced with something that's more useful and less annoying.

    3) Good idea! Actually we already planning to (going to?) include certain custom profiles for a few advanced models.

    4) Will investigate ;)

    Thanks for the feedback, and your offer. We're counting on you guys :)


  • December 8, 2014 1:13 PM CET
    Hi guys, how can delete wrong sets in the App?

    PS waiting for the Sbrick :-)

    • 4 posts
    November 16, 2014 10:00 AM CET
    While waiting for my SBricks...
    I downloaded the iOS app and have some suggestions about it:
    1) Please add some filters for official sets selection...
    I think even only production year and Theme filters could be enough to shorten list while searching
    2) Please add Set number to the set name (or as searchable field)... For many sets the official name isn't so popular and, most of all, official English names have been translated in many countries.
    3) I suggest to add a 3rd party MOC section to the market or the add-Profile screen. Once the SBrick will be officially released, I'm quite sure many "famous" MOCs will be made compatible (i.e: Sariel's, Paul Boratko's, Sheepo's and Jurgen's ones).
    4) IMHO, the steering wheel gyro graphics have to be changed/inverted: now the internal (brighter) graphics rotate accordingly to the steering movement, while the external (darker) circle follows phone movement... But this is disorienting... I think It would be better if the internal part would stay leveled with the ground (like an airplane level indicator).

    Go on with the good work, anyway.
    Should you need some help in developing/testing interface usability, I'll be happy to give support.
    • 178 posts
    November 6, 2014 10:36 AM CET

    The app in the AppStore is rather old. We've sent an upate recently and it's under review. It should be out in a week.

    • 10 posts
    November 5, 2014 11:49 PM CET
    The profiles that dont download are: Sariels Tank v0.3, 42030 Profile v1.7, Tank profile v0.2, sheepos profile v1.0 and jurgens 8043 v1.1. Could you give me your email address or something, i cant send pics from my iPhone
    • 178 posts
    November 4, 2014 12:37 PM CET

    The Android app is also nearly completed. Beta testers can access it this week with a bit of luck, the general public will be able to download it probably two weeks after the beta release (I'm sure we have to fix a few stuff here and there).

    • 12 posts
    November 4, 2014 12:30 PM CET

    What a pitty!

    I'm an Android user too.

    Have you date for a first android release?


  • November 4, 2014 11:53 AM CET
    Ok... thanks.... but I use android... so i have to wait a little more? :) ....
    • 178 posts
    November 4, 2014 11:07 AM CET

    Hi, the app is available for Apple devices from the App Store, you can download and try it right now. The curret version out is an old one, the most up-to-date version is currently under review by Apple.

    • 12 posts
    November 4, 2014 9:56 AM CET


    I was wondering if we can download yet the sbrick app from somewhere, because Caoimhin Marsh has downloades it the first of november. 


  • November 3, 2014 10:05 PM CET

    I've been reading that some people have downloaded the sbrick app..... Is the app official released or do we have to wait a little more..... I'm asking because i can't find the app at the apple store or googleplay :)