Forums » Support

Back To Topics

SBrick iOS App

    • 5 posts
    March 26, 2015 12:44 AM CET

    How do I sign into my account here through the App on my ipod touch..? I am trying to download my created profile that I designed..

     

    I don't see anywhere on the App to login at..???

    • 34 posts
    March 24, 2015 3:50 PM CET

    1. You're using the correct aspect ratio? It's 16:9 for iPhone 5 & 6, and 4:3 for iPhone 4S and iPad.

    2. As I mentioned before:

    [blockquote]Zsolt Majoros said:

    The version number is missing in the 4.1 fw version, it's a known bug, will be fixed in the v4.2 firmware.

    [/blockquote]

    • 8 posts
    March 23, 2015 8:33 PM CET

    [blockquote]Zsolt Majoros said:

    [blockquote]zver hz said: [blockquote]Zsolt Majoros said:

    [blockquote]zver hz said: How can I update the app to version 3.7? There is no link in my testflight enviroment. I use 3.6.3 version now, when I try to look sbrick properties, I see just zeros.[/blockquote]

    You got the invitation to your @mail.ru e-mail address:

     

    [/blockquote] I follow the link in email, open TestFlight and see: "You aren't currently testing any apps. To accept an invitation you must tap the link in the invitation email." Could you please forward me the invitation one more time? May there is something wrong with the link. [/blockquote]

    What email client are you using? There is an interesting bug with testflight, you can't open the invitation link in 3rd party apps, only in the official mail app on iphone/ipad.

     

    I invited everybody from the beta tester signup form now.

    [/blockquote]

    Thanks for advise. I've opened the link from native ios mail app successfully. So my current configuration is: iOS 8.2 SBrick App version 3.7.1 (build 310).

    1. I can use public profile to control my SBrick. But I still can't download my profile.

    2. I've tried to update the SBrick firmware. The process has gone smooth. Then I've switched the SBrisk off and on. And I see no information about SBrick in the App: hardware and firmware version are 0.0, battery level is 0.00V... What is wrong?


    This post was edited by zver hz at March 23, 2015 8:34 PM CET
    • 34 posts
    March 23, 2015 12:17 PM CET

    The version number is missing in the 4.1 fw version, it's a known bug, will be fixed in the v4.2 firmware.

    • 5 posts
    March 23, 2015 11:57 AM CET

    Hi

    I've 2 sbrick and an ios device. When i make the fw upgrade, it seems to work fine but i can't read a version number of fw after .. Is it normal ?

    The 2 bricks works fine on my ultimate 42009 and i'm now happy :=).

     

     

    • 34 posts
    March 23, 2015 9:37 AM CET

    I can invite an e-mail address only once, the testflight says you have been already invited.

    Interesting, maybe you could give me an other e-mail address.

     

    By the way, there is the same version in the app store (3.7.2) at the moment.

    • 28 posts
    March 21, 2015 11:51 PM CET

    Have you re-sent any invitations?  I haven't received anything from you.

    • 34 posts
    March 18, 2015 1:29 PM CET

    [blockquote]william zhang said:

    [blockquote]Zsolt Majoros said:

    [blockquote]Tull Clancey said:

    Could you please send/re-send my invitation?  I can't see that I've received one.

    [/blockquote]

    The invitation sent to your ...@thebottomofthesea.co.uk e-mail address, should I invite another one?

    [/blockquote]

    Yes, please send me the invitation email, tks

    [/blockquote]

    please give me your e-mail address, or sign up here: http://goo.gl/rjL7t2 

    • 1 posts
    March 18, 2015 1:24 PM CET

    [blockquote]Zsolt Majoros said:

    [blockquote]Tull Clancey said:

    Could you please send/re-send my invitation?  I can't see that I've received one.

    [/blockquote]

    The invitation sent to your ...@thebottomofthesea.co.uk e-mail address, should I invite another one?

    [/blockquote]

    Yes, please send me the invitation email, tks

    • 34 posts
    March 18, 2015 12:30 PM CET

    [blockquote]Tull Clancey said:

    Could you please send/re-send my invitation?  I can't see that I've received one.

    [/blockquote]

    The invitation sent to your ...@thebottomofthesea.co.uk e-mail address, should I invite another one?

    • 28 posts
    March 18, 2015 11:46 AM CET

    Could you please send/re-send my invitation?  I can't see that I've received one.

    • 34 posts
    March 18, 2015 11:36 AM CET

    [blockquote]zver hz said: [blockquote]Zsolt Majoros said:

    [blockquote]zver hz said: How can I update the app to version 3.7? There is no link in my testflight enviroment. I use 3.6.3 version now, when I try to look sbrick properties, I see just zeros.[/blockquote]

    You got the invitation to your @mail.ru e-mail address:

     

    [/blockquote] I follow the link in email, open TestFlight and see: "You aren't currently testing any apps. To accept an invitation you must tap the link in the invitation email." Could you please forward me the invitation one more time? May there is something wrong with the link. [/blockquote]

    What email client are you using? There is an interesting bug with testflight, you can't open the invitation link in 3rd party apps, only in the official mail app on iphone/ipad.

     

    I invited everybody from the beta tester signup form now.

    • 28 posts
    March 17, 2015 12:02 PM CET

    I also haven't yet received the email for test flight.

    • 5 posts
    March 14, 2015 6:31 PM CET

    Where do I get the updated APP..? I am still using the one from the test period from last August and it doesn't seem to want to work with the new Sbrick..

    • 8 posts
    March 13, 2015 6:39 PM CET
    [blockquote]Zsolt Majoros said:

    [blockquote]zver hz said: How can I update the app to version 3.7? There is no link in my testflight enviroment. I use 3.6.3 version now, when I try to look sbrick properties, I see just zeros.[/blockquote]

    You got the invitation to your @mail.ru e-mail address:

     

    [/blockquote] I follow the link in email, open TestFlight and see: "You aren't currently testing any apps. To accept an invitation you must tap the link in the invitation email." Could you please forward me the invitation one more time? May there is something wrong with the link.
    • 28 posts
    March 12, 2015 12:08 PM CET

    I sent in my request for the test flight install, I got the mail advising how to install Test Flight and wait for the email with the download link, but I didnt' get a download link.  Is it possible for you to send it again?

     

    Thanks.

    • 34 posts
    March 12, 2015 9:51 AM CET

    [blockquote]zver hz said: How can I update the app to version 3.7? There is no link in my testflight enviroment. I use 3.6.3 version now, when I try to look sbrick properties, I see just zeros.[/blockquote]

    You got the invitation to your @mail.ru e-mail address:

     

    [blockquote]Stefan Heumann said:

    Updated to v3.7 without problems. Software works fine (iPhone4S and iPod5G with new iOS 8.2). Now I can see my own profile, download and optionally also be deleted. Extensive tests follow this weekend with 4 SBricks.

    Do I have to update the SBricks with this software?

    [/blockquote]

    All SBrick iOS version works with all firmware, but its recommended to keep the brick's firmware up-to-date, every firmware update contains improvements.


    This post was edited by Zsolt Majoros at March 12, 2015 9:52 AM CET
    • 8 posts
    March 10, 2015 6:26 PM CET
    How can I update the app to version 3.7? There is no link in my testflight enviroment.
    I use 3.6.3 version now, when I try to look sbrick properties, I see just zeros.
    • 95 posts
    March 10, 2015 12:32 PM CET

    I am using fedora 18 with bluez-4.101 where gatttool is included or fedora 21 with bluez-5.23 without gatttool :-(

    (I finaly found a package with it :-) I also had to install python-mtTkinter. I will try on CentOS 7

     


    This post was edited by Frederic Ayrault at March 10, 2015 12:32 PM CET
    • 87 posts
    March 10, 2015 12:13 PM CET

    [blockquote]Frederic Ayrault said:

    When I use your tool I get SBrick Hw: 4.0 and SBrick Fw: 4.1. But I still can not get temperature end voltage informations (00.0°C and 0.0 V) (to use your tool with 4.1 I had to add a elif for 4.1 in sbrick.py)

    [/blockquote]

     

    Thanks. That confirms my first idea, 4.1 fw doesn't expose temp or volt. I never included 4.1 in the python code because I wasn't really sure. I have to modify the code to treat 4.0 and 4.1 as two of the same kind.

    Just curious, what linux distro are you using? Any kind of troubles with the python scripts or with the bluetooth connection?

    • 95 posts
    March 10, 2015 11:21 AM CET

    [blockquote]Jorge Pereira said:

    Did you power off the SBrick after the udpate?

    I read another post where you used my tool... when you say here "hardware and firmware version are 0.0, battery level is 0.00V and devide id is (null)" you are refering to another tool, like Nordic, right? What does my tool show at command line (after power cycle the SBrick)?

    [/blockquote]

    First of all I want to thank you for your tool and your help.

    Yes I powered off the SBrick.

    For the versions and level informations I get them from the Brick settings form the ios app

    When I use your tool I get SBrick Hw: 4.0 and SBrick Fw: 4.1. But I still can not get temperature end voltage informations (00.0°C and 0.0 V) (to use your tool with 4.1 I had to add a elif for 4.1 in sbrick.py)

     


    This post was edited by Frederic Ayrault at March 10, 2015 12:32 PM CET
    • 87 posts
    March 10, 2015 11:08 AM CET

    Did you power off the SBrick after the udpate?

    I read another post where you used my tool... when you say here "hardware and firmware version are 0.0, battery level is 0.00V and devide id is (null)" you are refering to another tool, like Nordic, right? What does my tool show at command line (after power cycle the SBrick)?

    • 95 posts
    March 10, 2015 10:59 AM CET

    I am tring to update the firmware of a SBrick using 3.6.3 version. I just have update (4.10) option even after the update

     

    After the update , hardware and firmware version are 0.0, battery level is 0.00V and devide id is (null)

     


    This post was edited by Frederic Ayrault at March 10, 2015 11:02 AM CET
    • 12 posts
    March 10, 2015 9:19 AM CET
    SBrick® app 3.7 works good, as far as I can see.

    At least my 8043S is working again with the "Jurgens Excavator v5.5" control-profile from the public profiles market!
    • 8 posts
    March 6, 2015 9:38 PM CET
    [blockquote]Stefan Heumann said:

    Hi,

    thanks you for sending me the link for testflight and the beta-sbrick v3.6.3. Now I have a few problems less! LogIn works, now I can load profiles from the market. But my own profiles I can not always see. Guys, keep up!

    Many greetings
    Stefan

     

    [blockquote] Hi! I've got the same problem: I can't load my own profile. - Ipad mini ios 8.1.3 Sbrick app version 3.6.3 (build 204)
    This post was edited by zver hz at March 6, 2015 9:39 PM CET