Forums » Support

Back To Topics

SBrick iOS App

    • 3 posts
    March 13, 2016 8:18 PM CET
    The problem is Apple Watch.
    If is in airplane mode The sbrick work correctly...
    This post was edited by luca pradella at March 13, 2016 8:19 PM CET
    • 3 posts
    March 11, 2016 10:44 AM CET
    The setting is correct.
    iPad use a 42030 4:3 profile
    iPhone a 16:9 profile.
    I view The setting of sbrick The temperature ecc. but the led not flash is fixed and the port test not to Be a results
    • 310 posts
    March 11, 2016 10:28 AM CET

    [blockquote]luca pradella said:

    With air ipad 2 is working correctly, but with 6s iphone is recognized sbrick but does not respond to any commands .
    How can I do?

    [/blockquote]

     

    Hello, 

    Could you give us more details about the problem? 
    Could you open the profile? Did you set the ports and profile? 

    Regards, 

    Balint Mezei - SBrick Team 




    • 3 posts
    March 10, 2016 11:24 PM CET
    With air ipad 2 is working correctly, but with 6s iphone is recognized sbrick but does not respond to any commands .
    How can I do?
    • 310 posts
    February 27, 2016 1:04 AM CET

    [blockquote]TheRebricker von Innerebner said:

    [blockquote]Tamas Misik said:

    Hopefully it will availabe within a few weeks. Thanks for your patience.

    [/blockquote]

    Is there an expected date on the iOS update that will support Sequence?

    [/blockquote]

     

    Hi, 

    We cannot specify an exact date yet, but it will be available soon. 

    Best wishes, 
    Balint Mezei - SBrick Team 

    • 5 posts
    February 26, 2016 8:00 PM CET

    [blockquote]Tamas Misik said:

    Hopefully it will availabe within a few weeks. Thanks for your patience.

    [/blockquote]

    Is there an expected date on the iOS update that will support Sequence?

    • 164 posts
    February 1, 2016 12:34 PM CET

    Hello guys.

    Currently only the latest Android application supports the Sequence and Clinometer controls. But don't worry. Our developers already work on the iOS version too. Hopefully it will availabe within a few weeks. Thanks for your patience.

    • 13 posts
    January 28, 2016 9:09 PM CET

    [blockquote]Ronny Wagner said:

    Hi

    I am trying to make a profile with a Sequence.

    I want to create a flashing LED.

    Everything work well in in profile Designer

    and i can add the profile to my creation but when a start my creation to controle my Sbrick

    then nothing happens. (The cration do not want to start)

    But if i take a way the Sequence in the profile then i can start it on then Iphone (but then i dont have the flashing light :-( )

    I have a Iphone 6 Plus

    BR

    Ronny

    [/blockquote]

    Same at my iPhone. It's so annoying. I couldn't wait for the flashlights and now the don't work!

    • 5 posts
    January 27, 2016 10:33 PM CET

    [blockquote]Ronny Wagner said:

    I am trying to make a profile with a Sequence.

    I want to create a flashing LED.

    Everything work well in in profile Designer

    and i can add the profile to my creation but when a start my creation to controle my Sbrick

    then nothing happens. (The cration do not want to start)

    But if i take a way the Sequence in the profile then i can start it on then Iphone (but then i dont have the flashing light :-( )

    I have a Iphone 6 Plus 

    [/blockquote]

     

    I too am having this issue. It seems the iPhone app doesn't yet support the Sequence control. That is one feature I am waiting for as well.

    • 1 posts
    January 27, 2016 5:35 PM CET

    Hi

    I am trying to make a profile with a Sequence.

    I want to create a flashing LED.

    Everything work well in in profile Designer

    and i can add the profile to my creation but when a start my creation to controle my Sbrick

    then nothing happens. (The cration do not want to start)

    But if i take a way the Sequence in the profile then i can start it on then Iphone (but then i dont have the flashing light :-( )

    I have a Iphone 6 Plus

    BR

    Ronny

     

     

     

     

     

     

     

     

     

    • 164 posts
    January 9, 2016 12:16 PM CET

    Frank,
    Are you sure that you use the latest version of SBrick application?
    https://itunes.apple.com/us/app/sbrick/id897834246?mt=8


    Thias,
    The
    SBrick uses the new BLE (Bluetooth Low Eneregy). Only the BT. 4.0 chips support the BLE, so as you wrote: " the chip inside the brick is not able to communicate via the old protocols." This is the reason why you can't use you iPhone 3gs.

    • 7 posts
    January 8, 2016 1:39 PM CET

    Ok, so you know more than me regarding the BT technologies, I never go that deep into this tech. I'm a software developer in switzerland, and made already some mobile apps, but unfortunately never done something with BT, so my knowlegde about BT is quiet poor.

    I think it's time that someone of the SBrick guys take care about your problem, they should be able to explain if its possible to implement both protocols...

    I just give you an answer to your post(s) because I had the same issue than you... :-(

    For me, all is working fine, exept the ratio-issue, but I can live with it.

    My son is happy as hell with his lego-model...

    I hope, they can help you, good luck !

    Regards Frank

     

    • 3 posts
    January 8, 2016 1:08 PM CET

    I did a bit of reading. The BT4.0 chips can communicate with the oder BT versions. There wouldn't be a problem for the new phones to connect to the brick would it only support the old 2.1 BT protocols. But it is impossible to old phones to communicate via the new 4.0 protocols of course. So it was a design decision to not use the old protocols (that would make it possible for old and new phones to connect the brick) but to use the new 4.0 protocols only.

    There might be resonable facts to make that kind of decision of course. The new protocols seem to save energy for better battery life. (I would not care about that) Or maybe the chip inside the brick is not able to communicate via the old protocols. Or ist simply the fact that it would be necessary to do all teh work twice, once for 2.1 BT and once for 4.0?


    This post was edited by Thias Thias at January 8, 2016 1:09 PM CET
    • 7 posts
    January 8, 2016 12:29 PM CET

    Hi Thias

    It's not a "wrong" BT chip, it's more the old BT-technology, the Iphone 4S (and upwards of course) have the new chip with BT 4.0. I don't would say, that this is a bad design decision, because they had to decide to go for the old BT tech, or the new one...

    I'm also a "daddy", and my 10 year old son plays with the sbricks (btw: with the lego model 42009) and I understand your statement, but I think, there are waaay more "adult"-players, who want to use their own phone/tablets, I think no one of those would buy a sbrick, if they don't work with the newer devices !

    I have an android device for myself, and can't get to work with it, so I bought an "old" Iphone from a friend, and I checked therefore the requirements and found out that the 4S is the first Iphone with BLE/BT4.0...

    So, I'm not 100% sure about your 3GS, maybe someone of the Sbrick-Team can confirm this...

    • 3 posts
    January 8, 2016 11:27 AM CET

    I was not able to get it to work. Just installed the app. The next step would be to add a profile, that did not work. The next step after that would be to connect to the brick. What you say is, that will not work because the 3gs has a wrong BT chip? Now that would be a nice example of bad design decision in my eyes... What would be better suited for a remote controller than an old cheap smartphone? I sure wont give my new 600 Euro IPhone into the hands of my 5 year old son to play with... 

    • 7 posts
    January 8, 2016 9:00 AM CET

    Hi Thias, I had/have the same issue with my Iphone 4S, they set the wrong ratio for the Iphone... I made a profile in 16:9, and then I could see/use it. It's a bit "squeezed", but it works...

    Tamas told me on 24. Nov 2015, the ratio bug will be fixed "within a few days", so I don't believe it will be fixed until next year. :-(

    However, I'm wondering, how you managed it to get it work with your 3GS, according the specs of your Iphone 3GS, it don't have BLE (Bluethooth Low Energy, also known as BT 4.0)

     

    • 3 posts
    January 7, 2016 5:42 PM CET
    I can not see any profiles I made for my iphone 3gs. Whats might be the problem? (Aspect ratio is set to 3:2)
    When klicking on "market" the list is empty, too.
    This post was edited by Thias Thias at January 7, 2016 5:45 PM CET
    • 3 posts
    December 15, 2015 4:43 PM CET

    So when can we expect the motion controlled/gyroscope features to come back to the profile market/potentially the designer? I know we can now create our own control profiles, but the feature to be able to control creations using the gyroscope has been gone for a while. I was just wondering because it was my personally favorite feature that made things easier to control. Hope to hear back soon, thanks.

    • 7 posts
    December 1, 2015 9:34 AM CET

    [blockquote]Tamas Misik said:

    Thanks for the report.

    It will be fixed in the new version which will be availalbe within a few days.
    The iPhone4s screen ratio bug with the custom profiles also fixed. 

    [/blockquote]

    Hi Tamas

    Any expected release date for the new version ?

    Frank

    • 5 posts
    November 24, 2015 6:03 PM CET

    Hello Tamas,

    i have an ipad mini 4 with IOS 9.1 and cant select an image for my own creations.

    wenn i tab Select image, the app ask for camera or Photo library, but nothing happens wenn i select one of this.

    On the Android app it works fine.

     

     

     

    • 164 posts
    November 24, 2015 12:47 PM CET

    Thanks for the report.

    It will be fixed in the new version which will be availalbe within a few days.
    The iPhone4s screen ratio bug with the custom profiles also fixed. 

  • November 22, 2015 1:53 AM CET

    [blockquote]Tamas Misik said:

    Dear Sascha and Mark,

    We will fix it. Thanks for the report! :)

    [/blockquote]

    Hello Tamas,

     

    In App Version 3.12 Build 492 it is not fixed.

    Login with an e-mail adress with +-Sign does also not work.

    • 164 posts
    November 20, 2015 9:41 PM CET

    Hello Casper,
    Yes, it's a know bug in the iOS 8.3.

    The apple fixed it in the newer iOS versions, so if you update to iOS 9 you will able to update the SBrick's firmware.
    But don't worry, if you use iOS even the oldest SBricks firmware works perfectly. We just updated the SBrick's firmware because the Android :)

    • 2 posts
    November 20, 2015 5:54 PM CET
    Hello,

    I just purchased two new sbricks and wanted to check if my two original sbricks (purchased during the initial release last year) were up to date with their firmware. On both my iPad Air2 and iPhone 6 the app tells me that a firmware update is not possible with iOS 8.3. Is this a known problem?
    • 164 posts
    November 4, 2015 12:08 PM CET

    [blockquote]D Han said: Hi Steffan, Thanks for the info as I need to confirm because https://social.sbrick.com/wiki/view/pageId/12/slug/application-device-compatibility only listed up to iOS 8. Cheers DHan[/blockquote]

    Thanks for the report. I have updated the list :)