Forums » Support

Back To Topics

SBrick iOS App

    • 2 posts
    May 22, 2015 1:43 PM CEST
    hello I bought 2 sbricks but I can not use them I have a ipad3
    no firmware no joystick nothing......................????
    This post was edited by pepu pepu at May 22, 2015 1:45 PM CEST
    • 57 posts
    May 20, 2015 7:10 PM CEST

    Sorry! I meant can't (did already update the original answer).

     

    • 2 posts
    May 20, 2015 5:54 PM CEST

    Problem here is that we still can share Profiles among users, i.e. make them public, and a Profile is a webservice so we can't download it as a file and send to someone else.

    Can or cannot - share profiles..?

    When I have a look to the Apple Appstore regarding the sbrick app, I can see in the screenshots a profile named "Joystick". The discription is: "Generic joystick controller with gyro sensors". But when I'm loged in with my 4S and go to market place, there is no joystick profile that gives me this function.

    Ulrich

     


    This post was edited by Ulrich Hils at May 20, 2015 7:33 PM CEST
    • 57 posts
    May 19, 2015 1:16 PM CEST

    [blockquote]Ulrich Hils said:

    Can somebody else upload a public profile, which will work with a iPhone 4S?

    [/blockquote]

     

    Problem here is that we still can't share Profiles among users, i.e. make them public, and a Profile is a webservice so we can't download it as a file and send to someone else.


    This post was edited by Fernando Correia at May 20, 2015 7:08 PM CEST
    • 2 posts
    May 19, 2015 11:05 AM CEST

    I really like controlling a MOC by using the joystick profile, where you can use the sensors of the phone. But I'm not able to find a public profile for my iPhone 4S, that will give me the opportunity to control my MOC this way. I tried to create it by myself...., but..., well... god gave me a brain but missed that part which is usually used to do programming stuff... :-)

    Can somebody else upload a public profile, which will work with a iPhone 4S?

    Thanks a lot!

    • 1 posts
    May 17, 2015 9:09 AM CEST

    Hi : 
    I can't login on my ios today . If any trouble on server today?

    • 23 posts
    May 12, 2015 10:38 AM CEST

    The profile won't connect to the Bricks anymore. Everytime I open the profile to controol my MOC, I onlt see 2 red-SBricks on the screen. In previous versions this worked.

    And OTA doesn't seem to work. After I do the firmware update, it still says is has V0.0. After OTA of my android phone, it does say V4.2.

    But even with frimware 4.2, the profile still won't connect to the SBricks.

    Currently, the Android app works better than the iOS app. Now I CAN controll my 2-SBrick moc with my Sony phone, but NOT with my iPod (iOS 8.3).

    The fact that working functions stop working regularly worries me.

    • 33 posts
    May 1, 2015 2:52 PM CEST

    Hi,

    I have installed the latest app from appstore on my iPad2 (latest iOS), updated the application, but still having the following issue:

    When I create a profile, I can not add an image: when I click on "Select Image", I get the prompt for "Camera" or "Photo Library", but then nothing happens.

    Also, I can not see "Sbrick" on the list of my applications in the "Settings", so I can not change the privacy settings either (if that would be the reason).

    Everything works beautifully otherwise and I experience no such behaviour on my iPhone 4S (same app, same iOS).

    Please advise. 

    Thanks a lot!

    Peter


    This post was edited by Peter Subert at May 1, 2015 2:53 PM CEST
    • 34 posts
    April 28, 2015 10:00 AM CEST

    [blockquote]Stefan Heumann said:

    Hello,

    tried to start SBrick-App (v3.7.1, over TestFlight) on my iPhone4S (iOS 8.3) but now the App has expired. How do I renew the app, or do I now need to load the app from the Apple Store?

    [/blockquote]

    Hi!

    You can download the latest SBrick iOS application (3.7.2) from the App Store.

    https://itunes.apple.com/us/app/sbrick/id897834246

    There are no beta preview build available at the moment.

    • 34 posts
    April 28, 2015 9:58 AM CEST

    [blockquote]F V said:

    [blockquote]Zsolt Majoros said:

    Hi!

     

    After the iOS 8.3 update we noticed that the OTA in the SBrick application stopped to work.

    We made some tests with earlier iOS versions, and it seems like a new iOS bug (probably because of the support of apple watch).

    We'll continue searching a workaround for this problem, but it should be fixed by Apple.

     

    [/blockquote]

     

    OTA update didn't work before iOS8.3, so I guess the apple watch support doesn't really have anything to do with it.

    Before it was the same thing, there is a 'loader' in screen, at the end of the loader the update is completed (that is what the screen says anyway), but nothing seems to have changed. So initially I thought maybe the update had worked, but it just didn't show the firmware version and such.

    [/blockquote]

    Which iOS and app version did you try with?

    We tested with iOS 8.1 and iOS 8.3 on more devices with the same SBrick, and it works with 8.1, but doesn't work with 8.3, so something obviously changed in the OS.

  • F V
    • 2 posts
    April 28, 2015 9:16 AM CEST

    [blockquote]Zsolt Majoros said:

    Hi!

     

    After the iOS 8.3 update we noticed that the OTA in the SBrick application stopped to work.

    We made some tests with earlier iOS versions, and it seems like a new iOS bug (probably because of the support of apple watch).

    We'll continue searching a workaround for this problem, but it should be fixed by Apple.

     

    [/blockquote]

     

    OTA update didn't work before iOS8.3, so I guess the apple watch support doesn't really have anything to do with it.

    Before it was the same thing, there is a 'loader' in screen, at the end of the loader the update is completed (that is what the screen says anyway), but nothing seems to have changed. So initially I thought maybe the update had worked, but it just didn't show the firmware version and such.


    This post was edited by F V at April 28, 2015 9:17 AM CEST
    • 34 posts
    April 27, 2015 6:21 PM CEST

    Hi!

    After the iOS 8.3 update we noticed that the OTA in the SBrick application stopped to work.

    We made some tests with earlier iOS versions, and it seems like a new iOS bug (probably because of the support of apple watch).

    We'll continue searching a workaround for this problem, but it should be fixed by Apple.

     

    • 1 posts
    April 24, 2015 10:12 PM CEST
    Hi, ich habe die SBRICK IOS 3.7.1 version und das Problem das die App beim öffnen von selbser wieder schliest! Auf iPad und iPhone. Also im moment nicht nutzbar. Wer kann mir Helfen
    • 9 posts
    April 22, 2015 11:15 AM CEST

    I tried to update my SBrick today and had the same problem as Allan 

    I tried with both an iPhone6 and an iPhone4S both with the latest version of iOS

    Initially the firmware info fields are all blank.
    I do the upgrade, and it says is completed successfully.
    I restart the SBrick,  and Bluetooth on the phone
    I go back into the Brick info, and the firmware info fields are still blank.

    • 8 posts
    April 14, 2015 11:02 AM CEST
    A few nights ago i have tried to update the 9 Sbricks that i own
     
    I just bought an Ipad Mini today, and have installed the latest Sbrick IOS version 3.7.2 (build 313). so far so good. App works fine, my preliminary Ropa profile i have made myself works. 
     
    I have then tried to update all the Sbricks i have, but i am a bit confused.
     
    I have 2 Sbricks that i have FW updated a long time ago, and they both show all the infos about FW version, and device ID. The FW version is 4.2   The LED lights constantly, when powered as they should. no problems.
     
    I then have 2 Sbricks where the LED lights constantly, but no info is shown in the Brick settings. When i attempt to update the FW, it says that i can update to 4.10. It starts updating, goes fairly fast, the LED blinks. It prompts that the udate was a success. If i then turn of the Bluetooth on the Ipad, and returns to the FW update, i then again get the red bar saying “UPDATE (4.10)”. So was the Sbrick then updated at all ???
     
    Then i have 5  sbricks, which i have all tried to FW update, but none of the gets the LED to light constantly after the FW update, and after the same procedure as the 2 Sbricks above, I then again can update to 4.10 just after having just updated them.
     
     
    So what is the current FW update 4.10 or 4.2?
     
    And am i doing something wrong?
     
    I am running iOS 8.2 updated just today.

    This post was edited by Allan Clausen at April 14, 2015 11:02 AM CEST
  • F V
    • 2 posts
    April 8, 2015 2:12 PM CEST

    [blockquote]Paul Nieuwkamp said:

    - OTA firmware upgrade works. I think... I don't know which version is installed on the sbricks shipped to me from the kickstarter, but the one sbrick I updated and the two I didn't show identical results: 0%, Last connect: never, hardware version 0.0, firmware version 0.0, battery level 0.00 V, device ID (null). The app does recognize which sbrick I've attached, correctly distinguishing between Huey, Dewey and Louie (Tiki, Niki, Viki). So for me there is a lot more missing than just the version number in fw 4.1 :) Unless ofc. the sbricks I received months ago already had 4.1?

    [/blockquote]

    same here, upgrade runs, after updating it says 'update complete' , I turn bluetooth off, and then on, it sees the brick again, but still no version info.

    Does this mean the update worked or not? the brick itself does works with the app version I've got installed (iPhone 6, app version 3.7.2 build 313)

     


    This post was edited by F V at April 8, 2015 2:14 PM CEST
    • 1 posts
    April 7, 2015 5:24 AM CEST

    Is there a complete and updated "how to use the app" document anywhere? Or even a video, though a document would be a thousand times better. I bought Sbricks on the Kickstarter, I have an iPad updated to 3.7.2 (build 313), and, obviously, I am signed up for an account. But I'm getting nowhere. Too much of this system seems to depend on the user tapping around the screen (for the iPad) or clicking around the screen (for this website) and hoping to get lucky. I have not been lucky. I have sooo many questions. Just a few to start:

      - The only FAQ I can find is on the wiki and it has nothing on it but "lorem ipsum" text. Is there a real FAQ?

     - How can I delete a creation? My app screen is full of broken experimental or accidental creations.

    - A friend tells me that there is an Emerald Night profile, but I cannot find it. I see only five profiles on the "store." There are seven profiles to choose from with a new "creation."

    Thank you.

     

     

    • 198 posts
    March 26, 2015 5:15 PM CET

    [blockquote]Paul Boratko said:

    Cool, thanks...

    The only Apple product that I own or have ever owned is this ipod touch and I only bought it to test the Sbrick back in August... And the only thing that I have ever used it for was the Sbrick..

    [/blockquote]

    I hope you found the "app store" application on the device. At the bottom of the screen you will find the "Search" menu. Then you can type "sbrick" to the search line then you can update/install the application. (You can select automatic updates at the iOS settings)

     

    • 5 posts
    March 26, 2015 4:34 PM CET

    Cool, thanks...

    The only Apple product that I own or have ever owned is this ipod touch and I only bought it to test the Sbrick back in August... And the only thing that I have ever used it for was the Sbrick..

    • 3 posts
    March 26, 2015 3:31 PM CET

    Same place it is on all Apple mobile devices :P It's the white A (made of a pencil, a brush and a horizontal bar, possibly a ruler) in a white circle on a blue background :)

    • 5 posts
    March 26, 2015 3:25 PM CET

    I thought that I had recently received a link for the newest App, but apparently I did not... Where is this App store located..?

    • 198 posts
    March 26, 2015 2:56 PM CET

    [blockquote]Paul Boratko said:

    Hmm.. I don't seem to have a "My Creations" I have "My MOC and My Set" on my App..  And when I go to the Market, it isn't asking for any login information, it just opens up and I can load various created profiles...

     

    [/blockquote]

    Please upgrade your app from the app store. The latest public version is 3.7.2

    • 198 posts
    March 26, 2015 2:55 PM CET

    [blockquote]Paul Boratko said:

    How do I sign into my account here through the App on my ipod touch..? I am trying to download my created profile that I designed..

     

    I don't see anywhere on the App to login at..???

    [/blockquote]

    You can login in the slide menu at the left.

    • 5 posts
    March 26, 2015 2:38 PM CET

    Hmm.. I don't seem to have a "My Creations" I have "My MOC and My Set" on my App..  And when I go to the Market, it isn't asking for any login information, it just opens up and I can load various created profiles...

     

    • 3 posts
    March 26, 2015 1:05 PM CET

    Hi,

    I've got three sBricks, an iPhone 4S running 7.1.2 and the app from the app store half an hour ago (3.7.2 / 313).

    My thoughts on the app so far:

    - When logging in at the market-page the keyboard blocks the view to the username (75%) / password (completely) fields. Logging in from the homescreen the username is visible, but the password is still behind the keyboard

    - There are zero profiles. No fancy joystick / gyro thingies, not even on the profile market.

    - When closing the port tester (at least when assigning ports to functions in a profile) the ports don't reset. There is no 'dead zone' so without reset the motors keep whining unless you get to the exact middle of the slider.

    - There's 16:9 mentioned everywhere but my profile created in the designer looks compressed. Zsolt is telling me 2 posts up it should be 3:4. If I look at the specs from Apple (https://www.apple.com/lae/iphone-4s/specs/) it should be 3:2?

    - OTA firmware upgrade works. I think... I don't know which version is installed on the sbricks shipped to me from the kickstarter, but the one sbrick I updated and the two I didn't show identical results: 0%, Last connect: never, hardware version 0.0, firmware version 0.0, battery level 0.00 V, device ID (null). The app does recognize which sbrick I've attached, correctly distinguishing between Huey, Dewey and Louie (Tiki, Niki, Viki). So for me there is a lot more missing than just the version number in fw 4.1 :) Unless ofc. the sbricks I received months ago already had 4.1?

     

    Other than that, it works great :) I had Designer Han's truck + lowloader driving through the living room in under 5 minutes (helped a lot by the fact this MOC already had an extension cord running to the location where the IR receiver was placed), including the time it took to unpack the sBrick and install the app :)

     

    @Paul Boratko: If the app is the same as on iPhone, press 'back' until you get to 'My creations', then press the =, at the top of the screen you should be able to log in. Otherwise, at the 'add profile'-page, press Market (top right), that should ask you to log in as well.


    This post was edited by Paul Nieuwkamp at March 26, 2015 1:36 PM CET