Forums » Support

Back To Topics

SBrick iOS App

    • 4 posts
    December 19, 2017 5:42 PM CET

    Any news on updates for iPhone X? Have bought two more SBricks and hoping these updates come soon...

    • 4 posts
    December 5, 2017 5:36 PM CET
    Just an update on my findings.
    So it looks like the the Remotr options in My Profiles it Public aren’t working on the iPhone X. Have tested on an iPhone 7 with iOS 11 and it works fine. So looks like it’s just not compatible with the iPhone X screen format possibly because of the notch. It’s clearly not an iOS 11 issue as far as I can see.
    • 4 posts
    December 2, 2017 10:59 PM CET
    Legomania said:
    G S said:

    I am new to this and have just bought my first sbrick and am having trouble with it. 

    I have download the app on the iPhone X and it sees the sbrick fine but when I go in to creations and try to add remote control profiles nothing appears in the My Profiles or Public sections. It does the loading animation but then it is empty so I am unable to do anything with the sbrick. 

    Is this a bug or is there something I can do, I have rebooted the phone and still no luck. 

    Thanks in advance 
    Gaz

     

    I'm experiencing exactly the same with my iPhone X. Could be that we need to wait for an update of the SBrick App. I'm stuck at the moment.

     


    So it’s a problem for everyone with the new iPhone X I guess. This is disappointing, I bought this hoping I could try the power functions as the standard Lego ones aren’t great so I’m now stuck. Hopefully support will be able to help or come up with a solution soon so we can use the sbrick. I will try it on the iPhone 8 and see if that works or it could be an iOS 11 problem.
  • December 2, 2017 8:16 AM CET
    G S said:

    I am new to this and have just bought my first sbrick and am having trouble with it. 

    I have download the app on the iPhone X and it sees the sbrick fine but when I go in to creations and try to add remote control profiles nothing appears in the My Profiles or Public sections. It does the loading animation but then it is empty so I am unable to do anything with the sbrick. 

    Is this a bug or is there something I can do, I have rebooted the phone and still no luck. 

    Thanks in advance 
    Gaz

     

    I'm experiencing exactly the same with my iPhone X. Could be that we need to wait for an update of the SBrick App. I'm stuck at the moment.

     

    • 4 posts
    December 2, 2017 2:38 AM CET

    I am new to this and have just bought my first sbrick and am having trouble with it. 

    I have download the app on the iPhone X and it sees the sbrick fine but when I go in to creations and try to add remote control profiles nothing appears in the My Profiles or Public sections. It does the loading animation but then it is empty so I am unable to do anything with the sbrick. 

    Is this a bug or is there something I can do, I have rebooted the phone and still no luck. 

    Thanks in advance 
    Gaz

  • November 30, 2017 11:00 PM CET

    Hi There,

     

    yes, rebooting the mobile device has fixed the issue. Thanks a lot.

    It looks like iOS 11 & iPhone X are not proving stability on  BT connections. 

     

    Thanks again for your support !

    Philippe

    • 11 posts
    November 30, 2017 10:04 PM CET
    K Tom said:

    Dear Galim!

    We are working on the new version what hopefully will fix your crash problems too.

    Does the app crashes on your device only when a profile runs?

    Thanks, Tamas

    Hello!
    Thank you for your answer.

    App crashes when there is connection with SBrick(s). It happens when a profile runs and also when testing SBrick in My Sbricks menu.

    • 3 posts
    November 30, 2017 9:27 PM CET
    Galim Makhmutov said:

    Hello, it is me again.

    I have tested several version of SBrick App. I tested the latest one 4.4.7, the first version with gamepad support 4.4.2 and the latest version 4.2.3 without gamepad support. SBrick FW is 20.

    I used legal ways to downgrade SBrick App using iTunes and Charles.

    The result if following: version 4.2.3 is working flawless and without crashes. Perfect. But it doesn't support gamepad which I really need to use. I tested it for 10+ minutes several times and it didn't crash.

    Version 4.4.2 and 4.4.7 are unstable and they crash whenever they want to. May be 15 seconds, may be 2 minutes after starting the profile, but the result is the same, the App crashes.

    So, something went wrong with App version 4.4.2.

    I remind, I am using iPhone 5 with iOS 10.3.3.

    I really hope that this will help.

    Do you need some more test? I will help gladly with anything I can. 

     

     

    Dear Galim!

    We are working on the new version what hopefully will fix your crash problems too.

    Does the app crashes on your device only when a profile runs?

    Thanks, Tamas

    • 3 posts
    November 30, 2017 9:21 PM CET

     

    Legomania said:

    Hello SBrickers,

    since I upgraded one of my SBricks to firmware 20 (hardware 5), the App does not connect anymore to the SBrick. The SBrick is recognized (available in the list of SBricks) but when selected it never exits : see image.

    I'm using SBrick v4.4 Update 7 under iOs 11.1.2. 

    Any idea ? 

     

     

     

    Dear LegoMania!
    I checked your logs, seems the Bluetooth of your device has been crashed or cached some service ids.
    Please reboot your mobile device and try again!The bluetooth restart is not enough, only the full device reboot helps.
    Does it help?
    KTamas

    This post was edited by K Tom at November 30, 2017 9:21 PM CET
  • November 27, 2017 8:58 AM CET

    Hello SBrickers,

    since I upgraded one of my SBricks to firmware 20 (hardware 5), the App does not connect anymore to the SBrick. The SBrick is recognized (available in the list of SBricks) but when selected it never exits : see image.

    I'm using SBrick v4.4 Update 7 under iOs 11.1.2. 

    Any idea ? 

     

    • 11 posts
    November 27, 2017 4:35 AM CET

    Hello, it is me again.

    I have tested several version of SBrick App. I tested the latest one 4.4.7, the first version with gamepad support 4.4.2 and the latest version 4.2.3 without gamepad support. SBrick FW is 20.

    I used legal ways to downgrade SBrick App using iTunes and Charles.

    The result if following: version 4.2.3 is working flawless and without crashes. Perfect. But it doesn't support gamepad which I really need to use. I tested it for 10+ minutes several times and it didn't crash.

    Version 4.4.2 and 4.4.7 are unstable and they crash whenever they want to. May be 15 seconds, may be 2 minutes after starting the profile, but the result is the same, the App crashes.

    So, something went wrong with App version 4.4.2.

    I remind, I am using iPhone 5 with iOS 10.3.3.

    I really hope that this will help.

    Do you need some more test? I will help gladly with anything I can. 

    • 11 posts
    November 24, 2017 10:09 PM CET
    Lénárd Pásztor said:

    Dear Glaim,

     

    Does the FW update solved the problem?

    Thank you for your answer.
    No, FW update didn't solve the problem.

    I tried to update to version 20 on Android with the SBrick App and it didn't work.
    Also, I tried updating via SBrick Simple Control to version 17. Didn't work, too.
    It seems that on Android it is working normally, but I can't use Android for SBrick control.


    I have reinstalled iOS app several times and it didn't work, too.

    Now I am going to do something with Bluetooth settings, as it seems that there isn't more options.

    • 138 posts
    November 24, 2017 11:39 AM CET

    Dear Glaim,

     

    Does the FW update solved the problem?

    • 11 posts
    November 23, 2017 9:40 PM CET

    So, still no answer. Makes me sad.

    OK, gonna make my own investigation on problem.
    It seems like SBrick with hardware version 5 is working properly (still more tests will be provided) and SBrick with hardware version 4 crashes the App.

    I am using iPhone 5 with iOS 10.3.3 and latest version of SBrick App and latest SBrick firmware. 

    UPD: I did more tests and it seems that is doesn't depend on hardware version. I have no clues. 
    I am going to try to update firmware from Android and see if that will work. 


    This post was edited by Galim Makhmutov at November 23, 2017 10:06 PM CET
    • 11 posts
    November 21, 2017 12:51 AM CET
    Lars Böhme said:

    Crashing app (still)

    Hello Vengit,



    I was very happy to see a new Update in the App Store few days ago, but I had to experience quickly that the SBRICK app is now more unstable then before. Before it was just an issue with the sequences, now it is impossible to drive the model with two sliders longer than 15 seconds. Then today I found the latest update 4.4.6 with stability improvements ready to install, but it is the same annoying behavior then before. Of course my Iphone 5 is up to date and firmware on the SBRICKs is up to date as well.
    I was asked to send in Videos of the issue directly to the developers few month ago, I did, but I received neither a feedback or a working software.
    I am still very unhappy with this situation, I see new features coming all the time but fixing existing issues seems not a priority at vengit

    I have the same issue. I thought it is because of gamepad as I wrote before but I tried several times without gamepad and the App still crushes very soon after starting the profile.

    Hope it will be solved. Please, Vengit:(

    • 11 posts
    November 9, 2017 5:40 PM CET

    I've been happy with Gamepad support on iOS, but not long. Just before the Lego Technic Trial competition I experienced that the app is crushing when using a gamepad. After restarting the app the following message appears. I am using Mad Catz C.T.R.L.i MFI gamepad.
    Hope the problem will be solved. 

    • 8 posts
    November 5, 2017 8:40 PM CET

    Crashing app (still)

    Hello Vengit,



    I was very happy to see a new Update in the App Store few days ago, but I had to experience quickly that the SBRICK app is now more unstable then before. Before it was just an issue with the sequences, now it is impossible to drive the model with two sliders longer than 15 seconds. Then today I found the latest update 4.4.6 with stability improvements ready to install, but it is the same annoying behavior then before. Of course my Iphone 5 is up to date and firmware on the SBRICKs is up to date as well.
    I was asked to send in Videos of the issue directly to the developers few month ago, I did, but I received neither a feedback or a working software.
    I am still very unhappy with this situation, I see new features coming all the time but fixing existing issues seems not a priority at vengit

     

    11.12.2017: update: they gave me a contact which seems to be a developer, he tried to send me some downloadlinks to bypass the appstore and get a new version installed. For any reason I could not install the version that should fix the issues. This is now 3 weeks ago and I am getting no feedback via mail, no feedback in facebook messenger, no working version in the app store...what's up with you guys, you keep promising that something will change but instead nothing happens...


    This post was edited by Lars Böhme at December 11, 2017 8:31 AM CET
    • 26 posts
    October 31, 2017 10:47 PM CET

    With my Steelseries Nimbus MFI-Gamepad the APP also didn't recognize the L1, L2, A, B, X and Y.  I'm looking forward to this being fixed.

    • 4 posts
    October 30, 2017 5:15 PM CET

    The APP works well on my iPhone and iPad, but it doesn't recognize all buttons from the Gampad.

    • 26 posts
    October 30, 2017 2:25 AM CET

    Michael: So the SBRICK app is working well with iOS 11 on iPhone?  Earlier Dmitry reported problems with iOS 11, are they solved?


    This post was edited by Timber Brick at October 30, 2017 2:26 AM CET
    • 4 posts
    October 28, 2017 10:18 PM CEST

    Hi everyone, has anybody the same Problem? With my MFI-Gamepad the APP didn't recognize the L1, L2, A, B, X and Y.

    I'm a little bit disappointed about this behavior.

     

    I'm tested with iPad Air and iPhone6. Both with iOS 11.0.3. Latest App and FW.

    Michael

    • 26 posts
    October 28, 2017 5:23 PM CEST

    MFi Gamepad question: Can I control two separate SBRICKS from two separate MFi gamepads paired to a single iphone? How about three or four game pads and SBRICKS?

    • 26 posts
    October 28, 2017 7:11 AM CEST

    I've been using the clinometer pitch to control the weapon on my battle bot.  The clinometer control stopped working this summer.  I'm using ios 10.3.3.  Is this a SBRICK app bug, or a problem with my phone?

    • 11 posts
    October 24, 2017 1:49 PM CEST

    [blockquote]Michael Leefers said:

    Hello Galim,

    did you use the original App or your own App that you presented here and on eurobricks?

     

    Regards, Michael

    [/blockquote]
    Hello!

    I did use the original App.
    The another App is not mine, I just tested it:) 

    • 4 posts
    October 24, 2017 1:45 PM CEST

    Hello Galim,

    did you use the original App or your own App that you presented here and on eurobricks?

     

    Regards, Michael