Forums » Support

Back To Topics

SBrick iOS App

    • 4 posts
    January 7, 2015 8:52 AM CET

    Just saw the new version of iOS app 3.2 and made a quick test before driving to work. :-)

    - LED is on...but how to identify the SBrick if it's allways lit?

    - 100% bug fixed

    - connecting bug fixed

    - firmware update bug fixed...but SBrick doesn't work anymore after firmware update! Connection is still fine.


    Will do more tests today - especially I will check the non working SBrick after firmware update. Didn't tried software restart so far.

  • January 7, 2015 1:55 AM CET

    [blockquote]Hubraum 6.8 said:

    Hi there

    Any chance you will release an iOS App version that can run on the old ipod touch 3g's (ios 4.3.3)?


    That is not possible, as that iPod does not have BLE. As I remember, it's only BT 2.1

    • 12 posts
    January 6, 2015 9:22 PM CET

    Finaly my 42030S works perfectly! :-)


    • 4 posts
    January 6, 2015 9:13 PM CET

    Hi there

    Any chance you will release an iOS App version that can run on the old ipod touch 3g's (ios 4.3.3)?

    My kids have this version and it would be great if the could use their ipod's to play with the sbrick Lego models rather than having to use my phone or ipad.



    • 11 posts
    January 6, 2015 8:57 PM CET
    I have problems with the new software too.

    In some profiles the controls are not visible (gamepad 2 for example) and other profiles don't work at all (generic car cockpit/sheepos profile - no picture, no functions).
    The connection seems not to be as stable as before. Sometimes my car just stops for a moment or the app doesn't even get a connection.
    All in all the App works much better now and I can control my Unimog very good. But we really need the profile designer to get adequate profiles.

    Please keep on working on the software. You are on the right way. I will do some more testing tomorrow.

    LED works now, 100% bug seems fixed and firmware update was successful.
    iPhone 6 iOS 8.1.2
    This post was edited by Philip Dreffkorn at January 6, 2015 9:03 PM CET
    • 2 posts
    January 6, 2015 6:58 PM CET
    First impression of new version of iOS app 3.2:

    - LED is now constantly on after OTA firmware update. Nice!
    - first, my bricks did not react to any form of input at all (port tester or profile)! I made it now working by switching off the bluetooth on my ipad, just keeping the bricks paired with my iphone (or the other way around). Doesn't seem to be a good idea to have two iOS devices compete with the bluetooth connection..
    - some profiles seem to be troubled on the iphone (control fields out of the range of the screen) but I am still checking this..

    Nice update, but I am still waiting for the profile designer! Any news on this?

    • 11 posts
    January 3, 2015 10:14 PM CET

    Joystick works on my iPhone 6 using iOS 8.1.2 very good. Did you assign the functions of the profile to the channels of the SBrick? Go to the set, then settings, add a profile (joystick for example), add your SBrick (bottom of the page) and tap on it. There you can assign Functions (acceleration/steering) to one ore more channels of the SBrick.

    I found another problem with the iOS App:
    when I use the joystick profile the display turns off after some time. Then the SBrick keeps in the last state and motors keep running until I reactivate the smartphone.
    The App should avoid turning off.

    This post was edited by Philip Dreffkorn at January 4, 2015 9:36 AM CET
    • 6 posts
    January 3, 2015 8:09 PM CET

    I now have port testing working on iPhone 6 ios 8.1.2

    I think when you delete the SBrick app from the phone some data remains and is used when you re-install the SBrick app. Is this true?

    I can drive my skid steer technic toy around with the port testing sliders and it is much fun.

    Cant seem to get the joystick to work on the iPhone 6 but it works well on the iPhone 4s.


    • 6 posts
    January 3, 2015 3:11 PM CET

    I would like to report sucess!

    I did a freash restore of IOS 8.1.2 on an iPhone 4s.

    i put two motors on C and D pads

    I opened SBick app:

    selected MOC,

    accepted name

    accepted image

    selected joystick

    opened the brick and set all channels to acceleration

    tested ports

    backed out and re-opened app

    turned on joystick

    tilting phone actates the two motors.



    Bob Beck





    • 36 posts
    January 2, 2015 9:24 PM CET

    [blockquote]Caoimhin Marsh said:

    I have the exact same problem as Justin, iPhone 4s and an android device that doesnt work well yet with sbrick


    I am experiencing the same issue with my iPhone 4s: the calibration settings screen does not fit the screen of the phone (the Max Value can not be set). IOS 8.1.2

    • 36 posts
    January 2, 2015 8:38 PM CET

    Hi sBrick Team,

    I have finally received my kickstarter brick and also the extra items I have ordered! Great presents for 2015, thanks!!! All kudos to the whole team!!!

    I have followed the installation steps and everything is working fine with my 4 x 4 Crawler set. The same time, I wanted to share my experience with you guys:

    Only 2 profiles works with the sBrick and the lego set (see screenshot attached):

    1. Joystick (Generic joystick controller with gyro sensors)

    2. Gamepad 2 (Generic gamepad with two control)

    I have headlights on the car, but they can not be individually controlled from the above profiles (unless I connect the light control to other channels). Other profiles that contain lights control, do not work with this set: be the remote control installed on the iPad2 or an iPhone 4S. IOS versions were: 8.+.

    Also noticed, that the same profile (Gamepad 2) are different if installed on the iPad2 (no option for light control) or on the smartphone. Please see screenshots attached.

    My questions are:

    How can I add/modify the control profiles in order to exploit the 4 individual channels?

    When will you add profiles that can control lights independently?

    What skills does the user need to have to  customize the control profile app?

    Which control profile do you recommend for the MKII Crane set (I want to build the ultimate fully motorized version), where 8 channels will need to work individually and simultaneously from the same control profile?

    At last, but not least about the packing: I suggest you attach the stickers (btw. I love them all!) onto a more solid plate, otherwise a single envelope does not protect the sticker sheet from getting wrapped and damaged. It happened to all my shipments, making some stickers useless:-(.

    Waiting for your kind and quick answers, as I am preparing to demo soon with the Crawler and the Crane in a significant local robotic community.



    This post was edited by Peter Subert at January 2, 2015 9:11 PM CET
    • 34 posts
    January 2, 2015 4:16 PM CET

    Would you provide your SBrick connection status to the statistics thread I tried start ?

    It should not replace this one, just used for collecting pure statistics on which device type/model is generally connecting ok or not.

    • 5 posts
    January 1, 2015 3:56 AM CET

    I have a question about the app, if I have a fourth gen ipod, will the Sbrick work with it, as I though I read somewhere it requires Bluetooth 4.0 and the ipod 4th gen lacks that and I have downloaded the app, but the app is recognizing the device as a Iphone 5 and the lower portion of the screen isn't visable. Could the app be optimized for the device, if the sbrick works with Bluetooth 2.1+ EDR? This is the only question that is keeping me from getting a Sbrick, if it will work with this device.


    Sbrick app custom skins by Tommy Styrvoky, on Flickr


    Though I did figure out how to make you own skins for the app


    Sbrick app custom skins by Tommy Styrvoky, on Flickr

    This post was edited by Tommy Styrvoky at January 1, 2015 4:08 AM CET
    • 10 posts
    January 1, 2015 1:47 AM CET

    I have the exact same problem as Justin, iPhone 4s and an android device that doesnt work well yet with sbrick

    • 3 posts
    January 1, 2015 1:04 AM CET


    Since the Sbrick requires bluetooth 4.0 or better, I would love to be able to use my iphone 4s with the app. I was wondering if the sbrick team could work on making some way for the app to adjust to the proper dimentions of the iphone 4s screen. For the most part the only trouble comes when fine tuning the profiles because its impossible to adjust the max range settings in the calibration. Since the Android app dosen't really work well, I'm stuck struggling to control my moc's with the iphone 4s, so I really need help with this. I love the products as I have just recieved my four sbricks today. I can't wait untill the apps are all working, and I hope you guys consider this idea. I also figure that being able to use my iphone 4s (My old phone) I could really save my main cell phones battery, so this would be a big help for me and anyone else with a iphone 4s as their main or older cell phone.



  • December 30, 2014 6:27 AM CET

    [blockquote]Wieger Offereins said:

    Will it be possible to re-name my SBricks, in the future?

    So I will be able to recognize them from a "distance"?


    You can rename the briks in the App already. It's not 'pushed' to the brick, though, so deleting it and re-adding it will make it show up with the generic name, and so will it also on other devices.. 

    • 12 posts
    December 29, 2014 11:37 PM CET

    Will it be possible to re-name my SBricks, in the future?

    So I will be able to recognize them from a "distance"?

    • 12 posts
    December 29, 2014 10:57 PM CET

    [blockquote]Lénárd Pásztor said on 23 december:

    Yes, it is a known bug with the current firmware. We already fixed it. OTA firmware upgrade will work the next release of the iOS app, then you can fix this issue by upgrading the app and the SBrick. The app is under Apple's review process, we hope they will put to public in next week.


    • 2 posts
    December 29, 2014 10:12 AM CET

    I have tested iphone 6 and ipad air2 (both IOS 8.1.2) and both can connect with my SBrick.

    Same experience about the bug (PF motor stop once the slider is at max. pos) from me.

    • 4 posts
    December 28, 2014 3:51 PM CET

    As Sebastian quotes

    [blockquote]sebastian madsen said: Hi.... i have an iPad air 2 With 8.1.2 iOS... But my iPad Can't find my Sbrick Wien i try to connect it... Then it's telling me that i have to wait for Bluetooth....[/blockquote]

    I have the same problem. Bleutooth cannot find the SBrick

    I posted this message on the Android part of the forum

    [blockquote]Yesterday I resived my SBrick.

    After powering on the SBrick the manual says the LED should turn on. I did not... I though is my SBRick broken.

    But after 2 times re-installing the App my Samsung S5 I was able to operate the SBrick.

    I found that the LED is working if your turn it on in the Manage Brick menu (identify led).

    I installed the SBrick on my 41999 and only profile Gamepad 2 was working, except the speed control was working reverse.

    I don't know who to reverse the output controls.

    The Joystick does not work at all and the steering profiles do not react very well.

    Gamepad 1 does not work at all, sometimes the app stoppes. Test 2 only shows 1 slider. So I probably have to re-install the app again..

    I also installed the SBrick app on our IPAD (software 6.1.3.) and IPOD but both cannot find the SBrick....[/blockquote]

    Is this related to the IPAD version (its an IPAD 2 software 6.1.3.)?



  • December 27, 2014 7:37 PM CET
    Hi.... i have an iPad air 2 With 8.1.2 iOS... But my iPad Can't find my Sbrick Wien i try to connect it... Then it's telling me that i have to wait for Bluetooth....
    • 57 posts
    December 27, 2014 5:06 PM CET

    The motor stop when slider reaches the maximum is a problem from the latest SW version confirmed by SBrick team in this forum. It will be fixed in the next version.

    This post was edited by Fernando Correia at December 27, 2014 5:06 PM CET
    • 1 posts
    December 27, 2014 4:03 PM CET

    Same problem here, app works ok untill you put one of The sliders to max, then motor stops. With The porttester The same, motors stop when sliders are at max.
    • 11 posts
    December 27, 2014 3:44 PM CET


    I got my SBrick today and have problems too. The LED of the SBrick can't be activated and the motor stops when I go with a channel up to maximum power, while the other motors keep running. Also the LEGO LED lights turn off when the slider is at maximum.

    I tested the SBrick with different batteryboxes (AA and AAA) and different cables. I think it is a software problem.


    The OTA function also doesn't work. The App crashes each time.


    Tested on iPhone 6 and iOS 8.1.2 

    • 1 posts
    December 26, 2014 12:37 PM CET



    've got my sBrick right in time for xmas, thx.

    I'm eager to write my own app to communicate with the brick. Is there any lib/api I can use provided or planned by u guys? Couldn't find any so far.