Forums » Support

Back To Topics

SBrick iOS App

    • 1 posts
    June 15, 2018 12:42 AM CEST

    I can't figure out how to add the controllers that I made on the computer onto the app on my iPod touch! How can I do this?

    • 1 posts
    April 29, 2018 11:05 PM CEST
    Sbrick team iOS App om the iPad is not working any more, help!!!
    This post was edited by Rubke mb at April 29, 2018 11:06 PM CEST
    • 10 posts
    April 14, 2018 6:48 PM CEST
    Send a direct message to SBrick to get some info about this issue stil no response hope they fix this error fast lucky for me my main model was also on my iPhone but the one under construction and the one I just was busy to SBrick the are useles at the moment maybe more people can sent a direct mail to SBrick to fix this
    • 1 posts
    April 12, 2018 2:11 AM CEST
    Hello sbrick team! The sbrick is very useful, well, was. The apps display ratio is all messed up on iPads. Could you please fix this? Other wise I can’t use my sbrick.
    • 1 posts
    April 10, 2018 11:21 AM CEST

    I have the same problem. iPad mini with IOS 11.3 (latest version). Sbrick app not scaling properly with the result that a part of the screen (with buttons on it) is not vissible wich makes the app (and my sBricks) compeletely useless!

    Please give us an update about this problem and when we can expect a sollution.

    • 2 posts
    April 7, 2018 8:15 PM CEST
    I am also having the too large image on both my iPad Air and iPad Pro. This started after the latest app up date.
    • 10 posts
    April 7, 2018 7:46 AM CEST
    Hi SBrick designers i just Made the latest update on my iPad mini for the sbrick app butt somehow the screen ratio is totally off everything is out of proportion so i don’t get everything on screen for example the log in screen but also the OWN creations page the run button wont show up so actualy you can’t do anything help plsz
    • 12 posts
    March 28, 2018 5:39 PM CEST

    Dear SBrick team!
    Thank you very much for the latest update of iOS app. Now it works good and without crashes! I am very happy since I can control my MOCs in a most comfortable way. Thank you very much.

  • March 24, 2018 9:34 AM CET
    Designer-Han Crielaard said:
    Hi Vengit,
    Any news on this??? It would help the community if you acknowledge the problem and give an indication of a Sbrick app update... Sad to have silence all those weeks. :-(
    Silence still, no updates, no comments, no news
    • 1 posts
    February 28, 2018 7:49 AM CET

    Why is not it possible to set the "Auto Reset" to "off"?

  • February 17, 2018 5:11 PM CET
    Hi Vengit,
    Any news on this??? It would help the community if you acknowledge the problem and give an indication of a Sbrick app update... Sad to have silence all those weeks. :-(
    Designer-Han Crielaard said:

    Hi Vengit,

    Finally decided to purchase 2 Sbricks instead of Buwizz. Main reasons; the broader community indicates that Sbrick has a better software user interface with more features.

    However:

    I am not able to pair with the Sbricks using an iPhone (latest IOS). Actually, the Sbrick app crashes as it tries to connect to the Sbrick (hw level 5, firmware 1). It does this all the time, regardless hard or soft reboots of the iPhone. As well it is impossible to upgrade the firmware of the Sbrick in this case either.

    How to proceed? Btw: I have to admit that it is really disappointing to buy Sbricks and need to replace them again for the tradiontal (reliable) PF IR receivers. :-(

    I guess you are aware of the above; can you give an indication when a new update of the Sbrick app can be expected? Thanks in advance.

     

  • February 13, 2018 11:55 AM CET

    Hi There,

    using SBrick v4.4 Update 11 on iPhone X, iOS 11.2.2.

    when trying to connect/configure my "old" sBricks (very old firmware), the application crashes. sBricks are available in the list but selecting any of them will crash the App after very few seconds. So it is not possible for me to give you the firmware version.

    Any idea ?

    Cheers

  • January 26, 2018 2:02 PM CET

    Hi Vengit,

    Finally decided to purchase 2 Sbricks instead of Buwizz. Main reasons; the broader community indicates that Sbrick has a better software user interface with more features.

    However:

    I am not able to pair with the Sbricks using an iPhone (latest IOS). Actually, the Sbrick app crashes as it tries to connect to the Sbrick (hw level 5, firmware 1). It does this all the time, regardless hard or soft reboots of the iPhone. As well it is impossible to upgrade the firmware of the Sbrick in this case either.

    How to proceed? Btw: I have to admit that it is really disappointing to buy Sbricks and need to replace them again for the tradiontal (reliable) PF IR receivers. :-(

    I guess you are aware of the above; can you give an indication when a new update of the Sbrick app can be expected? Thanks in advance.

    • 31 posts
    January 15, 2018 11:12 PM CET
    Timber Brick said:

    With my Steelseries Nimbus MFI-Gamepad the APP also didn't recognize the L1, L2, A, B, X and Y.  I'm looking forward to this being fixed.

    Hey Vengit, any progress on getting the buttons to work?

    Also:

    We have been enjoying controlling our Lego Battle Bots with SBRICK.  Team battles are really fun.  I can control two bots with my iPhone using a MFI gamepad for one, and the iPhone for the other.  Before I buy a second gamepad to control three bots, has anyone used multiple gamepads with the iPhone SBRICK app?


    This post was edited by Timber Brick at January 15, 2018 11:13 PM CET
    • 2 posts
    January 14, 2018 8:49 PM CET

    Hi again everyone,

    After talking with Tamas via email over me problem with the Sbrick app keep crashing I tried using the app on my partners iPad Pro and it worked fine. So this lead me to purchasing a new iPad for myself and now I'm happy to report my issues have now been solved. iPad is running IOS 11.2.1 with Sbrick v4.4 update 11, bricks are version 5 firmware 22.

    Thank you

    Dave

    • 12 posts
    January 14, 2018 1:06 PM CET
    K Tom said:
    Galim Makhmutov said:

    Hello, it is me again.

    I have tested several version of SBrick App. I tested the latest one 4.4.7, the first version with gamepad support 4.4.2 and the latest version 4.2.3 without gamepad support. SBrick FW is 20.

    I used legal ways to downgrade SBrick App using iTunes and Charles.

    The result if following: version 4.2.3 is working flawless and without crashes. Perfect. But it doesn't support gamepad which I really need to use. I tested it for 10+ minutes several times and it didn't crash.

    Version 4.4.2 and 4.4.7 are unstable and they crash whenever they want to. May be 15 seconds, may be 2 minutes after starting the profile, but the result is the same, the App crashes.

    So, something went wrong with App version 4.4.2.

    I remind, I am using iPhone 5 with iOS 10.3.3.

    I really hope that this will help.

    Do you need some more test? I will help gladly with anything I can. 

     

     

    Dear Galim!

    We are working on the new version what hopefully will fix your crash problems too.

    Does the app crashes on your device only when a profile runs?

    Thanks, Tamas

    Hello. 
    I was really expecting that new version (came out 22nd of December) will solve the crashing problem, but the problem wasn't fixed.

    I can't even use my iPhone to control SBricks without gamepad. For more than two month I had to borrow Android devices from my friends or use original IR-receivers. 
    I use the latest App version and latest SBrick firmware. 

    • 2 posts
    January 8, 2018 7:45 PM CET

    Hello there,

    This is my first post on here and I need some help or advice.

    I think my SBrick app is not working properly as I have recently updated the firmware on the bricks to version 22 and the hardware is V5.The app is version 4.4 update 11. The app will run for a few seconds and then crash and disconnect stopping the model. 

    I'm running it on an older iPad mini using IOS 9.3.5. I cannot update the OS any more but I have done a hard reset on it, reinstalled the app several times but still have the same problem of the app crashing. Initially I thought the bluetooth was the problem but after several days of trying I need some help/advice.

    My model has two SBricks installed one to run the crawler tacks (two channels) and a second Brick to run the winches derrick and slewing functions. It is a Manitowoc 4100 crawler crane.

    Is there anything I can do to help cure this problem. HELP!!!

    I'm kinda pulling my hair out this (what little I have LOL) as it worked fine until the last update.

    Thank you in advance for you help.

    Dave

    • 1 posts
    December 24, 2017 10:42 AM CET

    I want to use an old iPhone 4 with iOS 7.1.2 (latest).
    Downloaded the app, a previous version since current requires minimum iOS 8.
    However, when starting the app, the app is stuck at 'Please enable the bluetooth' on the startup screen.

    Tried the iPhone with another bluetooth device to test bluetooth and that works.
    Disabled/enabled the bluetooth several times, restarted the iPhone, reinstalled the app. Nothing gets me past the startup screen.

    Any ideas?
    Would be great if this can be solved so the kids can use these old devices to play with.

    • 4 posts
    December 19, 2017 5:42 PM CET

    Any news on updates for iPhone X? Have bought two more SBricks and hoping these updates come soon...

    • 4 posts
    December 5, 2017 5:36 PM CET
    Just an update on my findings.
    So it looks like the the Remotr options in My Profiles it Public aren’t working on the iPhone X. Have tested on an iPhone 7 with iOS 11 and it works fine. So looks like it’s just not compatible with the iPhone X screen format possibly because of the notch. It’s clearly not an iOS 11 issue as far as I can see.
    • 4 posts
    December 2, 2017 10:59 PM CET
    Legomania said:
    G S said:

    I am new to this and have just bought my first sbrick and am having trouble with it. 

    I have download the app on the iPhone X and it sees the sbrick fine but when I go in to creations and try to add remote control profiles nothing appears in the My Profiles or Public sections. It does the loading animation but then it is empty so I am unable to do anything with the sbrick. 

    Is this a bug or is there something I can do, I have rebooted the phone and still no luck. 

    Thanks in advance 
    Gaz

     

    I'm experiencing exactly the same with my iPhone X. Could be that we need to wait for an update of the SBrick App. I'm stuck at the moment.

     


    So it’s a problem for everyone with the new iPhone X I guess. This is disappointing, I bought this hoping I could try the power functions as the standard Lego ones aren’t great so I’m now stuck. Hopefully support will be able to help or come up with a solution soon so we can use the sbrick. I will try it on the iPhone 8 and see if that works or it could be an iOS 11 problem.
  • December 2, 2017 8:16 AM CET
    G S said:

    I am new to this and have just bought my first sbrick and am having trouble with it. 

    I have download the app on the iPhone X and it sees the sbrick fine but when I go in to creations and try to add remote control profiles nothing appears in the My Profiles or Public sections. It does the loading animation but then it is empty so I am unable to do anything with the sbrick. 

    Is this a bug or is there something I can do, I have rebooted the phone and still no luck. 

    Thanks in advance 
    Gaz

     

    I'm experiencing exactly the same with my iPhone X. Could be that we need to wait for an update of the SBrick App. I'm stuck at the moment.

     

    • 4 posts
    December 2, 2017 2:38 AM CET

    I am new to this and have just bought my first sbrick and am having trouble with it. 

    I have download the app on the iPhone X and it sees the sbrick fine but when I go in to creations and try to add remote control profiles nothing appears in the My Profiles or Public sections. It does the loading animation but then it is empty so I am unable to do anything with the sbrick. 

    Is this a bug or is there something I can do, I have rebooted the phone and still no luck. 

    Thanks in advance 
    Gaz

  • November 30, 2017 11:00 PM CET

    Hi There,

     

    yes, rebooting the mobile device has fixed the issue. Thanks a lot.

    It looks like iOS 11 & iPhone X are not proving stability on  BT connections. 

     

    Thanks again for your support !

    Philippe

    • 12 posts
    November 30, 2017 10:04 PM CET
    K Tom said:

    Dear Galim!

    We are working on the new version what hopefully will fix your crash problems too.

    Does the app crashes on your device only when a profile runs?

    Thanks, Tamas

    Hello!
    Thank you for your answer.

    App crashes when there is connection with SBrick(s). It happens when a profile runs and also when testing SBrick in My Sbricks menu.