Forums » Support

Back To Topics

SBrick Android App

    • 32 posts
    October 31, 2015 2:00 PM CET

    I made a simple profile in the profile designer.

    Then I went to the market and my profiles but it wasnt there.

    Please fix this!

    Thanks for your attention,

    Makar

    • 7 posts
    October 30, 2015 5:25 PM CET

    Hello,

    Available:
    SmartPhone with Android 4.4.2 (Explay Vega)
    SBrick - 2 pieces, Firmware - 4.4 (updated with Sbrick Simple)

    in Sbrick Simple application - all ok: all ports of the two modules work properly with motors

    problem:

    in SBrick application( 1.5, 1.6, 1.6.1, 1.7): SBrick My Creation -> When do "Add SBrick" in Linked SBricks and select SBrick from list - application is crash.

    Please fix it.


    Thanks.

    Vlad.


    This post was edited by Vlad . at October 31, 2015 2:36 PM CET
    • 32 posts
    October 30, 2015 8:25 AM CET

    [blockquote]Tamás Fábián said:

    The green LED flashing is perfectly normal if you've (possibly accidentally) turned the identification function on. :) This is what the LED do: you can check which SBrick you control by blink the LED.

    The identification function can be turned on with the simple control by tapping the status line wile it is connected (the line being green).

    Cheers,

    Tamas

    [/blockquote]

    Oh.I did tap the status line.I thought it would reconnect and tapped it.It connected but started flashing.

    Thanks,

    Makar

    • 178 posts
    October 29, 2015 4:33 PM CET

    The green LED flashing is perfectly normal if you've (possibly accidentally) turned the identification function on. :) This is what the LED do: you can check which SBrick you control by blink the LED.

    The identification function can be turned on with the simple control by tapping the status line wile it is connected (the line being green).

    Cheers,

    Tamas

    • 164 posts
    October 29, 2015 10:26 AM CET

    Oh ok. I understand.

    If the green led is flashing on the SBrick that not normal. Please try to update the firmware again.

    The SBrick works well? If not please contact us at info@sbrick.com about the replacement SBrick. 

    • 32 posts
    October 28, 2015 8:06 PM CET

    [blockquote]Tamas Misik said:

    [blockquote]Makar V said:

    I was just testing my train when one of the lights started flashing but the other didnt.Is there an explanation for this?

    [/blockquote]
     
    Are you sure the LED is not damaged? What happens if you connect the LED to an another port on the SBrick?

    [/blockquote]

    it was the green led in the sbrick

    • 164 posts
    October 28, 2015 11:49 AM CET

    [blockquote]Makar V said:

    I was just testing my train when one of the lights started flashing but the other didnt.Is there an explanation for this?

    [/blockquote]
     
    Are you sure the LED is not damaged? What happens if you connect the LED to an another port on the SBrick?

    • 4 posts
    October 27, 2015 6:15 PM CET

    [blockquote]Tamas Misik said:

    Dear Adam,

    The SBrick support your phone, you just need to update it to minimum 4.3 android.

    If you have android 4.3 or better, and the app doesn't work, please download the simple control application from google play and update the SBrick's firmware.
    https://play.google.com/store/apps/details?id=com.vengit.blecontrol&hl=en

    After
    the update please restart your phone.
    If doesn't work just try to pairing the SBrick with your phone in the Bluetooth setting menu.

    If you need any help just let me know.

    [/blockquote]

     

    Hello Tamás,

    thanks! I had the latest version of Android on the phone and the last firmware on the SBrick as well. Pairing the phone with the SBrick made it work.

    What is the reason behind this? Why was it not working without pairing the devices first?

    Thanks again and have a great day!

    Cheers!

    • 32 posts
    October 27, 2015 4:26 PM CET

    [blockquote]Tamas Misik said:

    Which application do you use? The Simple Control or the official SBrick Android app?

    [/blockquote]

    simple control

    • 164 posts
    October 27, 2015 2:06 PM CET

    Which application do you use? The Simple Control or the official SBrick Android app?

    • 32 posts
    October 27, 2015 1:57 PM CET

    I was just testing my train when one of the lights started flashing but the other didnt.Is there an explanation for this?

    • 32 posts
    October 27, 2015 12:52 PM CET

    [blockquote]Makar V said:

    The OTA update is finally working!Im updating right now and it seems to be working!

    [/blockquote]its done!

    • 32 posts
    October 27, 2015 12:33 PM CET

    The OTA update is finally working!Im updating right now and it seems to be working!

    • 164 posts
    October 27, 2015 12:19 PM CET

    [blockquote]Makar V said:

    any news?

    I cant wait till there is news

    [/blockquote]

    We have checked the application yesterday and it is promising, but the developers are still working on the OTA and a few minor things.

    • 164 posts
    October 27, 2015 11:55 AM CET

    Dear Adam,

    The SBrick support your phone, you just need to update it to minimum 4.3 android.

    If you have android 4.3 or better, and the app doesn't work, please download the simple control application from google play and update the SBrick's firmware.
    https://play.google.com/store/apps/details?id=com.vengit.blecontrol&hl=en

    After
    the update please restart your phone.
    If doesn't work just try to pairing the SBrick with your phone in the Bluetooth setting menu.

    If you need any help just let me know.

    • 4 posts
    October 27, 2015 11:45 AM CET

    Hi Guys,

    I would like to know, if you plan to add support to HTC One M7 phones.
    I have been trying to make SBrick work on my phone for quite some time now.

    I can find the SBrick, but neither my profiles nor the Brick tester seems to be working.

    I also tried with other phones (a Mlais MX Base and a Lenovo Vibe Z2 Pro) and they worked fine, I was able to control the attached motor. Only tried it with 1 Brick and for testing I only attached 1 motor, but tried it on different ports.

    In case you need some further details or possible log output or anything, let me know and I'll try to provide anything.

    Cheers!

    • 32 posts
    October 27, 2015 9:14 AM CET

    any news?

    I cant wait till there is news

    • 178 posts
    October 26, 2015 3:59 PM CET

    Mopping up the last few bugs in the internal test version. As a side-effect, a new Simple Control version has been released, it should be available in the next few hours.

    I've just created a new topic for the Simple Control, please discuss related topics there: https://social.sbrick.com/forums/topic/197/sbrick-simple-control-android/view/post_id/2510

    • 32 posts
    October 25, 2015 9:03 PM CET

    any news?

    • 164 posts
    October 23, 2015 3:47 PM CEST

    Great :) Thanks for the info! 

    • 2 posts
    October 23, 2015 1:05 PM CEST

    [blockquote]Tamas Misik said:

    Dear Russel, 
    Did you restart your phone after the update? 

    [/blockquote]

     

    Eventually figured it out. It started working after I unpaired the sbrick from the phone. 

    • 164 posts
    October 23, 2015 12:51 PM CEST

    [blockquote]Ed In't Veld said: Is there any news about the update? [/blockquote]

    Unfortunately nothing new. The developers are working on it. Hopefuly we can tell more next week :)

    • 164 posts
    October 23, 2015 12:47 PM CEST

    Dear Russel, 
    Did you restart your phone after the update? 

    • 2 posts
    October 22, 2015 1:30 PM CEST

    Thought I would share the results of my experience with my new sbrick. I have a galaxy S5, running android 5.0. My phone can see the s-brick, was able to update the firmware for the brick, but nothing will cause the brick to run any of the connected motors. This happens in both version 1.7 of the sbrick app, and the sbrick simple control app.

    Functional operation can not come quick enough. Otherwise my expensive sbricks are about as functional as actual bricks.

    • 17 posts
    October 21, 2015 1:12 PM CEST
    Is there any news about the update?