Forums » Support

Back To Topics

SBrick Android App

    • 7 posts
    December 8, 2015 3:52 PM CET

    [blockquote]Denis H said:

    Tamas

    I remember you and Sbrick team....that your initial and first statements was that Sbrick and app will work on 4.3+ devices, and THAT'S the reason i bought the sbrick in the first place (My phone is 4.3 and i'm not planning to purshase a new 4.4+ phone for this).

     

    Now your comments is very disturbing, because indicate that your are not involve in the development process.....so your developers are doing what they want, and that's maybe one of the reasons that this app have 1+ year old and counting and still in beta stage.....i want to repeat: ONE YEAR OLD!!! This is too much time for an APP to develop...

    [/blockquote]

    Tamas

    I totally agree with Denis, this is not professional !

    In my case, I can't get the SBricks running with my Galaxy A5.

    It was a present for my 10-year old son, he was disappointed having 8 PF-Motors, 2 SBricks and not be able to use it...

    Therefore I bought an used IPhone4S. Again, spent some "not planned" money to get it working.

    So, at least it works with the IPhone, but there are still issues (wrong screen ration for 4S, already posted 2 weeks ago)

    I'm a software developer myself and my superior would kick my a.... if I need that much time to fix issues/bugs !

    IMO, your team need some developers with more skills/experience.

    Your comments are desirable.

    Frank

    • 41 posts
    December 8, 2015 3:26 PM CET

    Tamas

    I remember you and Sbrick team....that your initial and first statements was that Sbrick and app will work on 4.3+ devices, and THAT'S the reason i bought the sbrick in the first place (My phone is 4.3 and i'm not planning to purshase a new 4.4+ phone for this).

     

    Now your comments is very disturbing, because indicate that your are not involve in the development process.....so your developers are doing what they want, and that's maybe one of the reasons that this app have 1+ year old and counting and still in beta stage.....i want to repeat: ONE YEAR OLD!!! This is too much time for an APP to develop...

    • 164 posts
    December 8, 2015 1:26 PM CET

    [blockquote]Ed In't Veld said: The login problems are over. When I want to make a profile and choose an controller hè said. Please log in[/blockquote]

    This is a know bug. Our developers are wokring on that. Please try to logout and login again. It will solve the problem. 

    About the Android 4.3:
    It seems our new application will works only with 4.4+ 
    More info about this soon. 


    • 17 posts
    December 8, 2015 1:20 PM CET
    The login problems are over. When I want to make a profile and choose an controller hè said. Please log in
    • 99 posts
    December 8, 2015 12:08 AM CET

    Basically the same results as Denis : the lag time is a big issue, the most annoying being that the app just cannot connect to the SBrick most of the time.

    Tried to install v1.9 on my Galaxy 10.1 tablet (Android 4.4.2): the app just won't start, it crashes instantly.

    Unfortunately, back to v1.6.1, the most stable until now.

    I really hope that v1.9.1 will solve all these problems, cause it's really better looking and better designed for sure!

    • 41 posts
    December 7, 2015 11:28 PM CET

    My test:

    1) The beta version of the APP don't work with devices with android lower than 4.4 (The app DON'T INSTALL), for example Samsung Galaxy S3 that use 4.3 version will not install.

    2) I use my Samsung Tab4 10" to test (android 4.4.2), a little difficult to test with a Technic Car due the big screen and controls (all my profiles were designed for a 5" phone). BUT there is my first test:

    - The app still disconnect-Connect-disconnect a lot, testing about 15 minutes happens at least 3 times (at 3 meters max)

    - This new app instroduce a VERY BIG INPUT LAG OR DELAY when you release a control (1 second aprox.); and sometimes when you start to press a control.....testing with one of my Technic Car (it's a fast buggy with 2 L motors), impossible to control because breaking and steeering.

    - The app looks prettier and indeed the profile management is working better.

    -  I don't have any issues with the login.

     

    I have only Technic Cars (sport cars, buggys, crawlers), so this app is NO GO for me due the BIG INPUT LAG.....impossible to drive with this app. So i go back to the 1.6.1 that works with my Samsung Galaxy S3 and don't have input lag.

     

    So, i will ask again the same question i made on February of this year: When we will get a working app???? another 5 months to fix that input lag maybe?

    I hate to write this, but this is the most disappointing and wanted (an the same time) products i have bought in many many years. Really disappointing!

     

     

     


    This post was edited by Denis H at December 7, 2015 11:29 PM CET
    • 17 posts
    December 7, 2015 10:48 PM CET
    Marc. Thanx a lot for the tip with the dummy letter. Its works wel. Tomorrow I Will test the app. Its in the netherlands time to sleep. Greetz
    • 99 posts
    December 7, 2015 10:41 PM CET

    [blockquote]Ed In't Veld said: Are there morele People with the login problems? Those the makers know the problems? [/blockquote]

    Check the upper and lower case of all letters. I had to find a workaround when I typed my email address, the app just wouldn't let me type a lower case initial and it refused to connect. I had to add a dummy letter at the beginning of my Id then to clear it, and then I could connect.

    Marc

    • 99 posts
    December 7, 2015 10:38 PM CET

    I have just downloaded and installed the new APK, testing in progress.

    First feeling : excellent work on the design. The profiles management is much better, the way to set-up every parameter is a huge improvement.

    Created a first, basic profile: the app worked fine.

    Created a second, still simple profile: worked too.

    The I quit the app and that's problems appeared : the phone (Sony Xperia, Android 5.0.1) lost the connexion with the SBrick and there was no way to reconnect it. Switched back to v1.6.1: same issue. A mix of I see it, I don't see it, and nothing works, even the port tester couldn't action the motors (although the SBrick was seen).

    The most annoying was that the phone just did not see the SBrick at the Android Bluetooth parameters level, and when it could see it, was unable to pair with the SBrick!!!

    Switched to the tablet, the Sbrick worked fine (phew!). Did a firmware update just in case. Firmware version is v4.3 now.

    Got back to the phone: I had to clear all app data, and it finally retrieved the SBrick.

     

    What I finally have is the following:

    - v1.9 can work, but it can lose the Sbrick if you quit the app.

    - When it works, there's a significant lag when you release a control : with a fast car, you will sure crash it!

    - When the Sbrick is lost, getting back to v1.6.1 (yes, the two apps are installed in parallel !) can solve the problem.

    - The v1.9.1 port tester is strange : first, you get the voltage and temperature, but not the versions information, and the sliders won't work.

    - If you manage to make the app work, and come back to the port tester, you can read the versions parameters (HW 4.0, SW 4.3 in my case)

     

    All in all, this new app looks great and will be much better, but 1) the Bluetooth management is not reliable and 2) there's this lag issue that can be critical.

    Still investigating (cache clearing, etc...) in case something can be done at the phone level.

    • 17 posts
    December 7, 2015 10:27 PM CET
    Are there morele People with the login problems?

    Those the makers know the problems?

    • 3 posts
    December 7, 2015 9:46 PM CET

    Awesome!  I did some testing with the new app and I'm able to control the SBrick from far distances 25-50ft without losing connectivity or crashing the app with over 30 minutes of testing.  I am running a Samsung Galaxy S6 on Android 5.1.1 with v4.4 of the firmware on the SBrick.  Great job!

    I saw this previously posted, but I am unable to use my SBrick social login as well.  Using guest only allows the simple control and wasn't able to access custom profiles I created with the previous version of the app.  I also wasn't sure if we needed to update the firmware on the SBrick.  Let us know when we can login to access the profile piece.

    Thanks again for letting us run the beta!

    • 95 posts
    December 7, 2015 9:42 PM CET

    The new application looks nice but I still cannot find the features I need

    I hope we are going to get the all the features available on iOS soon

    • 41 posts
    December 7, 2015 8:18 PM CET

    Tamas

    I found the problem.....you generate the APK compatible for Android 4.4+.....if you try to install in a android  device with 4.3, for example the samsung Galaxy S3 and many others, user will have the same issue.

    In my Samsung tab4 works, with a 4.4.2 version of android.

     

    PLEASE REGENERATE THE APP COMPATIBLE WITH 4.3+ DEVICES!!!! I CAN'T USE AND I CAN'T TEST THE APP!!!

     

    And i wonder why the app still don't work properly for about 1 year!!! silly me!!!

    • 41 posts
    December 7, 2015 7:53 PM CET

    Tamas

    Upload the same APK to google drive don't fix the damage APK. You upload the same damage file.....

    I donwload the 1.6.1 APK from your site and works fine!! even the apk have the sbrick logo, but beta don't. So this is not a download issue.

     

    Please regenerate the APK correctly and upload.

     And when i execute:

     "ERROR Analysis

    There has been a problem when analyzing the package"


    This post was edited by Denis H at December 7, 2015 8:01 PM CET
  • December 7, 2015 7:22 PM CET

    seems to work fine on my Samsung Galaxy Note4
    haven't tried all the different profiles yet, but think it will work.
    no problems with downloading, installing or connecting :)
    Good work! :)

     

    • 164 posts
    December 7, 2015 7:18 PM CET

    The new android apk on google drive -> https://goo.gl/CTWiZK

    • 164 posts
    December 7, 2015 7:07 PM CET

    Hello Ed,
    Our developers will look after soon what can be the problem. In the meantime please try to login with your facebook address or as a 'guest', without e-mail address and password.

    David:
    I will upload the apk to google play and dropbox soon. In the meantime please try to delete the application from your phone, and download it again. 

    • 17 posts
    December 7, 2015 6:33 PM CET
    A New message. I translate very bad.

    I am very happy with the New app. Only there is one problem. When I try to login there's a popup. Not valid email adress. I am sure That I try it with the True email adres
    • 17 posts
    December 7, 2015 6:08 PM CET
    Yesterday there is. Sorry for my problem. When I try to logo there's a popup. Not valid email adres. I am sure That I give the Good adress
    • 41 posts
    December 7, 2015 5:41 PM CET

    Tamas

    Now i can download, but the apk file is damage, because i have a package error message when try to execute in the phone. The apk don't have the Sbrick icon, have the android icon.

    I download the apk from a notebook, PC and the phone....all tries with the same error.

     

    • 164 posts
    December 7, 2015 5:17 PM CET

    Dennis: Please try this link: https://www.sbrick.com/sbrick_beta.apk
    It
    should works :) 

    • 41 posts
    December 7, 2015 4:50 PM CET

    Tamas,

    CAN'T download the Beta......that link redirect to https://www.sbrick.com/ 

     

     

    • 164 posts
    December 7, 2015 3:45 PM CET

    Hello Guys,

    You can download our new Android application on the following link: https://sbrick.com/sbrick_beta.apk
    This
    is just a beta version! If you find any bugs, just let us know. Please don't forget share with us what kind of device and OS version do you use.

    IMPORTANT:
    If you update the SBrick's firmware don't forget turn off and on the bluetooth on your device. Learn more about it here: https://social.sbrick.com/wiki/view/pageId/34/slug/android-sbrick-stops-working-after-ota-workaround

    The
    app has the same icon and same name as the previous version. Make sure that you use the latest version (it has totally new design).

    Thanks for your help :)

    • 1 posts
    December 7, 2015 9:31 AM CET

    Just got my SBrick a week ago. Add another owner with Android issues....

    I downloaded the new Simple app, but it can't update the firmware either.

    - seems to detect sbrick okay

    - ota says brick firmware is 4.0, 4.4 is available

    - starts update, gets stuck at 2/3%, every time

    I've done all the restarting of phone/brick, clearing bluetooth cache, etc. to no avail

    Moto G, Android 5.1

    Any ideas?

    Incidentally, if I go into the bluetooth settings of my phone it sees something called 'SBrick', but when I try to pair with it it says 'Pairing rejected by SBrick'. But when I lauch the Simple app it seems to see it okay. Does this mean anything?

    Did I just buy a useless piece of hardware?

    J

  • December 5, 2015 10:40 AM CET
    Nothing new?

    Well let's hope that no news means good news.
    Hope it will be solved before Christmas.
    So that the holidays can be used for SBrick playing.