Forums » Support

Back To Topics

SBrick Android App

    • 3 posts
    January 24, 2016 3:22 AM CET

    I solved my problem of non working Sbrick after OTA Update
    I use a Samsung Galaxy S5 with Android 5.0

    After i did a OTA Update from 4.0 to 4.3 with the 1.6.1 Android App, my Sbrick did not work. The connection to it worked, but it was impossible to control the Motors and the LED on the Sbrick was always on.
    I tried to restart BT, i stopped BT and delete all Data and Cache from BT, i reinstalled the Sbrick app, i updated the Firmware a several times, i restarted my phone, i shut it down and removed the Battery for 2 Minutes, i wiped the Android Cache Partition but nothing.
    Simple Control allways crash when i tried it, and the OTA Update to 4.8 allways failed at 2%.
    Last Night i updated the Sbrick App to 2.0 but it was even worse. With 2.0 OTA Update fails now too.

    Then, when i thought I had nothing left to loose i unpaired the Brick in the Android BT and voilà, everithing works fine. I had not even to do a restart. Update to 4.8 worked too, at first time. No crashes, no lag's. Everythin like it should be.

    I once read here in the Forum that one should never unpair a paired Sbrick with Firmware less than 4.4 and it's true, after i unpaired the Sbrick it was not possible to pair it again. But in my case, it's not necessary. The Sbrick app recognized the Sbrick without pairing. After the Update to 4.8 now i can pair it again.

    • 17 posts
    January 23, 2016 11:05 PM CET
    [blockquote]Anthony of Minas said:

    @Tamas

    Thank you for letting me know. It is good to know that the app does work perfectly on other devices.. Sad thing is I am not planning on changing my device.

    I have unistalled and reinstalled. Something that I thought was a fluke but appears to not be: The instructions when you first launch the app, I cannot swipe through them with ease. I swipe right but its like the slides are on a timer and wont slide away before the timer elapses. Or as if the touch input is not getting registered correctly.

    So after the reinstall, I can connect to SBrick sporadically, and also control it sporadically. I am on FF4.4 and I can't upgrade to 4.8 nor from the SBrick app nor from the Simple app. LED tester does not work. Please tell me if there is any more info you need me to provide.

    [/blockquote] In the first time its go Also by me. Try to Do it like me. Put 4 motors on the sbrick. Go to MY SBRICKS. Then move the sliders left and right. And the click on Upgrade Firmware. Maybe you have succes
    • 1 posts
    January 23, 2016 9:26 PM CET

    hi, i have just got an sbrick and have the app on my android tablet polaroid ND210 but it will not recognise the brick. i tried using the nRF master contol panel ap but this said my device was not comaptible with bluetooth smart....any ideas what i can do?

    • 41 posts
    January 23, 2016 2:56 PM CET

    Update:

    I have to use my Tablet Samsung Galaxy TAb4 10", android 5.0.2 to finally update the firmware to 4.8 version (last one) with the simple control.

     

    **Test Tablet Samsung Galaxy Tab4 10", android 5.0.2, firmware 4.8 (last one):

    - The LAG is still present....impossible to play!!! FIX THE LAG/DELAY, in the 1.6.1 and 1.7 there is NO LAG.

    - My Profiles are no showed in the app. I create a new profile (test) in the new profile designer....still don't show.

     

    **Test Samsung Galaxy S3, android 4.3, firmware 4.8 (ast one):

    - Same results!!! FIX THE LAG/DELAY and the Profiles!!!

     

    Not for been a beatifull app, will be OK......i prefer an UGLY and FAT app that ACTUALLY WORKS!!

    I don't know why i botter to test this app....is useless

     

    I suppose this will take another year to fix......

    • 41 posts
    January 23, 2016 1:34 PM CET

    @Tamas

    Test the 2.0 version of the APP in my Samsung Galaxy S3, android 4.3:

    (Uninstalla de old app, remove all, profiles, cache, etc)

     

    1) Now works with android 4.3

    2) I can't see my profiles in the app, created in the profile designer.

    3) I can't enter in to the new version of the profile designer (web, using chrome), the loading icon stay forever (i wait 10 minutes)

    4) FIX THE INPUT LAG OR DELAY!!!!! SAME PROBLEM WITH THE PREVIOUS VERSION....A LOT OF LAG, LAG, LAG and more LAG!!!! Impossible to play!!! i go will go back to 1.6.1 or 1.7 version of the app.

     

    Now the question is, i can use the 1.6.1 or 1.7 version with my "old" profiles???? because this 2.0 app is still a NO GO!!

     

    edit1: 

    I check the Sbrick tab, and i have the Firmware and Hardware 4.2b2.......upgrading the firmware fails always at 12% (try 15 times).

    I don't know if this is the firmware that suppose to work with the 2.0 app.

     

    edit2:

    Test the simple controls to update the firmware to 4.8 FAILS also at 12% (exact 14.000 bytes)....ALWAYS!!!!

    Can you provide an APP to only update the firmware?? OR provide a list of android device that CAN do a perfect firmware update to ask some friends if anyone have that device.


    This post was edited by Denis H at January 23, 2016 2:03 PM CET
    • 99 posts
    January 23, 2016 11:45 AM CET

    [blockquote]Frederic Ayrault said:

    It is also "difficult" to exit this app no quit option in the menu and/or the return key does not work. The only working way is to use the home key...[/blockquote]

    Frédéric, you never close an Android app... All you can do is to conceil the app, but it's always running until you clear it from the running apps list. Even after doing this, a lot of apps still run as background tasks, you must clear the cache to get rif of them.

    Android is not a "serious OS": it works, it's improving, but its first and only goal is to make people buy stuff from the Google Store. Gathering personal information is one of the ways they use to do it, that's why you cannot really control anything with a stock Android release. You may try an alternate release (Cryogen or whatever you will find), but at your own risks.

    It's even worst with iOS: Apple has really a full access to whatever you do on your device, it's the basis of their business model. And Microsoft is now working in their path with Windows 10...

    As for your other requests, you are right, but the first concern is to have an app that works!!!

    Marc

    • 95 posts
    January 23, 2016 10:35 AM CET

    I have just installed the new version and created a new profile to test the auto reset and output values for buttons

    and those fonctions are still not working. I am still waiting the "really cool features" promised

    It is also "difficult" to exit this app no quit option in the menu and/or the return key does not work. The only working way is to use the home key...

     

    X

    • 99 posts
    January 23, 2016 10:19 AM CET

    First test results with the Sony Xperia Aqua M4:

    The first feeling is good.

    - Same comments as for the Beta about the look&feel of the app: the design is excellent.

    - Firmware update worked perfectly

    - No problem to download a profile, setting up the controls was easy.

    - First drive test in the living room is OK. Must wait until I can test the car in real condition, but a huge Formula 1 with 2 RC Motors needs a lot of free space and i don't live in a castle ;)

    Unfortunatlely, the app still crashes on the Samsung Galaxy Note 10.1 with Android 4.4.2 (Rooted)...


    This post was edited by Marc Jaouen at January 23, 2016 10:24 AM CET
    • 99 posts
    January 23, 2016 9:49 AM CET

    [blockquote]Ed In't Veld said: On the wiki page I have see That sbricks worked well with the Sony xperia aqua m4. Is there any one That can say it is really true. I go to buy a New phone and its important for me That I can use it with the sbricks [/blockquote]

     

    Ed, I have an Aqua M4 and I confirm it works fine, at least with one SBrick. The best app version with this phone is 1.6.1, I am currently upgrading to the new version to see how it works.

  • January 23, 2016 9:45 AM CET
    Very excited to see the redesigned app and was hoping for good things, however I still get nothing.

    I have deleted and re-installed the app. I have tried to update the sbrick firmware from 4.3 and at 2% every time it fails. I have followed the tutorials but the sbrick does respond.
    The sbrick panel also doesn't activate the sbrick.

    Like other users I am not changing my device, therefore what information would you need to investigate my issues.

    JJ

    • 28 posts
    January 23, 2016 9:39 AM CET

    @Tamas

    Thank you for letting me know. It is good to know that the app does work perfectly on other devices.. Sad thing is I am not planning on changing my device.

    I have unistalled and reinstalled. Something that I thought was a fluke but appears to not be: The instructions when you first launch the app, I cannot swipe through them with ease. I swipe right but its like the slides are on a timer and wont slide away before the timer elapses. Or as if the touch input is not getting registered correctly.

    So after the reinstall, I can connect to SBrick sporadically, and also control it sporadically. I am on FF4.4 and I can't upgrade to 4.8 nor from the SBrick app nor from the Simple app. LED tester does not work. Please tell me if there is any more info you need me to provide.

  • January 23, 2016 1:26 AM CET

    Hello all, having a difficult time with the android app. I cannot find my creations that I made in Profile Designer anywhere on the app. Is this a known issue?  I may uninstall and re-install the app and see what happens.

     

    Ken

    • 17 posts
    January 23, 2016 12:22 AM CET
    This evening was very Good.

    I can try the New sbrick app. In the simple version the firmware can not be upgrade. Now in the official app it go on. The first times looks lik the other times and its go wrong. When I put motors on the bricks and use the sliert the motors go on. Then try to update the firmware and...... Yes it was worked.

    Tomorrow try to use the sbrick with my own creation on the mercedes arocs.

    Sleep well
  • January 22, 2016 10:23 PM CET

    Ok, now are both abrick v4.8 . Now works simple control only on LifeTab and no longer at the S4?

     

     

    • 164 posts
    January 22, 2016 9:16 PM CET

    Thanks for the report Karl, it really usefull for us!

    Please try to update the SBrick's firmaware. Maybe you use an older version.
    You will able to update it with the Simple Control for sure.

    After the update please don't fortget restart your device.

    What if happen if you use it only with one SBrick? You can play with it?

    Thanks for your help.
    Tamas.

  • January 22, 2016 8:58 PM CET

    delete and reinstall, again and again and again and.......

     

    Situation on Lifetab:

    • 164 posts
    January 22, 2016 8:39 PM CET

    Hi Anthony,
    Thanks for the report. We will look after what can be the problem on your device.

    I don't know prove you a complet list now, but we tested it with LG G3, LG G Flex2, OnePlus One, Samsung Galaxy s4 mini, Galaxy A5, HTC one for sure. Our developers tested it with some another mobile and tablets as well. And it worked perfectly for us.
    We will make a compatibily list soon.

    Karl and Anthony,
    Did you tried to delete and reinstall the app? ... I know this is not a professional answer to your problem, but you know ... this is Android... A reinstall sometimes solve every problem.  (Anyway, with our devices everything worked well without reinstall, so there will be some problem for sure. We will look after!)




  • January 22, 2016 8:39 PM CET

    I use first Device:

    LIVETAB S8312, Android-Version 4.4.2, Kernel-Version 3.4.67

    second Device:

    SAMSUNG Galaxy S4 GT-I9515, Android Version 5.0.1, Kernel-Version 3.4.0-5812669

    SBrick 00:07:80:2E:27:7C, v4.8

    SBrick 00:07:80:2E:3F:13, v4.3

    SBrick Simple Control works on both devices without any problems!

     


    Below: A screenshot from the S4. Both Bricks are turned on. More is not possible.

     

     

    • 12 posts
    January 22, 2016 8:38 PM CET

    Very big THANKS for a new version of app. It's working all, pad doesn't necessary to be reboot (there was a very stipid rule).

    I want to convey to request to make an EXIT button from mainmenu (not "logout", "exit"!). A can't exit from prog!


    This post was edited by Viktor Onishchuk at January 22, 2016 8:40 PM CET
    • 28 posts
    January 22, 2016 8:21 PM CET

    Nexus 4, Android 6.0.1 CM13.

    Bluetooth on > Menu > SBricks > Tap on the listed SBrick > See screenshot below

    I don't know if this has been asked before but in any case: What devices are you officially testing on? Could you please list them along with their Android versions so we can all have an idea?

    Does the app run well on the devices that you are testing on? And by well I mean can you actually use all functions provited in the app without fail? (or fail within an acceptable margin).

    It's quite disconcerting that a year+ later there still isn't a workable app that will let us enjoy your product. I have a test car that I have built a year ago on my desk that I see every day and it reminds me of all the things that the SBrick could allow me to create but that I can't due to not being able to reliably controll the SBrick.

    • 164 posts
    January 22, 2016 8:08 PM CET

    Dear Karl,

    Do you still use this device? Lenovo S8312 Livetab, Android 4.4.4, Bluetooth 4.0.

    "two brick simultaneously not function" Can you give us more details about this problem?
    Our developers will look after your problem as soon as possible.

    Thanks for the report.
    Tamas.

  • January 22, 2016 7:20 PM CET

    Is getting worse. Slowly, two brick simultaneously not function. I've had enough. I do not want more to deal with the crap.

    • 164 posts
    January 22, 2016 6:41 PM CET

    Hello Guys,

    Really sorry for the late reply and the big delay, but our new application finally relased!
    You can download it from Google Play: https://play.google.com/store/apps/details?id=com.vengit.sbrick

    Wiki
    for the new App: https://social.sbrick.com/wiki/view/pageId/36/slug/the-app

    Please
    try it and share with us your experiences.

    Thanks,
    Tamas

    • 17 posts
    January 19, 2016 10:36 PM CET
    On the wiki page I have see That sbricks worked well with the Sony xperia aqua m4. Is there any one That can say it is really true.

    I go to buy a New phone and its important for me That I can use it with the sbricks
    • 17 posts
    January 18, 2016 10:25 PM CET
    A few days...... a few weeks. .....A few months. .....

    I can't believe my self That I believe it