Forums » Support

Back To Topics

SBrick Android App

  • April 21, 2015 10:18 PM CEST

    Thx for the response.
    Ok, so connecting works fine, just using the sliders do not work?
    Did you connect to just one SBrick or more?
    Did you use a SBrick with new FW?
    As i did not update FW: did the api changes?
    Which Android-Version?

    This post was edited by Philipp Kaufmann at April 21, 2015 10:26 PM CEST
    • 34 posts
    April 21, 2015 7:04 PM CEST

    @Philipp I Tested your app on a galaxy S4, but it disconnects from the brick when I move the slider.

    @Matthew The iPhone's bluetooth chip is far better than the Android's, so you could try with that. We'll made some improvements around the OTA, maybe these fixes solves your problem also.


    We finished the more sbrick support (currently tested with 3), and the "one function two ports" feature, we'll make some additional bugfixes tomorrow, and you'll get a new android version.

    • 9 posts
    April 21, 2015 4:08 PM CEST

    I got my new SBrick connected up today, installed the 1.1 android app on my Galaxy Note 2 running Android 4.3

    But after  a couple hours of trying, I could not get the firmware update to work.

    From what I could tell, you need to update the firmware before you can use the 1.1 version of the app to control a MOC????


    I guess i'll try again tomorrow :-(

    Does the iPhone version work better? should I try to get one of my friends with an iPhone to do the firmware update?

    This post was edited by Matthew Boehm at April 21, 2015 4:09 PM CEST
  • April 21, 2015 1:07 PM CEST


    i delevoped a small test-app for my own, to see, if it's really such a problem to create a working app for Android.


    it works for me.

    Samsung Galaxy Note 2, Android 4.4.2

    scan SBricks
    use up to 4 SBricks simultanously.

    This post was edited by Philipp Kaufmann at April 21, 2015 1:08 PM CEST
    • 34 posts
    April 18, 2015 3:45 PM CEST

    I have a feeling that devices with plain android or Google made - and Moto G 1/2 are still product from 'owned by Google' era -  display same behavior, the Moto G2 does not work the same way as Nexus 7 for me (and Moto G 1 too, but with broken screen I do not play with that one much)

    • 13 posts
    April 18, 2015 2:20 PM CEST
    Ok, tested with nRF said that it stayed on FW 4.0. So OTA don't work on Moto G2. In that way the sbrick stays useless for me :(
    • 34 posts
    April 18, 2015 11:00 AM CEST

    Karsten, I'd suggest to check it, if it is really updated, I could not do that on my Nexus 7 tablet (even if it said update complete), but when using HTC One it was OK on first try. 

    I used the nRF Master Control Panel (BLE) to prove that the SBrick was still on FW 4.0 even after the success message on Nexus and went to 4.2b2 after update through HTC One. The versions are under the Device information service.

    Short info can be found in this video by TechnicBRICKs

    • 13 posts
    April 18, 2015 9:33 AM CEST
    Next try. At the end of OTA occurred a message that it could not connect to the sbrick. Then the app tells me that OTA is complete , ok. This time there was a little text message, that sbrick is up to date. After kicking ok, the app is terminated. Next time is the same.
    • 5 posts
    April 18, 2015 7:38 AM CEST

    [blockquote]Karsten Grosse said: Still the same with the latest version on Moto G2 (Android 5.02). No update on sbrick possible and the sbrick didn't work (even the port tester). Only LED on /off work. :([/blockquote]


    same phone, same android version.. and same problem. sbrick keeps asking to update firmare aswell as still being able to turn led on/off.. thats it

    • 13 posts
    April 18, 2015 12:07 AM CEST
    Still the same with the latest version on Moto G2 (Android 5.02). No update on sbrick possible and the sbrick didn't work (even the port tester). Only LED on /off work. :(
    • 99 posts
    April 17, 2015 10:48 PM CEST


    I have reported some issues in the Profile Designer thread, and was replied that theses bugs are Android problems, not PD problems.

    - Sliders position is not exactly what is defined in the PD (already reported)

    - Round items (such as the close button) are displayed as ovals (already reported). Managed to use a custom square buttom that looks good, although probably rectangular now.

    - Tried to use square sliders buttons. All messed up once displayed, will try plain jpgs instead of the fancy alpha-channel png I have used.

    - Tried to set a min and max value to the steering slider, still works from -1 to +1.

    - Pixelized pictures. Probably OK on a phone, but annoying on a tablet.

    - My background's background is supposed to be grey, it is displayed as green-grey


    Zsolt replied "Sadly, all of these are android bugs. Do you reported these bugs into the android app topic too?"

    • 95 posts
    April 17, 2015 9:52 PM CEST

    [blockquote]Zsolt Majoros said:


    We're updated the roadplan. This is the priority list for new functions, we'll work based on this. We're still working hard on more sbrick support, we have some android specific problems yet but we'll release it as soon as possible on next week. We're also fixed many reported problems.



    Thank you for the informations. Can we expect more than one brick next week?


    • 99 posts
    April 17, 2015 8:21 PM CEST

    Hi Karsten,


    The link for v1.1 was provided in the previous page of this thread :




    • 13 posts
    April 17, 2015 6:52 PM CEST
    Where can I find the latest download version for the Android app (it's a bit difficult to find for me, link? ).
    • 34 posts
    April 17, 2015 6:25 PM CEST


    We're updated the roadplan. This is the priority list for new functions, we'll work based on this. We're still working hard on more sbrick support, we have some android specific problems yet but we'll release it as soon as possible on next week. We're also fixed many reported problems.

    • 5 posts
    April 17, 2015 5:35 PM CEST

    Gr8, im sitting here with a problem, i think some one else also stated, i have the 1.1 version of the app, aswell as going several restarts reinstals and turning evry device on/off now, the app still keeps asking to update the firmware.. its already updated.. several times.. evrytime after the update it tries to find the sbrick which it does, and it allows me to test it, latency is nothing now compared to the 0.8 version, now even though it states to turn bluetooth on/off that doesnt work.. at all. it just keeps continiously asking to update the firmware... its updated.. the light will go on when i press it.. but adding controls or adding it to a profile NOPE so, what do i do now? im out of ideas..

    • 95 posts
    April 17, 2015 9:47 AM CEST

    I have finished the Ultimate 8043S and I now I can not wait playing with it but I need to manage 2 Sbricks...

    This post was edited by Frederic Ayrault at April 17, 2015 10:12 PM CEST
    • 99 posts
    April 16, 2015 1:25 AM CEST

    Just couldn't sleep - LOL.

    Well, I have an operational custom profile. One bugs plus Two display issues:

    1) Vertical sliders work fine, but whenever I try to rotate one to get a horizontal slider (steering mode), the app crashes when I launch the profile.

    2) The position of sliders in the app do not match their position in the Profile Designer. Something wrong in the coordinates and orientation management. Size management seems OK.

    3) The picture I have uploaded is mainly black and white. Too bad KitKat won't let me take screenshots, the picture is displayed with ugly red pixels in some areas. Tried both jpg and png formats it doesn't help...



    Edit : Orientation is OK. It's the coordinates management which is wrong : my horizontal slider was correctly placed in the PD, but was out of the screen in the app. Moving it towards the center allowed to have a working horizontal slider in the app.

    Edit 2 : Tried with another picture, which is correctly displayed (though somehow pixelized). I think the red pixels came from the fact that I had gamma-corrected the picture to improve the contrast. Forget this picture, I will dig further to understand what's going on.

    This post was edited by Marc Jaouen at April 16, 2015 1:41 AM CEST
    • 99 posts
    April 16, 2015 12:03 AM CEST

    Thanks Matej, 16:10 appeared in the app, I will use this format now. The app crashes when I try to use it, but I will certainly make it work with some patience. Tomorrow, cause I must be at work at 3:30AM and it's alread 12:00 !!!!



    • 34 posts
    April 15, 2015 11:19 PM CEST

    Works for me. 

    I'd suggest to make a new profile per each display ratio and see if something appears. 

    This post was edited by Matej Papluh at April 15, 2015 11:20 PM CEST
    • 99 posts
    April 15, 2015 8:34 PM CEST

    I confirm the inversion of channels B & C inverters. This one should be easy to fix ;)

    As for "My Profile" being empty, am I the only one or do you all have this problem ?


    • 99 posts
    April 15, 2015 2:16 PM CEST

    Hi guys,

    Have played with my ugly chassis in full sunlight during 15 minutes. Worked perfectly, the 5292 did not trigger any thermal/current limitation. That's what I needed :)

    Most urgent issues in my case.

    - Can you see your personal profiles in the app, or is it just me ? I managed to download the 4 stock profiles from the "all profiles area", but the list is empty when I enter "My Profiles". Is there a control on background dimensions ?

    - Inverter switches : random behavior. Some work, some don't (try to drive a car that goes left when you turn right - LOL!). Will try to build a check list if necessary.



    Edit : "invert buttons for channels B and C are still swapped." OK, it could be the explanation.

    This post was edited by Marc Jaouen at April 15, 2015 2:29 PM CEST
    • 34 posts
    April 15, 2015 2:12 PM CEST

    So, an update.

    I risked my working config on HTC One and used the beta app there. Each of the two SBrick was updated on the first try to 42b2.

    after that, they stopped responding = no port tester, no profile ... even phone restarts, profile reloads did not work, even app reinstall. After downgrade to 0.8 and loading 1.1 over the 0.8 it started to work. 

    Good news is that the response to control seems better.

    Bad news, old news:

    - app crashes as usuall

    - trouble loading profiles from market, had to delete and redownload in different order otherwise it would not add the last profile to creation (I tried to add the last downloaded profile and it had linked the one before)

    - invert buttons for channels B and C are still swapped.


    On Nexus 7 the Sbrick is still no usable even after upgrade (both brick and app). The profile loads but after about 1 sec of powering any channel it stops responding until exited and reloaded. Port tester seems ok. nRF exhibits similar behavior, after issuing a command (100%, 33%,-100%) the port works for even less than second and nRF disconnects. 

    • 99 posts
    April 15, 2015 12:19 AM CEST

    For sale, all items like new: 1 IR receiver v1, 1 IR Receiver v2, 2 Basic Remote Controls, 1 Speed Control Remote Control

    Just kidding, I keep them :)

    Came back home at 8:30PM. At 11:00PM, I was down in the parking lot driving this large & ugly F1 Chassis (5292 RC Motor + Servo), controlled from my tablet. It works really fine: congrats to the development team!

    Yes, I had a hard time updating the firmware : it worked after 4 attempts, I had the same problems as you guys. This issue should be a priority for the developers for sure.

    Yes, the app is still in draft mode, with several bugs to be corrected, and we all have tons of excellent ideas to improve it.

    But this basis is excellent : my first success was to control 1 XL, 1 M and 2 pairs of LED's with the ports tester, and it worked fine. If this core module is reliable, the rest will follow.

    The rest is a pure matter of screens design and development methodology. Test, test, and test again ;)

    There's a true difficulty with Android : while you have only half a dozen Apple devices, all with the same OS, it's really difficult to find two people with the same Android device and the same OS version. A CIO I met last year told me "Mobile apps ? Well, you can do it for the iPhone, it will work but you will lose money cause not enough users. With Android you'll have plenty of users, but the app won't work and you will lose money." Half joke, half truth...

    Fine, it's late. I will sleep on that, I'll be back in the next days and will cooperate when possible to this cool project.

    In the meantime, you can add a row to the table : Samsung Galaxy Note 10.1 LTE, KitKat 4.4.2 Rooted, Works :)


    This post was edited by Marc Jaouen at April 15, 2015 11:20 AM CEST
  • April 14, 2015 10:45 PM CEST
    Now I can control the Sbrick. Problem was that the sbrick had to be paired manually in the android bluetooth settings. Firmware update worked as well. But, as others already posted, only one sbrick can be configured and controlled at a time.
    Looking fordert to the next update.