Forums » Support

Back To Topics

SBrick Android App

    • 24 posts
    April 5, 2015 9:22 PM CEST

    Samsung Galaxy S3 running Android 4.3.

    Congratualtions to Sbrick for actually issuing an update when they said they would.  Well done!!

    However, just issuing any old rubbish that happens to be around isn't really what we all expected.  I cannot believe that this new version was actually tested before being allowed to escape.

    After going through all the problems that others have experienced with multiple OTA updates, un-installing and re-installing, turning bluetooth off and back on and turning the phone off and back on I've finally - after an hour or so - got to the point where I can discover a Sbrick without having to update it.  From it's reaction to the port tester the response seems very good.  However it would be nice if the Identity LED actually turned off and on instead of being permanently on!

    Finally, I get to building a control set.  The creation builds quite nicely and accepts an Sbrick without requiring an update and accepts a standard profile.  Great!  All I need to do now is to save it.  To do this it would be nice to be offered that option but no matter where I look there is no option to save a creation.  The consequence of this is that I can either edit the creation or delete it but actually use it.....no chance.

    I'm in the unfortunate position of being an early Kickstarter backer and thus accept that if I subscribe to absolute rubbish it's my own fault.  If I'd purchased my Sbricks after the Kickstarter campaign I'd be looking at legal action for a refund and expenses.  With Vengit being based in London and with the UK's  Consumer Protection Laws the advice I've been given is that it'd be a bit of an open and shut case as no defence appears possible.

    Come on Vengit - either publish a working Android app or finally admit that an Android application is beyond you and start arranging for refunds!

    • 21 posts
    April 5, 2015 8:14 PM CEST

    After another reinstali i can run profile. But invert for servo doesn't work.

  • April 5, 2015 7:15 PM CEST

    Everything works fine, just the two bricks do not.

    • 41 posts
    April 5, 2015 5:31 PM CEST

    I have some news..... i uninstall the sbrick app, restart the phone and install the sbrick app again.

    But now i go directly to the profile section (Don't go to the manage sbrick menu!!!), discovery the sbrick and update the firmware in the profile menu. When you are done with the update a screen shows ("update ok or something"), when i press OK the app crash, so.... i inmediatly restart the phone. Once the phone restart i enter the sbrick app and make a new creation, now i can select the sbrick without any update dialog. FINALLY!!!! Testing with a MOC (it's a Car) and works fine.....also i download my "test" profile and works fine.....the delay now is really minor, if can be reduced a little more will be perfect.

     

    Issues:

    - If i exit the app and want to use the profile i made for this MOC (play later for example), the discovery sbrick dialog stay forever.....can't discovery the sbrick. The only solution is to delete the MOC Creation profile and do all the process to add a creation (select the profile, select the sbrick, select the channels, etc.) in order to use it again.

    - Manage Sbrick menu is buggy.....firmware update CAN'T be done in that menu.

    - The App crash time to time.

    - Joystick type profile don't work...app crash.

     


    This post was edited by Denis H at April 5, 2015 8:19 PM CEST
    • 41 posts
    April 5, 2015 4:29 PM CEST

    @Zsolt

    Yes, i restart the BT every single time i update, also restart the phone, also uninstall sbrick app, restart the phone, install sbrick again....i have the same issue, firmware update over and over again. Impossible to use the Sbrick.

    Also tried with a Samsung Galaxy TAb4 10.1 (android 4.4.2) with the same Sbrick....same problem, firmware update over and over again.

     

    During testing..... i have already update the firmware 20 times, and still the app ask me for a firmware update.....THIS IS NOT NORMAL!!!


    This post was edited by Denis H at April 5, 2015 4:32 PM CEST
    • 4 posts
    April 5, 2015 4:03 PM CEST

    @ Zsolt Majoros,

    With "one function, 2 ports" do you mean controlling 2 ports on SBrick with one slider?

    This is what I want to do but I'm unable to get it to work.

    regards E. 

    X

  • April 5, 2015 3:34 PM CEST

    I now Ver. 1.0b installed on my Livetab.

    After that I started the app and turned on the SBrick.


    After logging in and downloading the profiles ...

    ... I start "Manage bricks" whereupon the following screen appears.

    After about 10 seconds the message "Discovering Bricks" disappears and I see the following ..


    If I select them the Sbrick then comes the following ...

    END !!! That's it, that's all about.

    PS: The same problem of course with both! Bricks !

    The "SBrick Simple" works without problems !!!

     

     

     

     


    This post was edited by Karl Fensterstock at April 5, 2015 3:51 PM CEST
    • 57 posts
    April 5, 2015 3:18 PM CEST

    I decided to give it a try with another SBrick, so I unpwered the first and powered the second one.

    It pairs with phone as second and distinct device.

    Although SBrick App continues to see the same SBrick ID and MAC address (00:07:80:2E:39:F2) which is quite weird and probably related withe the root cause of the problem with my device!?

    Hope this helps you to find where the bug hides...

    It might be an update problem similar to what observed with the market profiles. After moving into another men and return to "Manage bricks", it displays the right MAC Address.

    Tried it also with Samsung Galaxy Pro 12.2 (4.4.2). Same issues!

     

    Have a nice Easter. ;)


    This post was edited by Fernando Correia at April 5, 2015 3:41 PM CEST
    • 57 posts
    April 5, 2015 3:09 PM CEST

    Also tried to rename SBrick in my list of paired devices to "SBrick #01", but app continues to find it as "SBrick".

    Maybe it doesn't care about the name defined at device level and relies at manual rename at the App level.

     

    Find also another bug.

    When I download profiles from the market, App never remembers about the last downloade profile. If I delete another one and download it again than that's the last one and it doesn't remember its download status.

    However if I switch to another menu (e.g. Home) and switch back to Market menu, then it displays the downloaded profiles correctly.

     

    • 57 posts
    April 5, 2015 2:46 PM CEST

    Same problem here!

     

    Smartphone: Samsung Galaxy Note Edge

    Android OS: 4.4.4

     

    App keeps asking to update SBrick firmawre afther having already done so.

    Restarted BT, Sbrick and even the smartphone. Also tried to uninstall SBrick App and installed it again.

     

    I'm confient you'll find the issue and provide a fix soon. ;)

    • 13 posts
    April 5, 2015 2:46 PM CEST
    This is now my test:
    Deinstalled 0.8. After that installed 1.0b. Sbrick is found and said that I have to update. After update is complete there is a message like :"Could not connect to sbrick. Out of range or powered off..."

    Then message: "sbrick firmware update completed"... Clicked ok.

    Then message : sbrick was terminated and it restarts by itself with a blank screen and sbrick logo. When I go back there is every time my creation one more duplicated.

    And when I restart Bluetooth like I should, it's thesame. The sbrick is found and when I click on it, it says that it is not up to date. I can't select the sbrick for port test, I can only update or cancel, nothing more. So far on our Moto G2.
    Happy easter to all of us
    • 21 posts
    April 5, 2015 2:23 PM CEST

    [blockquote]Denis H said:

    BUT now everytime i want to use the sbrick (select in the port tester or profile screen) the app ask me again and again and again that i need to update the firmware (i already update the firmware 6 times)...i CAN'T USE THE SBRICK!! the app always ask me for an firmware update, all updates are OK. [/blockquote]
    Strange, in my case the app only once requests for update the firmware after updating. And I rejected this request.
    Do you try to delete completely the app and reinstall it? 

    • 34 posts
    April 5, 2015 2:20 PM CEST

    For everybody who updated the firmware and the app asks for another update, did you restarted the device's bluetooth?

    "one function, two ports" and more sbrick support will be solved next week.

    We'll fix the other problems also next week, thank you for your feedbacks.

    • 41 posts
    April 5, 2015 1:37 PM CEST

    Test the new 1.0b version of the app on my Samsung Galaxy S3 (i9300).... the app ask for an firmware update, i successful update the sbrick. BUT now everytime i want to use the sbrick (select in the port tester or profile screen) the app ask me again and again and again that i need to update the firmware (i already update the firmware 6 times)...i CAN'T USE THE SBRICK!! the app always ask me for an firmware update, all updates are OK. Also the app crash time to time (fortunately not during the update process).

    Sbrick-Team......at this point clearly you don't have the skill to make an android app for your own product....i suggest to hire a guy who knows about android development. I'm very disappointed with your product overall....we will have to wait another month for an update? 

    • 7 posts
    April 5, 2015 1:22 PM CEST

    I have the new S-Brick app installed. Then, the firmware should be updated on the S-Brick OTA. I did that. Now the S-Brick fail to connect ("could not connect to sbrick, it might have been power down, or gotten out of range") and the LED is permanently on. What can I do?

    after a lot of hours with very very many app crashes, a lot of force stops, cleared data and with a lot of restarting Bluetooth, App and SBrick now it works. (HTC One S Android 4.4.4)

     


    This post was edited by Tanja Causemann at April 6, 2015 9:58 AM CEST
    • 21 posts
    April 5, 2015 12:46 PM CEST

    Samsung S3 i9300

    In port tester, i havn't delay anymore. This is a very big step forward, as for my.
    Also i updated firmware my sbrick (for the first time).
    But i can't run any profile in "my new creation" - app is closed.

    For my phone model its a progress. Thanks!

    • 95 posts
    April 5, 2015 10:24 AM CEST

    [blockquote]Karsten Grosse said: Looked out for new version yesterday, but nothing in the playstore (still 0.8). Where can I find the new version (which seems to be not working) ? [/blockquote]

    You have to download it https://www.dropbox.com/s/x8cwbglsavsiune/SBrick_1_0b.apk?dl=0

     

    X

    • 10 posts
    April 5, 2015 10:11 AM CEST

    the others keep update and update and update again..........

    can't use!

    • 10 posts
    April 5, 2015 10:06 AM CEST

    i have 4 nos. of sbrick but just only the 1st one can update the fw, not the others, please help

    thank you

    • 13 posts
    April 5, 2015 9:22 AM CEST
    Looked out for new version yesterday, but nothing in the playstore (still 0.8). Where can I find the new version (which seems to be not working) ?
  • April 5, 2015 8:21 AM CEST

    This time app is much more stable on my Sony Z Ultra, OTA firmware update was sucсessful, but "one function, two ports" feature still don't work. I think that it is not so complicated feature, but devs still can't do anything with it.

     

  • April 5, 2015 4:32 AM CEST

    Samsung Galaxy Note 4 (SM-N910G) running stock 4.4.4, not rooted or anything. SBrick 0.8 app almost works for me.

    I can add a creation, set the picure and name, add an sbrick and those values seem to persist. But adding a profile doesn't work properly. Specifically, I add the profile (42030 in this case), it shows up but as soon as I leave that screen it disappears. So I can't associate channels on the brick with controls, because when I go into the brick properties to do that the profile vanishes. I can go into the profile control screen, but since no brick channels are assigned the controls don't do anything.

    And of course while I was taking screen shots to report this the app crashed. First time that's happened. Previously I've let the app turn on bluetooth for me, but this time I turned it on while the app was starting (and enabled wifi too), and just after leaving the "scan for device... pairing..." screen the app crashed.


    This post was edited by Deleted Member at April 5, 2015 4:38 AM CEST
    • 95 posts
    April 4, 2015 11:36 PM CEST

    OTA only works when there is only one sbrick powered

    after upgrading 2 sbriks (one by one)

    one is working andfor the other identify led and port testing stop to work !

     

     

     

     

  • April 4, 2015 11:18 PM CEST

    Ok, I installed the new version 1.0b. The Sbrick is found after about 10 seconds. When I select the Brick is the message "SBrick has been terminated". Will stop after each added a new Creation ????
    This version does not work:-(

     

     

     

     

    • 34 posts
    April 4, 2015 10:32 PM CEST

    Hi,

    Here is the new android version (v1.0b): https://www.dropbox.com/s/x8cwbglsavsiune/SBrick_1_0b.apk?dl=0

    Changelog:
    - device compatibilty fixes, compatibility with many new devices (eg. S3)
    - over the air firmware update
    - quick drive control method implementation
    - new API for faster and better communication
    - design improvements
    - navigation stack fix
    - and many bugfixes.

    Remember to turn off and on your bluetooth after firmware update!