Forums » Support

Back To Topics

SBrick Android App

  • March 14, 2015 3:27 PM CET

    Mir geht es genaus so wie Klaus,

    es wurde viel versprochen und bis jetzt fast nichts gehalten. An und für sich stehe ich

    solchen Projekten ja positiv gegenüber und bin auch bereit zu investieren, aber irgendwann

    möchte ich auch Ergebnisse sehen. Auch ich werde jetzt noch max. bis Juni 2015 warten.

    Sollte das ganze bis dorthin nicht funktionieren wie versprochen werde ich meine SBricks ALLE

    zurücksenden und mein Geld zurück verlangen !

     

    Egal ob iOS, Android oder Windows, es muß funktionieren !!!

    • 5 posts
    March 14, 2015 2:57 PM CET
    Ich glaube dass das die Entwickler interessiert. Geld haben Sie ja kassiert und sie werden sich noch mehr kassieren von gutgläubigen Interessenten.

    Die haben aber scheinbar kein Interesse was zum laufen zu bringen. Die 0.8 Version ist nur Hinhaltetaktik.
    Es gibt so viele Spielzeuge für 30,-€ ca. die über Bluetooth oder WLan gesteuert werden auf dem Markt. Da läuft alles mit einer eigenen App.

    Nur seltsam warum die SBrick-Entwickler das nicht auf die Reihe kriegen.

    Gruß
    M.R.
    • 7 posts
    March 14, 2015 2:11 PM CET

    Hallo SBrick Team,

    ich erlaube mir hier  in meiner Muttersprache mich mitzuteilen.

    Kurz vor Weihnachten kam das Päckchen mit den SBricks zu mir nach Hause geflattert. Mit großem Tatendrang ging ich die Sache zunächst an und habe gedacht das sich die Lego-Technik Modelle mit dem Tablett oder Smartphone steuern kann. Da ich kein Geldscheisser habe kann ich mir kein Apple Produkt zulegen und bin deshalb auf die Android App angewiesen wie bestimmt viele Andere Nutzer auch.

    Es ist nun ein gutes viertel Jahr vergangen seit die ersten SBrick bei den Nutzern eingetroffen sind.Ich verfolge seit dieser Zeit regelmäßig dieses Forum und hab auch alle Appversionen bisher versucht zum laufen zu bringen.Leider ohne Erfolg.

    Es ist leider ernüchtern festzustellen das bisher die App nicht funktioniert !!!

    Wenn sich bis zum Sommer 2015 nicht eine wesentliche Verbesserung der App einstellt so das  die Grundfunktion zur Steuerung funktionieren werde ich die SBricks  so leit es mir tut zurückschicken und das Geld zurückverlangen.

    Die Entwickler der App sollten sich meiner Meinung nach auf die Grundfunktionen der App konzentrieren und nicht um den ganzen Schnick Schnack drum herum.

    Viele Nutzer wären bestimmt zunächst mit einer einfachen App die funktionert zufrieden.

    mfg Klaus Eicher

     

    • 41 posts
    March 14, 2015 12:51 PM CET

    @Zsolt

    My Samsung Galaxy S3 have the Android 4.3 version.

    I upload a few log with the 0.8 log version of the app..... why you tell people to use the log version of the app, upload the Logs....if anyone of the Sbrick-Team look at it. PLease look at those log and fix the app!! another week is past.

     

    • 1 posts
    March 12, 2015 10:50 PM CET

    Im using sBrick with my Samsung Note 4 and the previous version was working really good. But since 0.8 the profile gets always removed from my MOC.

    I've already delete the App Data and did a reinstall.

    • 34 posts
    March 12, 2015 1:49 PM CET

    [blockquote]Denis H said:

    Any news about this app...more than 1 week from the 0.8 vesion.....also i send a few log using the "log" version in my Samsung Galaxy S3......still nothing?!?!!

    My sbrick is getting more and more DUST!!!

    [/blockquote]

    What android version are you using?

    SBrick app works properly on S3 with android 4.4.4

    https://www.youtube.com/watch?v=8StTYY-fgGs


    This post was edited by Zsolt Majoros at March 12, 2015 1:50 PM CET
    • 41 posts
    March 12, 2015 12:39 AM CET

    Any news about this app...more than 1 week from the 0.8 vesion.....also i send a few log using the "log" version in my Samsung Galaxy S3......still nothing?!?!!

    My sbrick is getting more and more DUST!!!

    • 1 posts
    March 11, 2015 6:37 PM CET

    hi! the app for galaxy s3 doesn't work! how can i solve this problem? thanks!

  • March 11, 2015 6:33 AM CET

    [blockquote]Jurgen Krooshoop said:

    Just installed version 0.8 and I could notice some improvements. Most functions work now, exept for one:

    I can now assign 2 SBricks to 1 profile and assign all the profile functions to the SBrick ports, but the profile can controll only 1 (the first) SBrick. All functions assigned to the second SBrick do not respond. So only half of my excavator profile works.

    Using Sony Z3 Compact, Android 4.4.4

    [/blockquote]

    I do have the same problem as Jurgen. I can assign all functions but only the first SBrick is working within the profile.

    Galaxy S4 Mini, Android 4.4.2

    • 95 posts
    March 10, 2015 11:11 AM CET

    According to Lénárd, we should be able to control more than one channel with on slider with v0.8

    But it is not working for me...

     

    XX

    • 19 posts
    March 9, 2015 12:20 PM CET

    for everyone still having issues with controlling SBrick (even from port tester) on Lollipop see my findings below.

    checked v0.8 on three different Nexus 5 phones this weekend, and the conclusion is: my Nexus 5 was still unable to control SBrick until i deleted all my BT pairings/trusted device settings (a headphone and a soundbar were paired/trusted). after doing so and couple of reboots and reinstalls everything seems to be ok now. other two Nexus 5 phones worked out of the box with the same unmodified 5.0.1 OS (they had no BT pairings prior installing SBrick app), so this gave me the idea to check BT settings. reported to devs, i hope this has to something with our issues.

     

    if it does not help, try to manually pair SBrick with the phone through Android setting. it worked me for the first time (but not later on) and made my SBricks finally controllable in the App.


    This post was edited by Gábor Polczer at March 9, 2015 12:25 PM CET
    • 7 posts
    March 8, 2015 11:17 PM CET

    0.8 does not work on a Galaxy S 5 with Lollipop (5.0) installed.

    • 7 posts
    March 7, 2015 10:07 PM CET

    0.8 does not work on a Galaxy Tab 4 or a Galaxy S 5

     

    Tab 4 - Profile assignment to creation does not stick, impossible to configure SBrick to specific features of the profile.

    S 5 - Attempting to discover SBricks crashes the app reliably.

    • 95 posts
    March 7, 2015 8:52 PM CET

    [blockquote]Miguel Angel Vilela said:
     

    And on top of all the issues... where is your issue tracker? I think your life (and ours!) would be a lot easier if you had an issue tracker like Bugzilla to keep track of each bug / feature request in one place, rather than have them all scrambled together in this forum like spaghetti ;)

    [/blockquote]

     

    This is a good idea. We will be able to know if a feature should works or not...

    • 3 posts
    March 6, 2015 9:50 PM CET

    What about firmware uogrades for the android app. I see that the iOS has the ability to do firmware updates and I have done one. If I then switch the Sbrick to operate from android will it still work? Are the firmware updates cross platform?

    • 4 posts
    March 6, 2015 9:02 PM CET

    Tried it on Nexus 4 with 5.0.1 android.

    When I want to select a profile on a creations, apps crashes. With all profile. Consequently, I can do nothing. things are getting worse and worse...

  • March 5, 2015 2:33 PM CET

    More on the latency prroblem: it seems to be specific to ports B & D and only when using them from a profile.

    Any control of any profile reproduces the issue, while latency is relatively low in all ports when using the port tester.

    So if I use only the left side of the SBrick, I can control a little car. More or less. Even the "low latency" ports (A & C) are lagging behind my commands enough to make it really hard to drive a little, mildly fast car (Sheepo's MAP, 2 L motors, 1:3) anywhere in particular. It's a lot more a crazy random bumper car than anything else. Making the car 3x slower, I can play a bit with it, but the latency still makes it harder to drive than with the PF IR controls. An example exercise is to leave the car centered on my Microsoft Natural keyboard, from a starting position on my desk near the keyboard. It's quite harder with the SBrick than with PF IR. Using the port tester makes the exercise a bit easier.

     

    Another issues I'm seeing is that when assiging the ports for a "Linked SBrick" in a MOC, the on/off switches do nothing. I can't invert port C where I have the Servo, so I had to invert port A instead (which does work) and use the Gamepad II profile upside down. While kinda usable, it's uncomfortable.

     

    Also, "Connecting to SBrick" isn't working very well either: every time I want to switch between a MOC's profiles and the port tester I need to restart the SBrick and the app, sometimes multiple times, otherwise it will never manage to connect (time out). Switching between profiles within one MOC seems unaffected so far.

     

    And on top of all the issues... where is your issue tracker? I think your life (and ours!) would be a lot easier if you had an issue tracker like Bugzilla to keep track of each bug / feature request in one place, rather than have them all scrambled together in this forum like spaghetti ;)

  • March 5, 2015 1:11 AM CET

    Version 0.8 seems a little bit better: it finally manages to connect to the SBrick when opening a profile! (Nexus 5, latest Android version)

    But I only got that one step forward, then faced Big Bugs:

    - Latency is TERRIBLE. Several seconds pass between me sliding the slider all the way to one side and the motor starting to spin. Are your logs collecting timing data?

    - Motors keep spining after closing profile.

    These 2 bugs make the SBrick unusable. You can't drive a vehicle that takes 2 seconds to start moving and 4 seconds to stop moving! I've tried several times and it's always 2-5 seconds between sliding the slider to one side and the motor spining, and 4-5 seconds between letting go of the slider (it returns to center immediately) and the motor eventually stopping.

     

    Plus the app still crashes miserably when trying the set the photo for a MOC. I get to pick an image, but a second or two after a tap on my photo... "Unfortunately, SBrick has stopped". Every. Single. Time. And "My Profiles" still doesn't load my profiles.

     

    Also, I have to say the workflow from fresh install to a working profile is long, confusing, far from intuitive. Once the UI and flows are final, please write a better User Guide for SBrick. I've read https://social.sbrick.com/wiki/view/pageId/9/slug/user-guide-for-sbrick and it's too densly packed with text and no images, hard to follow. Screenshot please, don't make reading this User Guide just as hard (or even harder) than using the app.

    • 41 posts
    March 4, 2015 10:41 PM CET

    @Tamas

    I install the 0.8 LOG Version and test with my Samsung Galaxy S3 (android 4.3):

    - Fresh install, i can discovery the sbrick in the port tester screen, BUT the port tester is not working (upload 1 log of this). The led on/off is working.

    - I try again in the same screen and now the sbrick is not longer discovery, i try severals times with the same result (upload 2 or 3 logs of that)

    - Try to discovery the sbrick in the profile screen and the sbrick CAN'T be discovery (upload 1 log of that)

    - The app hangs a lot.

     

    Hope you receive those logs and solve this issue.....the current app is NOT WORKING at all with the S3 (and suppose with others models).

    • 5 posts
    March 4, 2015 7:22 AM CET

    At Last an App that finally has some function! Using HTC One 4.4.3, can now control one brick with Joystick and sliders.  Would love to use the Volvo 42030S with two bricks, but cannot asign brick functions.  When second brick is added app goes crazy and flickers.  Much better but still along way to go to be as good as IOS.

    • 5 posts
    March 4, 2015 4:40 AM CET
    Hello,
    As I said with the Galaxy Note 4 and Android 4.4.4 a SBrick works without problems. No crashes . You can still enroll a second SBrick where you can test the channels and the port tester also goes but the second SBrick not work in the profiles. Only the first registered SBrick .
    Unfortunately, the reverse function does not work. Only either all or no reverse .
    I hope this will be .
    greeting
    M.R.
    • 7 posts
    March 4, 2015 3:24 AM CET

    0.8 does not work properly on Samsung Galaxy S5, Android 4.4.4

    Attempting to add a brick to the profile (which causes the app to look for SBricks) crashes the app every time. Version 0.6 worked better.

    • 200 posts
    March 3, 2015 10:49 PM CET

    [blockquote]Jetro de Château said:

    Why keep post APKs here instead of just putting them on Google Play?

    [/blockquote]

    The 0.8 is downloadable from the google play.

    This is a logger version, it can help for us in debugging: 

    SBrick.apk (v.080 Log): http://goo.gl/UEXTUu

  • March 3, 2015 10:44 PM CET

    Why keep post APKs here instead of just putting them on Google Play?

    • 164 posts
    March 3, 2015 7:46 PM CET

    Thanks for your feedbacks!

    Here is the v0.80 Andorid application, SAME as the previous I posted, but this version has a "Log" function.
    If your device can't connect to the SBrick, please help us and download the following apk:
    SBrick.apk (v.080 Log): http://goo.gl/UEXTUu

    Please
    try to use this App and if your device can't connect to the SBrick, then just press the "Upload Log" button on the "home screen", and we will see everything what happened in your phone.

    This App records everything in a "log" file. Please keep it in mind, if you are using the App for a long time, the result can be a large file, so please don't use the "data connection". When you are using the app make sure you only enabled Wifi connection on your phone

    Thanks!