Forums » Support

Back To Topics

SBrick Android App

    • 21 posts
    April 14, 2015 10:41 AM CEST

    [blockquote]Karl Fensterstock said:

    And now come this !!!!!

    I'm at a loss ???? [/blockquote]

    If i open "Manage Brick" and wait for 4-5 second than i also from time to time get "Sbrick is powered?". And now i chose detected sbrick immediately.

  • April 14, 2015 9:58 AM CEST

    Same problem here on Sony Xperia Z3 compact, Android 5.0.2. When I confirm the question: "SBrick is powered?" with "Yes", a message appears that a log data is transfered to the developers. @Devs: Do you receive this data? Does it help you to address this bug?

  • April 14, 2015 2:49 AM CEST

    [blockquote]Imre Kiss said:

    [blockquote]Karl Fensterstock said:

    [blockquote]Alexey Tikhvinsky said:

    But app is more stable now and OTA update works like a charm.

    [/blockquote]

     

    And why not by me ???

    [/blockquote]

    Try to reinstall, please.

    [/blockquote]

     

    I have clear the Cache, remove the data oft the application

    and i reinstall....

    ten times, hundred times...

    always the same result

    STEP 1 Clear the Cache

    STEP 2 Remove data

    STEP 3 Uninstall

    STEP 4 reinstall the App with File Manager

    STEP 5 Turn on the SBrick and 10 sec later start the App

    And now come this !!!!!

    I'm at a loss ????

     

     

     

     

    • 57 posts
    April 14, 2015 2:30 AM CEST

    [blockquote]Imre Kiss said:
    - oval joystick on some devices fixed
    [/blockquote]

    Don't think you have fixed this!Almost every single circunference from a profile I try on my 16:10 device, is displayed like an ellipse (joysticks, buttons, close button). Only slides seem to be displayed correctly.
    See the images bellow.

    Gamepad II (SBrick standard profiles)
    Here it also appears superimposed with another profil of mine... Don't know how to reproduce this, but it happens sometimes. :P

    Joystick & Sliders (SBrick standard profiles)


    Gamepad with buttons (SBrick standard profiles)

    42030S 16:10 (SBrick standard profiles)

    Own test profile #1

    Own test profile #2

    Please fix these ellipses! They look very unprofessional. :P


    [blockquote]Imre Kiss said:
    - toast message duplication problem fixed
    [/blockquote]

    Don't know what this means. Let's assume it is fixed... :)


    [blockquote]Imre Kiss said:
    - OTA only works when there is only one sbrick powered fixed
    - continously asks for firmware update, can't use the sbrick on some devices fixed
    - could connect to sbrick without restart after ota update fixed
    [/blockquote]

    Don't know how but after many tries managed to update my SBricks FW with version 1.0b
    Didn't even want to play with OTA this time... :P


    [blockquote]Imre Kiss said:
    - sbrick rename problem fixed
    [/blockquote]

    What did you fix exactly?
    Can't find how to rename a SBrick, but I'd love to... :(


    [blockquote]Imre Kiss said:
    - when downloading profiles from the market, app doesn't remember about the last downloaded profile fixed
    [/blockquote]

    No, you didn't fix this! It continues with exactly the same problems.
    It is not a blocking or critical problem, but quite annoying! :(


    [blockquote]Imre Kiss said:
    - joystick profile fixed
    [/blockquote]

    Don't know what do you think to have fixed, but rotated joysticks (e.g. 45º) continue to display upright and not working as intended. :(


    Management of custom profiles continue to look cahotic specially if you try to load more than one at once. Usually it can be recovered if user deletes all but one, although at this point things often went out control, buggy and then App is likely to crash at first touch...
    Please fix this - List actions just for the profile assignd to one creation, not the actions from every downloaded profile... This is causing the app to crash upon assignemt of a wrong funtion to one port. Futhermore, user has no easy and direct way to know which functions are assigned to a certain chosen profile.
    This behavior is really, really, really anoying and frustrating!! :(

    Maybe if you tell us how did you think to have fixed a certain bug, we could give you better quality feedback, to let you find why it is not yet fixed so many times. :P


    I work for large global company, and in what regards sw quality we have a principle to apply - "Eat your own dog sheet"
    I wouldn't want to be in your place if you were to work here...


    Looking forward to see all the bugs above fixed soon, as well as testing the ability to have more than one SBrick controlled from the same profile.

     


    This post was edited by Fernando Correia at April 14, 2015 2:31 AM CEST
    • 24 posts
    April 14, 2015 12:37 AM CEST

    Samsung Galaxy S3 with Android 4.3 with application version 1.1.

    Still continually asking for OTA update despite saying that the brick was updated successfully.  However, can't say that OTA does nothing as it does actually duplicate My Creation.  This might be useful sometime but would prefer that it actually updates the Sbrick.

    Still no option to save a creation so all I can do with a creation is edit it or delete it!

    Why oh why do I bother????

    • 34 posts
    April 13, 2015 10:50 PM CEST

    :( Can't update.

    Got the 1.1 from dropbox, removed the old version and all data from  Nexus 7 2nd with 5.0.2, reset BT, Sbrick was off, installed, turned on BT and Sbrick. App 1.1 found Sbrick and asked for update, the bar went all the way, restarted BT and still asking for update. Tried the same with restart of Sbrick and BT at the same time, again nothing. nRF still reports all versions with 4.0

    Tried the same with other Sbrick (only one up at a time) and same result. 

    • 95 posts
    April 13, 2015 10:35 PM CEST
    you can also try to clear the cache and remove the data of the application before reinstall it
    • 18 posts
    April 13, 2015 9:52 PM CEST

    [blockquote]Karl Fensterstock said:

    [blockquote]Alexey Tikhvinsky said:

    But app is more stable now and OTA update works like a charm.

    [/blockquote]

     

    And why not by me ???

    [/blockquote]

    Try to reinstall, please.

    • 21 posts
    April 13, 2015 9:51 PM CEST

    Samsung s3 i9300
    From the second try i could update my second sbrick (third i will try later).
    There is the error with invert on the port C

  • April 13, 2015 8:49 PM CEST

    [blockquote]Alexey Tikhvinsky said:

    But app is more stable now and OTA update works like a charm.

    [/blockquote]

     

    And why not by me ???

  • April 13, 2015 8:30 PM CEST

    "One slider - two+ channels" feature still don't work.
    But app is more stable now and OTA update works like a charm.

    • 95 posts
    April 13, 2015 8:14 PM CEST

    Is two or more sbrick support should work with version 1.1?

     

    What about two or more channels using a slider,

    or the auto reset and value features of bouttons?

     

    Thank you

     

     

     

     

     

     

     

     

     

  • April 13, 2015 7:36 PM CEST

    I installed version 1.1.
    The same problems as before.
    No OTA update possible (by one Brick).


    But both are recognized.

    If you select an exit the program.

  • April 13, 2015 6:57 PM CEST

    I'm currently using a Sony Xperia Z3 compact. After update from android 4.4.4 to 5.0.2 I have serious bluetooth problems which might not be related to the sbrick app. Atm, I cannot recomment updating your OS if you are using the same phone. Simple brick app recognizes the sbrick put no control of the individual channels. Sbrick app 1.0b endlessly tries to update the firmware. No channel control as well. As all android users I'm looking forward to the new working app release.

    • 34 posts
    April 13, 2015 6:53 PM CEST

    [blockquote]Imre Kiss said:

    PROGRESS REPORT

    The new version is late a bit: It expected to be released on Monday, hopefully.

    We are working now on the two or more bricks support.

    The following bugs fixed:

    - oval joystick on some devices fixed
    - creation image bug fixed
    - toast message duplication problem fixed
    - OTA only works when there is only one sbrick powered fixed
    - continously asks for firmware update, can't use the sbrick on some devices fixed
    - could connect to sbrick without restart after ota update fixed
    - sbrick rename problem fixed
    - when downloading profiles from the market, app doesn't remember about the last downloaded profile fixed
    - if want to use the created profile second time, the discovery sbrick dialog stay forever fixed
    - joystick profile fixed
    - data connections optimized
    - "check your internet connection" OTA bug fixed
    - port tester fixed on nexus devices

    [/blockquote]

    Here is the new version with the fixes above:

    https://www.dropbox.com/s/uh7olbs44yw7sk0/SBrick_1_1.apk?dl=0

     

    We have some further adventure with the more sbrick support on older devices, but I hope we finish it tomorrow. After that, you'll get an another update.

     

    We'll also submit it to google play, if the feedbacks are positive.


    This post was edited by Zsolt Majoros at April 13, 2015 6:55 PM CEST
  • April 13, 2015 5:06 PM CEST

    [blockquote]Jetro de Château said:

    It would also be very nice if you could use Google Play and update the app there ... ;)

    [/blockquote]

    But only a working app ;-)

     

     

     

  • April 12, 2015 9:53 PM CEST

    It would also be very nice if you could use Google Play and update the app there ... ;)

    • 57 posts
    April 12, 2015 7:53 PM CEST

    Many thanks for the update about bug fixing progress.
    It looks we have a lot important fixes with next version. :)

    One thing I consider important is also to show only the functions from the profile selected, when you assing functions to SBrick ports, instead of all and every defined function among the private profiles download. It is very confusing and troublesome.

     

    Thanks!
    Fernando

    • 18 posts
    April 12, 2015 7:40 PM CEST

    PROGRESS REPORT

    The new version is late a bit: It expected to be released on Monday, hopefully.

    We are working now on the two or more bricks support.

    The following bugs fixed:

    - oval joystick on some devices fixed
    - creation image bug fixed
    - toast message duplication problem fixed
    - OTA only works when there is only one sbrick powered fixed
    - continously asks for firmware update, can't use the sbrick on some devices fixed
    - could connect to sbrick without restart after ota update fixed
    - sbrick rename problem fixed
    - when downloading profiles from the market, app doesn't remember about the last downloaded profile fixed
    - if want to use the created profile second time, the discovery sbrick dialog stay forever fixed
    - joystick profile fixed
    - data connections optimized
    - "check your internet connection" OTA bug fixed
    - port tester fixed on nexus devices

  • April 11, 2015 8:34 PM CEST

    So, I too succumbed... Sariel's video (https://www.youtube.com/watch?v=EkXqQpfPDsI) clarified quite a few things and encouraged me to update.

     

    First firmware updated failed and I though "oh no, stuck in the infinite update loop, me too" but then 2nd attempt succeeded. Failed meaning the old firmware was still running, which you can tell because the LED is not on all the time, i.e. you can tell you're running the new firmware because the LED is on all the time.

     

    Thanksfully the "terrible latency on ports B & D" issue seems to have gone, I hope to never come back! Latency is acceptable in all channels now.

     

    Still found a few issues.

     

    1. MOC images look really, really bad. Super pixelated, and doesn't get any better over time. See screenshots of how it looks like when I use one of my pics from

    http://www.eurobricks.com/forum/index.php?showtopic=104050&st=25#entry2153330

     

    MOC image when set

    MOC thumbnail

     

    2. Reversing channels is unreliable. Sometimes it works, but rather rarely. I tried Gamepad II, Two Joysticks II and 2 profiles of my own. In all of them 1 or 2 channels needed to be reversed, but only once I managed to get all channels to work in the right direction. This was with one of my own profiles, but then I changed the Auto Reset value of one of its channels and when running the updated profile on the phone, reversing steering was no longer possible. By reversing a channel, I mean this:

     

    2 channels reversed

     

    3. Getting my own profiles updated on the phone is an adventure. After saving my profile at https://designer.sbrick.com/?profile=1744 I sent to Market in the phone, and re-downloaded it, then got back to my MOC and used it, it still had the old version. At some point I noticed there were 2 copies of my profile, with the exact same name and description and no version number, so no way to tell which one was the latest. At some other point I even had the controls of my other own profile, distored on top of the profile I was using:

     

    2 profiles on 1 

    In the end I managed to delete ALL profiles everywhere in the app (Market and MOC) and then download and add just the one profile I wanted to use. And it worked, but then as mentioned in #2 reversing the steering channel was no longer possible.

     

    4. Weird artifacts in profile background. Check the darker areas:

     

    Artifacts in the dark

     

    • 95 posts
    April 11, 2015 5:31 PM CEST

    Are you using v1.0 (https://www.dropbox.com/s/x8cwbglsavsiune/SBrick_1_0b.apk?dl=0)

    Play store version is still v0.80

     


    This post was edited by Frederic Ayrault at April 11, 2015 5:32 PM CEST
  • April 11, 2015 5:16 PM CEST

    @Mees van den Berg

    Have the same Problem with lenovo Livetab S8312 with Android 4.4.2

  • April 11, 2015 4:40 PM CEST
    Hee people
    I have an lg l bello with android 4.4.2
    And i've download the sbrick he is working great but when i want to discover sbrick than he crash.
    Can someone help?
    Thank you
    • 95 posts
    April 11, 2015 3:24 PM CEST

    [blockquote]M MBou said:

    App for Android 4.0

    I have an sBrick taht I use with my iPad mini and it works fine.

    However my son has a smartphone (Sony Xperia P) with android 4.0  and Sony announced that it will not be possible for this model to upgrade to further versions of android. That means that the sBrick android app requiring android 4.3 cannt be used.

    Thus my question:

    is there an "old" version of sBrick working with android 4.0?

     

    Thans and best regards

    [/blockquote]

    The SBrick only works using bluetooth low energy (BLE)

    BLE is only supported since android 4.3 providing bluetooth 4.0

    but not all devices running 4.3 have BLE

     

  • April 11, 2015 2:45 PM CEST

    I hope this weekend comes a working version !!!

    today, tomorrow ... a surprise ?!?!