Forums » Support

Back To Topics

SBrick Android App

  • April 27, 2015 8:40 AM CEST

    Hi again,

     

    So I got this car, with 2 Buggy motors for drive and servo for steering, which seems like it should be perfect to drive with SBrick... but it's only perfect for crashing :(

    There is still a noticeable lag in commands, I tell the car to steer and by them time (I hear) the servo steers the car it's too late, BAM!

     

    Then I also had lots of app crashes while driving. Like, LOTS. Every. Single. Time. I could drive for literally a few seconds, then app freezed, sometimes leaving with the Buggy motors at full gas! At least now when the app crashed motors would stop. This was all with v1.2 and the latest Android on a Nexus 5.

     

    I deleted the app cache and data, uninstalled the app, then tried again with v1.0 and v1.1. Same frustratin results, but I noticed in my system bluetooth settings that the phone seemed to be trying to connect to my Raikko bluetooth speaker, all the time. It was tricky but I managed to tell the phone to forget that speaker, and now I can drive for minutes and the app doesn't crash. Yay!

     

    SBrick team, please test the app in phones with more bluetooth devices than just SBricks, like real users will do ;)

    • 3 posts
    April 26, 2015 3:51 PM CEST

    Hi

    I have some problems with the connection to the Sbrick. 

    My phone: Sony Xperia Z2 with Android (lolipop) 5.0.2

    I can Connect to the Sbrick, and I've done the firmware update. The problem is that neither any profiles or the port tester work.

    I have all cables connected and everything is fine, so it should work...

    Please help!

     

    • 34 posts
    April 26, 2015 12:19 AM CEST

    Few more updates:

    - Got the v1.2 app and finally the 2 Bricks on one profile work ! Both HTC One and Nexus 7

    - The Nexus 7 can now hold onto the SBrick connection, but on dual Sbrick profile the Sbrick not used throws a "reconnecting" popup after a while. For example on 42009, after parking the crane the lower Sbrick function are not used, playing with the sliders associacted with upper Sbrick - the other one seems to disconnect which means 1. no functions until profile reload 2. popup showing up and distracting from/blocking functions still working

    - Nexus 7 has a stupid bug where the profile graphics displays is stretched and looses some area on the right. Upon exiting the profile to MOC screen (button in profile or Android back) and reloading its even more stretched, repeats again and again until app is killed and reloaded. See pic below

    - Tried to upgrade a friends SBrick from HTC and it did not work the first time. Had to close the app, BT, SBrick and phone power cycle and then it went. Even after the Sbrick was updated the port tester did not work on HTC One, but all worked on Nexus 7 that was not connected to that Sbrick before update. Strange.

    So far it seems to be some progress, at least with the devices I have. But would not suggest it to pure consumers yet.


    This post was edited by Matej Papluh at April 26, 2015 12:19 AM CEST
    • 1 posts
    April 26, 2015 12:12 AM CEST

    just downloaded latest update on v2 nexus 7 try to link had to do OTA  firmware update now stuck in loop turn off Bluetooth turn of app turn off SBrick turn all back on and tells me to do the processs over after 3 time I am getting ****** off any solution to this  

    • 99 posts
    April 25, 2015 11:12 PM CEST

    Just for information, I had too many application crashes with v1.2 and downgraded to version 1.1.

    Version 1.1 is operational when you can update the firmware and when you have only one Sbrick, so I'll stick to this version until a real working app, correctly tested and validated, is issued.

    • 3 posts
    April 25, 2015 9:37 PM CEST

    [blockquote]Simon Beaupré said:

    I do the new update for android.  Now everytime i want to connect to SBrick the program ask me to do the Firmware update and can't do nothing more, i try it 4 times.  The port tester didn't work anymore.  The LED test work.  Using Samsung galaxy tab4 8"  It works ok before the update but now it don't work.

    [/blockquote]


    Dear Sbrick Team

     

    I can state the same as above, I can do nothing with newest app version 1.2 I can only try to update the the firmware without any succes ! I am asking where is the improvement. I am waiting for working product since December 2014. I did not track every update but after 4 months I was expecting significant improvement but I can not do any simple action with the sbrick. (Samsung S4 mini).

    If this is the progres of 4 months the working app may appear in 2020.

    You really do not care about android customers.

  • April 25, 2015 8:21 PM CEST

    I'm going to order me a Blue Smart Control !!!

    • 4 posts
    April 25, 2015 8:13 PM CEST

    I do the new update for android.  Now everytime i want to connect to SBrick the program ask me to do the Firmware update and can't do nothing more, i try it 4 times.  The port tester didn't work anymore.  The LED test work.  Using Samsung galaxy tab4 8"  It works ok before the update but now it don't work.

     

    update:  After many and many ways to update the SBrick, i finally got it, can't find out really why this time it work.  (i try really near of my tablet, brand new battery, nothing connect to the port, etc...)  When it was update the light will stay ON.  The invert port button now didin't work but we can correct this problem by change the slide button angle 0 to 180 and 90 to 270.  Can't still not control 2 port for one action.  I try another way by install one slide on top of the second one but didn't work.


    This post was edited by Simon Beaupré at April 26, 2015 10:38 PM CEST
    • 6 posts
    April 25, 2015 8:57 AM CEST

    Hello!!

    Then, I have update the new version and I have again lots of problems!! Before the update, I can played just with one Sbticks, It was cool and I was just wait to play with 2 or 3 sbricks!!!

    Now i can't played with nothing!!!!  After update of wireware, the led stays on!, and when I wan't to ADD profiles in my creation, sbrick stop to play!!!!

    But, When i test port, all motors can turn!

    I know you try to repair all that you can in your software, but it sincerely began to be annoying!!!!

    • 13 posts
    April 24, 2015 11:28 PM CEST
    Moto G2 still doesn't work with app 1.2. The update doesn't work, like before. But I can switch on /off the led. That's soooo great, I can switch an led.

    Now I disconnected this little plastic piece from my 42030s. Maybe I'll come back after some months and look if you get this solved.
    • 1 posts
    April 24, 2015 8:52 PM CEST

    android app v1.2 install. and run and firmware update! bluetooth off/on, discover sbrick and
    "firmware is not up-to-date" message! again update again again again ....

    sbrick not working ㅠㅠ


    This post was edited by ChongTak Cho at April 24, 2015 8:57 PM CEST
    • 28 posts
    April 24, 2015 11:44 AM CEST

    [blockquote]Fernando Correia said:

    [blockquote]Antonis Minas said:

    @Fernando: Waiting before switching of bluetooth does not work. :/

    [/blockquote]

    What I wrote meant to wait between switching off and on back again.

    [/blockquote]

     

    Yes, yes. After the notification that the upgrade procedure completed, I left it there without touching either the phone or the sbrick. Still no luck though.. Once I even forgot it there after the upgrade was done for 20 minutes. Does not make a difference in my case..

    • 34 posts
    April 24, 2015 11:32 AM CEST

    @Miguel 1-function/2-ports will work with one sbrick in the next release. About your setup, I think these 3 options are producing the same result, unless you connect the 2 sbricks to two different power source, but I'll ask the hardware developers for detailed information.

    @Jetro the app contains this option to prevent the screen from locking, I just asked it because maybe some devices ignores this option.

     

    • 57 posts
    April 23, 2015 11:06 PM CEST

    [blockquote]Antonis Minas said:

    @Fernando: Waiting before switching of bluetooth does not work. :/

    [/blockquote]

    What I wrote meant to wait between switching off and on back again.

    • 28 posts
    April 23, 2015 7:48 PM CEST

    I have also tried several times using a Nexus 7 running Cyanogenmod 10 Android 4.3.1 but still no luck..

  • April 23, 2015 7:47 PM CEST

    I making sure the phone or tablet doesn't sleep during OTA update (or play) why isn't there an option in the app to keep the device from sleeping? I have several apps that have this option so it should be possible.

    • 28 posts
    April 23, 2015 7:24 PM CEST

    I have tried seleral times to upgrade to no avail. I have also tried a stock Moto G 2 running 5.0.2 but I still cannot upgrade the FW.

  • April 23, 2015 6:09 PM CEST

    [blockquote]Zsolt Majoros said:

    @Karl what android version are you using?

    [/blockquote]

     

    Hi Zsolt,

    i use Android 4.4.2

  • April 23, 2015 4:33 PM CEST

    Haven't played a lot with v1.2 yet, but I'm a little dissappointed that 1-function/2-ports only works when the 2 ports used are from different bricks, I only have 1 SBrick!

     

    Anyway, I wanted to ask: should I care for the following setup?

     

    Right now I have: 1x LiPo => 1x SBrick => 2x Buggy motors, on the same channel

    If I could have: 1x LiPo => 1x SBrick => 2x Buggy motors, one on a differet channel, how much power (current) can these motors draw?

    If I could have: 2x LiPo => 2x SBrick => 2x Buggy motors, one on a differet SBrick, how much power (current) can these motors draw?

    In other words, is the 3A limit per motor, per channel, or per SBrick?

    • 34 posts
    April 23, 2015 4:20 PM CEST

    The green led is lighting by default with firmware version 4.1 and later.

    We decided to use this behavior to show the SBrick is currently powered on.

    • 3 posts
    April 23, 2015 4:16 PM CEST

    Yes, I followed all details for upgrading the sbrick. However, I did the process one more time, being extra careful with all details: reinstalled app 1.2 on my phone (Sony Z2), updated the firmware again, stopped the app, turned off the sbrick after update, restarted bluetooth and did a new bluetooth pairing with my sbrick. And now it is back to life again! But green light is still always on, cannot turn it off with the button even though it says that it is off. So happy to have it working again!

    • 34 posts
    April 23, 2015 3:34 PM CEST

    @Karl what android version are you using?

    @Johan did you restarted your phone's bluetooth after the update?

     

    • 3 posts
    April 23, 2015 1:40 PM CEST

    Installed new 1.2 app today. Managed to update firmware and after that the green light on the Sbrick came on and stays on forever (even if app says identify LED off after clicking that button). However, the green light is the only thing working now, port testing does not work (motors not rotating) and controls does not work on MOCs. That is, no signal out on either of the four connectors. Tried to update firmware again (with success) but sbrick still does not work. Is it possible to downgrade the firmware somehow and bring back life in my sbrick?  I prefer being able to control the outputs over having the green light constantly on...

  • April 23, 2015 1:36 PM CEST

    @Zsolt

    I have installed the 1.2 V today and still have the same problems as before. If I select the menu item "Manage bricks" are both "SBricks" is displayed. If I select one of the two bricks, it takes about 5 seconds and the
    Program is terminated.

    Am I doing something wrong?

    • 3 posts
    April 23, 2015 1:28 PM CEST

    @Matthew

    I followed your steps and indeed the light turned on and een after several tries, whenever the power button is on the light turns on too. No longer need for updates.

    Unfortunately the profile problem is also replicated.

    Still, thanks for the tip ;)

    Hoping the team works this out soon, quite anxious to test the SBrick properly.