Forums » Support

Back To Topics

SBrick Android App

    • 57 posts
    April 23, 2015 10:18 AM CEST

    [blockquote]Antonis Minas said:

    Is there a "best practises" that need to be followed in order to successfully upgrade the firmware?

    [/blockquote]

     

    Don't know whether it helps or not, but I remember that after experiencing the same fw upgrade problem for several days I finally succeeded. At that time I tried to git it a longer time between switching smartphone BT off and on again. Waited something like 1 min.

    Give it a try and tell us. At least I could have a confirmation if it was it or not.

    Using SG Note Edge with 4.4.4

    • 28 posts
    April 23, 2015 8:48 AM CEST

    Hello,

    I have upgrated to v1.2 and I still cannot update the sbrick. Same behaviour as with 1.1. Connect to sbrick > get notified about the firmware update > update > firmware update completed > get promped for an update again. 

    Is there a "best practises" that need to be followed in order to successfully upgrade the firmware?

    I have been following this thread since I got my sbrick four months ago but its getting tyring to read through every single post in order to find the information you need :/

    I am using a Nexus 4 running stock 5.0.1

    • 99 posts
    April 23, 2015 6:37 AM CEST

    [blockquote]Denis H said:

    Tested the new 1.2 version of the app in my Samsung Galaxy S3

    [...}

    Now the app crash with any custom profile i use.

     

    [/blockquote]

     

    Updated to 1.2 app. Did not try yet to create a brand new profile, but did not experiment any regression so far. But did not see any improvement neither, I have one Sbrick only...

    Still the same display issues, especially visible on the large screen of a tablet.

     

    Marc

    • 3 posts
    April 23, 2015 4:28 AM CEST

    @Matthew

    I did forget to mention I'm using the 1.2 Android version.

    It does the update but keeps asking to update again. Out of curiosity tried it on a Motorola Moto E but result was the same as it installed immediately 1.2. No iPhones to try.

    • 9 posts
    April 23, 2015 3:48 AM CEST

    @Hugo

    That is the same problem I have.

    With version 0.8 of the SBrick app off the Play Store, the brick worked but had some problems (control lag, etc)

    When I installed the 1.1 APK the brick needs to be updated and continally fails. But you cannot use the brick on Android untill it is updated.

    I haven't tried the 1.2 Android version yet (I will in a few hours when I get home) but so far I cannot get my SBrick to update after trying a number of different phones (Galaxy Note 2, iPhone6, iPhone4S)

    • 3 posts
    April 23, 2015 3:30 AM CEST

    Hello there, I'm brand new to the SBrick community as I got my SBrick some hours ago.

    Been playing a bit with it out of the box then got an update for the Android version. After update, had to update the SBrick itself which seemed quite normal.

    But since then I can't use it. If I check it on "Manage Bricks" it insists in updating it again. When I try to simply use my creation the app crashes. Tried using other profile and kept happening.

    This happens both with my Samsung Galaxy S5 and Huawei Media Pad M1 8.

    • 41 posts
    April 23, 2015 1:46 AM CEST

    Tested the new 1.2 version of the app in my Samsung Galaxy S3

    - In the "What's new" says: oval joystick on some devices fixed and joystick profile fixed. BUT in the S3 the joystick profile make the app crash every time....tested also with a joystick custom profile and also crash.

    - The app still crash time to time in differents menus.

    - The app crash in custom profiles using custom backgrounds image (i use a png image).

    - The app crash in custom profiles when width is changed in the sliders other than default.

    - Sorry.....i have to correct the above....now the app crash with any custom profile i use.

     


    This post was edited by Denis H at April 23, 2015 2:35 AM CEST
    • 57 posts
    April 22, 2015 11:57 PM CEST

    Very good and much appreciated progess with multi SBrick support for Android app!

    Kudos to the Android development team!

    Like Frederic I also found that 1-function/2-ports only working when the 2 ports used are from different bricks. A very good progress anyway.

    App didn't crash oftenly, although I didn't played as much as before.  Still crashes with profiles that seem somehow corrupted resulting from problems previously described.

     

    Some of the previous problems still present:

    - Bad memory handling of the state from last profile downloaded via market.

    - LED Id function still misbehaving with alternate messages on screen not suitable anymore.

    - Still can't rename bricks (although it seems a not yet implemented feature).

    - Joystick, toggle and close button circles, still shown as ovals and at least in some cases also misplaced.

     

    Didn't play with multiple custom profiles downloaded and rotated controls, as I believe the same errors persist given the other and more fundamental errors still present.

    Didn't want to take hours and hours of frustration and trial and error to find what was already described, given it was not declared as fixed.

     

    It would be of great convenience for everyone (you and us), if you provide an updated known faults list, wiht each new SW release also wih indication of the presumably fixed previous reported errors.

    It would avoid many hours testing on hour side, just to find wheather you tried to fix something or not. ;)

    • 95 posts
    April 22, 2015 8:54 PM CEST

    Same behavior with my asus memopad 7 :-(

    • 95 posts
    April 22, 2015 8:20 PM CEST
    On my S4 (I need to test it on my tablet) 1 function 2 ports works only when the motors are connected on 2 sbricks

    This can be usefull in some cases but this feature should also works on the same sbrick
    • 34 posts
    April 22, 2015 7:37 PM CEST

    Android has technical differences that results you can't use the old firmware's control method.

    We made this firmware change, to solve this android problem, however the iOS works fine with the old one also.

    The battery charged? I'll make some tests tomorrow with iOS devices.

     

    We just submitted the new Android app (1.2) to the Google Play, a few hours and it will be available.

    • 9 posts
    April 22, 2015 11:34 AM CEST

    @Zsolt

    I tried to update the firmware with the Android 1.1 App as well at with the iOS version which is currently on the apple app store.

    for Android i tried using my Samsung Galaxy Note 2 (Android 4.3)

    for iPhone i tried both a iPhone6 and a iPhone4S both with the latest version of iOS.
    When trying to update with the iPhones i had the exact same problem that Allan talks about in the iphone thread (I also posted in there)

    All of them say that the update is succesful but as soon as i restart the app and try to connect to the brick, it says it needs to update the firmware.

     

    I have tried everything I can think of in the Android App, but I cannot seem to find a way to use the brick without updating it, is that correct?

    In the iPhone app on my friends phone, i could still control the brick on a MOC with the old firmware.

  • April 22, 2015 11:02 AM CEST

    @Matthew:
    thx for the info
    currently there is no plan to control MOCs,but you can use all 4 channels of a SBrick simultanously selecting the same SBrick for each slider.

    @Zsolt:
    Does the led-button work without disconnects? (please try many on off on off on off.....)

    • 34 posts
    April 22, 2015 10:07 AM CEST

    @Philipp connecting works, but when I want to send the first packet to control characteristic works fine (with slider move), but 1-2 second later it disconnects, and have to disconnect-connect again.

     

    @Matthew sounds weird, nobody reported ota problems on iOS devices yet. Which app version are you tried with?

    • 9 posts
    April 22, 2015 6:58 AM CEST

    @Philipp - Is there a way in your app to control a MOC? or is there only the 1 screen for testing the channels on the SBricks?

    Would be cool if you could make a simple control screen with some sliders, even it it was only for a single SBrick.

    • 9 posts
    April 22, 2015 6:55 AM CEST

    I tried my friends iPhone6 today, Firmware update _failed_ a few times (says completed succesfully but wants to do it again)

    And when I connect it to my android phone, it still says the firmware is old.

     

    I was able to get my MOC working using the iPhone6 and the SBrick with the Old Firmware.

     

    I cannot get the Android App to control the SBrick at all, the only thing it lets me do is upgrade the firmware, which always says "Success" but doesn't actually work.

     

    I tried Philipp's app on my Galaxy Note 2, and it connected fine and controlled the 2 motors I had on the SBrick.

     

    I will try with an iPhone4S tonight and see how that goes

  • April 21, 2015 10:18 PM CEST

    @Zsolt:
    Thx for the response.
    Ok, so connecting works fine, just using the sliders do not work?
    Did you connect to just one SBrick or more?
    Did you use a SBrick with new FW?
    As i did not update FW: did the api changes?
    Which Android-Version?


    This post was edited by Philipp Kaufmann at April 21, 2015 10:26 PM CEST
    • 34 posts
    April 21, 2015 7:04 PM CEST

    @Philipp I Tested your app on a galaxy S4, but it disconnects from the brick when I move the slider.

    @Matthew The iPhone's bluetooth chip is far better than the Android's, so you could try with that. We'll made some improvements around the OTA, maybe these fixes solves your problem also.

     

    We finished the more sbrick support (currently tested with 3), and the "one function two ports" feature, we'll make some additional bugfixes tomorrow, and you'll get a new android version.

    • 9 posts
    April 21, 2015 4:08 PM CEST

    I got my new SBrick connected up today, installed the 1.1 android app on my Galaxy Note 2 running Android 4.3

    But after  a couple hours of trying, I could not get the firmware update to work.

    From what I could tell, you need to update the firmware before you can use the 1.1 version of the app to control a MOC????

     

    I guess i'll try again tomorrow :-(

    Does the iPhone version work better? should I try to get one of my friends with an iPhone to do the firmware update?


    This post was edited by Matthew Boehm at April 21, 2015 4:09 PM CEST
  • April 21, 2015 1:07 PM CEST

    Hi,

    i delevoped a small test-app for my own, to see, if it's really such a problem to create a working app for Android.

    And:

    it works for me.

    Samsung Galaxy Note 2, Android 4.4.2

    Features:
    scan SBricks
    use up to 4 SBricks simultanously.

    http://sbrick.hosticus.com/SBrick.apk


    This post was edited by Philipp Kaufmann at April 21, 2015 1:08 PM CEST
    • 34 posts
    April 18, 2015 3:45 PM CEST

    I have a feeling that devices with plain android or Google made - and Moto G 1/2 are still product from 'owned by Google' era -  display same behavior, the Moto G2 does not work the same way as Nexus 7 for me (and Moto G 1 too, but with broken screen I do not play with that one much)

    • 13 posts
    April 18, 2015 2:20 PM CEST
    Ok, tested with nRF said that it stayed on FW 4.0. So OTA don't work on Moto G2. In that way the sbrick stays useless for me :(
    • 34 posts
    April 18, 2015 11:00 AM CEST

    Karsten, I'd suggest to check it, if it is really updated, I could not do that on my Nexus 7 tablet (even if it said update complete), but when using HTC One it was OK on first try. 

    I used the nRF Master Control Panel (BLE) to prove that the SBrick was still on FW 4.0 even after the success message on Nexus and went to 4.2b2 after update through HTC One. The versions are under the Device information service.

    https://play.google.com/store/apps/details?id=no.nordicsemi.android.mcp&hl=en

    Short info can be found in this video by TechnicBRICKs

    https://www.youtube.com/watch?v=0_NeGcnJVZw

    • 13 posts
    April 18, 2015 9:33 AM CEST
    Next try. At the end of OTA occurred a message that it could not connect to the sbrick. Then the app tells me that OTA is complete , ok. This time there was a little text message, that sbrick is up to date. After kicking ok, the app is terminated. Next time is the same.
    • 5 posts
    April 18, 2015 7:38 AM CEST

    [blockquote]Karsten Grosse said: Still the same with the latest version on Moto G2 (Android 5.02). No update on sbrick possible and the sbrick didn't work (even the port tester). Only LED on /off work. :([/blockquote]

     

    same phone, same android version.. and same problem. sbrick keeps asking to update firmare aswell as still being able to turn led on/off.. thats it