Forums » Support

Back To Topics

SBrick Android App

    • 195 posts
    November 26, 2014 4:30 PM CET

    This topic is for the Android app. Post opinions, suggestions, bugs.

    We've started to put together a database of the devices which work with the SBrick app and those that don't.  We'd like to ask you to help us in fleshing out this database; so if you the app works on your device (or doesn't), can you please add it to the Wiki here.


    This post was edited by Lénárd Pásztor at January 10, 2015 4:40 PM CET
    • 15 posts
    November 26, 2014 7:57 PM CET

    Hello again!

    I've just download the android App and I'm going to play with it. 

    I wish I had the Sbrick now, but I will have to wait for it.

    When is estimated to start out the first orders?

    Best Regards!

    • 26 posts
    November 26, 2014 11:56 PM CET

    Just downloaded the Android App.  Started to play with it but when I get to the point of adding a profile my phone just appears to search for a profile to link without finding any.

    Any suggestions?

    Thanks

    • 111 posts
    November 27, 2014 8:00 AM CET

    Norman Chalcraft said:

    Just downloaded the Android App.  Started to play with it but when I get to the point of adding a profile my phone just appears to search for a profile to link without finding any.

    Any suggestions?

    Thanks

    Yes, it's confusing. Tap Sbrick logo (Menu) and then Market, you get a "Test1-Android" profile with a checkbox. Now when you return to your Set and tap Linked Profiles there is this profile. Now you may tap Linked SBricks, tap your and map 4 controls from the profile (Gomb1, Gomb2, Kar1, Kar2) to ports. I'm using Kar1 and Kar2 but Kar1 only spins in one direction. Gomb is the magyar word for Button, Kar is for handle, thank you Google.


    This post was edited by Jorge Pereira at November 27, 2014 8:01 AM CET
    • 15 posts
    November 27, 2014 8:04 AM CET

    Yesterday I downloaded the App too and It's really a beta version.

    The App suddenly stops doing almost everything. Sometimes just enabling bluetooth, the App crashes.

    I agrre with Norman with the searching of a profile. I only find the "Test 1" profile.

    I think the App is very unstable to do something with it.

     

    • 111 posts
    November 27, 2014 8:12 AM CET

    Javier García Lancho said:

    Yesterday I downloaded the App too and It's really a beta version.

    The App suddenly stops doing almost everything. Sometimes just enabling bluetooth, the App crashes.

    I agrre with Norman with the searching of a profile. I only find the "Test 1" profile.

    I think the App is very unstable to do something with it.

    Please be patient. They don't even consider it beta:

    This is an alpha preview build, not for production use! Updates will coming sortly.

    • 15 posts
    November 27, 2014 8:21 AM CET

    Ok, Jorge, thanks for your information.

    • 195 posts
    November 27, 2014 10:01 AM CET

    True, ture, the app is quite messy yet, but it'll improve quickly. I already handed over a long bug list to the developers, including your findings complete with the translation of accindental hungarian labels :)

    • 15 posts
    November 27, 2014 10:42 AM CET

    Hello again Tamás.

    Have available Spanish translation already?.

    I'm spanish and i can help you with the translation into spanish. Deal me in with it if necesary.

     

    • 26 posts
    November 27, 2014 11:15 AM CET

    Thanks for your answer, Jorge.  Much appreciated.

     

  • November 28, 2014 9:34 AM CET

    I don't know what it would involve technically to make a translation (i.e. what software would I need), but I could do a german translation if you need one.

    Leg bedre, Christian

    • 111 posts
    December 2, 2014 1:26 PM CET

    There is a new version on Google,

    0.0.12

    There are now 4 profiles to use. Also from the release notes:

    * Bugfixes related to the user interface, mostly affecting remote
    control profile elements
    * Automatic, transparent BLE connection handling: the application will
    try to reconnect bricks in case of connection loss
    * Port tester function
    * Port invert function
    * New profiles in market
    • 2 posts
    December 3, 2014 2:39 PM CET

    Hello,

    Do not support "Samsung Galaxy notre 2" ??

    I can't install sbrick apll

    • 111 posts
    December 3, 2014 2:48 PM CET

    Hi.

    Samsung Galaxy Note 2 originally runs Android 4.1. Did you upgrade your phone to 4.3 or above? Android only fully supports Bluetooth 4.0 Low Energy specs with Android 4.3.

    • 15 posts
    December 3, 2014 8:58 PM CET

    Hello.

    I have Samsung Note 2 with Android 4.4.2 and I have install the App.

    BLE Android only after 4.3 as Jorge Pereira said.

    Bye!

    • 2 posts
    December 5, 2014 10:31 AM CET

    Tahnk you for your help.

    • 4 posts
    December 7, 2014 9:50 PM CET

    Hi

    After installing the 5 profiles one of them is not working.
    When I select the Joystick my app fails (send the report after the failure).
    I am using a Samsung S5 with Android version 4.4.2 (still waiting for the SBrick).

    Mike

    Updated to version 0.0.15

    In my opinion: Became worse......

    Of the 5 proflies:

    • Test 1 (2 vertical slide bars and 2 buttons)  --> OK nothing changed
    • Test 2 empty screen         --> NOK, no slidebars anymore
    • Joystick     --> App crashes (as before)
    • Gamepad 1 (1 joystick button) --> Was working before. Now bigger button not working  NOK
    • Gamepad 2 (2 slide bars 1 hor 1 ver)   --> Still working

    At this moment the Market does not show any profiles......


    This post was edited by Mike Verstappen at December 8, 2014 9:59 AM CET
    • 195 posts
    December 8, 2014 11:55 AM CET

    Javier: no, there's no spanish translation yet. The translations are not the highest priority right now, we have to clean up & stabilize the apps first. I appriciate your offer, thank you very much, we will need good translators / proof readers indeed :)

    Mike: thank you very much for the feedback, the dev are already working on it!

    • 111 posts
    December 8, 2014 12:33 PM CET

    Mike Verstappen said:

    • Test 2 empty screen         --> NOK, no slidebars anymore

    At this moment the Market does not show any profiles......

     

    Mike, this happened to me before (from 0.0.10 to 0.0.12). I cleared all application data and cache and force the app to kill, had to start my MOC all over again but if corrected those two problems.

    From 0.0.12 to 0.0.15 I had to do the same but because other things were not working. But I do have Test2 all slides showing 8and not carshing when I save) and I do have 5 profiles in Market.

    • 4 posts
    December 8, 2014 4:38 PM CET

    Ok, removed the app and re-installed the SBrick app.

    Now I can load my profiles again.

    Of the 5 proflies:

    • Test 1 (2 vertical slide bars and 2 buttons) --> OK
    • Test 2 (4 vertical slide bars)                      --> OK working again
    • Joystick --> App still crashes (as before)
    • Gamepad 1 (1 joystick button) --> Now bigger button not working NOK
    • Gamepad 2 (2 slide bars 1 hor 1 ver) --> Still working
    • 15 posts
    December 10, 2014 8:48 AM CET

    Hello.

    I installed version 0.0.15 of the App and now the Market does not show any profiles and there is not feedback when I push the "search" button.

    I have reinstall the App and I have the same problem.

    Could be possible to have one or two profiles precharged in the App?

    • 195 posts
    December 10, 2014 11:28 AM CET

    Hello, thanks, investigating, and yes, preloaded profiles would solve such issues.

    • 195 posts
    December 11, 2014 1:52 PM CET

    Sariel sent us the following bug report. I'll leave it here for the droid devs:

    Hi Tamas,

     
    Thank you very much, I have downloaded the app and all the profiles. Sorry to be a problem, but literally none of them works. I made sure the SBrick is connected and visible, I made sure the outputs are set, I can't find the problem.
     
    Here:
    - gamepad1: sometimes loads as an empty black square. When I touch the pad, a white circle appears on the lower right corner. Motors don't respond.
    - steeringwheel1, gamepad2, test1, joystick: it loads empty. No controls, just the background.
    - test2: it shows 4 sliders at first, but every time I start it again there is one slider less: three, two and now just one. Motors don't respond.
    - steeringwheel2: it makes the app crash.
     
    Any solutions? I would be happy to buy a newer SBrick prototype from you, but it looks like a software problem.
    • 3 posts
    December 11, 2014 5:27 PM CET

    Hello

     

    No supported whitch à Samsung galaxy S4 ative (GT-I9295) Android 4.2.2.

    It is possible to have the .apk file ?

     

    Thx

    • 195 posts
    December 11, 2014 5:30 PM CET

    You need at least Andorid 4.3 to install the app. The S4 active does have BLE, so that shouldn't be a problem.