Forums » Support

Back To Topics

SBrick Android App

    • 189 posts
    October 15, 2016 12:46 PM CEST

    [blockquote]Martin Dvorak said:

    Samsung Galaxy S6 edge, Android 6.0.1

    1) Public profiles load 1 of 10 tries.

    2) My profiles unable to load at all.

    3) Sbrick - test does not work, neither LED TESTER / UPDATE FIRMWARE

    4) Every time when app starts, there is f***** 9 list tutorial

    5) Tried on 4 sbricks what I have

     

    [/blockquote]

    Please try pair, then unpair the SBricks at the Bluetooth settings first.

    • 4 posts
    October 15, 2016 12:27 PM CEST

    Samsung Galaxy S6 edge, Android 6.0.1

    1) Public profiles load 1 of 10 tries.

    2) My profiles unable to load at all.

    3) Sbrick - test does not work, neither LED TESTER / UPDATE FIRMWARE

    4) Every time when app starts, there is f***** 9 list tutorial

    5) Tried on 4 sbricks what I have

     

    • 189 posts
    October 14, 2016 7:13 PM CEST

    For Android 5.0+ users: if you updated the sbrick firmware, then unpair the SBricks in the Android's Bluetooth menu, then you can continue.

    • 189 posts
    October 14, 2016 6:17 PM CEST

    Hi Guys,

    We are starting to test the new release. Here is a link for the Android version. This is not the public release, but it is very useful for us if you can test it also.

    Please download this apk if your Android app not works with your SBrick: http://dewsys.com/sbrick/releases/sbrick-4.2.0.68_2.135.16-r.apk
    Please
    send us your report here: https://docs.google.com/forms/d/e/1FAIpQLSeQMie_XRcylXdiV_qadJDqR3oqA6f8mmmFi_FOYS7ftB1zOQ/viewform or you can find feedback menu in the application.

    The new firmware version is 16. There are changes in the communication protocol to decrease the packet flow between the SBrick and the Phone. This will improve the connection stability. Of course the driver changed too. Please start with updating the firmware.

    With the new firmware the SBrick stores the name, so if you are in an exibition you can find your SBrick easier.

    We are still testing too, this is not the final version for the next public release, but I wanted to give you some progress about the app.

    • 95 posts
    October 11, 2016 3:13 PM CEST

    Finally after almost 2 years, a beta group is created...

    This could have been a good idea if there were more versions to test...

    the last one is almost 1 month old...

     

    • 310 posts
    October 7, 2016 5:18 PM CEST

    [blockquote]theodore pietrzak said:

    market fails to load on samsung galaxy s7. with androind 6.0.1
    reloaded app ad fiew time, try to load market many time, app work and can test the sbrick just fine, just un able to load profliles

    [/blockquote]

    Hello Theodore! 

    Please check your internet connection, we have not expereienced an issue like this before.

    If it won't work please reinstall the application. 

    If none of these work, please contact us again on info@sbrick.com

    Best regards, 

    Balint
    SBrick Team 

     

  • October 7, 2016 12:28 PM CEST

    [blockquote]Tamas Misik said:

    @Martin, 
    Unfortunately it seems the SBrick app doesn't work on Motorola phones. 
    Probabaly because the Motorla uses diferent Android OS than other brands (HTC, Samsung, etc..). We have contacted with the google about this problem. Hopefully we can find some souliton quickly.

    @Stephan,
    Thanks for the report. Yes, it seems like a bug. Our developers working on a new version, so probably this bug will fixed in the next version of our applcation. Thanks for you patience.


    More news about our Android application soon. Thanks for your patience. 
    Tamas

    Thank you Tamas for the reaction.......I will wait for a while and otherwise have to buy a second hand phone or so where the app works!

  • October 7, 2016 3:59 AM CEST

    market fails to load on samsung galaxy s7. with androind 6.0.1
    reloaded app ad fiew time, try to load market many time, app work and can test the sbrick just fine, just un able to load profliles

    • 164 posts
    October 3, 2016 1:09 PM CEST

    @Martin, 
    Unfortunately it seems the SBrick app doesn't work on Motorola phones. 
    Probabaly because the Motorla uses diferent Android OS than other brands (HTC, Samsung, etc..). We have contacted with the google about this problem. Hopefully we can find some souliton quickly.

    @Stephan,
    Thanks for the report. Yes, it seems like a bug. Our developers working on a new version, so probably this bug will fixed in the next version of our applcation. Thanks for you patience.


    More news about our Android application soon. Thanks for your patience. 
    Tamas

  • October 2, 2016 9:41 AM CEST

    Hi,

    It would be nice to read some positive news about SBrick on the internet! But as an early hour supporter (KickStarter) I have problems too. My brick makes contact with my Android 6.0.1 phone, but for the rest nothing works. The green LED is not on either. Found out that the app only starts if BlueTooth is disabled first....that is strange for an app that needs BlueTooth! Also if you press EXIT then the app doesn't exit but starts all over again. I guess we have to wait for a real software update, because the beta version is not working either and I will check a new brick in the store, because maybe the problem is in my never used brick. 

    Best regards

    • 6 posts
    October 2, 2016 3:28 AM CEST

    Hi

    I thought that I would give the SBrick another try since I wanted to add it to a creation that is using a RC Buggy motor.

    I was part of the KickStarter program, however since receiving my SBrick I have only had it 'sort-of' working a few times.  Now, it's not working at all... again.

    I have installed the latest version of the SBrick App from the Android Play Store, and when I start it up and go to SBricks I can see it detect my SBrick, but when I try to test the sliders/ports nothing happens.  When I go to My Creations and select a Profile, none of the controls/sliders work there either.  When I try to update the hardware firmware, it tells me that I am on the latest version, but doesn't tell me which version it is.

    If I run the nRF Connect App, I can see the SBrick, connect to it, and sent commands without any issue.  Therefore I suspect that the SBrick is working ok, but the SBrick App is not working.

    I installed the beta version of the SBrick App that you linked to in this thread, however when I go to SBricks it doesn't even detect my SBrick at all any more.

    I have uninstalled and reinstalled the SBrick App several times, and restarted my phone several times also, but I am wasting a lot of time on this.

    I am using a HTC One, Android 5.0.2.

    I also submitted a ticket on the docs.google page about a week ago but I have not received a response at all, hence I am posting here instead.

    Please let me know how I can get my SBricks working.

    Thanks in advance,
     - Stephan

  • October 1, 2016 9:56 PM CEST

    [blockquote]Balint Mezei said:

    [blockquote]Bram Vermeiden said:

    Hello I have bought a Sbrick today, but i cant connect it to my phone a moto g3.
    if I want to connect it with the bluetooth it says that the conection gets refused by the Sbrick.
    What do I need to do?

    [/blockquote]

     

    Hello! 

    We ask you to try out this apk, this is a beta version yet, but may can solve the connection issue. 

    https://drive.google.com/file/d/0B5qRW6HABNtqT2pyOEdtdkZsVlE/view?usp=sharing

    If it won't work please fill out his form, and our developers will contact you soon, 

    https://docs.google.com/forms/d/e/1FAIpQLSdIneJxqxmZMRasFSklMBO20-yOJGxY6zBCTnz-10eb1xoyIg/viewform

    Best regards, 

    Balint - SBrick Team 

    [/blockquote]

    Hi, The same problem with my new Moto G4 (Android 6.0.1) The app is only working and connecting with the brick if you start it the first time, but then the sliders are not working. The second time you start the app, you only get a black screen! I participated in the Kickstarter project, so I do have one of the first SBricks!

    Best regards,

    Martin

    • 3 posts
    September 29, 2016 9:51 PM CEST

    We need to join the BETA Google+ group first. What group is that?

    • 164 posts
    September 29, 2016 3:33 PM CEST

    Hello Guys,

    Our official testing program has started. You can get the latest beta app from here: https://play.google.com/apps/testing/com.vengit.sbrick

    It
    seems we have an application which works on many android devices, but unfrotunately it doesn't work on any device, because the Android. This is why we contacted with the Google. It seems we will work together in the future and we try to solve this problem together.

    If you would like to help us, please try it out our latest beta app. :)


    Thanks,
    Tamas


    • 164 posts
    September 29, 2016 3:23 PM CEST

    [blockquote]Adam Liebl said:

    Hello,

     

    i have fill the Formular 1,5 weeks ago. But no answer. What is now the Probelm with my Sbrick?

    [/blockquote]


    Hi Adam, 
    Sorry for the late reply.

    Plese try it our latest beta application: https://play.google.com/apps/testing/com.vengit.sbrick





    • 95 posts
    September 29, 2016 1:25 PM CEST

    [blockquote]Tamas Misik said:

    New Android application (4.1.0.31_0.127.15-d) 
    -> https://drive.google.com/file/d/0B5qRW6HABNtqT2pyOEdtdkZsVlE/view?usp=sharing

    Not
    public, just test version. Please try it and let us know your experiences.


    [/blockquote]

    The app still crash on my phone or tablet

     

    • 2 posts
    September 28, 2016 7:30 AM CEST

    Hello,

     

    i have fill the Formular 1,5 weeks ago. But no answer. What is now the Probelm with my Sbrick?

    • 310 posts
    September 23, 2016 9:04 PM CEST

    [blockquote]Bram Vermeiden said:

    Hello I have bought a Sbrick today, but i cant connect it to my phone a moto g3.
    if I want to connect it with the bluetooth it says that the conection gets refused by the Sbrick.
    What do I need to do?

    [/blockquote]

     

    Hello! 

    We ask you to try out this apk, this is a beta version yet, but may can solve the connection issue. 

    https://drive.google.com/file/d/0B5qRW6HABNtqT2pyOEdtdkZsVlE/view?usp=sharing

    If it won't work please fill out his form, and our developers will contact you soon, 

    https://docs.google.com/forms/d/e/1FAIpQLSdIneJxqxmZMRasFSklMBO20-yOJGxY6zBCTnz-10eb1xoyIg/viewform

    Best regards, 

    Balint - SBrick Team 

    • 1 posts
    September 23, 2016 5:31 PM CEST

    Hello I have bought a Sbrick today, but i cant connect it to my phone a moto g3.
    if I want to connect it with the bluetooth it says that the conection gets refused by the Sbrick.
    What do I need to do?

    • 164 posts
    September 16, 2016 10:06 AM CEST
    • 2 posts
    September 15, 2016 8:46 PM CEST

    Hello,

    i have a problem with one of my Sbricks. The Sbrick App shows me that i have a Connection. But when i test the Ports form the brick nothing happen. Is a Lego Servo on a Port and i turn on the Batteriepack the Servo do the Calibration.

    What can i do? 

    • 310 posts
    September 12, 2016 9:41 AM CEST

    [blockquote]Taylor Shin said:

    SBrick Android App doesn't run on LG tablet.

     

    Tablet Model Number:

    LG-V521 (T-Mobile U.S.)

     

    Hardware version:

    Rev. 1.0

     

    Problem:

    If I run SBrick app, the screen becomes black and nothing happens.

     

    Update:

    O wait, it's running!! But the screen breaks up when I tilt(the tablet tries to rotate its screen) it, the introduction screen breaks up and becomes unrecognizable.

     

     

     

    [/blockquote]

     

    Hello!

    We did not experience any issue like this before, could you send us some picture about it, on info@sbrick.com

    Please try to reinstall the application, if it won't work contact us again. 

    Best wishes, 

    Balint - SBrick Team 

    • 2 posts
    September 12, 2016 2:05 AM CEST

    SBrick Android App doesn't run on LG tablet.

     

    Tablet Model Number:

    LG-V521 (T-Mobile U.S.)

     

    Hardware version:

    Rev. 1.0

     

    Problem:

    If I run SBrick app, the screen becomes black and nothing happens.

     

    Update:

    O wait, it's running!! But the screen breaks up when I tilt(the tablet tries to rotate its screen) it, the introduction screen breaks up and becomes unrecognizable.

     

     

     


    This post was edited by Taylor Shin at September 12, 2016 2:07 AM CEST
    • 164 posts
    September 7, 2016 10:27 AM CEST

    New Android application (4.1.0.31_0.127.15-d) 
    -> https://drive.google.com/file/d/0B5qRW6HABNtqT2pyOEdtdkZsVlE/view?usp=sharing

    Not
    public, just test version. Please try it and let us know your experiences.


  • September 6, 2016 10:06 AM CEST
    Last night I changed  one of the servo motors and the problem has been solved so the problem is the servo motor and not the bricks sorry I assumed it was the brick.
     
    Thanks for the quick response and the tip about contact Lego.
     
    I can say that the app version 4.0.3. is the best version until now it is stable and works perfectly.
     
    In this version you can set contact in ms what is the purpose of this?
     
    With kind regards,

    This post was edited by bricker bricker 72 at September 6, 2016 12:07 PM CEST