Forums » Support

Back To Topics

SBrick Android App

    • 164 posts
    September 5, 2016 8:43 PM CEST

    Please test it again. If you are sure your servo motor works perfectly and the problem will be with the SBrick please contact us and we will help you. 

    ButI tihnk this will be a problem with your servo motor. If you contact with the LEGO you will get a new one. 

  • September 5, 2016 7:10 PM CEST

    hi guys I updated to version 4.0.3.9.r and it worked until now perfectly.

     

    but now I have a problem with 2 sbricks ( until now they worked perfect) al the others work correct.

    the problem is that when I want to steer with a servo motor, it on one side steer and returns to center and the other side it steers but do not return to center.

    the profiles I programmed are correct until now they worked correct the problem also appears when I test the the brick.

    so I think their is a problem with the bricks?

     

    I use hardware version 4 and 5 with firmware version 12 and android 6.0.01 on a samsung galaxy s5 neo

     

    what can I do to solve the problem? and it need to be quick please  because I have A large demonstration in a few weeks ( Lego World in the Netherlands )

     

    with kind regard,

     

    Bricker Bricker 72

    • 310 posts
    August 24, 2016 3:02 PM CEST

    [blockquote]John Helzer said: I can connect to my sbricks with an old iPod touch, but not with my new droid turbo 2. Every time I try to connect to the sbricks in the app, it just buffers and buffers until the app crashes, even though in the settings it says they are paired. I have the latest firmware and update on the app.[/blockquote]

     

    Hello John! 

    It looks like a special issue, please try to reinstal the application, and sign in again. 

    You don't need to connect it through your bluetooth settings of your device, the application automatically see the brick. 

    Please try the reinstal, and contact us again, what happened. :) 

    Regards, 

    Balint - SBrick Team 

    • 1 posts
    August 23, 2016 5:59 PM CEST
    I can connect to my sbricks with an old iPod touch, but not with my new droid turbo 2. Every time I try to connect to the sbricks in the app, it just buffers and buffers until the app crashes, even though in the settings it says they are paired. I have the latest firmware and update on the app.
  • August 23, 2016 11:43 AM CEST

    [blockquote]Tamas Misik said:

    [blockquote]Vsevolod Kindiakov said:

    The 4.0.3.9-r version is the first improvement I've seen in the last year. I've been able to go through the "Upgrade firmware" process without it failing. It is still unstable - sometimes I can't get into testing an SBrick after tapping on it in the list (just keeps doing the circle animation until I restart the app). Sometimes I can't get the list of profiles - it fails to grab them.

    Disconnection issues are still there when controlling my MOC - one of the SBricks will keep disconnecting and reconnecting (and sometimes it will think it's reconnected, but I still have no control and have to exit and re-enter the profile).

    Better than before, but still fairly unusable here.

    Nexus 4 5.1.1

    [/blockquote]

    Dear Vsevolod,

    Did you update your SBrick firmware? If not please do it! The latest firmware version the 12.

    If you need any help about the firmware update just let me know. 


    [/blockquote]

     

    Yes, as I mentioned - I've managed to get through the update process without hangups this time. My two SBricks are on 4.12, but the issues described are still there. :(

    • 3 posts
    August 22, 2016 7:07 PM CEST

    [blockquote]Tamas Misik said:

    [blockquote]Chris Pst said: The update did not fix my problem... could somebody please reply to my previous question. Thanks[/blockquote]

    Hi Chris,

    Can you please download the Simple Control apk form the google play: https://play.google.com/store/apps/details?id=com.vengit.blecontrol
    Please
    try to udapte your SBrick's firmware with this application. 

    If oyu need any help about the update, just let me know.

    [/blockquote] Hi Tamas, Thanks for replying! However as stated in my initial question the simple app does not see my brick, so how can i upload the firmware?

    Update: I managed to get my androids working using the following steps

    1) downloaded APK for 2.0.2

    2) updated the firmware to version 8

    3) now the bricks became visible in APK for 4.0.1

    4) updated to firmware version 12

    At first glance, most functions seem to work! I would suggest to add steps like this to a FAQ so others can find a solution more easily

     


    This post was edited by Chris Pst at August 22, 2016 9:08 PM CEST
    • 164 posts
    August 22, 2016 4:27 PM CEST

    [blockquote]Vsevolod Kindiakov said:

    The 4.0.3.9-r version is the first improvement I've seen in the last year. I've been able to go through the "Upgrade firmware" process without it failing. It is still unstable - sometimes I can't get into testing an SBrick after tapping on it in the list (just keeps doing the circle animation until I restart the app). Sometimes I can't get the list of profiles - it fails to grab them.

    Disconnection issues are still there when controlling my MOC - one of the SBricks will keep disconnecting and reconnecting (and sometimes it will think it's reconnected, but I still have no control and have to exit and re-enter the profile).

    Better than before, but still fairly unusable here.

    Nexus 4 5.1.1

    [/blockquote]

    Dear Vsevolod,

    Did you update your SBrick firmware? If not please do it! The latest firmware version the 12.

    If you need any help about the firmware update just let me know. 


    • 164 posts
    August 22, 2016 11:24 AM CEST

    [blockquote]Chris Pst said: The update did not fix my problem... could somebody please reply to my previous question. Thanks[/blockquote]

    Hi Chris,

    Can you please download the Simple Control apk form the google play: https://play.google.com/store/apps/details?id=com.vengit.blecontrol
    Please
    try to udapte your SBrick's firmware with this application. 

    If oyu need any help about the update, just let me know.

    • 4 posts
    August 22, 2016 11:00 AM CEST

    [blockquote]Pio Murmann said:

    Hello everybody,

    just for info: In the last few weeks I had some trouble with SBrick App and my 4 SBricks (Firmware 4.12). I use a Samsungs Galaxy S5 (Mobile phone) and installed the App version 4.0.2. I loose the Bluetooth connection to my 4 after a few minutes. I disconnect the connection power off/power on the 4 SBricks an then it works for a few minutes. Then the same problem. I tried to download and install Version 4.0.3-9r: Also the same problem. OK. I installed the the SBrick App 4.0.1. This version works fine with all my SBricks.

    But now a surprise: On my Tablet (Samsung Galaxy Note 10.1) I installed 4.0.1. I tried to connect to my SBricks. If I tried to start the App the message "App angehalten" (a german App version) appears. I installed SBrick App 4.0.2 the same Problem. I download and install SBrick App 4.0.3-9r. Wow! It works fine! I can start my App and connect to all my 4 SBrick (Firmware 4.12) at my Lego MOC. I configure my profile and all works fine! Great!

    Best regards

     

    [/blockquote]

    BTW, I download the version 4.0.3-9r from: https://drive.google.com/file/d/0B2dAUNpc5UBXaURoanFQN1VhTGc/view?usp=sharing

    • 4 posts
    August 21, 2016 1:33 PM CEST

    Hello everybody,

    just for info: In the last few weeks I had some trouble with SBrick App and my 4 SBricks (Firmware 4.12). I use a Samsungs Galaxy S5 (Mobile phone) and installed the App version 4.0.2. I loose the Bluetooth connection to my 4 after a few minutes. I disconnect the connection power off/power on the 4 SBricks an then it works for a few minutes. Then the same problem. I tried to download and install Version 4.0.3-9r: Also the same problem. OK. I installed the the SBrick App 4.0.1. This version works fine with all my SBricks.

    But now a surprise: On my Tablet (Samsung Galaxy Note 10.1) I installed 4.0.1. I tried to connect to my SBricks. If I tried to start the App the message "App angehalten" (a german App version) appears. I installed SBrick App 4.0.2 the same Problem. I download and install SBrick App 4.0.3-9r. Wow! It works fine! I can start my App and connect to all my 4 SBrick (Firmware 4.12) at my Lego MOC. I configure my profile and all works fine! Great!

    Best regards

     

     

  • August 20, 2016 5:30 PM CEST

    Hello Tamas, so far it looks good!
    As long as I've never been able to experiment with my Bricks. I will continue to test and continue to report.

    • 3 posts
    August 20, 2016 5:20 PM CEST

    [blockquote]Vsevolod Kindiakov said:

    The 4.0.3.9-r version is the first improvement I've seen in the last year. I've been able to go through the "Upgrade firmware" process without it failing. It is still unstable - sometimes I can't get into testing an SBrick after tapping on it in the list (just keeps doing the circle animation until I restart the app). Sometimes I can't get the list of profiles - it fails to grab them.

    Disconnection issues are still there when controlling my MOC - one of the SBricks will keep disconnecting and reconnecting (and sometimes it will think it's reconnected, but I still have no control and have to exit and re-enter the profile).

    Better than before, but still fairly unusable here.

    Nexus 4 5.1.1

    [/blockquote]

    I am also running a Nexus 4 with stock Android 5.1.1 and no issues at all at the moment with this version.

  • August 20, 2016 5:15 PM CEST

    The 4.0.3.9-r version is the first improvement I've seen in the last year. I've been able to go through the "Upgrade firmware" process without it failing. It is still unstable - sometimes I can't get into testing an SBrick after tapping on it in the list (just keeps doing the circle animation until I restart the app). Sometimes I can't get the list of profiles - it fails to grab them.

    Disconnection issues are still there when controlling my MOC - one of the SBricks will keep disconnecting and reconnecting (and sometimes it will think it's reconnected, but I still have no control and have to exit and re-enter the profile).

    Better than before, but still fairly unusable here.

    Nexus 4 5.1.1

    • 3 posts
    August 20, 2016 8:27 AM CEST
    The update did not fix my problem... could somebody please reply to my previous question.

    Thanks
    • 3 posts
    August 19, 2016 11:40 PM CEST

    [blockquote]Tamas Misik said: Hi Guys, A new (4.0.3.9-r) test version is available: https://drive.google.com/file/d/0B2dAUNpc5UBXaURoanFQN1VhTGc/view?usp=sharing Please test it and share with us your experiences. Thanks for your help.[/blockquote]

    It seems as if this version fixes my Nexus 4 issues (disconnecting). Nice work.


    This post was edited by Bas Rieter at August 20, 2016 1:03 PM CEST
    • 164 posts
    • 3 posts
    August 14, 2016 10:33 PM CEST

    I've recently purchased a Sbrick. I had really high expectations because you have a potentially great product! unfortunatly it has not lived up to its expectations yet. I've runned into a few things.

    1)  The ipad links to the brick without a problem. I can turn on the led and use the ports of the Sbrick from the "My Sbrick" window without a problem. However, no information regarding the brick status is shown in the window.

    2) Using the Ipad, at maximum deflection of a slider the power of the motor will be set to 0 instead of 100%

    3) Both the S4 and the S7 see a Sbrick, however the address is different from that of the ipad.  I can not turn on the led nor use the ports of the Sbrick from the "My Sbrick" window. Niether any status information is shown. When a link is established with an android device the ipad can not acces the brick. when releasing the link the ipad can acces the brick again. So, it seems that some sort of connection is made. 

    In all three devices a different name can be assigned to the brick...

    In the Sbrcik simple app niether the s4 nor the s7 show a connection.

    I've added a picture of the menu's on the three devices. By the way, what do the T and the M in front of the address mean?

    How can these issues be fixed?

    Samsung galaxy S7 with android 6.0.1

    Samsung galaxy S4i mini with android 4.4.2

    ipad 2 ios 9.3.4

    Sbrick v4.0 update 1 on al devices

    Sbrick with newest firmware

     

    Some suggestions:

    1) Can you change the structure of the forum such that a answer of a question could be found without having to go through 45 pages of a single thread.

    2) Create a slider which enables mixing of two or more channels by means of a formula. This would be very handy for skid steering

     

              

    • 99 posts
    August 1, 2016 10:21 PM CEST

    [blockquote]Karl Fensterstock said:

    [blockquote]Tamas Misik said:

    [blockquote]Karl Fensterstock said:

    PS: Can you give me an Android device name where the SBrick App 100% works?

    I would like to buy it.

    [/blockquote]

    Sorry for the late reply. As we see in our logs, on these devices the SBrick application works without any problem. 

    D6603 Sony Xperia Z3
    A0001 OnePlus One
    SM-J500FN Samsung Galaxy J5

    We will coming out with a longer list with more details soon.


    [/blockquote]

    Thank you Tamas!

    I now use V4.0.2 the problems but not, unfortunately, less.

    [/blockquote]

     

    The Sony Xperia Aqua M4 works fine too.

  • August 1, 2016 2:26 PM CEST

    [blockquote]Tamas Misik said:

    [blockquote]Karl Fensterstock said:

    PS: Can you give me an Android device name where the SBrick App 100% works?

    I would like to buy it.

    [/blockquote]

    Sorry for the late reply. As we see in our logs, on these devices the SBrick application works without any problem. 

    D6603 Sony Xperia Z3
    A0001 OnePlus One
    SM-J500FN Samsung Galaxy J5

    We will coming out with a longer list with more details soon.


    [/blockquote]

    Thank you Tamas!

    I now use V4.0.2 the problems but not, unfortunately, less.

    • 164 posts
    August 1, 2016 1:25 PM CEST

    [blockquote]Karl Fensterstock said:

    PS: Can you give me an Android device name where the SBrick App 100% works?

    I would like to buy it.

    [/blockquote]

    Sorry for the late reply. As we see in our logs, on these devices the SBrick application works without any problem. 

    D6603 Sony Xperia Z3
    A0001 OnePlus One
    SM-J500FN Samsung Galaxy J5

    We will coming out with a longer list with more details soon.



    This post was edited by Tamas Misik at August 1, 2016 1:25 PM CEST
    • 310 posts
    July 25, 2016 6:59 PM CEST

    [blockquote]Vlad . said:

    Hi, with 11 and next 12 firmware my sbricks (2 parts) not work now always.

    When i run "Creation", appliaction can not connnect to sbrick.

    Explay Vega android 4.4.2

     

     

    [/blockquote]

    Hello! 

    After the FW update please restart your device. 
    If it is still won't work, please fill out this, to help our developers solve the issue, 

    https://docs.google.com/forms/d/e/1FAIpQLSdIneJxqxmZMRasFSklMBO20-yOJGxY6zBCTnz-10eb1xoyIg/viewform

    Thanks, 
    Balint Mezei 
    SBrick Team 

    • 95 posts
    July 24, 2016 11:38 AM CEST

    I still have connection problems with 4.0.2.4-d Can you please send me the app to downgrade my sbricks ?

     

    Thank you

     

    I have noticed one strange thing with 4.0.2.4-d

    Simple Control reports v12 for the 3 sbricks I am using now while there is still one in 4.1 for SBrick...

    • 7 posts
    July 23, 2016 11:12 PM CEST

    Hi, with 11 and next 12 firmware my sbricks (2 parts) not work now always.

    When i run "Creation", appliaction can not connnect to sbrick.

    Explay Vega android 4.4.2

     

     

    • 99 posts
    July 23, 2016 10:38 PM CEST

    Hi guys,

    I have just tested the latest version of the app, with the most difficult configuration : a fast racer with 2 RC Buggy motors. I you have built this type of cars that have a peak speed of 15km/h, you know how hard it is to control them without crashes.

    One word to say it all : PERFECT !!!!

    The first critical point is the ability to limit the steering range. We can do that with the new generation of the Android app (it was not possible before version 2.0). +0.3 / -0.3 worked great in my case and the car was a pleasure to drive.

    Same comfort as a physical remote control. If some of you have watched my last video built with the 2003 Lego RC Unit, my next video will show that the SBrick can provide the same driveability with a similar chassis.

    The second critical point is, of course, the random disconnection problem we had with the previous app versions. With my Sony Xperia, this problem is over now : the only disconnections occured when the car went out of range, like 25m away from the phone.

    Fine. It doesn't help much those who still experience this kind of trouble, but I can testify that the SBrck is not the cause : the cause is the extrem variety of Android devices, some being close to the standards, some being not.

    I will soon post a video showing this car in action, and believe me, I will clearly highlight the fact that the SBrick is now fully operational even if you run Android!


    This post was edited by Marc Jaouen at July 23, 2016 10:39 PM CEST
    • 310 posts
    July 23, 2016 3:23 PM CEST

    [blockquote]Trevor Lien said:

    I have been trying to figure out how to use Profile Designer and Sbrick app (I think they are supposed to work together, each doing half of the job).  I have studied the guide at 
    and searched for answers and how-to guides elsewhere but am not finding answers for novices.
    A few critical confusions:
     
    In Profile Designer::
    What do the "Channel" fields do?
     
    The first Field says "You can define the control Channels here.  The channels can be selected in the sbrick app" ...
    - Do channels refer to the physical ports on the sbrick?
    - Obviously "Defining" and "Selecting" are 2 different things because one is done in the Profile Designer and the other is done in the Sbrick App.  Which is which?  What to the 2 words mean in this context?
    - What are valid entries for this field?
    - How does this field map to a specific Sbrick and a specific port that a device is plugged into?
     
    ​The second "Channel" field says the exact same thing in the tool tip!
    - ​This is a longer field - maybe it is a description?...
    - If it is a description - then how does it differ from "Name"... in other words, Where does this label show up?
    - If it is not a Description, then what are valid entries for this field?
     
    What are ​Points?​
    The description tool tip simply says that you can define them.
    - is this related to the Pulse Width Modulation of the port being controlled?
    - What are the units of measurement?
    - How do the Points influence a Motor?  a Light?  a Servo?
     
    ​Can I save Profiles ?
    Is there such a thing as a Profile "file"?
    How do I get a Profile onto my Sbrick controlling device/phone?
     
    In the SBrick App:
    - How do I assign a Profile to an Sbrick?
    (...or do I assign Sbricks to a profile?)
    - What is a "Creation"? (MOC?, Profile? )
    ​- On the Creation tab, it can show multiple profiles, but it doesn't show any Sbricks...Does that mean that I've missed a step?
    - Also, Sbricks and Creations are on different tabs in the application: does this mean they alternative approaches to doing the same thing?​
    - can you assign a "Creation" to an Sbrick?  or Sbricks to a creation?
    - The Creations have "Channel" selections; are these mapped to a Profile or an Sbrick?  (Or something else?)
    - Creations have media files, just like Profiles: Is there a layout Editor for the Creations?  What are these media files used for?
    - When I assign a second Profile to a Creation, only the first profile is displayed when I run the Creation;  am I missing a step?
    - When configuring a Creation, it requires tests with a connected Sbrick; will the Creation only work with that specific Sbrick in the future?
    - Is it intended that you build a new "Creation" for each MOC you make in order to use a given "Profile"?
     
    ​Using both Profile Designer and Sbrick App:
    - Is there an app to create or edit profiles locally, on my phone or tablet so that you only set up the controls in one app?
    - Are there any "How to" videos that walk you through the process - showing how it is supposed to work?
    - Is there a Wiki or other location where people can discuss back and forth about SBrick issues?
    (Considering that users can't reply to individual comments here, or search for answers)
     
    Any help would be greatly appreciated - I see that many people are using the Sbrick successfully - I'd like to be one of them!
    ​Thanks!

    [/blockquote]

    Hello!

     
    I try to answer all your questions, if i missed something please contact us again. :)
     
    What do the "Channel" fields do?
    The first Field says "You can define the control Channels here.  The channels can be selected in the sbrick app" ...
    - Do channels refer to the physical ports on the sbrick?
    - Obviously "Defining" and "Selecting" are 2 different things because one is done in the Profile Designer and the other is done in the Sbrick App.  Which is which?  What to the 2 words mean in this context?
    - What are valid entries for this field?
    - How does this field map to a specific Sbrick and a specific port that a device is plugged into?
    ​The second "Channel" field says the exact same thing in the tool tip!
    - ​This is a longer field - maybe it is a description?...
    - If it is a description - then how does it differ from "Name"... in other words, Where does this label show up?
    - If it is not a Description, then what are valid entries for this field?
     
    The "Name" field is for the profile designer. If you set for example 3 sliders, it is easier if you set here that which slider is for what. If you want a steering slider, Set "Steering" in the name, and it will be obvious for you. If you want an other one for acceleration name this one, and you will know which one is the one you need. 
     
    The "Channels" field is for the application. When you add SBricks port to the profile you downloaded this descriptions will be there. If you want to set a servo motor (for steering for example) to the A port, you need to select in the application the A port and the "Steering" channel you set in the profile designer. And this way it is easier to find what function you are looking for. 
     
    What are ​Points?​
    The description tool tip simply says that you can define them.
    - is this related to the Pulse Width Modulation of the port being controlled?
    - What are the units of measurement?
    - How do the Points influence a Motor?  a Light?  a Servo?
     
    The points refer to, set motors or LEDs in a specific time to start or stop. If you set "start" for 1, the slider start on the top. (In the case of acceleration, you won't control your creation forward, only backward.) 
    If you set "zero" to 1, your creation stops when you reached the top of the slider.
    Maybe it is the easiest way to try it out. Create a profile, and add 3-4 sliders to it (in the profile designer) and set different values. And you will understand this faster. :) 
     
    Can I save Profiles ?
    Is there such a thing as a Profile "file"?
    How do I get a Profile onto my Sbrick controlling device/phone?
     
    If you are signed in, in our social site, when you open the profile designer you are automatically signed in to it also. 
    If you save a profile you created, when you start the application on your device, that profile will be there in the application too, in "My profiles" menu. 
    Actually you only have to create the profile in the PD (profile designer) and save it. 
     
    In the SBrick App:
    - How do I assign a Profile to an Sbrick?
    (...or do I assign Sbricks to a profile?)
    - What is a "Creation"? (MOC?, Profile? )
    ​- On the Creation tab, it can show multiple profiles, but it doesn't show any Sbricks...Does that mean that I've missed a step?
    - Also, Sbricks and Creations are on different tabs in the application: does this mean they alternative approaches to doing the same thing?​
    - can you assign a "Creation" to an Sbrick?  or Sbricks to a creation?
    - The Creations have "Channel" selections; are these mapped to a Profile or an Sbrick?  (Or something else?)
    - Creations have media files, just like Profiles: Is there a layout Editor for the Creations?  What are these media files used for?
    - When I assign a second Profile to a Creation, only the first profile is displayed when I run the Creation;  am I missing a step?
    - When configuring a Creation, it requires tests with a connected Sbrick; will the Creation only work with that specific Sbrick in the future?
    - Is it intended that you build a new "Creation" for each MOC you make in order to use a given "Profile"?
     
    The method is the next. You add a creation with the "+" sign. You set the name of the creation and a description if you want to. It is not necessary. Just basic information for yourself. 
    Media is for upload a picture to make more beatiful the interface. You can set a downloaded picture or you can take a photo.

    Then you add a profile. There will be public profiles and your profiles you created in the profile designer previously. You have to download the one you want, and set. 
    You will see that the application set the profile you chosen. There will be an "x" and a star and a gear. With the X you can delete it, the star doesen't matter actually, and the gear is what more important. 
    With the help of this, you can add the SBricks port to the buttons/sliders, so to the functions. Here you will find the names of the "Channels" you set in the profile designer. 

    You need to check on your SBrick which motor is refered to which port. If you set a servo motor, to the A port, here you need to set it. And you set all the ports to the functions. Than you go back and just click on thepicture of the profile, and you can enjoy it. :)
     
     
    ​Using both Profile Designer and Sbrick App:
    - Is there an app to create or edit profiles locally, on my phone or tablet so that you only set up the controls in one app?
    - Are there any "How to" videos that walk you through the process - showing how it is supposed to work?
     
    We haven't got an application to edit or create it on your device, the profile designer is only available on PC-s. 
    Soon we will release our tutorial videos for the PD, maybe it will be easier. But it takes us some time to finish them. 
     
    I hope i could helped to you, if you have further questions feel free to ask. 
     
    Best wishes, 
    Balint Mezei
    SBrick Team