Forums » Support

Back To Topics

SBrick Android App

  • May 5, 2016 11:42 PM CEST

    When there is finally an update which then might also works with my equipment?

    The latest version V 2.0.2 is indeed already 8 weeks old!

    • 310 posts
    May 5, 2016 11:54 AM CEST

    [blockquote]Ogel Freak said:

    [blockquote]Balint Mezei said:

    [blockquote]Ogel Freak said:

    Got 2 Sbricks today and tested with 2 Android devices (both on 5.1.1)

    - Nexus 4 -> Doesn't work. App says it's connected but nothing happens when I turn a slider or something.

    - Nvidia Shield K1 -> Works without any problems. Don't even have to pair the SBrick ;-)

    [/blockquote]

    Hi,

    Which firmware version do you have? The newest is 4.8. If you have an older version you have to update it. 

    After updating you have to restart your phone. Everytime you update you should restart it. 
    If it doesen't work, please download the SBrick simple control application, (It is available on google play), and try the brick with that. 
     
    If you tried all of these, and nothing could solved the problem, please write us again. 

    Regards, 

    Balint Mezei - SBrick Team 

    [/blockquote]

    Hi,

    Thanks for your feedback. Installed the newest firmware.

    The Nexus 4 now works with the 'Simple control' app but not with the normal SBrick app.

    Regards, Frank

    [/blockquote]


    Hello Frank! 

    We are continuously working on solving this issue. 

    Soon it will be fixed. 

    We ask for some patience. 

    Regards, 

    Balint Mezei - SBrick Team 


    This post was edited by Balint Mezei at May 5, 2016 11:55 AM CEST
    • 2 posts
    April 26, 2016 5:12 PM CEST

    [blockquote]Balint Mezei said:

    [blockquote]Ogel Freak said:

    Got 2 Sbricks today and tested with 2 Android devices (both on 5.1.1)

    - Nexus 4 -> Doesn't work. App says it's connected but nothing happens when I turn a slider or something.

    - Nvidia Shield K1 -> Works without any problems. Don't even have to pair the SBrick ;-)

    [/blockquote]

    Hi,

    Which firmware version do you have? The newest is 4.8. If you have an older version you have to update it. 

    After updating you have to restart your phone. Everytime you update you should restart it. 
    If it doesen't work, please download the SBrick simple control application, (It is available on google play), and try the brick with that. 
     
    If you tried all of these, and nothing could solved the problem, please write us again. 

    Regards, 

    Balint Mezei - SBrick Team 

    [/blockquote]

    Hi,

    Thanks for your feedback. Installed the newest firmware.

    The Nexus 4 now works with the 'Simple control' app but not with the normal SBrick app.

    Regards, Frank

    • 310 posts
    April 23, 2016 1:27 PM CEST

    [blockquote]Stephan Froden said:

    -= Lynx =- - thanks for the tip.  I played around a bit more and found the following:

    • Let's say you want to "move" something on the phone screen, and this might take 1 second to complete.
    • Then let's say that you want to "swipe" something, and this might take 0.5 seconds.
    • Then let's say that you want to "flick" something, and this might take 0.1 seconds.
    • Well, to get past the tutorial screens, I had to "flick" each screen very fast.  Much faster than a "swipe", and even faster than a "flick".

    @ Balint Mezei - I am using a HTC One running Android 5.0.2

    Now... I am in the App proper, but all of my profiles and creations from before I upgraded have disappeared.  Is this normal?  Each time I update the App, do I have to set-up everything all over again?  What is the incentive to update if I'm going to lose all my configurations each time?

    I understand the SBrick and App have some advantages over the Lego PF IR controls (when they work), but the Lego PF IR controls have one huge advantage: THEY WORK!  You insert the batteries into your creation and remotes, turn them on, and they work.  I don't want to have to play around with dodgy Apps each time I want to control my creations, and so far the SBrick and App have been much too unreliable.

    I have now lost interest in the SBrick once again.  Maybe I'll try again in another year.

    [/blockquote]


    Hello! 

    Thank you for sharing this information with us. 

    We are working on the new application continuously.

    With it you won't need to set all the things from the start. 

    Best wishes, 

    Balint Mezei - SBick Team 

    • 6 posts
    April 21, 2016 9:43 PM CEST

    -= Lynx =- - thanks for the tip.  I played around a bit more and found the following:

    • Let's say you want to "move" something on the phone screen, and this might take 1 second to complete.
    • Then let's say that you want to "swipe" something, and this might take 0.5 seconds.
    • Then let's say that you want to "flick" something, and this might take 0.1 seconds.
    • Well, to get past the tutorial screens, I had to "flick" each screen very fast.  Much faster than a "swipe", and even faster than a "flick".

    @ Balint Mezei - I am using a HTC One running Android 5.0.2

    Now... I am in the App proper, but all of my profiles and creations from before I upgraded have disappeared.  Is this normal?  Each time I update the App, do I have to set-up everything all over again?  What is the incentive to update if I'm going to lose all my configurations each time?

    I understand the SBrick and App have some advantages over the Lego PF IR controls (when they work), but the Lego PF IR controls have one huge advantage: THEY WORK!  You insert the batteries into your creation and remotes, turn them on, and they work.  I don't want to have to play around with dodgy Apps each time I want to control my creations, and so far the SBrick and App have been much too unreliable.

    I have now lost interest in the SBrick once again.  Maybe I'll try again in another year.


    This post was edited by Stephan Froden at April 21, 2016 9:46 PM CEST
    • 310 posts
    April 19, 2016 12:15 PM CEST

    [blockquote]Bram Verbout said:

    Hi guys,

    I designed a profile for the Lucio Crashtender, just like he made in his instructions. My S-Brick app on my telephone (Sony Xperia Z1) says I have to choose a 16:9, so I did. So I made a profile, just like Lucio described. When I use the app, I can choose public profiles but not my own designed profile. It doesn't appear in my profile list. I already made another one like the first one but i still cannot see it on the telephone. I saved my work at the https://designer.sbrick.com/ so I can see the 2 profiles any time when I log in on to the site. 

    The S-Brick is working because when I choose for example the "Hand drawn driving controls v3.2, the light button is working and some of the lights on the crashtender are working. 

    So I'm wondering what I do wrong, the S-Brick is actived, the phone-app is working and updated.

    Can you help me?

     

    Regards,

    TallBoyBram 

    [/blockquote]


    Hello! 

    How many account do you have? 

    We think that the problem could be that you use another account in your application and in the Profile Designer (at the same time in this site.)

    Please check this, if we were wrong, please write us at info@sbrick.com 

    Best wishes, 

    Balint Mezei - SBrick Team 


    • 2 posts
    April 18, 2016 6:05 PM CEST

    Hi guys,

    I designed a profile for the Lucio Crashtender, just like he made in his instructions. My S-Brick app on my telephone (Sony Xperia Z1) says I have to choose a 16:9, so I did. So I made a profile, just like Lucio described. When I use the app, I can choose public profiles but not my own designed profile. It doesn't appear in my profile list. I already made another one like the first one but i still cannot see it on the telephone. I saved my work at the https://designer.sbrick.com/ so I can see the 2 profiles any time when I log in on to the site. 

    The S-Brick is working because when I choose for example the "Hand drawn driving controls v3.2, the light button is working and some of the lights on the crashtender are working. 

    So I'm wondering what I do wrong, the S-Brick is actived, the phone-app is working and updated.

    Can you help me?

     

    Regards,

    TallBoyBram 

    • 310 posts
    April 12, 2016 2:20 PM CEST

    [blockquote]Stephan Froden said:

    I got 2 SBricks as part of the KickStarter campaign.  At the time, the Android app was crap, so I basically put them aside and haven't used the SBricks since (feeling that they were a waste of money until a usable app was available).

    I recently decided to try and give the SBrick another go.  I downloaded the lastest version from the Google App Store.  When it loads it now shows a screen that says "Thank you for downloading SBrick.  Now you will see a short tutorial about how to use the application.  Swipe left".

    In theory, this sounds great, because the old app was not very intuitive, so some sort of tutorial is welcome.

    However, the App won't let me swipe left as directed.  It won't let me swipe in any direction.  I just see that same into to the tutorial screen the entire time.

    So, from my point-of-view, the app is still crap.  How am I supposed to use the app if I can't get past the tutorial?

    Sorry if this has been covered before... I haven't read through the entire 43 pages in this topic yet.

    [/blockquote]

     

    Hi, 

    What kind of device do you use? I forward this issue to our developers. :) 

    Soon we will post some tutorial videos, it may help. :) 

    Regards, 

    Balint Mezei - SBrick Team 


    This post was edited by Balint Mezei at April 12, 2016 2:20 PM CEST
    • 310 posts
    April 12, 2016 2:14 PM CEST

    [blockquote]-= Lynx =- said:

    [blockquote]Stephan Froden said:

    I got 2 SBricks as part of the KickStarter campaign.  At the time, the Android app was crap, so I basically put them aside and haven't used the SBricks since (feeling that they were a waste of money until a usable app was available).

    I recently decided to try and give the SBrick another go.  I downloaded the lastest version from the Google App Store.  When it loads it now shows a screen that says "Thank you for downloading SBrick.  Now you will see a short tutorial about how to use the application.  Swipe left".

    In theory, this sounds great, because the old app was not very intuitive, so some sort of tutorial is welcome.

    However, the App won't let me swipe left as directed.  It won't let me swipe in any direction.  I just see that same into to the tutorial screen the entire time.

    So, from my point-of-view, the app is still crap.  How am I supposed to use the app if I can't get past the tutorial?

    Sorry if this has been covered before... I haven't read through the entire 43 pages in this topic yet.

    [/blockquote]

     

    Haha. Just tried that too. Yes, for some reason swiping in tutorial works awful. I got it working by swiping from center of screen, 1 in 5 swipes actually changes page.

    Try that, because app (if it works for you) is really great now. For my purposes, it covers all functionality I need.

    If swiping works, don't forget to uncheck checkbox at the end, to skip this "fun" next time. Hope this helps.

    [/blockquote]

     

    Thank you for the information! :) 

  • April 12, 2016 11:24 AM CEST

    The app is still big crap. Meanwhile there are on Kickstarter similar projek I support now.

    This looks a lot better and then end my two SBricks in the trash.

    • 16 posts
    April 12, 2016 9:11 AM CEST

    [blockquote]Stephan Froden said:

    I got 2 SBricks as part of the KickStarter campaign.  At the time, the Android app was crap, so I basically put them aside and haven't used the SBricks since (feeling that they were a waste of money until a usable app was available).

    I recently decided to try and give the SBrick another go.  I downloaded the lastest version from the Google App Store.  When it loads it now shows a screen that says "Thank you for downloading SBrick.  Now you will see a short tutorial about how to use the application.  Swipe left".

    In theory, this sounds great, because the old app was not very intuitive, so some sort of tutorial is welcome.

    However, the App won't let me swipe left as directed.  It won't let me swipe in any direction.  I just see that same into to the tutorial screen the entire time.

    So, from my point-of-view, the app is still crap.  How am I supposed to use the app if I can't get past the tutorial?

    Sorry if this has been covered before... I haven't read through the entire 43 pages in this topic yet.

    [/blockquote]

     

    Haha. Just tried that too. Yes, for some reason swiping in tutorial works awful. I got it working by swiping from center of screen, 1 in 5 swipes actually changes page.

    Try that, because app (if it works for you) is really great now. For my purposes, it covers all functionality I need.

    If swiping works, don't forget to uncheck checkbox at the end, to skip this "fun" next time. Hope this helps.

    • 6 posts
    April 12, 2016 7:00 AM CEST

    I got 2 SBricks as part of the KickStarter campaign.  At the time, the Android app was crap, so I basically put them aside and haven't used the SBricks since (feeling that they were a waste of money until a usable app was available).

    I recently decided to try and give the SBrick another go.  I downloaded the lastest version from the Google App Store.  When it loads it now shows a screen that says "Thank you for downloading SBrick.  Now you will see a short tutorial about how to use the application.  Swipe left".

    In theory, this sounds great, because the old app was not very intuitive, so some sort of tutorial is welcome.

    However, the App won't let me swipe left as directed.  It won't let me swipe in any direction.  I just see that same into to the tutorial screen the entire time.

    So, from my point-of-view, the app is still crap.  How am I supposed to use the app if I can't get past the tutorial?

    Sorry if this has been covered before... I haven't read through the entire 43 pages in this topic yet.

  • April 9, 2016 8:18 PM CEST

    After the first contact of a slider !!! Whether on Galaxy S4 or Livetab.

    Screenshot from my S4

    Photo from Livetab

    Simple Control is working properly on both Devices.

    • 310 posts
    April 8, 2016 3:09 PM CEST

    [blockquote]Karl Fensterstock said:

    When will finally have a working version for the Samsung Galaxy S4 GT-I9515 and

    LIFETAB S8312 published?

    Any other Bluetooth application works with these devices properly.

    [/blockquote]

     

    Hello Karl, 

    Have you tried the simple control application? (You can download it from Google play) 
    What is your exact problem with the 2.0.2 version? Did your device find the Sbrick or where does it stuck? 

    In the next week we will test a new driver, that hopefully solve this problem. But till the new update there is 2-3 weeks, so we should ask for some patience. 

    Fortunately, on most of the devices it works, we are sorry that on your device it doesen't. We do our best to fix this isuse as soon as possible. 

    Thanks for your patience, 

    Regards, 

    Balint Mezei - SBrick Team 

  • April 7, 2016 6:27 PM CEST

    When will finally have a working version for the Samsung Galaxy S4 GT-I9515 and

    LIFETAB S8312 published?

    Any other Bluetooth application works with these devices properly.


    This post was edited by Karl Fensterstock at April 7, 2016 6:29 PM CEST
    • 310 posts
    April 6, 2016 6:36 PM CEST

    [blockquote]Ogel Freak said:

    Got 2 Sbricks today and tested with 2 Android devices (both on 5.1.1)

    - Nexus 4 -> Doesn't work. App says it's connected but nothing happens when I turn a slider or something.

    - Nvidia Shield K1 -> Works without any problems. Don't even have to pair the SBrick ;-)

    [/blockquote]

    Hi,

    Which firmware version do you have? The newest is 4.8. If you have an older version you have to update it. 

    After updating you have to restart your phone. Everytime you update you should restart it. 
    If it doesen't work, please download the SBrick simple control application, (It is available on google play), and try the brick with that. 
     
    If you tried all of these, and nothing could solved the problem, please write us again. 

    Regards, 

    Balint Mezei - SBrick Team 
    • 2 posts
    April 4, 2016 4:35 PM CEST

    Got 2 Sbricks today and tested with 2 Android devices (both on 5.1.1)

    - Nexus 4 -> Doesn't work. App says it's connected but nothing happens when I turn a slider or something.

    - Nvidia Shield K1 -> Works without any problems. Don't even have to pair the SBrick ;-)


    This post was edited by Ogel Freak at April 4, 2016 4:35 PM CEST
  • March 29, 2016 4:21 PM CEST

    [blockquote]Marc Jaouen said:

    [blockquote]Muhamad Khairi Safari said:

    my prob is the app cant see th sbrick at all only the simple controller app works to update the firmware other than that its not working..

    [/blockquote]

     

    Did you try to pair the SBrick first?

    - Reset all bluettoth services, apss, etc...

    - Deactivate and reactivate the Bluetooth

    - Check if the phone sees the SBrick and pair it

    - Go in the app and check if it sees the SBrick

    [/blockquote]

     

    I tried all that also the phone would pair with the sbrick but disconnects immediately.

     

     

    • 99 posts
    March 28, 2016 2:57 PM CEST

    [blockquote]Muhamad Khairi Safari said:

    my prob is the app cant see th sbrick at all only the simple controller app works to update the firmware other than that its not working..

    [/blockquote]

     

    Did you try to pair the SBrick first?

    - Reset all bluettoth services, apss, etc...

    - Deactivate and reactivate the Bluetooth

    - Check if the phone sees the SBrick and pair it

    - Go in the app and check if it sees the SBrick

  • March 28, 2016 10:31 AM CEST

    [blockquote]Marc Jaouen said:

    [blockquote]Muhamad Khairi Safari said:

    apparently i tried on my buddy's xiaomi phone on android 4.4 and it works perfectly.. so i suspect its the app 

    [/blockquote]

    I have observed similar situations after receiving my new Sbrick (replacing the older faulty one).

    - I have a Sony Xperia (Lollipop) and an older Galaxy Note (Kit-Kat)

    - Both could see the SBrick, but the Sony couldn't connect nor update the firmware

    - I managed to update the firmware with the Simple Controller App on the Galaxy Note

    - I had to pair the SBrick on the the Xperia before it could work with app v2.0

    - Everything went fine after that, I can even connect to both SBrick at the same time or one by one (the app v2 is great for that)

    All in all, it works perfecly, only the firmware update was a bit difficult (yet possible).

    [/blockquote]

     

    my prob is the app cant see th sbrick at all only the simple controller app works to update the firmware other than that its not working..

     

    • 99 posts
    March 27, 2016 10:43 AM CEST

    [blockquote]Muhamad Khairi Safari said:

    apparently i tried on my buddy's xiaomi phone on android 4.4 and it works perfectly.. so i suspect its the app 

    [/blockquote]

    I have observed similar situations after receiving my new Sbrick (replacing the older faulty one).

    - I have a Sony Xperia (Lollipop) and an older Galaxy Note (Kit-Kat)

    - Both could see the SBrick, but the Sony couldn't connect nor update the firmware

    - I managed to update the firmware with the Simple Controller App on the Galaxy Note

    - I had to pair the SBrick on the the Xperia before it could work with app v2.0

    - Everything went fine after that, I can even connect to both SBrick at the same time or one by one (the app v2 is great for that)

    All in all, it works perfecly, only the firmware update was a bit difficult (yet possible).

    • 310 posts
    March 25, 2016 1:24 PM CET

    [blockquote]Muhamad Khairi Safari said:

    apparently i tried on my buddy's xiaomi phone on android 4.4 and it works perfectly.. so i suspect its the app 

    [/blockquote]

     

    Hi, 

    We check out what could be wrong.
    On most of the android phones the application works fine, but there are some device on which for some reason it doesen't.
    We are working on solving this problem. 

    We should ask for your patience, 

    Regards, 

    Balint Mezei - SBrick Team 

  • March 24, 2016 2:13 AM CET

    apparently i tried on my buddy's xiaomi phone on android 4.4 and it works perfectly.. so i suspect its the app 

  • March 24, 2016 1:56 AM CET

    i just got my sbrink even after upgrading the firmare on the sbrick to 4.8 i still cant connect to it using the Sbrick App v2.0 Update 2..

     

    My phone is LG G4 android 6.0

    • 310 posts
    March 20, 2016 8:15 PM CET

    [blockquote]bricker bricker 72 said:

    [blockquote]Balint Mezei said:

    [blockquote]bricker bricker 72 said:

    [blockquote]Balint Mezei said:

    [blockquote]bricker bricker 72 said:

    Yesterday I updated my SBrick app and now it does not function good anymore!!!!

    App version v2.0.2

    Firmware version 8

    Hardware version 4

    Android 5.1.1

    Samsung neo 5

    Sometimes I have to start a profile I few times before the SBrick responds although it is connected! And then it works but when I want to use a profile white more than 1 SBrick only 1 works and I can see that it is connected with the other ones  but they do not respond.

    When I test the bricks they work perfectly, but when I open a profile then I get the problem as mentioned.

    My conclusion is there is nothing wrong with my phone or SBricks  but there is something wrong within the app.

    What to do to solve the problem?????????

    I already tried a lot to solve it, I tried all the suggestions mentioned here on this forum but they do not work!

    I hope to hear from you soon,

     

    with regards,

     

    Bricker Bricker 72

    [/blockquote]

     

    Hello, 

    I forwarded this problem to our developers. They try to fix it as soon as possible. 

    Thank you for the report. 

    Regards, 

    Balint Mezei - SBrick Team 

    [/blockquote]

     

    thanks for your reply but how do I find out when my problem is solved? and what I need to do to solve it.

     

    Kind regards,

     

    Bricker Bricker 72

    [/blockquote]

     

    Hello, 

    Others have also experienced this problem. Our developers check out what could be wrong. 
    In the next version it will be fixed. Your phone will offer you the update, you will see immediately. (Thorugh Google Play) 

    May i ask you, what kind of phone do you have? 

    Regards, 

    Balint Mezei - SBrick Team 

    [/blockquote]

     

    samsung galaxy S5 Neo, and do I have to remove the app and than download it again or wil it go automaticly within the app?

     

    kind regards,

     

    bricker Bricker 72

    [/blockquote]

     

    It will go automaticly. :) 

    Thank you for the information. :) 

    Regards, 

    Balint Mezei - SBrick Team