Forums » Support

Back To Topics

SBrick Android App

    • 2 posts
    March 8, 2016 5:21 PM CET

    [blockquote]Balint Mezei said:

    [blockquote]Ricky Mak said:

    Hi SBricks Supports,

    I used SBrick app to update the firmware of my SBrick. The app indicated the updated was completed. However, the SBrick does not response to the app anymore. The LED on Sbrick lights up all the time once the power is on. None of the port is responding nor the LED can be turned off again. I can see the correct firmware version from the app after firmware updated. I tried to update the firmware again but the app refuses by saying that the firmware it the latest.

    So what can I do to recover my Sbrick? Please help.

    Thank you.

    Ricky.

    [/blockquote]

     

    Hi, 

    Did you restart your phone after the update? 
    Whenever you update a new firmware version you have to restart your device. 

    [/blockquote]

    I tried restarting my phone/sbricks. I also tried to reinstall the app. But these do not help.

    I am pretty sure this is the problem of Sbrick. I have other Sbricks which use the original firmware works with my phone very well.

    My andriod phone is Samsung Note Edge andriod 4.4. The App ver is 2.0.1.

    Is there any way to force updating the firmware of Sbrick again?

     

    Thank you.

    Ricky.

    • 310 posts
    March 6, 2016 9:41 PM CET

    [blockquote]Christoph Pfenninger said:

    Hi Sbrick team

    Today simple controll was updated by the Play Store.
    Now i could finally update to the firmware 4.8 with simple control since a long time.

    Thank you guys.

    All my creations will work now as they should be.

    I have a Sony Z1 Compact with android 5.1.1. The sbrick app V2.0 update 1 will will work neu without any crashes.

    [/blockquote]

    Hi,

    Good to hear that you're satisfied with SBrick. :) 

    Thank you for the feedback. :) 

    Balint Mezei - SBrick Team 

  • March 6, 2016 9:15 PM CET

    Hi Sbrick team

    Today simple controll was updated by the Play Store.
    Now i could finally update to the firmware 4.8 with simple control since a long time.

    Thank you guys.

    All my creations will work now as they should be.

    I have a Sony Z1 Compact with android 5.1.1. The sbrick app V2.0 update 1 will will work neu without any crashes.

    • 310 posts
    March 6, 2016 12:59 PM CET

    [blockquote]Ricky Mak said:

    Hi SBricks Supports,

    I used SBrick app to update the firmware of my SBrick. The app indicated the updated was completed. However, the SBrick does not response to the app anymore. The LED on Sbrick lights up all the time once the power is on. None of the port is responding nor the LED can be turned off again. I can see the correct firmware version from the app after firmware updated. I tried to update the firmware again but the app refuses by saying that the firmware it the latest.

    So what can I do to recover my Sbrick? Please help.

    Thank you.

    Ricky.

    [/blockquote]

     

    Hi, 

    Did you restart your phone after the update? 
    Whenever you update a new firmware version you have to restart your device. 


    This post was edited by Balint Mezei at March 6, 2016 1:02 PM CET
    • 2 posts
    March 6, 2016 6:47 AM CET

    Hi SBricks Supports,

    I used SBrick app to update the firmware of my SBrick. The app indicated the updated was completed. However, the SBrick does not response to the app anymore. The LED on Sbrick lights up all the time once the power is on. None of the port is responding nor the LED can be turned off again. I can see the correct firmware version from the app after firmware updated. I tried to update the firmware again but the app refuses by saying that the firmware it the latest.

    So what can I do to recover my Sbrick? Please help.

    Thank you.

     

    Ricky.

    • 310 posts
    March 5, 2016 6:10 PM CET

    [blockquote]Ewen Robertson said:

    Hi What is going on with the Android App, I canot connect to s bricks, at all even with the basic app.  they work perfectly on IOS.  The App seams slow and will sometimes show the sbrick but do nothing, message is "please turn sbrick on".  I hadn't used it for a few weeks and previously the app was working great.  Phone is HTC M9, thanks

    [/blockquote]

     

    Hello,

    Firstly, we can advise you to check the SBrick-s firmware version. The newest is 4.8.
    If the problem was the version, after the update, please restart your phone. 

    If you still have the problem please send us a message on info@sbrick.com

    Best regards,
    Balint Mezei - SBrick Team 


    • 5 posts
    March 5, 2016 10:58 AM CET

    Hi What is going on with the Android App, I canot connect to s bricks, at all even with the basic app.  they work perfectly on IOS.  The App seams slow and will sometimes show the sbrick but do nothing, message is "please turn sbrick on".  I hadn't used it for a few weeks and previously the app was working great.  Phone is HTC M9, thanks

    • 95 posts
    March 3, 2016 10:30 PM CET

    [blockquote]Tamas Misik said:

    Hi Frederic,

    Based on our tests they will work perfectly in the new version :)

    [/blockquote]

     

    Thank you.

     

    • 164 posts
    March 3, 2016 12:01 PM CET

    Hi Frederic,

    Based on our tests they will work perfectly in the new version :)

    • 95 posts
    March 3, 2016 11:02 AM CET

    [blockquote]Balint Mezei said:

    Hello!

    We absolutely understand your concern. We do our best. We testing the appliaction these days, it is nearly finished.

    In the new version, 

    ¤ We redesigned port assignments,
    ¤ The main screen has changed (there will be two types of view),
    ¤ We improved the SEQ function,
    ¤ There will be a big step with the control and chanel panels (Soon you will see what does it mean, we're sure you will like it.)
    ¤ Clinometer has been developed,
    ¤ We fixed some bugs about output values, and zero/start points,
    ¤ and a lot of other issues has been fixed.

    Tests are very promising, but we ask you to be patient, just for a couple of days. 
    In 24 hours we're going to share some other information with you. 

    Balint Mezei - SBrick Team 

    [/blockquote]

     

    Thank you for this answer.

    What about the auto reset and output value for buttons?

     

    • 310 posts
    March 3, 2016 3:39 AM CET

    Hello!

    We absolutely understand your concern. We do our best. We testing the appliaction these days, it is nearly finished.

    In the new version, 

    ¤ We redesigned port assignments,
    ¤ The main screen has changed (there will be two types of view),
    ¤ We improved the SEQ function,
    ¤ There will be a big step with the control and chanel panels (Soon you will see what does it mean, we're sure you will like it.)
    ¤ Clinometer has been developed,
    ¤ We fixed some bugs about output values, and zero/start points,
    ¤ and a lot of other issues has been fixed.

    Tests are very promising, but we ask you to be patient, just for a couple of days. 
    In 24 hours we're going to share some other information with you. 

    Balint Mezei - SBrick Team 

    • 12 posts
    March 2, 2016 10:42 PM CET

    It's a Very Good idea. Maybe only android-app make as open-source (also as android os)?

    We see for last several moths that sbrick team does not cope, does not time to release an android app. Especially an another app was released from other developers.

    • 16 posts
    March 2, 2016 9:28 PM CET

    May be it is better to release app as open-source, somewhere on GitHub or similar, where SBrick team will be prime maintainer, and will make Google Play releases?

    Of cource app itself will not work without Profile Designer API access and server(s), and SBrick firmware is still in hands of developers. But I am sure there are a lot of people among SBrick owners who will contribute to app development, especially in case of fixing small bugs.

    • 95 posts
    March 2, 2016 8:46 PM CET

    I really starting to lose patience


    Where is the new version promised for early last week!

     

    When are you going to provide a roadmap?

     

    • 99 posts
    March 1, 2016 8:36 PM CET

    [blockquote]Stephen Wilson said:

    I've been hoping to use the sbrick during an up and coming Brickworld event, but I can't re-asign the channels to control functions.

    I have a very limited space to locate the sbrick and I need to change the assingments from what is provided on the "Yellow Car Profile", this profile is exactly what I need, but I have to change the channel funtions.

    No matter what I do , the channel selections don't change. Any help here?

    [/blockquote]

    Hi Stephen, you should post in the Profile Designer section. Anyway : if you start from a standard profile, make a copy of it first (I think it's possible now), and this copy should be customisable. The best approach in my opinion is to create directly your own profile.

    • 7 posts
    March 1, 2016 4:47 PM CET

    I've been hoping to use the sbrick during an up and coming Brickworld event, but I can't re-asign the channels to control functions.

    I have a very limited space to locate the sbrick and I need to change the assingments from what is provided on the "Yellow Car Profile", this profile is exactly what I need, but I have to change the channel funtions.

    No matter what I do , the channel selections don't change. Any help here?

    • 16 posts
    February 29, 2016 11:16 AM CET

    [/blockquote]

    Hi,

    The new version will be available early next week.
    A lot of issue have been fixed, for example the sony z1 compact connenction error and so on.
    More information coming soon.
    Thank you for your patience!

    [/blockquote]

    So?

    Slowpoke

    • 95 posts
    February 24, 2016 8:27 PM CET

    [blockquote]Balint Mezei said:


    Hi,

    The new version will be available early next week.
    A lot of issue have been fixed, for example the sony z1 compact connenction error and so on.
    More information coming soon.
    Thank you for your patience!

    [/blockquote]

    Still no news! 1 year, 2 monthes and counting...

     

    • 41 posts
    February 23, 2016 12:26 AM CET

    If anyone have a Bluetooth controller you should definitely be using the SbrickController instead of the official sbrick app.

    I'm using with the Moga Pro Controller and the SbrickController 0.5 version and works perfect.....even this app have less lag/delay, and the feeling to control a Car (Buggy, Crawler, supercar) is better with a stick.

     

    Thanks to the SbrickController app now i considering to buy another sbrick to play with my son ( i have another Moga Pro controller)

     

    • 4 posts
    February 19, 2016 6:02 PM CET

    I retire that I have told, I have retry to play with the sbrick and everytginh doesn't work. I can only move a motor during 1sec and after nothing. Need to restart the brick.

    I have belived that android app has made progresse but not !

    • 164 posts
    February 19, 2016 2:25 PM CET

    Dear Jurgen,

    Thanks for your feedback about the new port settings menu. This isn't the final version yet. This part will be imporved in the future. Don't worry, the "port tester" will be available again. The port assignment will be really simple and fast. ;)

    About your 2nd and 3rd point: We didn't get any similar feedbacks from other users. Can you tell us more details about this: "The profile market has lots of trouble fetching the profiles."
    Our developers will look after what can be the problem.

    The iOS and the Windows version will be the same like the Android app soon. The new app can be unusual for first try, but it is more ergonomic, easier to use and it has much more potential than the old version. 

    If you have any other suggetstions about our new app, feel free to contact us. Your feedbacks are really useful for us. 

    • 4 posts
    February 19, 2016 12:38 PM CET

    I have made some test after month of non use, using the new app on my nexus 4.

     

    And, all functions works ! Connecting to the sbrick, led tester, port tester, profile and motor. 

     

    A little bit more latency with the wifi on, but I assume that this is due to my phone wich priorise the wifi traffic instead of bluettooth. With wifi off, everything work. After 1 year, it is not too late !

     

    I prefere the new version regarding the ergonomy.

     

    So good guy.

    • 1 posts
    February 19, 2016 10:17 AM CET

    N.B. This isn't a complaint as such, but a heads up for anyone else experiencing similar issues.

    My SBrick would only respond to LED checks, even port checking wouldn't work. Hardware was 4.0, firmware 4.2b2 (that shows you how long it's been since I used it last!), so I tried an update. But no matter what I did - un/reinstalling SBrick/SBrick Simple, clearing data/cache, rolling back apps, troubleshooting with the nRF Control app, the updae stopped at ~5%. However, after pairing the SBrick with my phone directly it updated first time (Sbrick app 2.0.1) and on firmware 4.8 there is no need to pair first.

    HTC One M7, Android 5.0.2 if anyone is interested.

    As for the app, Jurgen has said it for me. Assigning ports is a particular frustration.

    • 23 posts
    February 18, 2016 11:11 PM CET

    Got back to my SBricks after a couple of months. And I see the app has completely changed, and I'm sorry but I really don't like the new App:

    1. Assigning the ports to the functions has become very difficult. In the iOS version you can tap the SBrick-picture, the motor will run briefly and you can easily assing the correct funvtion to the port directly. Now, you have to 1. SBricks -> Select 1 of the SWBricks -> 3. Select Port Tester -> 4. test one port -> 5. go back to MOC's -> 6. go to Settings -> 7. Select profile settings again -> 8. and then you can assign a port to a function.

    As you see, something which took 2 ticks, now takes 8 !! Imaging you have a model with 2 SBricks and 8 functions ...

    2. The profile market has lots of trouble fetching the profiles.

    3. When trying to open the Excavator-profile, the app shows a black screen once it has connected to the Sbricks.

    4. The App can show only 1 1/2 moc on 1 screen, previously you could see more than 4 Mocs at once.

    Guys, this is very frustrating. Last October during Lego World the system finally worked almost perfectly, and now there are lots of bugs .... again. 

    My bricks are up to date, using Sony Z3 Compact Android 5.1.1

    Please Please Please don't change the iOS-app into this new version.

    • 95 posts
    February 17, 2016 8:48 PM CET

    [blockquote]Tamas Misik said:

    The 2.0.1. the latest version. We sent the e-mail to those people who don't know our latest app yet.
    The new app will available soon. Thanks for your patience.

    [/blockquote]

    Sorry for my misunderstanding. I read " - new featuers".

    I though I will finally be able to use the auto reset and output values for buttons ;-(

     

     


    This post was edited by Frederic Ayrault at February 17, 2016 8:48 PM CET