Forums » Support

Back To Topics

SBrick Android App

    • 25 posts
    February 20, 2015 9:07 AM CET

    Gabor: When we bought/pledged sbricks, it was not question of having to also buy an IOS device!!! So no, this is not acceptable. 2 monthes do still be in alpha version is not acceptable. Simple function like switching on then off a light does not works!!! I can't let you say that we, android users, should shut up and accept that!!!

    • 7 posts
    February 19, 2015 7:14 PM CET

    @Tamás Fábián

    Thanks. Now it works if I was logged in.


    This post was edited by Tanja Causemann at February 19, 2015 7:19 PM CET
    • 19 posts
    February 19, 2015 6:09 PM CET

    hey guys, don't be a jerk, android app is still alpha! it's no secret that vengit developed SBrick for iOS and Android is secondary. just look at all the videos they published since day 1 @ kickstarter. please borrow an older iPhone or iPad if you can not wait for Android app to go beta/final.


    This post was edited by Gábor Polczer at February 19, 2015 6:10 PM CET
  • February 19, 2015 5:59 PM CET

    [blockquote]Peter Quick said:

    ... I'm starting to think I want my money back.  The hardware is cool, but the app sucks....  Let's just make the basic stuff work correctly.

    [/blockquote]

    Also I think already about it.

     

    • 2 posts
    February 19, 2015 12:00 AM CET

    More testing on Android App 0.0.60

    Port testing - C has been swapped with B port.  This was correct in a previous version.

    When connecting a SBrick - clicking on the port doesn't activate it, or the app just crashes....

    Try to start a profile - all I get is connecting to the SBrick, it never allows me to go into the profile to try it out.

    My profiles - this doesn't work....

    Seriously guys, I'm starting to think I want my money back.  The hardware is cool, but the app sucks....  Let's just make the basic stuff work correctly.

    I'm part of a LUG group in Colorado, so I can influence people to buy or not buy.  Right now I would tell them not to buy, because you don't properly support Android. And there is no support, just a group of really really frustrated users.  Would someone on the actual team acknowledge all the existing issues/defects....

    • 95 posts
    February 18, 2015 9:13 PM CET

    [blockquote]Sylvain CACHEUX said:

    So please keep your word: debug the existing, do NOT add new functions before existing is REALLY reliable!

    [/blockquote]

    I do agree with you but I think we need some "basic" functions we have already discuss earlier.

    For me the android app should do the same than the ios version...

  • February 18, 2015 7:27 PM CET

    Status mit LENOVO LIFETAB_S831X :

    Mit Simple Control 1.5 funktioniert folgende Testkonfiguration einwandfrei !

     

    Bis auf einen kleinen Buchstabendreher ;-)

     

    Mit 0.0.60 gibt es permanente Systemabstürtze.

     


    This post was edited by Karl Fensterstock at February 19, 2015 6:00 PM CET
    • 168 posts
    February 18, 2015 5:38 PM CET

    Thanks Tanja, I've fixed that, please try again.

    • 7 posts
    February 18, 2015 4:46 PM CET

    Hello,

    HTC One S (CyanogenMod / Android 4.4.4) bluetooth connection works with 0.0.60 but Market does not work.

    Best regards
    Tanja

    • 25 posts
    February 18, 2015 3:19 PM CET

    Here is what I pledged for:

    Pledge £280 or more
    40 backers Limited (60 left of 100)
    This is the LEGO® Trains "Diehard" fan pledge, the most effective one at the cheaper price per SBrick. :)
    Receive 8 SBricks and get control of your ultimate train layout. Remote control up to 8 trains, or 32 layout devices (track switches, semaphores, etc), or any combination that better suits your train layout specifics.
    As a bonus receive the instructions for our track switch and semaphore designs.

    Where are the "Diehard" train functions in a usable app? No slider that keeps its position when releasing, no working button to switch on lights, just to speak about only these 2 points. So hard to do a button function that works? On, Off : too complicated?

    And where is the "bonus"? But anyway, I'd rather an app that's not crashing, existing functions working, than a bonus.

    I've just received a communication by kickstarter, indicating all existing functions will be debuged and reliable at the end of this month. Big challenge. I hope I won't be disapointed again.

    So please keep your word: debug the existing, do NOT add new functions before existing is REALLY reliable!

     

    Bonus info: I've re(re-re-re...)tried the "handdrawed" profile. When steering, you can't use the other slider (but the contrary hopefully works: you can drive and then steer). Lights still not work.

  • February 17, 2015 10:31 PM CET
    Hello everybody. I can confirm that. Also happens to HTC one M8 Android 5.0.1 HTC Sense 6.0. But the app works fine for me. connects very quickly. only the joystick works only in one plane. no reaction of the engines on the second joystick axis.
    • 19 posts
    February 17, 2015 2:00 PM CET

    Little feedback for 0.0.60 on nexus 5 & 9 (Android 5.0.1):

    - No matter what I try (clear cache/app data/reinstall), still cannot control any of my SBricks with this app. Freshly downloaded profiles load and most of the time can connect to the linked SBrick, but controls do nothing. Same applies to Port tester. BTW my SBricks have FW upgraded a month ago through and iPad (led is always on now).

    - When launching app without BT turned on, the notification to allow/deny BT does not disappear after touching "Allow", a second touch is needed to get it switch BT on and dissmiss this notification. BTW "Deny" button is useless here, as it does nothing just keeping notification displayed. Closing app would be much more logical here.

    - Profile designer cannot load my custom profiles, though log-in process seems to be successful.


    This post was edited by Gábor Polczer at February 17, 2015 2:02 PM CET
    • 95 posts
    February 17, 2015 1:37 PM CET

    Last version is 0.0.60 the home page is 2 weeks old...

    I am not able to find the dropbox link for this version

     

    [blockquote]Peter Quick said:

    Guys I downloaded the Sbrick from the posted APK on the main page.

    The version from the main page is 0.0.41

    THe version on Google Play is 0.0.60

    Which is the most recent version of the Android OS App?

    Also I installed the Sbrick App on an Samsung S3 (0.0.60)

    I sideloaded 0.0.41 on my Kindle Fire HD 6"

    On both devices I have issues maintaining and keeping a connection.

    Biggest issue is that I can't see any profiles I created in the profile designer.  

    Also - please keep posting the apk so I can keep sideloading on my Kindle Fire.

    [/blockquote]

    • 2 posts
    February 17, 2015 5:14 AM CET

    Guys I downloaded the Sbrick from the posted APK on the main page.

    The version from the main page is 0.0.41

    THe version on Google Play is 0.0.60

    Which is the most recent version of the Android OS App?

    Also I installed the Sbrick App on an Samsung S3 (0.0.60)

    I sideloaded 0.0.41 on my Kindle Fire HD 6"

    On both devices I have issues maintaining and keeping a connection.

    Biggest issue is that I can't see any profiles I created in the profile designer.  

    Also - please keep posting the apk so I can keep sideloading on my Kindle Fire.

  • February 17, 2015 2:02 AM CET

     

    The Sbrick app can be a little temperamental which is not odd since it is still in alpha. Alpha versions of applications are buggy by definition, nor do all features work. They are however generally functional, as is the Sbrick android app. I have had my bad spells with it: generally figuring out in what order things should be done, episodes of it crashing, not being able to connect to the Sbrick, showing a blank screen without functions, things getting broken after an update, etc. But in all cases I was able to resolve the issue.

     

    A list of things i have tried when the Sbrick did not do what i wanted:

     

    1. Look at the instructional video and videos of other people to see if i was missing something.

    2. Make sure Bluetooth is enabled.

    3. Make sure the Sbrick is battery-pack that powers the Sbrick is turned-on.

    4. Sometimes it helps to turn bluetooth off and on again.

    5. Reboot the device (smartphone, tablet).

    6. Clear the cache of the app, clear data of the app, if these fail reinstall the app.

    7. Patience, sometimes it takes a while for the Sbrick to be discovered. It rarely happens but if all else fails, put it away for a couple of hours sometimes it will resolve itself.

     

     


    This post was edited by Franciscus van der Maat at February 17, 2015 2:26 AM CET
    • 7 posts
    February 16, 2015 8:41 PM CET

    Samsung Galaxy S5, Android 4.4.4

    App version 0.0.60

    Every time the app looks for SBricks, it adds another ID to the list, but only the ID with the name "SBrick" works, and I presume this is the physical ID of my only unit.

    App crashes if you click on buttons that launch dialogs too quickly or too often when they do not respond to the initial press.

    I have created my own profile that uses a gamepad controller and a slider. Only the slider works, no matter which ports are assigned to the SBrick.

    App crashes often during use.

    • 34 posts
    February 16, 2015 6:12 PM CET

    Thank you all of your feedback! We'll work hard this (and next) week to repair all issues reported by you.

    We'll also publish a long term roadplan both for android, iOS, and profile designer releases next week.

    • 5 posts
    February 15, 2015 3:47 PM CET

    Just tested the 0.60 version. Clearing cache does seem to help, and playing around with the hand-drawn profile I have a fairly stable operation.

    Remarks are however:

    • Sometimes it will lose connection and the app says "brick is powered off or out or range" when it isn't. Need to restart app or BT on/off to repair connection.
    • Light button does not work, only blinks once when turned "off" No respons when turned on.
    • M-motors will give humming sound in "idle" The L-motor does not have this nor the servo.
    • If I engage the steering control first, the accelerate slider becomes unresponsive if used simultanously . First using the accel, does allow using both at the same time.
    • The B and C channel are switched in the SBrick port tester
    • At maximum output, the port tester reverts to idle power which is very annoying.
    • Going through MyMOC-> Linked Bricks -> Port tester (arrow to the right) will often crash the system. Going first through "Manage bricks" and the to the port tester this error does not occur and also fixes the crash for going the other route....

    Tested on Xiaomi Mi2S Miui 6 (Android 4.4.4)

    On my Samsung SM-P600 (note 10.1) I also noticed the following aspects:

    • The new profiles were not available (can be due to aspect ration differences)
    • The joystick controls do not work at all
    • Changing profiles will plot the changed profile over the previous one, even after killing the app. First I had to delete all profile and then add a new oen to repair.
    • In the "Gamepad with buttons" profile, the steering control become unresponsive if the accel is engaged first, so opposite error as seen in the other profile.

    So clear improvements, but not there yet...

    Martijn Nab

    P.S. And as some other already mentioned, in Android on some browsers, scrolling through the forum does not work well anymore. Used to be ok...


    This post was edited by Martijn Nab at February 15, 2015 3:52 PM CET
    • 16 posts
    February 15, 2015 10:48 AM CET

    Indeed, clearing all adroid sbrick data does help. I have yet to test in more details, but at least I am able to use a profile without crashing...

  • February 15, 2015 7:16 AM CET

    I tried the sbrick simple app. The user interface is BLANK. There's nothing on it. 

    This forum is also BLANK from an android phone's browser. I think the two problem is in connection with each other. Look after javascript on the page, because it crashes the browser.  

    • 23 posts
    February 14, 2015 11:29 PM CET

    I did that, but the results were the same.

  • February 14, 2015 11:07 PM CET
    Try a Profil without any background
    • 23 posts
    February 14, 2015 10:16 PM CET

    With v0.0.60 my excavator-profile still doesn't work. Now the controll-elements are squeezed horizontally. The further the controll is to the right, the more it's moved to the right.

    And everything I touchg when the profile is opened closes the profile again.

    In the output-assignment-screen, when i press the picture of the SBrick to test the ports, the app crashes.

    I even tried the standard profile with 2 joysticks and 2 sliders: only the sliders work, the joysticks don't do a thing. And whatever settings I try, I can't get the profile to controll the 2 SBricks. I also tried removing the app completely including files and cache as Jürg suggested, but that didn't change anything.

    Using Sony Z3 Compact, android 4.4.4

    • 25 posts
    February 14, 2015 10:03 PM CET

    [blockquote]juerg siegenthaler said:

    When Androis app, it is important if you installed the 0.0.60 that you, in the settings of the operating system deletes all SBrick data. Important.
    Then uninstall the old version and install the new app.
    The app will crash the first time. Now you repeat the procedure and deletes all files which relate to the app including cache. Also important to dispense with a background in profile. it worked for me and basically runs stable.

    [/blockquote]

     

    The app should clean itself if the installer does not. Cache should be erased when an update is installed, especialy if it's known that data in cache brings problems. Users should not have to handle that, from my point of view. I know app is in alpha version (after weeks and weeks...), but at least install process should be masterised, no?

  • February 14, 2015 9:53 PM CET

    When Androis app, it is important if you installed the 0.0.60 that you, in the settings of the operating system deletes all SBrick data. Important.
    Then uninstall the old version and install the new app.
    The app will crash the first time. Now you repeat the procedure and deletes all files which relate to the app including cache. Also important to dispense with a background in profile. it worked for me and basically runs stable.