Forums » Support

Back To Topics

SBrick Android App

    • 7 posts
    March 12, 2016 7:13 PM CET

    Very sad. In this new version I have all stopped working sbrik module (firmware version 4.8). I use Android 4.4.2, Vega Explay.

    Problem: When using the menu item "Sbrick" - sbrik is, and sliders interlace - all 4 ports are working. But when I create a menu "My creation" the profile (any). No one port does not work. In addition, after using the Profile - ports do not work, and in the menu item "Sbrick". You have to disable and enable BT again. 

     

    P.s. In SBrickController apllication: work is fine !


    This post was edited by Vlad . at March 12, 2016 7:15 PM CET
    • 16 posts
    March 12, 2016 11:57 AM CET
    To assign same port to different buttons channels on those buttons should be named in the same way. Got me nervous first too.
    E.g. I jave 5 buttons that have different names and values but channel is Gearbox. Then in port assignment I assign Gearbox once to some port and all buttons manage it.
    Same for Slider and button, I have drive slider with -1 to 1 and no auto reset button for full forward. Channel on both say Drive, and both work. As a bonus button change looks from off to on in gradient as I move slider.
    • 6 posts
    March 12, 2016 9:30 AM CET

    Hello!!

     

    I am not fine this morning!!!    Since i have update yesterday the sbrick appli, it doesn't work like it work before!   I Can't having my 3 sbricks together and i can't give the same function on 2 different button....... Well, ALL IS DAB!!!!     I need to came back on the last update!!    I have a lego exposition in 1 month!   Thanks to give me quickly a way!

    • 99 posts
    March 12, 2016 2:15 AM CET

    Congratulations, guys : we can say today that you made it :)

    v2.0.2 has corrected the last flaws of the previous release and, at least for my usage, everything is OK now.

    - The push button with values assignment and auto-reset works now, I needed that to change gear easily for cars with a gear box

    - Limiting the steering span works, a mandatory feature for high-speed racers

    - Most of all, updating a profile in the app can be done in real time, the reload button is terrific! Compared to the nightmare it was one year ago, it's night and day.

    I must check now if this release works on my tablet too (v2.0.1 did not), but this app is perfect on my Xperia M4.

    It was long for sure, but it was worth waiting :)

     

    Edit: the app crashes on my tablet...


    This post was edited by Marc Jaouen at March 12, 2016 2:20 AM CET
    • 87 posts
    March 11, 2016 11:52 PM CET

    Hi!

    Updated Android app today, seems fine. But what I really enjoyed was the Simple Control last week - I finally managed to upgrade the firmware from 4.2b to 4.8 with it and that made all the difference: I have a Sony Xperia Z1 and every time I wanted to use the SBrick I spent almost 10 minutes trying to get a sucessfull session, now EVERY TIME it works immediately.

    Thanks and keep perfecting the app.

    • 16 posts
    March 11, 2016 9:40 PM CET

    Just received update, it is amazing!

    First of all, I have no more things to ask from functionality side, as of now. Waiting for that "robotics" features that were mentioned, because I don't know what else can be done, that will be a surprise.

    Love channel grouping by name, it is really needed. I did 5 buttons with different values, and assigned port/direction with 1 setting. Great!

    That button state mixing also looks cool, especially when slider and button are connected to same port. Moving slider changes looks of button, now there is much more sense to put some cool graphics for different states.

    Test port during assignment is also useful, I see it being used a lot in designs where brick is covered or placed deeper in structure.

    And general cudos for menu style, brick "naming", etc etc.

    For some reasons I have to restart app several times for all changes to take effect, but on 3rd or 4th time all was set.

     

    Great update, was worth waiting.

  • March 11, 2016 8:30 PM CET
    I have updated again, but still get nothing. I am still unable to update the sbrick using either the main app or simple app from 4.3 to 4.8. Neither app controls the sbrick either creating a profile, or connecting using the sbrick test.

    I am using Asus zenfone 2 (Z00_AD) running android 5.0
    • 95 posts
    March 11, 2016 7:35 PM CET

    [blockquote]Tamas Misik said:

    Hi Guys,

    Thanks for your patience. The new (2.0.2.) android application available on google play: https://play.google.com/store/apps/details?id=com.vengit.sbrick&hl=en

    [/blockquote]

    Today I have to congratulate Vengit Team for the new version. I have quickly test it and now I will be able to control my train, a crossing and a switch.

    For the train I use a slider (auto reset yes) and a button (auto reset yes and output 0) and it works perfectly the slider control the motor and the button stops the motor (the slider also goes to the middle position :-)

    For the crossing or swith I use to button (auto reset yes, using the same channel but with the output set to 1 for the first one and -1 for the second) and this is also working the motor turn clockwise with one button and in the opposit direction with the other.

    Edit : I just have a little problem. I have set up the slider to control 2 motors in opposit direction (I have 2 88002 on the same train base 6x28) and most of the time the motors does not start at the same time and a few time one turns but not the other :-(

    Edit2 : I made a new profile with 11 buttons all with auto reset no and output set from 0 to 1 with a .1 step the problem only occurs with .4 (mimum value to start a motor) there is no problem when using .5 and more I this this can be a motor issue

    But when I use the buttons the 2 motors starts at time but I still have the problem when I use the slider

    Once again thank you for this release


    This post was edited by Frederic Ayrault at March 11, 2016 8:50 PM CET
    • 164 posts
    March 11, 2016 2:40 PM CET

    Hi Guys,

    Thanks for your patience. The new (2.0.2.) android application available on google play: https://play.google.com/store/apps/details?id=com.vengit.sbrick&hl=en

    • 310 posts
    March 9, 2016 3:51 PM CET

    [blockquote]Ricky Mak said:

    [blockquote]Balint Mezei said:

    [blockquote]Ricky Mak said:

    Hi SBricks Supports,

    I used SBrick app to update the firmware of my SBrick. The app indicated the updated was completed. However, the SBrick does not response to the app anymore. The LED on Sbrick lights up all the time once the power is on. None of the port is responding nor the LED can be turned off again. I can see the correct firmware version from the app after firmware updated. I tried to update the firmware again but the app refuses by saying that the firmware it the latest.

    So what can I do to recover my Sbrick? Please help.

    Thank you.

    Ricky.

    [/blockquote]

     

    Hi, 

    Did you restart your phone after the update? 
    Whenever you update a new firmware version you have to restart your device. 

    [/blockquote]

    I tried restarting my phone/sbricks. I also tried to reinstall the app. But these do not help.

    I am pretty sure this is the problem of Sbrick. I have other Sbricks which use the original firmware works with my phone very well.

    My andriod phone is Samsung Note Edge andriod 4.4. The App ver is 2.0.1.

    Is there any way to force updating the firmware of Sbrick again?

     

    Thank you.

    Ricky.

    [/blockquote]

     

    Hi, 

    Sorry for the late answer. The firmware could be the problem. The newest version is 4.8 
    On google play, you can find the Sbrick Simple Control application. You can update your firmware with this, if the simple app doesen't work. 

    Soon our new android application will be available. If your problem is still exist, contact us on info@sbrick.com, and we check it again.

    If there is a problem with SBrick we will give you a new one, don't worry about it. 

    Best wishes, 

    Balint Mezei - SBrick Team 

    • 3 posts
    March 8, 2016 7:46 PM CET

    [blockquote]Ricky Mak said:

    [blockquote]Balint Mezei said:

    [blockquote]Ricky Mak said:

    Hi SBricks Supports,

    I used SBrick app to update the firmware of my SBrick. The app indicated the updated was completed. However, the SBrick does not response to the app anymore. The LED on Sbrick lights up all the time once the power is on. None of the port is responding nor the LED can be turned off again. I can see the correct firmware version from the app after firmware updated. I tried to update the firmware again but the app refuses by saying that the firmware it the latest.

    So what can I do to recover my Sbrick? Please help.

    Thank you.

    Ricky.

    [/blockquote]

     

    Hi, 

    Did you restart your phone after the update? 
    Whenever you update a new firmware version you have to restart your device. 

    [/blockquote]

    I tried restarting my phone/sbricks. I also tried to reinstall the app. But these do not help.

    I am pretty sure this is the problem of Sbrick. I have other Sbricks which use the original firmware works with my phone very well.

    My andriod phone is Samsung Note Edge andriod 4.4. The App ver is 2.0.1.

    Is there any way to force updating the firmware of Sbrick again?

     

    Thank you.

    Ricky.

    [/blockquote]

    Try to pair and unpair the Sbricks. May be you have to restart your phone after that, or delete the App Data.

    • 2 posts
    March 8, 2016 5:21 PM CET

    [blockquote]Balint Mezei said:

    [blockquote]Ricky Mak said:

    Hi SBricks Supports,

    I used SBrick app to update the firmware of my SBrick. The app indicated the updated was completed. However, the SBrick does not response to the app anymore. The LED on Sbrick lights up all the time once the power is on. None of the port is responding nor the LED can be turned off again. I can see the correct firmware version from the app after firmware updated. I tried to update the firmware again but the app refuses by saying that the firmware it the latest.

    So what can I do to recover my Sbrick? Please help.

    Thank you.

    Ricky.

    [/blockquote]

     

    Hi, 

    Did you restart your phone after the update? 
    Whenever you update a new firmware version you have to restart your device. 

    [/blockquote]

    I tried restarting my phone/sbricks. I also tried to reinstall the app. But these do not help.

    I am pretty sure this is the problem of Sbrick. I have other Sbricks which use the original firmware works with my phone very well.

    My andriod phone is Samsung Note Edge andriod 4.4. The App ver is 2.0.1.

    Is there any way to force updating the firmware of Sbrick again?

     

    Thank you.

    Ricky.

    • 310 posts
    March 6, 2016 9:41 PM CET

    [blockquote]Christoph Pfenninger said:

    Hi Sbrick team

    Today simple controll was updated by the Play Store.
    Now i could finally update to the firmware 4.8 with simple control since a long time.

    Thank you guys.

    All my creations will work now as they should be.

    I have a Sony Z1 Compact with android 5.1.1. The sbrick app V2.0 update 1 will will work neu without any crashes.

    [/blockquote]

    Hi,

    Good to hear that you're satisfied with SBrick. :) 

    Thank you for the feedback. :) 

    Balint Mezei - SBrick Team 

  • March 6, 2016 9:15 PM CET

    Hi Sbrick team

    Today simple controll was updated by the Play Store.
    Now i could finally update to the firmware 4.8 with simple control since a long time.

    Thank you guys.

    All my creations will work now as they should be.

    I have a Sony Z1 Compact with android 5.1.1. The sbrick app V2.0 update 1 will will work neu without any crashes.

    • 310 posts
    March 6, 2016 12:59 PM CET

    [blockquote]Ricky Mak said:

    Hi SBricks Supports,

    I used SBrick app to update the firmware of my SBrick. The app indicated the updated was completed. However, the SBrick does not response to the app anymore. The LED on Sbrick lights up all the time once the power is on. None of the port is responding nor the LED can be turned off again. I can see the correct firmware version from the app after firmware updated. I tried to update the firmware again but the app refuses by saying that the firmware it the latest.

    So what can I do to recover my Sbrick? Please help.

    Thank you.

    Ricky.

    [/blockquote]

     

    Hi, 

    Did you restart your phone after the update? 
    Whenever you update a new firmware version you have to restart your device. 


    This post was edited by Balint Mezei at March 6, 2016 1:02 PM CET
    • 2 posts
    March 6, 2016 6:47 AM CET

    Hi SBricks Supports,

    I used SBrick app to update the firmware of my SBrick. The app indicated the updated was completed. However, the SBrick does not response to the app anymore. The LED on Sbrick lights up all the time once the power is on. None of the port is responding nor the LED can be turned off again. I can see the correct firmware version from the app after firmware updated. I tried to update the firmware again but the app refuses by saying that the firmware it the latest.

    So what can I do to recover my Sbrick? Please help.

    Thank you.

     

    Ricky.

    • 310 posts
    March 5, 2016 6:10 PM CET

    [blockquote]Ewen Robertson said:

    Hi What is going on with the Android App, I canot connect to s bricks, at all even with the basic app.  they work perfectly on IOS.  The App seams slow and will sometimes show the sbrick but do nothing, message is "please turn sbrick on".  I hadn't used it for a few weeks and previously the app was working great.  Phone is HTC M9, thanks

    [/blockquote]

     

    Hello,

    Firstly, we can advise you to check the SBrick-s firmware version. The newest is 4.8.
    If the problem was the version, after the update, please restart your phone. 

    If you still have the problem please send us a message on info@sbrick.com

    Best regards,
    Balint Mezei - SBrick Team 


    • 5 posts
    March 5, 2016 10:58 AM CET

    Hi What is going on with the Android App, I canot connect to s bricks, at all even with the basic app.  they work perfectly on IOS.  The App seams slow and will sometimes show the sbrick but do nothing, message is "please turn sbrick on".  I hadn't used it for a few weeks and previously the app was working great.  Phone is HTC M9, thanks

    • 95 posts
    March 3, 2016 10:30 PM CET

    [blockquote]Tamas Misik said:

    Hi Frederic,

    Based on our tests they will work perfectly in the new version :)

    [/blockquote]

     

    Thank you.

     

    • 164 posts
    March 3, 2016 12:01 PM CET

    Hi Frederic,

    Based on our tests they will work perfectly in the new version :)

    • 95 posts
    March 3, 2016 11:02 AM CET

    [blockquote]Balint Mezei said:

    Hello!

    We absolutely understand your concern. We do our best. We testing the appliaction these days, it is nearly finished.

    In the new version, 

    ¤ We redesigned port assignments,
    ¤ The main screen has changed (there will be two types of view),
    ¤ We improved the SEQ function,
    ¤ There will be a big step with the control and chanel panels (Soon you will see what does it mean, we're sure you will like it.)
    ¤ Clinometer has been developed,
    ¤ We fixed some bugs about output values, and zero/start points,
    ¤ and a lot of other issues has been fixed.

    Tests are very promising, but we ask you to be patient, just for a couple of days. 
    In 24 hours we're going to share some other information with you. 

    Balint Mezei - SBrick Team 

    [/blockquote]

     

    Thank you for this answer.

    What about the auto reset and output value for buttons?

     

    • 310 posts
    March 3, 2016 3:39 AM CET

    Hello!

    We absolutely understand your concern. We do our best. We testing the appliaction these days, it is nearly finished.

    In the new version, 

    ¤ We redesigned port assignments,
    ¤ The main screen has changed (there will be two types of view),
    ¤ We improved the SEQ function,
    ¤ There will be a big step with the control and chanel panels (Soon you will see what does it mean, we're sure you will like it.)
    ¤ Clinometer has been developed,
    ¤ We fixed some bugs about output values, and zero/start points,
    ¤ and a lot of other issues has been fixed.

    Tests are very promising, but we ask you to be patient, just for a couple of days. 
    In 24 hours we're going to share some other information with you. 

    Balint Mezei - SBrick Team 

    • 12 posts
    March 2, 2016 10:42 PM CET

    It's a Very Good idea. Maybe only android-app make as open-source (also as android os)?

    We see for last several moths that sbrick team does not cope, does not time to release an android app. Especially an another app was released from other developers.

    • 16 posts
    March 2, 2016 9:28 PM CET

    May be it is better to release app as open-source, somewhere on GitHub or similar, where SBrick team will be prime maintainer, and will make Google Play releases?

    Of cource app itself will not work without Profile Designer API access and server(s), and SBrick firmware is still in hands of developers. But I am sure there are a lot of people among SBrick owners who will contribute to app development, especially in case of fixing small bugs.

    • 95 posts
    March 2, 2016 8:46 PM CET

    I really starting to lose patience


    Where is the new version promised for early last week!

     

    When are you going to provide a roadmap?