Forums » Support

Back To Topics

SBrick Android App

    • 95 posts
    February 17, 2015 1:37 PM CET

    Last version is 0.0.60 the home page is 2 weeks old...

    I am not able to find the dropbox link for this version

     

    [blockquote]Peter Quick said:

    Guys I downloaded the Sbrick from the posted APK on the main page.

    The version from the main page is 0.0.41

    THe version on Google Play is 0.0.60

    Which is the most recent version of the Android OS App?

    Also I installed the Sbrick App on an Samsung S3 (0.0.60)

    I sideloaded 0.0.41 on my Kindle Fire HD 6"

    On both devices I have issues maintaining and keeping a connection.

    Biggest issue is that I can't see any profiles I created in the profile designer.  

    Also - please keep posting the apk so I can keep sideloading on my Kindle Fire.

    [/blockquote]

    • 2 posts
    February 17, 2015 5:14 AM CET

    Guys I downloaded the Sbrick from the posted APK on the main page.

    The version from the main page is 0.0.41

    THe version on Google Play is 0.0.60

    Which is the most recent version of the Android OS App?

    Also I installed the Sbrick App on an Samsung S3 (0.0.60)

    I sideloaded 0.0.41 on my Kindle Fire HD 6"

    On both devices I have issues maintaining and keeping a connection.

    Biggest issue is that I can't see any profiles I created in the profile designer.  

    Also - please keep posting the apk so I can keep sideloading on my Kindle Fire.

  • February 17, 2015 2:02 AM CET

     

    The Sbrick app can be a little temperamental which is not odd since it is still in alpha. Alpha versions of applications are buggy by definition, nor do all features work. They are however generally functional, as is the Sbrick android app. I have had my bad spells with it: generally figuring out in what order things should be done, episodes of it crashing, not being able to connect to the Sbrick, showing a blank screen without functions, things getting broken after an update, etc. But in all cases I was able to resolve the issue.

     

    A list of things i have tried when the Sbrick did not do what i wanted:

     

    1. Look at the instructional video and videos of other people to see if i was missing something.

    2. Make sure Bluetooth is enabled.

    3. Make sure the Sbrick is battery-pack that powers the Sbrick is turned-on.

    4. Sometimes it helps to turn bluetooth off and on again.

    5. Reboot the device (smartphone, tablet).

    6. Clear the cache of the app, clear data of the app, if these fail reinstall the app.

    7. Patience, sometimes it takes a while for the Sbrick to be discovered. It rarely happens but if all else fails, put it away for a couple of hours sometimes it will resolve itself.

     

     


    This post was edited by Franciscus van der Maat at February 17, 2015 2:26 AM CET
    • 7 posts
    February 16, 2015 8:41 PM CET

    Samsung Galaxy S5, Android 4.4.4

    App version 0.0.60

    Every time the app looks for SBricks, it adds another ID to the list, but only the ID with the name "SBrick" works, and I presume this is the physical ID of my only unit.

    App crashes if you click on buttons that launch dialogs too quickly or too often when they do not respond to the initial press.

    I have created my own profile that uses a gamepad controller and a slider. Only the slider works, no matter which ports are assigned to the SBrick.

    App crashes often during use.

    • 34 posts
    February 16, 2015 6:12 PM CET

    Thank you all of your feedback! We'll work hard this (and next) week to repair all issues reported by you.

    We'll also publish a long term roadplan both for android, iOS, and profile designer releases next week.

    • 5 posts
    February 15, 2015 3:47 PM CET

    Just tested the 0.60 version. Clearing cache does seem to help, and playing around with the hand-drawn profile I have a fairly stable operation.

    Remarks are however:

    • Sometimes it will lose connection and the app says "brick is powered off or out or range" when it isn't. Need to restart app or BT on/off to repair connection.
    • Light button does not work, only blinks once when turned "off" No respons when turned on.
    • M-motors will give humming sound in "idle" The L-motor does not have this nor the servo.
    • If I engage the steering control first, the accelerate slider becomes unresponsive if used simultanously . First using the accel, does allow using both at the same time.
    • The B and C channel are switched in the SBrick port tester
    • At maximum output, the port tester reverts to idle power which is very annoying.
    • Going through MyMOC-> Linked Bricks -> Port tester (arrow to the right) will often crash the system. Going first through "Manage bricks" and the to the port tester this error does not occur and also fixes the crash for going the other route....

    Tested on Xiaomi Mi2S Miui 6 (Android 4.4.4)

    On my Samsung SM-P600 (note 10.1) I also noticed the following aspects:

    • The new profiles were not available (can be due to aspect ration differences)
    • The joystick controls do not work at all
    • Changing profiles will plot the changed profile over the previous one, even after killing the app. First I had to delete all profile and then add a new oen to repair.
    • In the "Gamepad with buttons" profile, the steering control become unresponsive if the accel is engaged first, so opposite error as seen in the other profile.

    So clear improvements, but not there yet...

    Martijn Nab

    P.S. And as some other already mentioned, in Android on some browsers, scrolling through the forum does not work well anymore. Used to be ok...


    This post was edited by Martijn Nab at February 15, 2015 3:52 PM CET
    • 16 posts
    February 15, 2015 10:48 AM CET

    Indeed, clearing all adroid sbrick data does help. I have yet to test in more details, but at least I am able to use a profile without crashing...

  • February 15, 2015 7:16 AM CET

    I tried the sbrick simple app. The user interface is BLANK. There's nothing on it. 

    This forum is also BLANK from an android phone's browser. I think the two problem is in connection with each other. Look after javascript on the page, because it crashes the browser.  

    • 23 posts
    February 14, 2015 11:29 PM CET

    I did that, but the results were the same.

  • February 14, 2015 11:07 PM CET
    Try a Profil without any background
    • 23 posts
    February 14, 2015 10:16 PM CET

    With v0.0.60 my excavator-profile still doesn't work. Now the controll-elements are squeezed horizontally. The further the controll is to the right, the more it's moved to the right.

    And everything I touchg when the profile is opened closes the profile again.

    In the output-assignment-screen, when i press the picture of the SBrick to test the ports, the app crashes.

    I even tried the standard profile with 2 joysticks and 2 sliders: only the sliders work, the joysticks don't do a thing. And whatever settings I try, I can't get the profile to controll the 2 SBricks. I also tried removing the app completely including files and cache as Jürg suggested, but that didn't change anything.

    Using Sony Z3 Compact, android 4.4.4

    • 25 posts
    February 14, 2015 10:03 PM CET

    [blockquote]juerg siegenthaler said:

    When Androis app, it is important if you installed the 0.0.60 that you, in the settings of the operating system deletes all SBrick data. Important.
    Then uninstall the old version and install the new app.
    The app will crash the first time. Now you repeat the procedure and deletes all files which relate to the app including cache. Also important to dispense with a background in profile. it worked for me and basically runs stable.

    [/blockquote]

     

    The app should clean itself if the installer does not. Cache should be erased when an update is installed, especialy if it's known that data in cache brings problems. Users should not have to handle that, from my point of view. I know app is in alpha version (after weeks and weeks...), but at least install process should be masterised, no?

  • February 14, 2015 9:53 PM CET

    When Androis app, it is important if you installed the 0.0.60 that you, in the settings of the operating system deletes all SBrick data. Important.
    Then uninstall the old version and install the new app.
    The app will crash the first time. Now you repeat the procedure and deletes all files which relate to the app including cache. Also important to dispense with a background in profile. it worked for me and basically runs stable.

  • February 14, 2015 9:45 PM CET

    hello everybody. i have now tested the whole day, the Android app and the app ios test flight. It runs, although not always stable, but it works. In the Android app, there are only problems if there is a background image in PD is selected, then it Does Not Work in the app. in the IOS app to do it.
    Now for all .... I revise my opinion of yesterday and tell the app including PD function for an alpha operation actually pretty neat.
    I apologize for my displeasure yesterday at SBrick team. Keep it up and listen to the boys and girls of the comunity.

    So it's yet.
    Greetings from Switzerland

    • 3 posts
    February 14, 2015 9:02 PM CET

    Dear Developers




    With SBrick you had great idea, your advertisement of "playability" with SBrick were even better, but the reality is now quite bitter.
    Thanks to Sylvain CACHEUX I want to say the same as he. I can sign myself under each if his comments and complains!

    Think about future of this project which was really well taken and supported by many people.
    I guess you will not get many distributors of you product as long it is useless for android users, I would not sell it at all to others at this development stage!

    Please put the app in open source, others will do your job with fan, the product will gain functionality and defenitely will increase your sales and reseler numbers.

    Think about it before alternative options appear on the market.

    regards
    Marcin


    • 16 posts
    February 14, 2015 8:59 PM CET

    Mmh.... installed 0.60 on my Asus, good news is that discovery works nearly correctly (sometimes very long discovery, but can be aborted by hitting screen). I was able to discover and test 2 sbricks. Bad news: as soon as I try anything related to profiles, instant crash!

    • 25 posts
    February 14, 2015 6:20 PM CET

    Hello,

     

    Installed 0.0.60. app crashes when deleting the profile applied to a moc (to put another one). Jurgens excavator's profile makes application crashing.

    Loading of profiles list and selection of profile is very slow.

    Application does not save credentials for profile designer.

    New behavior about buttons: when taping to set on, displays is on, but lights are still off. When taping to set it off, displays goes off, and ligths flashes on and remains then off...

    Joysticks does not work at all.

    Still no slider that keeps position when releasing (which would allow you to remove your finger from screen, so practical when running trains - I tried "auto reset" option, but not working).

    When managing to have a profile running, sbrick stops responding after a variable time.

    Guys: instead of adding functions, debug the existing ones.

    I'm getting less and less patient. If at the end of this month (which will be 2 monthes since we have sbricks in our hands, largely enough to debug an app) we have no communication from developpers with a clear calendar with clear steps for each function debuging, I'll begin a true campaign to tell all what I'm thinking now of sbrick to all french LUGs I know (which makes hundreds of people). You are warned. I'm tired of waiting news, tired of an app still in alpha version with many bugs although reported since more than 1 month while IOS is working well. I just now think that vengit does not care at all of android users. No true communication, no true debuging of the existing functions, addition of functions also bugged, so consideration for people (backers) who allows you to realize your project. 350 € for 8 sbricks not usable (and I'm don't mention the "goodie" I was supposed to have). That's ENOUGH !

    As you know, when a bad reputation is done, it's very difficult to get it good. Think about it!

    If you have problems, tell them.

    If this is beyond your developing skills, then put it in open source!

    Sylca


    This post was edited by Sylvain CACHEUX at February 14, 2015 6:53 PM CET
    • 4 posts
    February 14, 2015 6:02 PM CET

    Hi

    did the update to the newest version from 0.26. App crash every time i want to add a profile. Went back to 0.26.

     

  • February 13, 2015 10:09 PM CET

    hello. have the new app 0.0.60 installed and tested. does not work on htc one m8. keeps crashing after approx 1 minute.

    app connects not even with sbrick.

    I am very very disappointed, have 2 sbrick bought for much money and it does not work. I am now since 2 weeks on tinkering with no visible success. it can not be. what we have paid for all the money for the stones we may also expect something in return. looking from my side of this is very bad advertising for all the superior sbrick to buy.
    it also does not use if the app a color update subjects in each release. The developer should focus on the function instead of always replace only the color.

    Sorry but this needed to be said now.

    • 21 posts
    February 13, 2015 5:48 PM CET

    [blockquote]Denis H said:

    Testing the Sbrick simple app v1.5

    Samsung Galaxy S3

    Android 4.3

    Now indeed the discovery is really fast, like 0.1 sec

    Connecting take about 2 seconds

    BUT, sliders don't work at all....i just can play with slider like 5 minutes, even left slider at max for about 15 or more seconds, and NO engine is moving. And occasionaly one engine moves about 1 sec (like a massive delay). PLEASE can you borrow a S3 and test, S3 is a popular model. This app and the other is still trash, sorry but i start to get a little angry with this purchase.

    [/blockquote]
    All the same.
    Also can't add profile from PROFILE DESIGNER. 

    • 41 posts
    February 13, 2015 5:17 PM CET

    Testing the Sbrick simple app v1.5

    Samsung Galaxy S3

    Android 4.3

    Now indeed the discovery is really fast, like 0.1 sec

    Connecting take about 2 seconds

    BUT, sliders don't work at all....i just can play with slider like 5 minutes, even left slider at max for about 15 or more seconds, and NO engine is moving. And occasionaly one engine moves about 1 sec (like a massive delay). PLEASE can you borrow a S3 and test, S3 is a popular model. This app and the other is still trash, sorry but i start to get a little angry with this purchase.


    This post was edited by Denis H at February 13, 2015 5:18 PM CET
    • 95 posts
    February 13, 2015 3:21 PM CET

    I do agree with Juerg Siegenthaler about the custom profiles and the login

     

  • February 13, 2015 12:40 PM CET
    And I forget... When i'm Login whit User and passord it must be possible to save the setings so that i the Next time Only press the Login Button and im loged in whitout entering user and password
    Android 5.0.1, HTC Sens 6.0
  • February 13, 2015 12:32 PM CET
    Can you please add an update button to mark the profile as updated, so in the android app the profile will shown as changed.
  • February 12, 2015 8:22 PM CET

    [blockquote]Frederic Ayrault said:

    I fogot this one but I think it is working with ios

    https://social.sbrick.com/videos/7730/96/sbrick-reset-profile

    I tried to change the auto reset without success...

     

    X

    [/blockquote]

    Got the Same problem, it seems it works only whit IOs... very sad