Forums » Support

Back To Topics

SBrick Android App

    • 1 posts
    January 7, 2015 9:29 PM CET

    Does anyone try a SBrick with a Samsung Galaxy S3 with CyanogenMod Android 4.4.4?

    • 21 posts
    January 7, 2015 9:07 PM CET

    I have the same "long" delay. Especially when using steering control or two ports.
    When the slider quickly move in different directions, for example 20 times, brick continues to perform these commands for 15-20 seconds.

    Several times the application was closed itself.

    Inversion of ports does not always work (if on/off is the inversion).
    (Samsung Galaxy S3, 4.3)

    This post was edited by Maxim Baybakov at January 7, 2015 9:57 PM CET
    • 41 posts
    January 7, 2015 8:26 PM CET


    Just test the android 0.25 version with the Crawler 9398 and a MOC (is a car), both have only steering and with my samsung S3 i can discovery and connect the sbrick...THANKS fot that!!!!!


    This are my observations/issues:

    - The joystick  and gamepad 1 profile don't work at all.

    - Gamepad 2 works, but both sliders are too i can't reach the max power without exit the screen with my fingers (left for steering and up/down for acceleration/reverse)....not a good experience with this type of creation. For Cars/4x4 we need a gamepad with both shorter slider, and binary (0 = stop and 1 = full throttle)

    - For some reason when i go 50% with any slider (with gamepad 2) and release the slider....the engine get stuck at 50% without touching the screen.

    - With gamepad 2, i choose the steering in the "C" slot.....if i reverse only that port....don't work....i have to also reverse "B" port to work properly......strange issue.

    - I noticed that there is a delay when i touch the sliders in the cel and the engines actually start to move.....with my MOC (car) that runs faster than the Crawler is impossible to drive with that delay. This can be improved?? i know that with BT devices is always a very little delay, but i think in this case is longer that the "normal".


    Also i try to change the Gamepad 2 profile editing the .json file......what's "frame" description? for the x,y,z,w



    This post was edited by Denis H at January 7, 2015 8:37 PM CET
    • 5 posts
    January 7, 2015 7:52 PM CET


    I updated app to 0.0.25.

    I can add MOC only and download only base profiles (Test, Joistick etc.)

    I can't change direction of motors.



    • 57 posts
    January 7, 2015 7:32 PM CET

    [blockquote]Christian Treczoks said:

    a software like this would never, ever, be released.


    Yes, maybe not beta and still alpha quality. And then?

    I think we all should be a bit more comprehensive! Since the kickstarter campaign and as all other kickstarter projects we knew there was an implicit risk.

    And we honestly must admit these guys have made a fantastic job so far!!!

    I must confess that I was prepared for considerable delays, when I raised my pledge. I did it mainly to expresse my support and to help this project to happen. Something we didn't get from LEGO for years, and probably we will never get.

    After all they have managed to deliver the hardware to us, with the minimal delay of one month!!! Honestly I never expect such good performance. I've seen projects from much bigger companies with plenty of resources allocated, to fail miserably or to slip far from that!...

    Ok, we have delays with the apps, but we have quality hardware and aparently without relevant failures found so far (firmware bugs count little here as they can be solved with ease).
    Furthermore Vengit is in at least 4 app/sw development fronts (iOS, Android, WP, Profile Designer, SBrick firmware), with at least one pretty stable (iOS) at the brick delivery time. Android has big issues, but still it allows to do some tests already!
    Ok, still a lot to do in what regards the profiles design and management, poor documentation (but app still in heavy developemt phase), but come on! Were you really expecting much more than this at this point?Or did o preffer to have nothing released to test, meaning you could do nothing with your SBricks?

    This you can also test and give your feedback/suggestions to incorporate the product.
    Other platforms support will arrive at their time! Give them time a space to make the right decisions and software design, which IMO where they should focus now, for us to get the perfect product.

    Also you never heard from Vengit about excuses for the "delays", and I know there were several difficulties with significant impact, that could have caused much bigger delays by themselves and were also not their responsibility. They have always resisted to the tempation of making them public and after all we already have the SBricks in our homes!


    Kudos Vengit!!


    This post was edited by Fernando Correia at January 7, 2015 7:34 PM CET
  • January 7, 2015 6:07 PM CET

    Just updated.

    a) Select my MOC, tap "linked profiles" -> crash.

    b) How do I remove a set from the "my sets" list?

    c) And why is this app "portrait mode only"? - Nearly every other app I use works in any orientation, and, as a table user, I prefer landscape.

    Still quite alpha, it seems. If my software would crash after only two taps, QA would rip me another one, and I would have to bring cake for all. But a software like this would never, ever, be released.

    Leg bedre, Christian

    • 34 posts
    January 7, 2015 5:13 PM CET


    any release notes to share ? ;)

    Tested on Nexus 7, I needed to wipe the app and reinstall to get the profiles work, port tester was working right after update.

    Otherwise no change for me, was working before and its also now. And there still seems to be much more lag and random inputs on Nexus 7 compared to HTC One.

    This post was edited by Matej Papluh at January 7, 2015 5:49 PM CET
    • 201 posts
    January 7, 2015 4:54 PM CET

    New android app here:

    • 24 posts
    January 7, 2015 3:14 PM CET

    [blockquote]Tamás Fábián said:

    The sets are removed intentionally, they had no real function. We'll figure out some other method to store the set number if you're building an SBrick into an official lego set.

    I fixed the discovery bug yesterday afternoon, we'll put a version to the store ASAP.



    Thanks, Tamas.

    • 167 posts
    January 7, 2015 10:31 AM CET

    The sets are removed intentionally, they had no real function. We'll figure out some other method to store the set number if you're building an SBrick into an official lego set.

    I fixed the discovery bug yesterday afternoon, we'll put a version to the store ASAP.

    [blockquote]Norman Chalcraft said:

    Samsung Galaxy S3 - GT19300 - Android4.3

    Cleared cache, deleted data, uninstalled 0.21.

    Installed 0.22 - changes since 0.21 - only the version number.

    Still can't add a Set, only a MOC.  Still can't discover a brick.  We live in hope!


    • 21 posts
    January 6, 2015 9:38 PM CET

    [blockquote]Norman Chalcraft said:...

    Still can't add a Set, only a MOC.  Still can't discover a brick.  We live in hope! 


    SBrick 0.0.22

    - Port inverter fix
    - Profil view crash fix
    - Market layout fix
    Wait for another patch :)
    • 24 posts
    January 6, 2015 5:49 PM CET

    Samsung Galaxy S3 - GT19300 - Android4.3

    Cleared cache, deleted data, uninstalled 0.21.

    Installed 0.22 - changes since 0.21 - only the version number.

    Still can't add a Set, only a MOC.  Still can't discover a brick.  We live in hope!


    • 17 posts
    January 6, 2015 5:35 PM CET

    I downloaded 0.0.22


    Sadly, the fixes still don't actually make it work on an Galaxy S4. Brick remains only useable via the port testers. All profiles etc. don't work.

    • 34 posts
    January 6, 2015 4:47 PM CET

    got the 0.22 

    What's New
    - Port inverter fix - YES, it works
    - Profil view crash fix - not sure, the profile delete still crashes the app sometimes
    - Market layout fix - changed icon colors, what else ?


    [blockquote]Fernando Correia said:


    It is stated in several places that SBrick requires a BLE (BT Smart) compatible device.

    It is also written that Android brought support to this only with version 4.3.


    Unfortunately technical limitations are nowhere to be found on the Sbrick KS page or homepage so I really feel for the guys having incompatible HW. The early pledgers had no playstore page to tell them the version compatibility.

    In terms of consumer laws the missing/hidden compatibility can be a reason for full refund. SBrick is being marketed to general population and not to specialist (as engineering sample). So blaming it solely on the customers is not really correct.

    • 95 posts
    January 6, 2015 9:36 AM CET

    Verson 22 is available. I have cleaned the cache, deleted the datas, uninstalled the application before installing the new version

    (I have a gt-i9505 runing stock 4.4.2) I have downloaded Test 2 and port inverter works fine now :-)


    I am now looking forward to be able to control 2 channels with only one slider


    Thank you for this update





    This post was edited by Frederic Ayrault at January 6, 2015 9:37 AM CET
    • 57 posts
    January 6, 2015 1:17 AM CET


    It is stated in several places that SBrick requires a BLE (BT Smart) compatible device.

    It is also written that Android brought support to this only with version 4.3.

    First you can check if your hardware supporte BT Smart. Then if it is the case you can look for cooked ROM with a newer Android version, that supports the required functionality.

    SBrick is great if you have the right hardawre. Involved technology is quite new, so a couple of double checks are required to know if you have some chances to get it working with your current hardware before buying SBrick. Otherwise the only option is to upgrade to a newer Smartphone or Tablet.




    This post was edited by Fernando Correia at January 6, 2015 1:17 AM CET
    • 2 posts
    January 6, 2015 12:42 AM CET

    I'm very surprised and disappointed after the excitement of receiving my sbricks.

    I tried to get the app from Google play and it says it is incompatible with both my Asus tablet and my ZTE smartphone (android 4.2.1 and 4.1.1 respectively).

    What can I do to work this around, maybe I didn’t read some instructions, or when are you expanding the app to a broader range of devices?

    I still admire your work, now I just want to take advantage of it…



    • 25 posts
    January 5, 2015 6:44 PM CET

    I agree with Jetro.

    Rather than doing profiles, I think it would be better to split the screen into small sections, for each of which user can choose slider (for example 2 vertical units, 1 horizontal unit (or the contrary if positionned in landscape)), button (1 V unit x 1 H unit), joystick (2 V units x 2 H units), gyro (idem), ... controls and place them like he/she wants (and zones for naming (like "door opening" or "train A speed"), then configure with which Sbrick each control would be affected (with inverterds), then save his display.

    Like this, train users, for example, could control several trains in the same screen on a tablet, including lights, rail junctions, or other particular functions.

    Thank you, and happy new year !


  • January 5, 2015 3:41 PM CET

    I have just received my sBrick today. I was able to install the app on my Samsung Galaxy S2 (custom ROM: cyanogenmod, Android 4.4.4) and my Samsung Galaxy Tab Pro 8.4

    A few comments on the app:

    • The sBrick hardware is useless without a decent app. While I am happy to have received my sBrick around the expected time and the quelity of the sBrick appears to be good, not having a working app within the same timeframe does detract from the overall experience
    • The app appears to have been made only with phones in mind. I cannot use it in landscape mode except for some specific screens
    • I was able to download the profiles in the market tab, but the app is going to need some serious help files! Rather than having to first create a set (only MOC for now) and blindly choose a profile (no indication of what each profile actually contains) it would be good to be able to select a profile and use it on the fly by adding a "configure" button on the profile screen. That way you can easily see and test profiles before you assign them to a creation. Right now the only action I am offered when clicking on a profile is "delet" !?

    Please push out a general update to the backers when you have a functional beta of the app

    • 21 posts
    January 4, 2015 2:43 PM CET

    Dear developers,
    When can we expect a patch on app with elimination of undetected Sbrick on Samsung S3? Can you name the time - one week, two weeks or month ...

    • 1 posts
    January 3, 2015 1:17 AM CET

    I received my SBrick a few days ago. The iOS app works alright on the iPhone 4S. It connects to the Sbrick most of the times. I can download profiles from the market,
    and most of them works.I have the same problems as many of you have mentioned; the motors stop when full power is applied, and "identify LED" does not work.

    Also also have a Galaxy Note (GT-N7000). This device does originally only support Android versions up to 4.2.1, but for the sake of the Sbrick, I rooted
    and flashed it to Android 4.4.4 (using Slimroms). The Sbrick app works almost perfectly now! Motors can be powered 100% without shutting down, both in the port tester and in the various profiles.  Identify LED also works.

    • 7 posts
    January 2, 2015 10:57 PM CET

    Samsung Galaxy S5

    Android 4.4.4

    SBrick version 0.0.21

    Port testers work.

    Profiles can be downloaded from the market.

    Brick can be paired.

    No profiles work with the paired brick, varied bugs similar to those already reported - gyros don't work, some motors/ports don't register.

    Shrill sound appears to be motor braking when sliders are in the "off" position, but not actually off. Recommend adding a "dead zone" to all self-centering controls where the motor is physically off to improve battery life.

    Product is essentially unusable at this point.

    When is there expected to be a profile building tool?

    • 10 posts
    January 2, 2015 10:08 PM CET

    The description in the Android Market (now) says "This is an alpha preview build, not for production use!".

    So the team is working on somethine better, it just means Android users have to wait. It may not be ideal but since the hardware is done and the iOS App seems OK a lot of people can work it fine.

    I can wait!

    • 17 posts
    January 2, 2015 6:51 PM CET

    I would probably describe it as Alpha rather than Beta considering most of it doesn't work, especially in comparison to the iOS one. (Which is an entirely different looking app)


    Generally, at the moment the port testers work most of the time. The LED tester only work on rare occasions.


    Amusingly, I have an S4 which can connect to the brick but with a very unstable and unfunctional app and a Apple 4 which has a nice app, but can't connect. Fun and games!

    This post was edited by Toku Betsu at January 3, 2015 6:11 PM CET
    • 28 posts
    January 2, 2015 6:45 PM CET

    Just received my SBrick in the mail. Installed SBrick app v0.0.21 from the Play Store.

    I have a Nexus 4 running stock Android 5.0.1.

    Here is my feedback for the app:

    • I cannot delete Sets.
    • When I try to remove Linked Profiles while editing a set the app crashes.
    • I cant get any of the profiles to control the SBrick.
    • Using "Identify led" and "Port tester" is the only way that I can control the SBrick.
    • As soon as I try any of the linked profiles in a Set, the menu becomes unresponsive. I can slide it open but none of the options work.
    • The market only loaded once.

    I hope this helps yous guys somehow.

    Unfortunately I cannot control the SBrick in order to control my creations.

    Let me know if there is anything that you would like me to try out and give you feedback!