Forums » Support

Back To Topics

SBrick Android App

    • 2 posts
    December 29, 2014 10:32 PM CET

    Just tested one of my Sbricks for the first time. First time right! Love it. Using Sbrick 0.21 on a Samsung S5 mini. Ultimate control, 4 slider controle, over the 42030.

    The only thing I notice; it creates a very high pitched sound when active. Is that normal?

    This post was edited by Michel Scheffer at December 29, 2014 10:33 PM CET
  • December 29, 2014 8:35 PM CET

    It's good. I buy a Samsung Galaxy Pocket 2 (SM-G110H) in 4.4.2 Android version and V4.0 Bluthoot. I DL apps in first time. It's OK for sinchronise a smartphone and SBrick. But don't find a commands for my 42030. I make it?

    • 17 posts
    December 29, 2014 8:12 PM CET

    Okay, has anyone manage to get any profile to work on a Galaxy S4? I removed them and downloaded the current set (Including Test 1 & Test 2 now.) None of them do diddly squat.

    The bit which amazes me is the ports work perfectly via the Manage Brick test interface. Just create a section of the interface in the APP where we have better access to those 4 sliders. At least then people can do some stuff.


    Another thing I have noticed, is that you can't delete the sets you have created under My Sets. I removed the profiles from each one, then tried to remove the Sets themselves. Nothing. Delete icon does nothing. So be careful not to create to many Sets.


    Just imagine if the SBrick has been shipped out at the original release date :)


    I don't mind the release of the SBrick before it is really ready, just because the Test ports part of the App shows you what it will eventually be capable of. Just gotta sit tight a while.

    • 24 posts
    December 29, 2014 12:23 PM CET

    Thanks to Tamas for publishing the communications protocol in the forum Suggestions.

    Using this information together with the utility nRF Master Control Panel I have been able to control my Sbricks.  This shows that there aren't any significant problems with the Sbrick itself, it is just major problems with the Android app.


    • 24 posts
    December 28, 2014 7:05 PM CET

    Uninstalled Sbrick app and installed new version from Playstore, version 21, on to my Samsung Galaxy S3 running Android 4.3.

    Changes?  None in performance that I can see!!  Still can't add a set only a MoC.  Still can't discover any Sbrick!  Only change that I can see is the version number!

    • 10 posts
    December 28, 2014 4:00 PM CET

    [blockquote]Toku Betsu said:

    My SBrick app updated last night. Was previously on 0.0.20 and is now 0.0.21. Apparently a scan fix has been done.

    [/blockquote]"Apparently" yes, because I see no changes on my LG G2. SBrick visible in Bluetooth menu of the phone, but SBrick App can't find it.


    Also the LED doesn't go on, it just flashes for a fraction of a second when you turn on the power. Not sure if this is normal behavior?

    This post was edited by Nick Matthews at December 28, 2014 4:06 PM CET
    • 4 posts
    December 28, 2014 3:43 PM CET

    Yesterday I resived my SBrick.

    After powering on the SBrick the manual says the LED should turn on. I did not... I though is my SBRick broken.

    But after 2 times re-installing the App my Samsung S5 I was able to operate the SBrick.

    I found that the LED is working if your turn it on in the Manage Brick menu (identify led).

    I installed the SBrick on my 41999 and only profile Gamepad 2 was working, except the speed control was working reverse.

    I don't know who to reverse the output controls.

    The Joystick does not work at all and the steering profiles do not react very well.

    Gamepad 1 does not work at all, sometimes the app stoppes. Test 2 only shows 1 slider. So I probably have to re-install the app again..

    I also installed the SBrick app on our IPAD (software 6.1.3.) and IPOD but both cannot find the SBrick....


    I hope the software bug will be fix sone

    • 25 posts
    December 28, 2014 3:27 PM CET

    Hello everybody,


    I'm running the app version 0.0.21, on Samsung Galaxy Note II, version android 4.4.2.

    The market is ok, I managed to download all profiles.

    With the Sbrick manage bricks, I find a sbrick, the identify led works (I noticed that last time I tested, the 2 first on/off, it did not worked, then the 3rd time it worked), the port tester works with all ports, and the OTA (???) indicates that the function will be available soon.

    When I select the home page in the menu, it just displays a welcome message. When taping on it, it displays a kind of controler (joystick, black screen with white border, ...) but nothing happens on Sbrick.

    When I select "my set", I tap the "+" and create a new profile via the "add new moc button (no possibility to add an existing lego model). This adds a profile. When taping on it, I can rename it, then change its image. I can also find my sbrick (discover is a bit long). Then I tap on the Sbrick to set the ports, which works. I tap "save your set!" button and ... it crashes. Impossible to save. If I tap on the profile before, it opens the profile screen (with buttons, sliders, etc.) but it warns me that "couldn't discover all bricks!" with cancel and retry button. Retry redisplays the same message, and cancel let me on the profile, which is obviously not working.

    I tried to change the port on my Sbrick, but same error, the app is crashing, returning to my phone screen when saving my set. I manage to change the profile, and go into the sbrick ports, but always crashing when saving.


    Edit: I uninstalled the app, reinstalled, redownload the market, recreate a new moc profile, and this time it worked! I do not know what changed, I guess the cache has been reset.

    It may be helpful for others, that's why I'm posting :-)


    So that's all I can test for the moment...


    I guess you guys take some rests with your families during the holidays, after all the work you did with the hardware part, and think the app will be improved in january!


    Best regards,


    This post was edited by Sylvain CACHEUX at December 28, 2014 3:32 PM CET
    • 17 posts
    December 28, 2014 3:12 PM CET

    My SBrick app updated last night. Was previously on 0.0.20 and is now 0.0.21. Apparently a scan fix has been done.

    • 327 posts
    December 28, 2014 12:53 PM CET

    [blockquote]Charles Di Caro-Debizet said:

    My Smartphone is too old.

    Is it possible to use an application on Windows 8.1 ?



    We are working the app for WP 8.1. We will release it in January.

  • December 28, 2014 8:19 AM CET

    My Smartphone is too old.

    Is it possible to use an application on Windows 8.1 ?

    • 9 posts
    December 28, 2014 12:09 AM CET

    Hi, finally I managed to test my SBrick on other phones, since I can't get mine to work:

    It bonded perfectly with my friend XPERIA M running on 4.4.2 Android and the app worked fine. I thanked my friend and tried to clean her phone since she won't be needing neither the app nor the BLE bond with the SBrick - no problems there. But then I tried to re-bond the SBrick to her phone and it wasn't possible anymore! The phone displayed a message that went something like this: "The phone can't connect to SBrick because of the wrong PIN number or wrong password"

    I guess the same happened on my phone (XPERIA SP, Android 4.3) and my tablet (LG G-pad 8.3, Android 4.4.2) - at first I could connect the with the SBrick just fine, but when the app wasn't working at all I disconected the device in order to try a clean start - then the phone and the tablet couldn't be connected anymore - also the message like on my friends phone doen't appear.

    Is it possible, that when I disconected the SBrick form my phone (the only option is to tap "disaple connection with SBrick) that it was actually a lock for that connection and now it won't connect anymore?

    How do I reverse that and is it even possible without beeing an Adroid programmer???

    Thanks for you help,

    best regards, miha

    • 10 posts
    December 27, 2014 8:50 PM CET

    Nordic nRF Master Control Panel is a fantastic piece of software. Unfortunately SBrick-App still doesn't discover my SBrick (Nordic does).

    In the meantime SBrick on my LG G2 didn't start anymore. It just closes one second after starting without any feedback. Had to reset my phone, as deleting all data and cache and force closing the app didn't do anything.

    So... still no luck on my LG G2, I ran a few tests on a Moto G and a Galaxy Note 3 though:

    • SBrick was discovered, but Led didn't turn on in the testpanel and the testsliders didn't do anything. I've tried it about ten times before it started working. I gave up with the Galaxy Note 3, it just wouldn't do anything, even though the SBrick was found. Note that Bluetooth was either disabled on the Moto G or the Note 3 to prevent intermission.
    • Eventually when I got a profile to work on the Moto G I could confirm the Gyro is flaky and worked on the wrong axis. Unusable.
    • After playing around with a few controls the responsetime seemed to improve.
    • After a short while the controls just stopped working, I might have been messing around with different profiles too much.
    • Controls can't be reversed, or it isn't clear where this should happen, the on/off switches in the brick view don't seem to do anything (on/off wouldn't be a logical description anyway)
    • There's no feedback from the App whether or not you're connected to an SBrick. The profile just fires up and controls either work or not. There should be a way to see that you're connected and everything should work.

    (some old comment about APIs)

    I'm considering diving into an Android App myself, but my guess is I don't have time for that in the next 4 months, as I have many higher prio-activities next to my regular workweek.

    EDIT - Actually, I might as well have a look so I requested membership for development. I want this damn thing to be big success, so anything I can help with is a good thing.

    This post was edited by Nick Matthews at December 27, 2014 9:35 PM CET
    • 21 posts
    December 27, 2014 8:18 PM CET

    [blockquote]Norman Chalcraft said:In order to check the visibility of an SBrick I have installed the utility Nordic nRF Master Control Panel.  Using this  can discover an SBrick, connect to it and even Bond with it.[/blockquote]

    Thank you for program! Now I saw my bricks :)
    At least we have three people with a problem "discovering sbrick..." using Galaxy S3. I hope we will not stay without attention!

    This post was edited by Maxim Baybakov at December 27, 2014 8:19 PM CET
    • 34 posts
    December 27, 2014 4:06 PM CET

    Check it on your PC when logged in to play store

    Does it list yor devices as compatible ?

    And per info written here it does not support your version (only 4.3+ ) because of Bluetooth profile support

  • December 27, 2014 3:57 PM CET

    I have Android 4.1.2 and Idon't even see the application in the store.

    Is it possible to work with Windows 8.1 ?

    • 34 posts
    December 27, 2014 3:07 PM CET

    After another round of tests.

    - linking and unliking profiles is a sure way how to crash the app, after two - three times it is a sure thing

    - also playing with the profiles, port testing, assignment of functions, etc leaves the app in a state that it won't controll the SBrick althoug it is discovered. There are different level of disconnect - sometimes the port test works but profiles don't, sometimes after jumping the screen back an forth it starts working (not on first try), sometimes not event the port testing and LED light respond and restart of app and SBrick is needed

    - sometimes I cannot choose anything from the menu - restart app

    - here is my take on profiles as l

    1. Steering wheel 1 - gyro is totally random, not usable
    2. Steering wheel 2 - see above
    3. Test 1 - displays a metal background - no controlls
    4. Test 2 - displays random number of sliders - the ones that are displayed can be added to Sbrick and work
    5. Joystick - not working - haven't found a controll to be added that it would respond to, as it would be gyro controlled anyways, see #1/2 
    6. Gamepad 1 - not working seems to display 3 controlls over each other
    7. Gamepad 2 - the one and only working for me - except that I can revers the acceleration; one can easily lose the focus as the max deviation is too close to the edge of screen and the detection is sensitive (4.7" on HTC)

    - Still haven't found a way to invert controls, tried the switches in the SBrick controll setup, but does not work for acceleration, steering nor sliders

    I also found some (.json) files in the storage and tried editing those. But it does not seem to take effect, even when changing a single digit in one slider position. Other than that the descriptive language does not seem to be difficult, I'd suggest to release the option to hand edit the profiles for those who like to experiment. And describe some of the values and references. 

    I have the feeling that the HW received a good chunk of development, but the SW at least the Android one, is utterly lacking.

    If you have problems in catching up, please go opensource ! Somebody else will...

    • 3 posts
    December 27, 2014 2:53 PM CET

    Hi SBrick team


    I received my SBrick with delay - after Christmas... it's fine ;  )


    But connecting it to my Samsung galaxy S4 mini or S3 with android 4.3 ends on permanent "Discovering SBricks"


    I just realise that it is not only my problem...

    What next ? I can wait but kids are disapointed for second time,


    Greets & waiting for support



    • 10 posts
    December 27, 2014 2:45 PM CET

    I've been playing around with my 2 SBricks for a while. Well, play around, I tried to, but I'm having trouble getting them to work, the same with the App. I'm sorry to post this big pile of complaints, and I do expect a lot to be improved, but so far I'm underwhelmed.

    The build quality of the bricks is excellent, as is the packaging. The rest is a nice touch... althogh I'm missing the instructions to build it into 42009 (actually I'll like to try and do that myself) Note that this is the most important part, software can be fixed on the fly.

    So please bear with me while I spew out my complaints after playing around with the SBricks for about an hour, and the App for the past few verions.

    First of all my LG G2 won't pair with the SBricks, my wife's Moto G seems to work every now and then but I'm getting messages about the PIN being denied, even though I can only assume there is no PIN to enter. The LED only flashed for a fraction of a second on startup. I've tried everything with my LG G2, it can see the bricks but not pair with them, de SBrick App will keep searching forever. Really dissappointing but really not something I can pin on the SBricks, who knows maybe my LG G2 is at fault here. I did unpair the SBricks to re-Pair, and they seem to be instantly deny the connection. I'm hoping for a Lollipop Update soon and/or I'll factory reset my device somewhere in the next few months, so I'll check it then.

    So... Once I'm paired and SBrick will find the SBrick I can setup the controls, and all ports seem to function. I had to fumble around a lot to get anything to work. "All further steps will be explained through the SBrick app itself" is far from true. There's nothing in the App. Guessing and playing around with it will get you there...

    I'm sorry to say the App is just the worst. I realize it isn't finished, but it's in a state where I wouldn't even release it to Google Play. The Menu sometimes doesn't work, brings you to the wrong screen, or just doesn't to anything, the back button is showing some really unexpected behavior as well. Available profiles are really rushed and the accelerometer worked on the wrong axis for me. Edit and Delete icons on top mostly don't do anything. If there is nothing to delete, or the delete button does nothing, don't display it. The background is horrible, I'd rather have a grey/neutral backgorund than the blurry half-repeating image thay is there now.

    However, I like the structure of Sets and Profiles. Putting a title and an image in there is a nice touch.

    The input of the App is really laggy, my SBrick took 0,5 sec to 1 second to even respond to some commands. Don't know why, but this is really bad.

    I'm having doubts that the know-how is available to you for building a proper Android App, it seems that it was built by an inexperienced team. I'm sorry if that seems insulting, but that is how I feel about it's current state. The software is the key to the SBrick's usability and it's failing right now. You should consider bringing out an API as soon as possible, because there are a lot of Android Hobbyists out there that will blow this App away with something better in a matter of weeks. Get community support on this!


    I hope you see my rant as the constructive criticism that I meant it to be. I might find the time to get into detail about the App and post some more specific problems I found.

    • 24 posts
    December 27, 2014 2:24 PM CET

    I've just received my SBricks so I'm keen to try them out using my Samsung Galaxy S3 with Android 4.3 and the SBrick version 20.  However....

    The app opens OK but when I try to add a set I only have the option to Add a MOC - I don't even see any reference to a year to pick a set from.

    By going to Market in the SBrick menu I can see 7 different profiles so this one bit appears OK.  However whenever I edit a MOC and try to link a brick it just sits there "discovering".

    Similarly, if I try to Manage Bricks all I get is a permanent "Discovering Sbricks".

    In order to check the visibility of an SBrick I have installed the utility Nordic nRF Master Control Panel.  Using this  can discover an SBrick, connect to it and even Bond with it.

    Basically, I'm left with 2 useless Sbricks due to what appears to be faulty software which appears to have no user documentation.  I had hoped that with the understandable delays in SBrick delivery we would have had working software to use with them.

    Is there any realistic timescale for getting the Android app to work??

    • 26 posts
    December 27, 2014 1:35 PM CET

    The sBrick team wants to integrate support for some lower Android versions next year. But you will need an OTG cable and a special bluetooth dongle.

  • December 27, 2014 11:54 AM CET



    i receive my 2 sbricks today and i have a Samsung Galaxy Note GT-N7000 with 4.1.2 Android version (it's a last version available). It's over or a version for old Android version is prepared? Sorry for my English, i'm French.

    This post was edited by Romuald Marechal at December 27, 2014 11:59 AM CET
    • 34 posts
    December 26, 2014 4:22 AM CET

    Installed the app today - fresh from Play store, 0.0.20 the app info says

    Victims - HTC One with 4.4.3 and Google Nexus 7 2nd gen with 4.4.4; Volvo 350F and Crawler

    here are my comments

    - "All further steps will be explained through the SBrick app itself" - Not. I know it's an early alpha, but there are probably hundreds SBrick on the way to users that will end up with puzzled expression as in "what to do now?" A simple numbered list on first screen would be good start or a help button.

    - Fortunately I could add my SBricks and test them without problems

    - Linking and unlinking profiles results in app crash - not consistent behavior, sometimes yes, sometimes no

    - After linking Sbrick there is no explanation what are the input types, or in the profiles ... there is no way to know which control is linked to which input name

    - How to invert input ? Is this the ON/OFF button next to channels ? Haven't found any impact of changing those ... and haven't found any invert

    - Out of the 7 profiles in 0.0.20 I found only the Gamepad 2 working close to expected. Gyro ones do not really work (calibration ?), joystick sensitivity is off,...

    - On HTC phone the controlls on Gamepad2 were quite good, although with smaller screen and non lockable controll positions, the control would eagerly center itself upon slight miss of focus.

    - the Nexus tablet was worse of, the controlls seemed more random and for some reason there was kind of lag to even basic inputs.

    Even with all this, it has some promise as I spent quite some time running the Volvo through the port tester sliders. The Crawler could be driven with that one profile and still can be fun.

    • 9 posts
    December 25, 2014 11:22 PM CET

    Hi guys, still no success - I tried that Nordic app also on my LG G-pad 8,3 with Android 4.4.2 - just once I also got this message in log when trying to bond it with SBrick:

    ERROR (0x85): Gatt error

    Got this topic om the web:

    Any ideas?

    • 57 posts
    December 25, 2014 10:39 AM CET

    Maybe you're experiencing a similar problem to the one I described in my post from 24.Dec at iOS topic.

    Check there for my solution - Switch BT off at you iPhone for awhile.