Forums » Support

Back To Topics

SBrick Android App

    • 95 posts
    January 6, 2015 9:36 AM CET

    Verson 22 is available. I have cleaned the cache, deleted the datas, uninstalled the application before installing the new version

    (I have a gt-i9505 runing stock 4.4.2) I have downloaded Test 2 and port inverter works fine now :-)


    I am now looking forward to be able to control 2 channels with only one slider


    Thank you for this update





    This post was edited by Frederic Ayrault at January 6, 2015 9:37 AM CET
    • 57 posts
    January 6, 2015 1:17 AM CET


    It is stated in several places that SBrick requires a BLE (BT Smart) compatible device.

    It is also written that Android brought support to this only with version 4.3.

    First you can check if your hardware supporte BT Smart. Then if it is the case you can look for cooked ROM with a newer Android version, that supports the required functionality.

    SBrick is great if you have the right hardawre. Involved technology is quite new, so a couple of double checks are required to know if you have some chances to get it working with your current hardware before buying SBrick. Otherwise the only option is to upgrade to a newer Smartphone or Tablet.




    This post was edited by Fernando Correia at January 6, 2015 1:17 AM CET
    • 2 posts
    January 6, 2015 12:42 AM CET

    I'm very surprised and disappointed after the excitement of receiving my sbricks.

    I tried to get the app from Google play and it says it is incompatible with both my Asus tablet and my ZTE smartphone (android 4.2.1 and 4.1.1 respectively).

    What can I do to work this around, maybe I didn’t read some instructions, or when are you expanding the app to a broader range of devices?

    I still admire your work, now I just want to take advantage of it…



    • 25 posts
    January 5, 2015 6:44 PM CET

    I agree with Jetro.

    Rather than doing profiles, I think it would be better to split the screen into small sections, for each of which user can choose slider (for example 2 vertical units, 1 horizontal unit (or the contrary if positionned in landscape)), button (1 V unit x 1 H unit), joystick (2 V units x 2 H units), gyro (idem), ... controls and place them like he/she wants (and zones for naming (like "door opening" or "train A speed"), then configure with which Sbrick each control would be affected (with inverterds), then save his display.

    Like this, train users, for example, could control several trains in the same screen on a tablet, including lights, rail junctions, or other particular functions.

    Thank you, and happy new year !


  • January 5, 2015 3:41 PM CET

    I have just received my sBrick today. I was able to install the app on my Samsung Galaxy S2 (custom ROM: cyanogenmod, Android 4.4.4) and my Samsung Galaxy Tab Pro 8.4

    A few comments on the app:

    • The sBrick hardware is useless without a decent app. While I am happy to have received my sBrick around the expected time and the quelity of the sBrick appears to be good, not having a working app within the same timeframe does detract from the overall experience
    • The app appears to have been made only with phones in mind. I cannot use it in landscape mode except for some specific screens
    • I was able to download the profiles in the market tab, but the app is going to need some serious help files! Rather than having to first create a set (only MOC for now) and blindly choose a profile (no indication of what each profile actually contains) it would be good to be able to select a profile and use it on the fly by adding a "configure" button on the profile screen. That way you can easily see and test profiles before you assign them to a creation. Right now the only action I am offered when clicking on a profile is "delet" !?

    Please push out a general update to the backers when you have a functional beta of the app

    • 21 posts
    January 4, 2015 2:43 PM CET

    Dear developers,
    When can we expect a patch on app with elimination of undetected Sbrick on Samsung S3? Can you name the time - one week, two weeks or month ...

    • 1 posts
    January 3, 2015 1:17 AM CET

    I received my SBrick a few days ago. The iOS app works alright on the iPhone 4S. It connects to the Sbrick most of the times. I can download profiles from the market,
    and most of them works.I have the same problems as many of you have mentioned; the motors stop when full power is applied, and "identify LED" does not work.

    Also also have a Galaxy Note (GT-N7000). This device does originally only support Android versions up to 4.2.1, but for the sake of the Sbrick, I rooted
    and flashed it to Android 4.4.4 (using Slimroms). The Sbrick app works almost perfectly now! Motors can be powered 100% without shutting down, both in the port tester and in the various profiles.  Identify LED also works.

    • 7 posts
    January 2, 2015 10:57 PM CET

    Samsung Galaxy S5

    Android 4.4.4

    SBrick version 0.0.21

    Port testers work.

    Profiles can be downloaded from the market.

    Brick can be paired.

    No profiles work with the paired brick, varied bugs similar to those already reported - gyros don't work, some motors/ports don't register.

    Shrill sound appears to be motor braking when sliders are in the "off" position, but not actually off. Recommend adding a "dead zone" to all self-centering controls where the motor is physically off to improve battery life.

    Product is essentially unusable at this point.

    When is there expected to be a profile building tool?

    • 10 posts
    January 2, 2015 10:08 PM CET

    The description in the Android Market (now) says "This is an alpha preview build, not for production use!".

    So the team is working on somethine better, it just means Android users have to wait. It may not be ideal but since the hardware is done and the iOS App seems OK a lot of people can work it fine.

    I can wait!

    • 17 posts
    January 2, 2015 6:51 PM CET

    I would probably describe it as Alpha rather than Beta considering most of it doesn't work, especially in comparison to the iOS one. (Which is an entirely different looking app)


    Generally, at the moment the port testers work most of the time. The LED tester only work on rare occasions.


    Amusingly, I have an S4 which can connect to the brick but with a very unstable and unfunctional app and a Apple 4 which has a nice app, but can't connect. Fun and games!

    This post was edited by Toku Betsu at January 3, 2015 6:11 PM CET
    • 28 posts
    January 2, 2015 6:45 PM CET

    Just received my SBrick in the mail. Installed SBrick app v0.0.21 from the Play Store.

    I have a Nexus 4 running stock Android 5.0.1.

    Here is my feedback for the app:

    • I cannot delete Sets.
    • When I try to remove Linked Profiles while editing a set the app crashes.
    • I cant get any of the profiles to control the SBrick.
    • Using "Identify led" and "Port tester" is the only way that I can control the SBrick.
    • As soon as I try any of the linked profiles in a Set, the menu becomes unresponsive. I can slide it open but none of the options work.
    • The market only loaded once.

    I hope this helps yous guys somehow.

    Unfortunately I cannot control the SBrick in order to control my creations.

    Let me know if there is anything that you would like me to try out and give you feedback!


    • 34 posts
    January 2, 2015 4:16 PM CET

    Would you provide your SBrick connection status to the statistics thread I tried start ?

    It should not replace this one, just used for collecting pure statistics on which device type/model is generally connecting OK or not.

    • 25 posts
    January 1, 2015 3:49 PM CET

    Hi gents,


    Give feedback (always useful for developers - include your android version and phone/tablet model), but keep in mind that the android actual version of the app is still in development, it's a beta version just released for us to test our just received Sbricks and be able to play a little bit during our vacations.

    After all efforts done to have the hardware ok and send it, I think Sbrick team can have a little rest during this holiday period, even if we are also on holiday, with our Sbricks, impatient to see them animating our models.

    Let's be comprehensive and patient... Roma did not get built in one day!


    Sylca (simple backer)

    This post was edited by Sylvain CACHEUX at January 1, 2015 10:47 PM CET
    • 9 posts
    January 1, 2015 10:59 AM CET

    [blockquote]Zsolt Pogonyi said:

    Hi Everybody!

    I can't pairing my phone with SBrick. I have Sony XPeria SP, Android 4.3, BLE Checker say BLE Supported. nRF Master Control Panel can connect, without previosly pairing. SBrick LED blink shortly after switching power on. I tried it with AA batteries (8881) and rechargeable battery box (8878). My phone bluetooth settings found the SBrick, but can't pairing. I have the latest SBrick Android App version 0.0.21 and this can't discover SBrick. Please help!



    Hi same phone, same problems. The first time I was able to pair with SBrick, but since the older version of the app didn't work, I unpaired the devices in order to start the whole procedure again - then I couldn't pair my devices anymore. I tried to clear the bluetooth cache, but it seems it doesn't clear right, there are always 12kB of data in cache that just won't go away. I tried the same on XPeria M, first time pairing wnet ok, app was working, after unpairing, no pairing could be done again!

    • 1 posts
    January 1, 2015 5:09 AM CET

    Seems to be a huge gap between the current app version 0.0.21 and what is shown in some of the promotional videos.  


    And certaily acts like 'alpha' software.  Certainly has a lot of potential.  Is there a timeline for a beta release that might be more usable and closer to some of the promotional videos?  





    • 3 posts
    January 1, 2015 1:12 AM CET


    I currently have a fully up to date samsung galaxy note 3, I am having trouble controlling my creations at all. The profiles in the app can't be adjusted, and for some reason the motors I am trying to power are acting really weird. I can't wait till the adroid app catches up with the ios one because right now it's between the android app and my iphone 4s which isn't exactly compatable with the app screen size wise (more details in the ios forum...). Bottom line, I can't easily control my creations so I hoping for a some serious updates. I know you guys are trying your best, just trying to share my experiences so far... 



    • 34 posts
    December 30, 2014 11:38 PM CET

    [blockquote]Sylvain CACHEUX said:


    Interresting point: when having a pb with a profile, go to market, delete profile, then redownload it and it works better! (does not work with joystick or gamepad 1 for me - sometimes app crashes when deleting the profile in the set edition)


    Thanks. Your confirmation of this behavior had me trying again and succeeding.

    I want to add, that for the profile to reload I needed to remove it from all MOCs. I tried deleting it from market before and it failed reloading, but left it linked to one of the early MOCs. 

  • December 30, 2014 11:22 PM CET

    A profile type for 42030 (or other officials models) exist in market?

    • 25 posts
    December 30, 2014 6:18 PM CET



    I went with further tests.

    Test1 profile is ok, but button does not switch off the lights (light turns on, but when switching off the button, displays shows it off, but light are still on). Interresting point is that it's possible to have all range of lighting with a slider, not just on/off !!! That opens possibilities! Note: sometimes, when releasing the slider, it comes to center, but the motor is still working.

    One useful thing would be to have a reminder on the profile's displays with which slider is "slider 1", which is "slider 2", etc. (idem with buttons). That would help a little bit (even maybe add to which port it's linked!).

    Profiles which uses gyro are not really working well with my phone (Samsung Galaxy Note 2). Impossible to get them work correctly (zero or full speed, direction not taken in account, etc.).

    Joystick or gamepad 1 (display pb - the joystick stick does not appears) not working either. Gamepad 2 also have pb, impossible to get it work, and displays seems to be corrupted/distorded.


    Interresting point: when having a pb with a profile, go to market, delete profile, then redownload it and it works better! (does not work with joystick or gamepad 1 for me - sometimes app crashes when deleting the profile in the set edition)

    I know it's still under development, it's just to give you a feedback :-)

    See you later... (and warn me if you need a test :-) )


    • 1 posts
    December 30, 2014 10:52 AM CET

    Hi Everybody!

    I can't pairing my phone with SBrick. I have Sony XPeria SP, Android 4.3, BLE Checker say BLE Supported. nRF Master Control Panel can connect, without previosly pairing. SBrick LED blink shortly after switching power on. I tried it with AA batteries (8881) and rechargeable battery box (8878). My phone bluetooth settings found the SBrick, but can't pairing. I have the latest SBrick Android App version 0.0.21 and this can't discover SBrick. Please help!

    This post was edited by Zsolt Pogonyi at December 30, 2014 1:27 PM CET
    • 25 posts
    December 30, 2014 9:22 AM CET



    Just a suggestion: as there is more and more profiles, it's becoming a little bit hard to remember which one have sliders, or steering whell, or light switches.

    So it would be very nice that, when selecting the profile, we could have a little image of the controlers, just to quickly see which profile it is really in terms of controlers.


    And as previously asked, inverters for each port would be very nice to have.


    Thank you :-)



    This post was edited by Sylvain CACHEUX at December 30, 2014 9:22 AM CET
    • 10 posts
    December 30, 2014 1:59 AM CET

    [blockquote]Maxim Baybakov said:At least we have three people with a problem "discovering sbrick..." using Galaxy S3. I hope we will not stay without attention![/blockquote]

    Make that 4...

    • 17 posts
    December 30, 2014 1:34 AM CET

    They should put the profile for the 42030 up on Market if it works. At least people could do something with it.

    • 4 posts
    December 29, 2014 11:20 PM CET

    [blockquote]Sylvain CACHEUX said:

    Edit: I uninstalled the app, reinstalled, redownload the market, recreate a new moc profile, and this time it worked! I do not know what changed, I guess the cache has been reset.


    Same here, Android app crashes and you can't save an sbrick in a moc until you uninstall and re-install.

    As mentioned elsewhere the brick makes a high pitch whine when operating, and there's no obvious way to reverse inputs it seems. Also noticed that sometimes on 'releasing' a slider the motor not stop, and you have to tap in the middle position when the control already is to stop or centre.

    All that, given it's in Beta and I've got it working within an hour I'm quite happy :-) Just have to remember down is forward, and up backwards...


    • 34 posts
    December 29, 2014 10:34 PM CET

    Which profile did you use ?

    No problems with reversing inputs ?