Forums » Support

Back To Topics

SBrick Android App

    • 16 posts
    February 11, 2015 8:16 PM CET

    For some reason I missed the announcement of SBrick Control "lite"... Good news, it works great on my Asus memopad 7 ME572C!

    • 23 posts
    February 11, 2015 8:04 PM CET

    Now my profile is visible in the market. I downloaded it but that's when all kinds of things started to go wrong:

    * The profile doesn't shop up correctly: the joysticks buttons are white, the sliders and joysticks are placed too low. Below is a picture so you can see the difference between the correct iOS profile (top) and the incorrect android version (bottom)

    * One MOC can containt multiple SBricks, but I can controll only one. It doesn't matter which SBrcik I select in the MOC-edit page, I end up controlling the same SBrick every time.

    * The only button that works in the profile is the close button, everything else (including touching only the background) crashes the app.

    * When downloading the profile from the market, it never gives the message Download complete

    * When selecting an image for your MOC, it never gives the message Complete

    * Everytime I reopen the App, I have to login again, whereas the Ios app keeps you logged in

    I'm using Sony Z3 compact, android 4.4.4, PD in chrome, App v0.0.41


    This post was edited by Jurgen Krooshoop at February 11, 2015 8:24 PM CET
    • 5 posts
    February 10, 2015 6:25 PM CET


    Version 1.5 works like a charm. Connecting is really fast. Sudden disconnects/loss of control happen sometimes, but the app will recover from them and reconnect really fast (0,1 to 1 sec)



    • 178 posts
    February 10, 2015 10:39 AM CET

    The new version is in the store, it indeed fixed the long (re)connection time problem, at least for me.


    With LG G3 phones it took sometimes MINUTES to connect in like 1 in ever 4 occasions.

    With my Sam. S4 with CM11 snapshot connect time is aroun 0.1 sec every time ;)


    Give it a spin folks!


    jean-christian rey: please test the latency, one of the fixes I've made might have fixed that too. If not, than that's a firmware - application - operating system incompatibility issue and will require further tweaking, even firmware modification.

    • 178 posts
    February 10, 2015 8:01 AM CET

    Thank you all for the feedback.

    I've found the problem that caused the slow connection. Basically Android can connect automatically, whenever a device becomes available. This means it probably has to try for a long time. The other method is to connect immediately, because we know the device is available. In the first case, the OS only scans "lazily", and misses most of the advertisement packets. In the seciond case it does much better job discovering devices quickly.

    Of course I've choosen the wrong method.


    The latency can also be caused by this, as a the connection parameters could also be set up to be "lazy". This is fine for a smart watch, but not for an SBrick. Latency can also be caused by recent firmware, as the new firmware is smarter, but slower. This will either be solved in the next release in a few hours, or I'll implement version detection and "quick drive" as we call it. That consumes less bandwidth and using it instead the old DRIVE command results in more stable connections and even slightly better range.


    This post was edited by Tamás Fábián at February 10, 2015 8:01 AM CET
  • February 10, 2015 12:44 AM CET


    thank you its working on lg-700

    but there is a latency,more than 3 second

    • 5 posts
    February 10, 2015 12:00 AM CET


    First respons on the emergency app version 1.3:

    Works like a charm, no latency, no humming sound, no occurence of motors getting stuck or not gearing back to idle position, no need to reset app or brick. There are still some disconnects present (but much less as the full app), but the app will recover from that by reconnecting after a while (reconnection can however take 30+ seconds)

    Also reconnects nicely if power is cut temporarily from the Brick or the phonescreen is turned "off" for a moment

    In short, this is exactly what you would expect as minimum basic functionality of any usefull app.

    Tested on Xiaomi Mi2S Android 4.4.4 (Miui 6)


    Martijn Nab


    This post was edited by Martijn Nab at February 10, 2015 12:10 AM CET
    • 178 posts
    February 9, 2015 8:40 PM CET

    Hi everyone,

    I apologize for this unfortunate regression in the Android application.

    We're of course in the middle of resolving the issue for good, but this still won't help you what I think would be fast enogh.

    I've written a new, but fairly simple Android application. We used something similar during the development and testing of the electronics and firmware.

    It's more reliable exactly because of it's relative simplicity, this means no profile designer, and no versatile profiles, only a simple four slider controller.

    You can find it in the play store under com.vengit.blecontrol: , it's name is "SBrick Simple Control".

    There is a version under review that works around the firmware bug, please allow a few hours before it gets into the store. The most recent version is 1.3.

    Please read the app description.

    Please install & test.

    Any feedback will help the original (an partly already re-written) application to be better.

    This post was edited by Tamás Fábián at February 9, 2015 8:45 PM CET
  • February 9, 2015 3:36 AM CET


    i want to know ,there is an update for lg-700?(android)

    because its not functionnal again and i ask for myself if i will be change that for another one day ?alaways,that not reconize the Sbricks

    • 5 posts
    February 8, 2015 7:37 PM CET


    My short summary after testing the new akp and profile designer.

    Xiaomi Mi2S on Android 4.4.4 (Miui 6)

    • Profile designer works best under chrome. Else it gets stuck in "saving" mode when you want to save the profile. In a complex profile with background etc also Chrome got stuck
    • When you select your profile in the market, it gets no checkmark showing it was downloaded. Only when you exit it briefly shows the checkmark
    • Horizonal sliders are compressed into 4:3 ratio when designed for and shows on a 1280x720 (16:9) screen. This makes them look weird. Light and buttons are shown correctly. The new offical profiles (like the hand-drawn driving controls) also has this.
    • The light will go on, but never off, as mentioned in many previous posts.
    • The M-motor will not return to "off" mode, but keep poducing a humming sound which means that on idle position still some power is being applied.
    • The 0.41 app with profile designer still break connection a random moments. Reset of the app, the brick and the BT connection are then required to find the brick again


    So conclusion: You guys added another set of unreliable tools with new failure modes like the motors not stopping completely to a basic functionality that is not at all improving by any serious amount.

    Guys, stop this BS and get the basic app working. The fact that you cannot get a stable connection between the app and the brick is getting quite embarassing!




    • 25 posts
    February 8, 2015 5:55 PM CET


    Used new version and progile designer. Saved 2 simple profiles, installed apk.

    Appli still crashes (and more often than in previous version). Button are still blocked in "on" position (even if displaying off icon), impossible to get lights off with button... (incredible that it's not solved yet, regarding all other things done, this should not be that complicated to debug...). Impossible to log on in the app to get back the profiles done in profile designer. I changed pwd to be sure, but nothing to do. App does not show anymore the profiles that was working before... Joysticks not working in the app. In last profile, buttons switch on the lights/motor, but the displays is still off. Retaping get a displays to on, but lights/motor is still on (instead of getting off, as it's the 2nd tap).

    conclusion: some progress, but still disappointed.

    Finaly managed to log in in the app, but with my email address (not pseudo or full name). Should be indicated that app asks for the email address. Some weird displays (several buttons/slider appears although I took only 1 of them (solved after clearing the cache), impossible to delete the sbrick in the model settings (no trash icon), the profile stops responding (all switching off and the nothing, have to go out and in agin, same pb with buttons as described above, ...). Application should have a button to clear cache.

    I also noticed that leds are geting less bright a short instant when "sliding" a motor to full speed, the full reverse, full speed, etc. Each time, the led have a short instant less light. I think that the current call of the motor is the source of this problem, but I did not noticed it before. It's worrying me as the sbricks specs was indicating that the current handled was high enough to support high load. So it should not be a problem for sbrick to have a motor sollicited.

    This post was edited by Sylvain CACHEUX at February 8, 2015 5:55 PM CET
  • February 8, 2015 2:54 PM CET

    I found the dropbox link under and announcements.

    I have just tested both the Profile Designer and the latest Android App. Even the version is still 0.41, it is new. I guess the reason the version no. is not changed has something to do with the fact that it is not avavilable at play store yet (and why they make available a separate link). I uninstalled my previously installed SBrick App, and installed this one.

    Even there is still some stability issues, I am able to make my own profile from my laptop and use it on my Samsung S4. Even it was a very simple test, it worked very well. I didnt experience any delay in the control, the control of my little teest car is way more accurate and faster than that with LEGO remote.

    The major remaining issues, as I see it:

    - Stability, the App looses connection with the SBrick very often when I am doing something in the App. However, once a profile is started, I can drive for a long period of time without loss of connection. So it is more like very irritating, rather than a show stopper. What I do in such situations, is that I stop the app, turn off the power to the SBrick, start the app, turn on the SBrick. This procdure works almost every time.

    - Joystick control doesnt work yet.

    - A very limited selection of controls are available in the designer yet.

    I have not tried with several SBricks yet, but I will do so later.

    Thanks for good progress! This is looking promising, and I am confident that we will get more the coming weeks.

    • 5 posts
    February 8, 2015 12:07 PM CET

    [blockquote]Frederic Ayrault said:

    Ok I am starting to understand the new version with login is available from the link on dropbox in the home page.

    The first problem is there is no version in the file name and when the app is installed the version is still 0.0.41 !



    Where did you find this dropbox link? I have no clue where to find it, and also no update in the android app-store.

    As many I am also getting kind of frustrated by the Vengit not being able to meet their own promises....




    • 95 posts
    February 7, 2015 5:53 PM CET

    Ok I am starting to understand the new version with login is available from the link on dropbox in the home page.

    The first problem is there is no version in the file name and when the app is installed the version is still 0.0.41 !

    And I still have connection problems!

    I can not see the slider created with the profile designer in the ports and channels

    I can not control two motors with the same slider (gamepad with buttons profile)

    The app still crash



    • 25 posts
    February 7, 2015 4:12 PM CET

    Indeed, open source would be so nice.

    Anyway people need the HW, so there is no loss of anything for VengIT...

    • 24 posts
    February 7, 2015 2:17 PM CET

    [blockquote]Denis H said:

    Samsung Galaxy S3

    Android 4.3

    Last sbrick app (the one with profile designer feature)


    Still i can't discovery and connect my Sbrick.

    You guys should focus on deliver a working app, before go further.


    I couldn't agree more, Denis.

    I have been involved with software development for over 50 years (yes, I am that old) and the most basic rule is that you don't play with bells and whistles until the basic app works.

    Please, please, please if getting the software to work is beyond the capabilities of the current team make it Open Source - I'm sure that someone will be able to do the job!


    • 41 posts
    February 7, 2015 2:02 PM CET

    Samsung Galaxy S3

    Android 4.3

    Last sbrick app (the one with profile designer feature)


    Still i can't discovery and connect my Sbrick.

    You guys should focus on deliver a working app, before go further.

    • 95 posts
    February 7, 2015 1:13 PM CET

    Yesterday we were supposed to get a new version...


    • 4 posts
    February 7, 2015 10:20 AM CET

    [blockquote]Sylvain CACHEUX said:



    Not solving either the button swicht off problem... (v0.0.41 on samsung galaxy note II with Android 4.4.2)

    I'm not there have been a new release, as I think reminding that my last test was also with v0.0.41...




    Same here. The SBrick software version is still 0.0.41.

    And it still can't discover the brick with my Op3n Dott tablet. The tablet has Intel SoC, I'm starting to think that this might be a problem.

    • 25 posts
    February 7, 2015 9:33 AM CET



    Not solving either the button swicht off problem... (v0.0.41 on samsung galaxy note II with Android 4.4.2)

    I'm not there have been a new release, as I think reminding that my last test was also with v0.0.41...


  • February 7, 2015 9:03 AM CET

    New app version did't solve problem of using two outputs for one function. If we assign same function for two or more outputs - only one motor will work. 
    For all I know - this is not new problem, people said about that about month ago. Should we hope that developers will undertake something soon?

    • 95 posts
    February 5, 2015 10:54 PM CET

    I think you can find here some guys who can help you.

    But I think you should first try to solve connections problems before adding new fuctions.

    I also think you should release more versions to let us help you to see if fixes works.

    If I agree about we need profile designer, I think you should add other functions before like using more than one SBrick to be able to use the 42009S or the ultimate version (for me I also would like to be able to control 2 channels with the same slider


    I think I can wait to have a full working version but I do need to see some progress...


    Thank you






    • 21 posts
    February 5, 2015 7:48 PM CET

    [blockquote]Maxim Baybakov said:

    I have the same "long" delay. Especially when using steering control or two ports.
    When the slider quickly move in different directions, for example 20 times, brick continues to perform these commands for 15-20 seconds.

    Several times the application was closed itself.

    Inversion of ports does not always work (if on/off is the inversion).
    (Samsung Galaxy S3, 4.3)


    Was this promlem solved? This delay limits the using of sbrick very much.

    • 19 posts
    February 5, 2015 5:17 PM CET

    looking forward to test next version, you bet i will report if still not working :)

    • 340 posts
    February 5, 2015 4:31 PM CET

    [blockquote]Gábor Polczer said:

    yeah Lénárd, i can provide such on nexus 5 & 9, perfect for lollipop testing. just define what you need.


    Sounds great, thanks! :)

    I will come back to you if the next release not work with Nexus.