Forums » Support

Back To Topics

SBrick Android App

    • 2 posts
    September 17, 2019 5:27 PM CEST
    Donát Raáb said:
    Marko Kovač said:

    Same problem here, Samsung Galaxy S9 fully updated and the newest version of SBrick application. Can't connect to SBricks in the application. In bluetooth settings I can pair and unpair with the SBricks. All other bluetooth devices work without any problems.

    I wrote you through the application bugreport form, via contact e-mail address and got no answer whatsoever. Not good SBrick team, not good...

    What you can actually do while they fix it or answer is to get the last working .apk installer.

    I found a previous version here:

    https://apkpure.com/sbrick/com.vengit.sbrick

    it is safe to download and will work again, however you have to set up your creations again.

    Also go to "Play" application, and between settings disable automated update (or update only via Wi-Fi) options to prevent the previous version getting updated.

    Thanks, I also thought of that, but knew that I will loose my creations...

    Luckily I managed to download the creation from my profile on the web.

  • September 17, 2019 5:10 AM CEST

    I can not confirm any issues with version 4.5.5 on a Google Pixel XL with Android 10. I had the same problem as others are describing it now with a previous version on the same device. Not sure, but I think it was 4.5.4. It looks like the way it was implemented in previous versions is working until Android 9, but not on Android 10, and the way it is now implemented does work on Android 10, but not on previous versions. Maybe you must implement both ways and check somehow the Android version or API version on the devices the software is installed on. But that's just my assumption. Hope you do not just reverse all, because I assume my problems would reoccur on Android 10 then. ;-)


    Thanks for your work,
    Marc

     

     

    • 2 posts
    September 16, 2019 9:11 PM CEST
    Marko Kovač said:

    Same problem here, Samsung Galaxy S9 fully updated and the newest version of SBrick application. Can't connect to SBricks in the application. In bluetooth settings I can pair and unpair with the SBricks. All other bluetooth devices work without any problems.

    I wrote you through the application bugreport form, via contact e-mail address and got no answer whatsoever. Not good SBrick team, not good...

    What you can actually do while they fix it or answer is to get the last working .apk installer.

    I found a previous version here:

    https://apkpure.com/sbrick/com.vengit.sbrick

    it is safe to download and will work again, however you have to set up your creations again.

    Also go to "Play" application, and between settings disable automated update (or update only via Wi-Fi) options to prevent the previous version getting updated.

    • 2 posts
    September 16, 2019 8:50 PM CEST
    Donát Raáb said:

    Dear Support and community,

    my SBrick software for Android got updated, since then however I have my SBricks turned on the app couldn't find them. Before update if worked like charm for years. I need to run my trains at show ASAP.

    Troubleshoot guide steps didn't work.

     

    Same problem here, Samsung Galaxy S9 fully updated and the newest version of SBrick application. Can't connect to SBricks in the application. In bluetooth settings I can pair and unpair with the SBricks. All other bluetooth devices work without any problems.

    I wrote you through the application bugreport form, via contact e-mail address and got no answer whatsoever. Not good SBrick team, not good...

    • 2 posts
    September 14, 2019 9:44 AM CEST

    Dear Support and community,

    my SBrick software for Android got updated, since then however I have my SBricks turned on the app couldn't find them. Before update if worked like charm for years. I need to run my trains at show ASAP.

    Troubleshoot guide steps didn't work.

  • September 12, 2019 12:02 PM CEST

    Hello Sbrick community !

    I'm don't know if i'm in the good section.

    I just download the new version of Android app + Firmware update.

     

    Now my gamepad doesn't work ...

    Video : https://youtu.be/OUyRplPtIW4

    Best Regards!

    • 1 posts
    September 7, 2019 9:27 PM CEST

    Hi, I'm new to SBrick and couldn't find any answers with a quick search. I tested mine with galaxy S4 and it worked fine, however I cannot see it under SBricks page on galaxy S8 (Android 9). Is it not supported or is there anything I can do?

    Thanks

    • 1 posts
    September 3, 2019 8:42 AM CEST
    Just wondering: My son is a happy user of my Xperia Tablet Z (bought some 5 years ago), which sadly runs only Android 5.x. The official Lego Boost app works on it, but SBrick does not. What is the minimum Android version that the app is able to work on? Is there a chance to get (even an unsupported development version, I understand the risks) the app that will be able to run on that tablet as well? (I know, I should buy myself an iPad or allow my son to use my phone...). Thanks! Jan
    • 198 posts
    July 10, 2019 2:19 PM CEST
    Marc André Wyss said:

    Does someone work on the SBrick App for Android 10? I do not see the SBricks within the Sbrick App on Android 10 (on Pixel XL), but I see them within the Android 10 System itself. Futhermore the SBrick App complains about it was written for an older version of Android when I'm starting it.

    Thanks for any information. And yes I know Android 10 is still beta. :-)

    Thanks for the report, we will check this out.

  • July 9, 2019 7:38 PM CEST

    Does someone work on the SBrick App for Android 10? I do not see the SBricks within the Sbrick App on Android 10 (on Pixel XL), but I see them within the Android 10 System itself. Futhermore the SBrick App complains about it was written for an older version of Android when I'm starting it.

    Thanks for any information. And yes I know Android 10 is still beta. :-)

    • 20 posts
    June 20, 2019 8:32 PM CEST

    coolsmilecoollaughing: good job SBRICK!!! Thank you very much!

    • 198 posts
    June 20, 2019 1:12 AM CEST

    Hi Guys,

    The login problem was fixed. Please restart the app, then it should works. Really sorry for the delay... :(

    • 12 posts
    June 19, 2019 9:57 PM CEST
    Are you serious!? Lénárd, who is a member of the SBrick staff, posted on this very thread just two days ago, saying they were taking care of the issue. How can this be a joke, much less a bad one?
    • 20 posts
    June 19, 2019 9:08 PM CEST

    HI SBRICK? Are you still alive? ANDROID is calling for help!!! This is a very bad joke from you ,SBRICK?

    • 3 posts
    June 19, 2019 3:32 PM CEST

    Any update on android log in issues?

    • 20 posts
    June 18, 2019 9:58 PM CEST

    Hello? Is there still anybody out there? Android is calling for help!!!

    • 3 posts
    June 17, 2019 9:15 PM CEST

    Just made a test and I get the same error message. Guest mode is working.

    • 20 posts
    June 17, 2019 8:40 PM CEST

    The problem with android still continues? Only profile-designer = WINDOWS is fully functional which was not the thing on sunday afternoon when profile... was out of service totally. 

    • 3 posts
    June 17, 2019 3:49 PM CEST

    Wonderful. Thank you!

    • 198 posts
    June 17, 2019 3:36 PM CEST
    RaresBota said:

    Hello,

    I'm trying to log in to android app but all I get is "There is a problem with your internet connection". App tested on different phone with the same result. Is there an easy fix on my end?

    Thank you!

    Thanks for the report, It seems this will a problem at the cloud service, we are on it!

    • 3 posts
    June 17, 2019 3:26 PM CEST

    Hello,

    I'm trying to log in to android app but all I get is "There is a problem with your internet connection". App tested on different phone with the same result. Is there an easy fix on my end?

    Thank you!

    • 3 posts
    January 16, 2019 3:02 PM CET
    Alexandre Campos said:

    Indeed! You could also make it a "control" to be insertable in the Profile Designer, which would display this telemetry data.

    Such an option was very useful.

     

    • 3 posts
    January 16, 2019 2:30 PM CET
    Lénárd Pásztor said:
    PetSild said:

    Hi,

    in the settings there is an option to see the telemetry data such as temperature and voltage.

    If you could set the warning the lowest voltage. Example for lipo 2S value of 7.2 V. The user would then have total control about the condition of the battery.

    Please DEV of the app to add such a feature, a lot of users will be very happy, thank you very much. Pet

     

    How do you connect the lipo to the SBrick? Are you found customer ready solution or you "hacked" a custom cable?

    Very simply, I used the original Lego power connector and soldered my own reduction of 2S lipol.

     


    This post was edited by PetSild at January 16, 2019 2:36 PM CET
    • 198 posts
    January 16, 2019 2:04 PM CET
    PetSild said:

    Hi,

    in the settings there is an option to see the telemetry data such as temperature and voltage.

    If you could set the warning the lowest voltage. Example for lipo 2S value of 7.2 V. The user would then have total control about the condition of the battery.

    Please DEV of the app to add such a feature, a lot of users will be very happy, thank you very much. Pet

     

    How do you connect the lipo to the SBrick? Are you found customer ready solution or you "hacked" a custom cable?

    • 198 posts
    January 16, 2019 2:02 PM CET
    Alexandre Campos said:

    Indeed! You could also make it a "control" to be insertable in the Profile Designer, which would display this telemetry data.

    Exactly! :)