Forums » Support

Back To Topics

SBrick Android App

    • 2 posts
    June 26, 2015 12:46 PM CEST

    [blockquote]Imre Kiss said:

    Try to delete the app and reinstall please!

    [/blockquote]

    Deleted and reinstall several times, but nothing changed.


    This post was edited by Dmitriy Kal'ko at June 26, 2015 12:48 PM CEST
    • 18 posts
    June 26, 2015 11:50 AM CEST

    [blockquote]Dmitriy Kal'ko said:

    Hallo!

    Six months have a sbrick, but never managed fine to use it. Version 1.5 can only update the firmware of the sbrick and login. Sliders in port tested not working. A constantly lit led, while the mute function is available. When will I be able to use your sbrick?

     Device: Samsung Galaxy Note 3 (SM-N9005), Android 5.0

    [/blockquote]

    Try to delete the app and reinstall please!

     

    • 2 posts
    June 25, 2015 8:00 PM CEST

    Hallo!

    Six months have a sbrick, but never managed fine to use it. Version 1.5 can only update the firmware of the sbrick and login. Sliders in port tested not working. A constantly lit led, while the mute function is available. When will I be able to use your sbrick?

     

    Device: Samsung Galaxy Note 3 (SM-N9005), Android 5.0

    • 99 posts
    June 23, 2015 9:45 PM CEST

    Hi all :)

    Two weeks without an update... What's the roadmap now?

    I was wondering if you were working on a new profile rendering module, something that would solve the dismorphing and colors issues ;)

    Marc

  • x y
    • 3 posts
    June 18, 2015 7:27 PM CEST

    I can confirm the fw update ran OK on Nexus 7 2012, with the 5.0.1 factory image, using sbrick 1.5 app in "slow" update mode, with the BT LE Enabler patch. I guess it's worth to try 5.0.1 on a 2013 as well.

    Btw now the above config recognizes the brick, yet I cannot do much with it still. No port test, no profile is kept selected, etc.

    I will maybe come back with a detailed report, but I understand this is a not supported scenario.


    This post was edited by x y at June 18, 2015 7:27 PM CEST
    • 178 posts
    June 18, 2015 2:50 PM CEST

    Hi,

    this is a known issue with the current Andorid release, we're fixing it.

    • 7 posts
    June 17, 2015 2:33 PM CEST

    Hi,

    did someone got the sbrick running on an Nexus 7 2013? I am still stuck in an endless firmware update loop :(  i made a clean installation on a freshly updated (factory ota) android 5.1, to avoid any conficts from older apps orphane files or android 4.4.4,  but the sbrick requests a firmware update anytime.

    regards

    Michael

    • 41 posts
    June 10, 2015 7:24 PM CEST

    Tested the 1.5 version of the app (Samsung Galaxy S3)...seems to improve in a few items.

     

    Issues remaining:

    - The app still crash time to time when discovering the sbrick or when you select a profile.

    - The image in the profile (custom) in the app still looks like color washed, if i look the image with the gallery app of the phone looks normal.

    • 99 posts
    June 10, 2015 4:22 PM CEST

    [blockquote]x y said:

    If not, can someone please send me the fresh 1.5 apk?

    [/blockquote]

     

    I have uploaded the apk of v1.5 here :

    https://drive.google.com/folderview?id=0Bz4836rw3CVWMk5pSWVYVTRGTjg&usp=sharing

  • x y
    • 3 posts
    June 10, 2015 1:40 PM CEST

    Dear Lénárd,

    As I wrote, the Play Store doesn't show the SBrick app for my device, which I guess is normal, as there is no official BT LE support.

    I haven't checked since my last post. Did you change something in the Store config? Shall I retry?

    If not, can someone please send me the fresh 1.5 apk?

    • 99 posts
    June 9, 2015 11:23 PM CEST

    Hi all,

    I have upgraded to v1.5: now we have a clean app! You seem to have corrected a lot of "details".

    Questions:

    - What do you mean by "Duplicate creation bug fix" ?

    - Do you have plans for the profile rendering module ? We still have dimension, position and color issues...

    • 340 posts
    June 8, 2015 4:26 PM CEST

    [blockquote]x y said:

    Hello. I have actually almost managed to get SBrick up and running on a Nexus 7 (2012). I will add the instructions to the Wiki, but first I would need as many version apk-s as possible. I found only a 0.8 as a standalone download, and of course nothing appears for the tablet in the Play Store, as no BT LE support (officially).

    Yet, it turned out this can be fixed with an app. So now I have an SBrick found in my app 0.8, but I cannot add any profiles, thus I cannot continue with setup. Please make the recent versions as apk available for test purposes.

    Thanks.

    [/blockquote]

    Hi,

     

    Did you tried the 1.5 from the google play?

    https://play.google.com/store/apps/details?id=com.vengit.sbrick&hl=en

  • x y
    • 3 posts
    June 5, 2015 8:15 PM CEST

    Hello. I have actually almost managed to get SBrick up and running on a Nexus 7 (2012). I will add the instructions to the Wiki, but first I would need as many version apk-s as possible. I found only a 0.8 as a standalone download, and of course nothing appears for the tablet in the Play Store, as no BT LE support (officially).

    Yet, it turned out this can be fixed with an app. So now I have an SBrick found in my app 0.8, but I cannot add any profiles, thus I cannot continue with setup. Please make the recent versions as apk available for test purposes.

    Thanks.

    • 1 posts
    June 1, 2015 8:02 PM CEST

    Hi,

    I just wanted to say that I have exactly the same problem as vijay.  The app calls for a software update of the sbrick and, when I accept, the app crashes (I am now using v1.4, the same thing happend with v1.3).  I don't know if this is related but I also tried sbrick simple control app and it works, although it is not usable because of the huge delay between input and sbricks response (I have to wait ~5s after pressing a button for the engine to turn on).

    EDIT: Sorry, I forgot to mention, my phone is Moto G 2nd gen with 4G LTE running Android 5.0.2.

    Best,

    Paweł


    This post was edited by Paweł Biernat at June 3, 2015 11:45 PM CEST
    • 1 posts
    May 31, 2015 10:16 PM CEST

    I connected an Sbrick to my car today (first time using an Sbrick), everything seems to work on my Nexus 5, but for some reason I don't see how to select the 'joystick' mode, it's not listed in the market.

    How do I use my phone like a joystick, or is this not possible with my Nexus 5 or something?

    • 5 posts
    May 31, 2015 3:12 AM CEST

    Amazing I now have a working Android App! can control two bricks, use a profile, save a profile.  I can switch it on and off and it still works. At last its working as i should although it would have been good have it working like IOS form the start. 

    HTC one 5.0.2

     

     

    • 99 posts
    May 25, 2015 6:03 PM CEST

    You're right, v1.4.1, Fernando :) I was in a hotel when I did the upgrade rapidly without checking what was exactly the version number. And you're - unfortunately - right about the distorted profile display :(

    The rest of the app is operational and has been improved.


    This post was edited by Marc Jaouen at May 25, 2015 6:04 PM CEST
    • 57 posts
    May 25, 2015 11:49 AM CEST

    [blockquote]Marc Jaouen said:

    I have upgraded to v1.5 of the app, but I'm not home and couldn't test it yet...

    [/blockquote]

    I just see v1.4.1 in store!?

    Will test with SBricks in the afternoon. So far just realized there are no progresses regarding the aspect of the profiles when shown at smartphone display. Still appear heavily distorted.


    This post was edited by Fernando Correia at May 25, 2015 12:18 PM CEST
    • 99 posts
    May 24, 2015 11:23 PM CEST

    I have upgraded to v1.5 of the app, but I'm not home and couldn't test it yet...

    As for browsers: I'm currently testing the new Adblock browser, based on Firefox, and I love it!!! This website didn't work well with the android stock browser but works perfectly now :)

     

     

  • May 24, 2015 11:03 PM CEST
    hi vijay,
    the scrolling-problem is a website-problem and only if you use androids default browser or chrome. if you use firefox, scrolling works as it should.
    • 5 posts
    May 24, 2015 9:21 PM CEST

    so i found out that i still cant update the sbrick, but i did spot something.. when i start the Sbrick up, the LED will flash shortly once, and stay off when powerd. updating doesnt do anything, yet i can still turn on/off the LED to test, ports wont work and even though trying evry thing to instal it

    Instal > turn off BLueTooth > turn off the brick > turn off the app > start evrything up > askes again to update firmware..

     

    even tried turning my phone on and off.. no results.. nothing..

     

    Phone: Motorola Moto G 2014 - Android 5.0.2 - 

    Sbrick update setup: Battery box, 6x AA batteries on a stand that can hold my phone and the sbrick so it wont move during updating also using a converter cable conected to the Sbrick to give it power.

    (i havent tried using different batteries yet..)

     

    im also thinking if its possible to update the Sbrick using a Laptop with Bluetooth 4.0.. (windows 8.1)

     

    Edit: just something else i spotted relating to the website, i cant scroll down on the website of sbrick for some reason using my phone.. not sure if the problem is website related or phone related..


    This post was edited by vijay jansen at May 24, 2015 9:24 PM CEST
  • May 23, 2015 2:41 PM CEST

    [blockquote]zver hz said:

    Hello!

    I use some noname android device: model QC706EU, Android 4.4.4, core 3.10.28, CPU Qualcomm MSM8916.

    I've installed SBrick App version 1.4. When I try to connect to my SBrick the app show the message "you need to update firmware". And when I try to update the firmware the app crashes.

    Any ideas?

    [/blockquote] I have tyhe same problem! What could it be?

     

  • May 23, 2015 2:39 PM CEST

    [blockquote]Lénárd Pásztor said:

    [blockquote]Markiyan Cherniha said:

    ''Hello. I need your help. I didn`t uprade my SBrick in v 1.0 . Now i have v1.4 but i can`t still uprade! And now I have problems with discovering... after discovering the app is crashing. So, what should i do?''

    [/blockquote]

    Hello!

    What is your phone type and android version?

    [/blockquote] Hello. My phone ia Fly 4413. Everything works well, 4.4 KitKat. But SBrick don`t work!

  • May 23, 2015 1:41 PM CEST

    [blockquote]Christoph Pfenninger said:

    Hi

    I Updated my Sony Z1 compact to Android Version 5.0.2 and the sbrick to version 1.3. Then i updated my two sbricks with the new firmware successfully.

    Now i can't use My Creations anymore. I can enter to configure my creations to add my profiles, which will not be saved.

    the only way to use my sbricks is, with the Port tester in Manage Bricks.

    I am now very satisfied with this software. I hope it will get better soon. 

    [/blockquote]

     

    Since I deinstalled the complete sbrick App including all my cerations, and reinstalled the newest one, all functions work again without problems. 

    thank you sbrick Team.

    One function i still miss. I would like to control two sbricks with one creation.

    Thanks

    • 8 posts
    May 20, 2015 12:08 PM CEST

    Hello!

    I use some noname android device: model QC706EU, Android 4.4.4, core 3.10.28, CPU Qualcomm MSM8916.

    I've installed SBrick App version 1.4. When I try to connect to my SBrick the app show the message "you need to update firmware". And when I try to update the firmware the app crashes.

    Any ideas?