Forums » Support

Back To Topics

SBrick Android App

    • 95 posts
    April 5, 2015 10:24 AM CEST

    [blockquote]Karsten Grosse said: Looked out for new version yesterday, but nothing in the playstore (still 0.8). Where can I find the new version (which seems to be not working) ? [/blockquote]

    You have to download it



    • 10 posts
    April 5, 2015 10:11 AM CEST

    the others keep update and update and update again..........

    can't use!

    • 10 posts
    April 5, 2015 10:06 AM CEST

    i have 4 nos. of sbrick but just only the 1st one can update the fw, not the others, please help

    thank you

    • 13 posts
    April 5, 2015 9:22 AM CEST
    Looked out for new version yesterday, but nothing in the playstore (still 0.8). Where can I find the new version (which seems to be not working) ?
  • April 5, 2015 8:21 AM CEST

    This time app is much more stable on my Sony Z Ultra, OTA firmware update was sucсessful, but "one function, two ports" feature still don't work. I think that it is not so complicated feature, but devs still can't do anything with it.


  • April 5, 2015 4:32 AM CEST

    Samsung Galaxy Note 4 (SM-N910G) running stock 4.4.4, not rooted or anything. SBrick 0.8 app almost works for me.

    I can add a creation, set the picure and name, add an sbrick and those values seem to persist. But adding a profile doesn't work properly. Specifically, I add the profile (42030 in this case), it shows up but as soon as I leave that screen it disappears. So I can't associate channels on the brick with controls, because when I go into the brick properties to do that the profile vanishes. I can go into the profile control screen, but since no brick channels are assigned the controls don't do anything.

    And of course while I was taking screen shots to report this the app crashed. First time that's happened. Previously I've let the app turn on bluetooth for me, but this time I turned it on while the app was starting (and enabled wifi too), and just after leaving the "scan for device... pairing..." screen the app crashed.

    This post was edited by Deleted Member at April 5, 2015 4:38 AM CEST
    • 95 posts
    April 4, 2015 11:36 PM CEST

    OTA only works when there is only one sbrick powered

    after upgrading 2 sbriks (one by one)

    one is working andfor the other identify led and port testing stop to work !





  • April 4, 2015 11:18 PM CEST

    Ok, I installed the new version 1.0b. The Sbrick is found after about 10 seconds. When I select the Brick is the message "SBrick has been terminated". Will stop after each added a new Creation ????
    This version does not work:-(





    • 34 posts
    April 4, 2015 10:32 PM CEST


    Here is the new android version (v1.0b):

    - device compatibilty fixes, compatibility with many new devices (eg. S3)
    - over the air firmware update
    - quick drive control method implementation
    - new API for faster and better communication
    - design improvements
    - navigation stack fix
    - and many bugfixes.

    Remember to turn off and on your bluetooth after firmware update!

    • 10 posts
    April 4, 2015 8:51 PM CEST

    hello,everybody,i am using galaxy note2(Ver. 4.4.2) and have same problem which is can not using more than one sbrick in one profile control,it's sad because i've bought 4 nos. of sbrick that i want to do all RC on my 42009 and 8043,but not fully working.

    to sbrick design team,thank you for debugs work hard and please keep going to solve problem on android system,i am really don't want to buy ios system.

    btw,i found a small tips on profile design, if i want to use my own image for backgroung,do not upload image format in .jpg,it does not work,but it works in .png format.

    wish you all happy with playing lego creation

    p.s. please forgive my bad english ;p

    • 34 posts
    April 4, 2015 8:22 PM CEST

    1-2 hours and it's here :)

    • 1 posts
    April 4, 2015 8:17 PM CEST

    Any news on the update?

    • 10 posts
    April 4, 2015 4:09 PM CEST

    I sure hope the next release will work, my sbrick is sitting under a pile of dust, hoping to get used this year.

    • 164 posts
    April 3, 2015 10:40 PM CEST

    Altough it seems like a prototype, we are glad to see that not only us but other people also try to make the "Lego experience" better. :)

    Anyway, this topic for our Android app, and the "Terms of Service" ( prohibits any advertisements on our website, so please keep this in mind. 

    @For the others
    We know that our android App doesn't work perfectly on all devices yet, but don't worry! We are working hard on it! Tomorrow we will release a new version of Android application with device compatibilty fixes, over the air firmware update, design improvements, navigation stack fix, and many bugfixes. Thanks for your patience!

  • April 3, 2015 5:46 PM CEST

    Hallo Nikolaus,

    looks good. I think I change the system !!

    I am also from Austria and the SBrick I will soon dispose ;-)

    • 4 posts
    April 3, 2015 4:53 PM CEST

    Hello Freinds of LEGO !


    if You want to see a working system then goto or search on Youtube for bluesmartcontrol !

    You will find some Videos from last weekend during an Exibition in Vienna, where a large Train System was running also with 7 bluesmartcontrols at a time, controlling semaphores, switches, Trains and also an RFID Reader for automatic Train detection !

    Unfortunatly they dont sell by now, because they want to have a working Android App before going public !


    BTW, with "normal" Bluetooth You can connect 7 Units at  a time, but You can have 256 Units paired, thats a fact Android always had !!

    It looks to me that this constraint is also true for BLE devices where You can find "256 Connections possible" !!! It just dont work this way !!


    best regards



    • 13 posts
    April 3, 2015 4:38 PM CEST
    No, I did not tried this yet , because it's the phone of my wife.

    If I kill all her previous BT connections for one try of my lego she may kill me. It's the pairing with our car for example which is a bit complicated. I will try this if others can confirm this workaround.
    • 19 posts
    April 3, 2015 2:51 PM CEST

    [blockquote]Gábor Polczer said:

    for everyone still having issues with controlling SBrick (even from port tester) on Lollipop see my findings below.

    checked v0.8 on three different Nexus 5 phones this weekend, and the conclusion is: my Nexus 5 was still unable to control SBrick until i deleted all my BT pairings/trusted device settings (a headphone and a soundbar were paired/trusted). after doing so and couple of reboots and reinstalls everything seems to be ok now. other two Nexus 5 phones worked out of the box with the same unmodified 5.0.1 OS (they had no BT pairings prior installing SBrick app), so this gave me the idea to check BT settings. reported to devs, i hope this has to something with our issues.


    if it does not help, try to manually pair SBrick with the phone through Android setting. it worked me for the first time (but not later on) and made my SBricks finally controllable in the App.



    have you tried this or not??!

    • 13 posts
    April 3, 2015 2:47 PM CEST
    ... hopefully some fix ... upcoming version...Huh ? Maybe, soon, this is what we hear from the beginning of sbrick, but only promises. I can understand that it is not easy to get the app ready, but I bought the sbrick with the official promise that it works under android. The sbrick does not work with the Moto G2 (only LED on / off) so far. With the IRs it's working. So where is the limit?
    • 19 posts
    April 3, 2015 10:17 AM CEST

    you could have been waiting a bit more and try the next update before leaving. i have had similar 5.0.1 issues on my nexus5 but reported it and found a solution (it was about BT pairings and trusted devices, you can read it above). hopefully devs managed to include some fix for it in the upcoming version, and also android 5.1 will be ok this time. but you know, have fun with the IR.

    This post was edited by Gábor Polczer at April 3, 2015 10:19 AM CEST
    • 13 posts
    April 3, 2015 9:02 AM CEST
    So this week you told us, something should happen with the new Android version. Well, I am very happy with the Android version now on our Moto G2. I can still switch the LED on / off and nothing more. The sbrick is only a piece of plastic and nothing more. And no, we do not have any iOS devices. I bought the sbrick because it should work with Android. :-(
    Still no function on my Volvo 42030. So I put in the old IRs and give up. Thanks for nothing and good bye.
  • April 2, 2015 5:06 PM CEST


    no good android news

    sh.. :-(

    This post was edited by Karl Fensterstock at April 2, 2015 10:27 PM CEST
    • 95 posts
    April 2, 2015 1:09 PM CEST

    [blockquote]Gábor Polczer said:

    would it be better if Sbrick was iOS exclusive? they started development on iOS, and ported it to two other platforms later. Android app is still alpha but will be better with every update, and the next will be a big one as stated above. please stand by give valuable feedback when it's live.


    Once again I disagree. At the beginnig no one told us they will focus on iOS

    For me there is more and more time betwen the update (we also waited 1 month

    since v0.26 to get a working version...)

    March 11th I get a " It is on the todo list, thanks for reporting it! :) " answer


    I think we have already send a lot of feedback, we have asked for more precise roadmad,

    bug traker and some guys also propose to help to debug the app...


    This post was edited by Frederic Ayrault at April 2, 2015 1:09 PM CEST
    • 19 posts
    April 2, 2015 12:46 PM CEST

    would it be better if Sbrick was iOS exclusive? they started development on iOS, and ported it to two other platforms later. Android app is still alpha but will be better with every update, and the next will be a big one as stated above. please stand by give valuable feedback when it's live.

    • 95 posts
    April 2, 2015 12:14 PM CEST

    [blockquote]Gábor Polczer said:

    when devs put in new functions everyone is mad about buggy basic functionality, when they focus on fixing basic functionality users are rushing new functions. hard to make everyone happy, huh?

    for me, it would be fine if the new Android app base functions were finally ok and later they expanded functionality in little steps. one can always borrow an iOS device if some advanced feature is crucial (like showing MOCs @ exhibitions), so it's far not as bad as some folks are saying. if iOS wasn't an alternate option, it would be really annoying, but please keep in mind that Android app is v0.80 while iOS app is v3.7.2 !!!


    Now I can not agree with you because I bought my sbrcks in august, I got them for Christmas and I am still not able to use them for a model with 2 sbricks like the ultimate versions of Jurgen or my train where I need to control two 88002 with the same slider and running in the opposite way.


    And why such a difference between ios android ?

    v0.80 is also one month old!


    This post was edited by Frederic Ayrault at April 2, 2015 12:17 PM CEST