Forums » Support

Back To Topics

SBrick Android App

    • 7 posts
    November 25, 2019 9:02 PM CET
    I can't do the test... Because the step 3. is not clear. Can't find "mode 1 or 2"...
    (magyarul tudjuk valahol folytatni a beszélgetést? Úgy lehet könnyebb lenne. 
    A legújabb szoftverrel a Galaxy s8-ammal is ugyanez a hiba) 
    Lénárd Pásztor said:
    Mikes Attila said:

    Thank you. 

     

    ... And can you make "driver" for Xbox one elite controller via otg cable?

    Because my phone (galaxy s9) handles my controller, but the sbrick app controller settings not work (elöször csatlakoztass egy kontrollert) 

     

    Can you do the steps mentioned below? We need some logs to make it possible. Thanks!

     

    • 340 posts
    November 25, 2019 8:53 PM CET
    Mikes Attila said:

    Thank you. 

     

    ... And can you make "driver" for Xbox one elite controller via otg cable?

    Because my phone (galaxy s9) handles my controller, but the sbrick app controller settings not work (elöször csatlakoztass egy kontrollert) 

     

    Can you do the steps mentioned below? We need some logs to make it possible. Thanks!

  • November 24, 2019 2:56 PM CET

    I have updated the android-app to v 4.6.3, but now the app on my phone (Samsung Galaxy A40, Android 9) does not even see my sbricks (2 connected, hardware v 4, firmware v 0). My phone does see the 2 sbricks, but cant be paired with them (I already had paired and dispaired them once, and after that I never could pair again). With v 4.6.1 the app at least could see the sbricks, but I could not update them (there was no update button vissible), according to v 4.6.1 the sbricks had hardware version 4, firmware version 0. I also have installed sbrick simple control, but that could not see the sbricks either.

    When powering the sbricks, both show a blinking light for a short moment, as expected with firmware v 0.

    Then I tried to connect with an ipad (ipad air 2, ios 12.3.1 (no permission to location!)) and sbrick v 4.5.4. This version does see the sbricks and the led-test works. Surprisingly, today I am also able to update my 2 sbricks to firmware v 25 (which did not work about a week ago).

    Then I tried connecting again with the android app 4.6.3 .... and it works!!

    So, with some minor work around things work again. But it is still strange that the android-app  4.6.3 didnt see my sbricks with firmware v 0.

    Hope this may help others.

    • 7 posts
    November 24, 2019 2:49 PM CET

    Thank you. 

     

    ... And can you make "driver" for Xbox one elite controller via otg cable?

    Because my phone (galaxy s9) handles my controller, but the sbrick app controller settings not work (elöször csatlakoztass egy kontrollert) 


    This post was edited by Mikes Attila at November 24, 2019 9:53 PM CET
    • 340 posts
    November 24, 2019 2:30 PM CET
    Mikes Attila said:

    404...please update this link. 

    Thank you! 

    "Strange.. Can you help with the debugging?

    Please install this app: 

    application link

    then follow these steps:

    1. restart the device (or eat least the bluetooth
    2. pair the gamepad
    3. test the mode "1" (from the 4 options) to  walk in the menu with the gamepad, or mode "2" to move the cursor
    4. set the gamepad mode to "1" from
    5. start the SBrick app
    6. please choose the OK from the shown up pop (input method question)
    7. tap to the pre-selected hw keyboard"

    Then hopefully we have some logs about the problem.

     

    Sorry, fixed.

    • 7 posts
    November 24, 2019 2:23 PM CET

    404...please update this link. 

    Thank you! 

    "Strange.. Can you help with the debugging?

    Please install this app: 

    application link

    then follow these steps:

    1. restart the device (or eat least the bluetooth
    2. pair the gamepad
    3. test the mode "1" (from the 4 options) to  walk in the menu with the gamepad, or mode "2" to move the cursor
    4. set the gamepad mode to "1" from
    5. start the SBrick app
    6. please choose the OK from the shown up pop (input method question)
    7. tap to the pre-selected hw keyboard"

    Then hopefully we have some logs about the problem.

     


    This post was edited by Lénárd Pásztor at November 24, 2019 2:29 PM CET
    • 340 posts
    November 24, 2019 10:53 AM CET
    Krzysztof Marczewski said:

    Looks like the newest version of Sbrick App (4.6.3) still doesn't recognize pad controllers.

    Device is paired! I can even move around app, but cannot set any controls! Still sticking with version 4.4.13 and Brick Controller 2.

    Strange.. Can you help with the debugging?

    Please install this app: https://a.dewsys.com/apps/com.vengit.sbrick-4.6.3-221.apk

    then follow these steps:

    1. restart the device (or eat least the bluetooth
    2. pair the gamepad
    3. test the mode "1" (from the 4 options) to  walk in the menu with the gamepad, or mode "2" to move the cursor
    4. set the gamepad mode to "1" from
    5. start the SBrick app
    6. please choose the OK from the shown up pop (input method question)
    7. tap to the pre-selected hw keyboard

  • November 23, 2019 8:38 PM CET

    Looks like the newest version of Sbrick App (4.6.3) still doesn't recognize pad controllers.

    Device is paired! I can even move around app, but cannot set any controls! Still sticking with version 4.4.13 and Brick Controller 2.

    • 178 posts
    November 20, 2019 4:52 PM CET

    Hello everyone,

    a couple of you complained that no SBricks could be seen after upgrading the SBrick app and/or Simple Control.

    One of our collegues had the same issue, and we successfully reproduced the problem.

    The issue were finally resolved by changing certain settings on the phone.

    The SBrick apps need permission to access the device's location, and the location services must be enabled. This is a limitation of the Android OS and this is so to protect your privacy.

    Since the list of Bluetooth devices correlates with the physical location of the device, all application need to have permission to access location services.

    So, If you suddenly unable to see your SBrick on your device, please follow these steps (the name of the menu items and settings might be different on different devices):

    1. Go to "Settings" and then "Apps & notifications". Choose "SBrick" and/or "SBrick Simple Control". Open "Permissions", and make sure that "Location" is enabled.

    2. Got to "Settings" and then "Security & lock screen". Choose "Location" and make sure "Use location" is on.

    So again, you have to give the application permission to access location AND make sure that location services is actually enabled.

    Feel free to give to give us feedback on this.

    Cheers,

    Tamas

    • 340 posts
    November 18, 2019 2:26 PM CET
    Cristian Sala said:
    1: what does it mean? Your saved configurations, or there is no profile on the "market"? Have you seen that you can adjust the aspect ratio, so the app can scale? It is a new feature that enable use of profiles that not designed for your screen ratio.

    After the automatic update of the app all the configurations stored on mobile are gone. had to re-download all the profile and configure the on all the models.

    a feature to export/import config will be very good!

    5: new bug, you are the first reporter about that. Can you tell your device / OS type?

    Samsung A7 (2017) Android 8.0.0. It seem to happen if I leave the app unused for some time while having the profile loaded and the model connected.

     

     
     
     

    Ok, thanks! Started to fix them. I will report here if I have the date for the next release.

    • 2 posts
    November 16, 2019 1:16 PM CET
    1: what does it mean? Your saved configurations, or there is no profile on the "market"? Have you seen that you can adjust the aspect ratio, so the app can scale? It is a new feature that enable use of profiles that not designed for your screen ratio.

    After the automatic update of the app all the configurations stored on mobile are gone. had to re-download all the profile and configure the on all the models.

    a feature to export/import config will be very good!

    5: new bug, you are the first reporter about that. Can you tell your device / OS type?

    Samsung A7 (2017) Android 8.0.0. It seem to happen if I leave the app unused for some time while having the profile loaded and the model connected.

     

     
     
     

    This post was edited by Cristian Sala at November 16, 2019 1:16 PM CET
    • 340 posts
    November 16, 2019 12:50 PM CET
    Cristian Sala said:

    hello I'm here to report some bugs revealed after the new app update 4.6.1 on Android.

    1) all profile are gone

    2) if you use an sbrick with firmware 23 (or any not latest version) the app says that there is an update, but the button to do the update  is not visible

    3) yesterday we were trying to register a new user with the app but the app did respond with a variable like $[fault] or so on

    4) a guy has associated the controls to the profile in the app, saved, but if he exit the app and re-enter, the association is lost

    5) sometimes the profile is freezing while using it.. you had to terminate the app and restart it

     

     
     
     

     

    HI,

     

    Thanks for the detailed report.

    1: what does it mean? Your saved configurations, or there is no profile on the "market"? Have you seen that you can adjust the aspect ratio, so the app can scale? It is a new feature that enable use of profiles that not designed for your screen ratio.

    2: we temporary disabled the fw update, because we have received some reports about the new firmware can brick the SBrick. I understand this is confusing, it seems we missed to disable the new firmware alert.

    3: known bug, fixed in the next release.

    4: new bug, I've testing it too.

    5: new bug, you are the first reporter about that. Can you tell your device / OS type?

     

    • 2 posts
    November 11, 2019 3:44 PM CET

    hello I'm here to report some bugs revealed after the new app update 4.6.1 on Android.

    1) all profile are gone

    2) if you use an sbrick with firmware 23 (or any not latest version) the app says that there is an update, but the button to do the update  is not visible

    3) yesterday we were trying to register a new user with the app but the app did respond with a variable like $[fault] or so on

    4) a guy has associated the controls to the profile in the app, saved, but if he exit the app and re-enter, the association is lost

    5) sometimes the profile is freezing while using it.. you had to terminate the app and restart it

     

     
     
     
    • 340 posts
    October 25, 2019 3:01 PM CEST
    Marko Kovač said:
    Clément TeClem said:
    Marko Kovač said:
    Lénárd Pásztor said:

    Finally.. the android app went back to the Play store.

    yeah, but does it work?!?

    Good !
    But, I am not enthusiastic to test it ...
    My profiles are complex ... I don't want to configure them a second time if I must rollback on 1.4 foot-in-mouth

    I have only one profile, so I tried it... Of course it doesn't work. Rolled back to 1.4.

    Pretty dissapointing sbrick...

     

    Yes, it is the same version. We now have an android device which can be used to reproduce this bug, so we started to fix it.

     

    • 7 posts
    October 22, 2019 8:04 PM CEST
    Clément TeClem said:
    Marko Kovač said:
    Lénárd Pásztor said:

    Finally.. the android app went back to the Play store.

    yeah, but does it work?!?

    Good !
    But, I am not enthusiastic to test it ...
    My profiles are complex ... I don't want to configure them a second time if I must rollback on 1.4 foot-in-mouth

    I have only one profile, so I tried it... Of course it doesn't work. Rolled back to 1.4.

    Pretty dissapointing sbrick...

    • 2 posts
    October 22, 2019 4:54 PM CEST
    Marko Kovač said:
    Lénárd Pásztor said:

    Finally.. the android app went back to the Play store.

    yeah, but does it work?!?

    Good !
    But, I am not enthusiastic to test it ...
    My profiles are complex ... I don't want to configure them a second time if I must rollback on 1.4 foot-in-mouth

    • 7 posts
    October 22, 2019 4:45 PM CEST
    Lénárd Pásztor said:

    Finally.. the android app went back to the Play store.

    yeah, but does it work?!?

    • 340 posts
    October 22, 2019 2:15 PM CEST

    Finally.. the android app went back to the Play store.

    • 7 posts
    October 16, 2019 6:35 PM CEST
    Jan Přikryl said:
    Marko Kovač said:

    [...]

    Luckily there are other applications which work better...

    Can you elaborate? I am really tired of not being able to use the official app on my son's tablet at all...

    Thanks!

    Jan

    If you have some console with controller which uses bluetooth try BrickController2. I use PS4 controller to drive my modded GT3RS around :)

    • 7 posts
    October 16, 2019 6:31 PM CEST
    Krzysztof Marczewski said:
    Marko Kovač said:
    Lénárd Pásztor said:

    Hi,

    While we working on the next release you can roll back to the previous using this build: https://apkpure.com/sbrick/com.vengit.sbrick

     

    Your latest version of application still doesn't work for me. I rolled back to an older version and it worked. When the newest version came up I thought that you resolved problems with previous build.

    I also had problems with downloading my profile from your web.

    Luckily there are other applications which work better...

    I revert to 4.4.13 because it is only stable version which i could find. Newest 4.5.8 doesnt work and it deletes all my profiles. I also had trouble to connect to my account.

    Same here. That version also works for me.

    • 2 posts
    October 16, 2019 8:08 AM CEST
    Marko Kovač said:

    [...]

    Luckily there are other applications which work better...

    Can you elaborate? I am really tired of not being able to use the official app on my son's tablet at all...

    Thanks!

    Jan 

  • October 15, 2019 10:11 PM CEST
    Marko Kovač said:
    Lénárd Pásztor said:

    Hi,

    While we working on the next release you can roll back to the previous using this build: https://apkpure.com/sbrick/com.vengit.sbrick

     

    Your latest version of application still doesn't work for me. I rolled back to an older version and it worked. When the newest version came up I thought that you resolved problems with previous build.

    I also had problems with downloading my profile from your web.

    Luckily there are other applications which work better...

    I revert to 4.4.13 because it is only stable version which i could find. Newest 4.5.8 doesnt work and it deletes all my profiles. I also had trouble to connect to my account.

    • 7 posts
    October 14, 2019 10:57 PM CEST
    Lénárd Pásztor said:

    Hi,

    While we working on the next release you can roll back to the previous using this build: https://apkpure.com/sbrick/com.vengit.sbrick

     

    Your latest version of application still doesn't work for me. I rolled back to an older version and it worked. When the newest version came up I thought that you resolved problems with previous build.

    I also had problems with downloading my profile from your web.

    Luckily there are other applications which work better...

    • 340 posts
    October 1, 2019 3:39 PM CEST

    Hi,

    While we working on the next release you can roll back to the previous using this build: https://apkpure.com/sbrick/com.vengit.sbrick

    • 38 posts
    September 25, 2019 7:02 PM CEST

    My android still works, but not as properly as before. Are you fellows at SBRICK only making updates if you are drunken?