Forums » Support

Back To Topics

Profile Designer

    • 1 posts
    November 22, 2018 6:05 PM CET

    Hey Guys,

    I need some help with (as I thought) an simple problem. But I can’t find the right solution to solve. Maybe you could help me.

    What I want to operate is just run an M Motor in one direction (forward) for a timed moment of 2,9 sec. (sequence exists, and works), but after that operation I want exact the same, but reverse with the same M Motor.

     

    Maybe there is a possible solution with an circuit, but I don’t know how to figure it out. One though is to use the slider, an when

    I move it upwarts the circuit starts the sequence which runs the motor for 2,9 sec. and when I move it downwarts another circuit starts the 2nd sequence which runs the motor for 2,9 sec in the other direction.

     

    I’m to stupid for that. Any advanced user her, who could help me?

     

    Thanks in advance for your support.

    Regards

    Marc

    • 26 posts
    November 10, 2018 7:14 PM CET

    Regarding my previous post about multiple circuits targeting the same channel:  This could be visually represented in profile designer:

    1. In the target box for a circuit, place a "*" ahead of each channel in the pop up menu which already is assigned to a circuit.

    2. If an already used channel is selected, then a new box appears below and to the left of the target menu.  It lists the circuit(s) that already target the selected channel.  Add an arrow that points from the other circuits to the target menu.  In the documentation area, add the text, "When multiple circuits target the same channel, their output adds together, and is capped at +1, or -1."

    Why is this useful?  I'm designing a 4 wheel servo steering vehicle, and will use multiple circuits targeting the same servo channel to switch between normal steering and crab side steering modes.

    • 137 posts
    November 10, 2018 12:25 PM CET

    At first, I'm working on a tool for the PD where you can alter a profile's aspect ratio (and save it as a copy). After that, I'll going to do this fix for the S9+ and so on.

    I hope everything will be released on the first days of the next week.

    Thanks for your patience.

    • 1 posts
    November 10, 2018 10:27 AM CET

    I got my sbrick and spent a few hours trying to get it to work through my phone (Samsung s9+) before realising the screen ratio issue. Are there plans to fix it?

     

    I've managed to get it to work through an old tablet but would prefer to use my phone.

    • 26 posts
    November 6, 2018 6:40 AM CET

    I'd like to target a given channel with two separate circuits acting on input from two separate controls.  For example I'd like to move the left joystick in the x direction, and have it move a servo.  Then I'd like to move the right joystick in the x direction and have it move the same servo the opposite direction.  Currently, this doesn't work.  I set up two circuits. One is Input: Left Joystick - X, Logic: Linear, Target: "LF Servo".  The "LF Servo" channel is set up in a slider.  The Second circuit is is Input: Right Joystick - X, Logic: Linear, Target: "LF Servo".  Here's what happens.  Nothing works unless I assign the right and left joystick - x to an SBRICK port, wasting two ports.  Then, only the circuit I created last affects the "LF Servo" channel.  Turning off the second circuit allows the first circuit to work.

    Is there something I can do to make this work?  If not, please change the circuit behavior programming so that if two different circuits target the same channel, then their output is summed, and capped at +1 or -1.  Please also let a control be active for circuit input when not assigned a port.

    • 22 posts
    November 2, 2018 2:27 PM CET

    I have an iPhone XS which is 19.5:9, and I have also found that there is no selection for this ratio in designer.

    As previously pointed out, in profile designer, choosing 18.5:9 actually creates a 19.5:9 profile?

    But then there is no way of filtering these back again other than by choosing ALL.

    Please fix the profile ratios in designer.

    • 1 posts
    November 2, 2018 1:30 PM CET

    Hello,

    Got galaxy s8, app says my aspect is 18:5_9. When I create profile in designer and choose 18:5.9 it still creates profile with 19:5.9 aspect ratio. Even your own in designer filter does not show any profiles under 18:5.9. Could you fix that? Would not it be easier for all to be able to select aspect ratio in mobile app too? How can I select my aspect manually. With aspect 18:5_9 I get no public profiles

    Regards

    Martin

    • 137 posts
    October 4, 2018 1:01 PM CEST
    Karun Gupta said:

    Hello sir, a newbie here from India!

    I made a profile to control 2 trains at a time using the same controller. 

    The profile can be found at: https://designer.sbrick.com/?profile=39138

    Can you kindly let me know how I can get the profile to use on my sbrick iphone app? Not able to figure that out. Its not showing under private profiles either on my sbrick app. I am using am iphone X running ios12.

    Hey there!

    That's because the iPhone X got a weirder aspect ratio, it's got 18,5:9. As I can see, you setted your profile to 16:9.

    Sadly, once you created the profile, you can't change this parameter, since it's playing a main role in the width and height calculations.

    Please note the hints when you're creating a new profile. You can see the popular device names under every aspect ratio. When you're creating a profile with the proper aspect ratio, it should appear in the SBrick app too.

    • 1 posts
    September 28, 2018 5:21 PM CEST

    Hello sir, a newbie here from India!

    I made a profile to control 2 trains at a time using the same controller. 

    The profile can be found at: https://designer.sbrick.com/?profile=39138

    Can you kindly let me know how I can get the profile to use on my sbrick iphone app? Not able to figure that out. Its not showing under private profiles either on my sbrick app. I am using am iphone X running ios12.

    • 7 posts
    July 7, 2018 1:34 AM CEST

    I accidentally deleted the background from a profile and not able to add it back. Is there a way to add a "Background" to an already existing profile. I have replaced backgrounds but in this case there is no background object in the "Controls". Profile is https://designer.sbrick.com/?profile=29072'

    • 7 posts
    July 7, 2018 1:22 AM CEST
    Zsolt Szrapkó said:
    Hambone said:

    Does anyone know what the maximum number of objects (pictures/controls/sequences) allowed for a profile? I seem to have hit the maximum. I add a picture and a control and save it, but when I edit the profile from the home page the picture is gone and control attributes are not there. The maximum seems to be around 40?  I have sequences each with multiple channels plus two train engine controls (see picture below). Given that there is a maximum is there a way around it?

    Hi Hambone!

    Actually we doesn't setted a maximum quantity for the control elements nor to the channels – it's seems like a bug. If you're sends me a profile ID, i will check it out.

            Hi Zsolt,

            Profile https://designer.sbrick.com/?profile=33755 is an example where objects disappear. Sequence #14

            had channels defined , the profile was saved, the home page  was clicked and the same profile was again                edited. Sequence #14 is now missing the added channels. At this point even if a picture is added to the                   profile and saved going back to the home page and editing the profile the picture is no longer there. 

    • 3 posts
    June 26, 2018 6:50 AM CEST

    Hi Zsolt! It is Nokia 7 plus. I can set profiles only with ratio 16:9


    This post was edited by surizs at June 26, 2018 7:15 AM CEST
    • 137 posts
    June 25, 2018 9:57 PM CEST
    surizs said:

    Could you support 18:9 ratio?

    We're supporting it with the 18.5:9.

    But there can be differences between devices, which leads to the question: What's is your device? :)

    • 3 posts
    June 24, 2018 8:45 AM CEST

    Could you support 18:9 ratio?

    • 8 posts
    June 18, 2018 6:27 AM CEST

    Please add a "Play Sound" control to the profile designer. The sound would play on the device running the SBrick app. This seems like a simple capability to add to the profile designer.

    The benefit it would give is that the device running the app could also be connected to an external Bluetooth speaker, which is where the sound would actually be played. Therefore a (mini) Bluetooth speaker could be placed in a model and play the appropriate sound(s) selected from within the SBrick app.

    Adding this capability to the Profile Designer would provide a simple means to enhance SBrick's functionality without requiring any change to the SBrick hardware.

    Regards,

    David

    • 7 posts
    May 10, 2018 6:04 AM CEST

    Hi Zsolt,

    Thanks for looking at this issue.

    Profile (https://designer.sbrick.com/?profile=33755). Browser is Firefox. 

    Sequence of events:

    1. Edited profile with a new sequence #13 containing two events.

    2. Saved profile to home page (it is the first profile on home page).

    3. Edited the profile. The name for sequence #13 is missing as well as the two events.

    Screen shots are below for above events.

    1. Edited profile with a new sequence #13 containing two events:

    2. Saved profile to home page (it is the first profile):

    3. Edited the profile. The name for sequence #13 is missing as well as the two events:

    https://screenshotscdn.firefoxusercontent.com/images/5969aac5-f160-4772-8b23-1d72bc8f61e7.png

    • 137 posts
    May 7, 2018 4:22 PM CEST
    Hambone said:

    Does anyone know what the maximum number of objects (pictures/controls/sequences) allowed for a profile? I seem to have hit the maximum. I add a picture and a control and save it, but when I edit the profile from the home page the picture is gone and control attributes are not there. The maximum seems to be around 40?  I have sequences each with multiple channels plus two train engine controls (see picture below). Given that there is a maximum is there a way around it?

    Hi Hambone!

    Actually we doesn't setted a maximum quantity for the control elements nor to the channels – it's seems like a bug. If you're sends me a profile ID, i will check it out.

    • 7 posts
    May 5, 2018 12:43 AM CEST

    Does anyone know what the maximum number of objects (pictures/controls/sequences) allowed for a profile? I seem to have hit the maximum. I add a picture and a control and save it, but when I edit the profile from the home page the picture is gone and control attributes are not there. The maximum seems to be around 40?  I have sequences each with multiple channels plus two train engine controls (see picture below). Given that there is a maximum is there a way around it?

    • 1 posts
    April 4, 2018 7:32 PM CEST

    Hello,

    I've got a problem with the profile designer.

    in one of my profiles, unfortunately very complicated with 12 channels in use, the point "backround" is deleted  in the menue "controls" .

    Now the backround i black and that is not good for using.

    Has anybody got an idea how to fix this error?

     

    Thanks from Kiel

    Rainer

    • 10 posts
    March 30, 2018 11:46 AM CEST
    Hi people if i want to edit stuf in the profile designer on my iPad i find one isseu if i click and hold one of the profiles i get the screen delete edit etc
    But somehow in the sequence editor this aint working so i can not add a extra node to make the sequence
    • 7 posts
    February 27, 2018 8:27 AM CET

    Hi,

    Peter, thanks for replying to my last post. 

    I have successfully used a circuit object and a motion sensor to trigger motorized train track switches that are setup in a sequence object. Is it possible to trigger different sequence objects depending on how many times the train passes the motion sensor? For example,  on odd numbered passes trigger the sequence for switch 1 and for even number of passes trigger another sequence for switch 2?.

    Thanks

    • 33 posts
    February 20, 2018 2:45 PM CET
    Hi,
    Switch to other browser than IE. I had the same issue earlier. FF or Chrome would equally be good.
    Peter Subert (Brickpower)
    • 7 posts
    February 20, 2018 9:26 AM CET

    Not able to delete two circuit object handlers from a profile. Able to delete the objects from the profile initially, but after saving the profile, then going back to the Home page and editing the same profile, the objects are back on the profile layout. 

     

     

     

    • 1 posts
    February 13, 2018 8:35 PM CET

    Can you please publish the Claas Xerion, Mobile Crane MK II and Porsche offical public profiles in 18.5:9 ratio as you did for the Unimog profile? This would be a great added value for the community as the copy into other ratio is still not available in Profile Designer.

    • 1 posts
    January 31, 2018 3:01 AM CET

    Hello, I can't change the input channel on the circuit editor. I need to do this so I can use 2 movement sensors. Anyone has a solution please ?