Forums » Support

Back To Topics

Profile Designer

    • 178 posts
    September 7, 2021 2:38 PM CEST

    Hey Reckless_glitch,

    could you please try to import thi file?

    https://social.sbrick.com/public/profile-62659-black-batty-2.0.zip

    I just did an export with my browser and as far as I can tell there's nothing wrong with the archive. It imports correctly.

    If it import correctly for you also then the export fuction is broken. If the import still doesn't work, then the import is buggy.

    Thanks,

    Tamas

    • 323 posts
    September 7, 2021 1:23 PM CEST
    Reckless_glitch said:

    BUG on Importing Profiles:

    Since i cannot make my profile (62659) public, but I need to give it to other people (I sell mocs on rebrickable, recomending the sbrick) my only way right now is by exporting zip files.
    Yet no matter how I export them (from the home screen or from the profile itself) when reimporting them I get:

    Error loading profile: Could not load image for image: file://profile/controls/image/background/3532bae9065f843ac9ac42190025ed352ce75a37.png. Network issue, or profile imported incorrectly. Try again later, or try deleting and re-importing the profile.

    It was working with one export I had made before but even that does not import anymore.

    Can you fix that, please, I have several people waiting for that very profile.

     

    Hi,

     

    Thanks for reporting it, we fixing the issue.

     

    • 16 posts
    September 3, 2021 7:14 PM CEST

    BUG on Importing Profiles:

    Since i cannot make my profile (62659) public, but I need to give it to other people (I sell mocs on rebrickable, recomending the sbrick) my only way right now is by exporting zip files.
    Yet no matter how I export them (from the home screen or from the profile itself) when reimporting them I get:

    Error loading profile: Could not load image for image: file://profile/controls/image/background/3532bae9065f843ac9ac42190025ed352ce75a37.png. Network issue, or profile imported incorrectly. Try again later, or try deleting and re-importing the profile.

    It was working with one export I had made before but even that does not import anymore.

    Can you fix that, please, I have several people waiting for that very profile.

    • 16 posts
    September 3, 2021 7:03 PM CEST

    Hi, let me ask again,

    Is it possible to dampen the output of a channel somehow? Especially if I quickly change the input, the output should change slowly.

    Usecase: I have some 3.5 kg Batmobile here, driven by 2x PF L-Motors and I even need to use the small 12 tooth gears.
    When it is driving at full speed and I reverse speed quickly (which may happen, as soon as I use a game controller), it puts enormous stress on all parts involved. (It broke off half of the teeth of a gear the other day, never seen that before) I'd like to reduce that stress by prohibiting speed reversals somehow.
    Buwizz and Mould King (I think) have that implemented because it is usefull for anything with a high inertia.
    Any ideas?

    • 323 posts
    August 31, 2021 1:00 PM CEST
    Hi Todd,
    Are you using the SBrick app? This feature what you need only supported by SBrick Pro.
    Todd said:

    Hi Guys

    Newbie here.  I have a total of 10 lego trains controlled by SBrick(s) and have built a single app to control them all.

    However, if they are not all switched on, the App does not work.  How do I get around this?

     

    Any help would be much appreciated.

    Thanks

    Todd

     

    • 2 posts
    August 25, 2021 8:23 AM CEST

    Hi Guys

    Newbie here.  I have a total of 10 lego trains controlled by SBrick(s) and have built a single app to control them all.

    However, if they are not all switched on, the App does not work.  How do I get around this?

     

    Any help would be much appreciated.

    Thanks

    Todd

    • 16 posts
    August 3, 2021 5:59 PM CEST

    Hi,

    Is it possible to dampen the output of a channel domehow? Especially if I quickly change the input, the output slowly changes.

    Usecase: I have some 3.5 kg Batmobile here driven by 2x PF L-Motors and I even need to use the small 12 tooth gears.
    When it is driving at full speed and I reverse speed (which happens as soon as I use a game controller), it puts enormous stress on all parts involved. (It broke off half of the teeth of a gear (none LEGO) the other day, never seen that before) I'd like to reduce that stress by prohibiting speed reversals somehow.
    Buwizz and Mould King (I think) have that implemented because it is usefull for anything with a high inertia.
    Any ideas?

    • 323 posts
    November 5, 2020 12:31 PM CET
    Jens Heyer said:
    Hi, is it possible to create a flashlight with the profiledesigner? Or brakelights like in the 42030 profile?

     

    you can try the circuits for that or the SBrick Pro which enables programming.

  • November 4, 2020 10:10 AM CET

    Trying to create a new (private) profile.

    However, I cannot add anything to the new profile (I already have to use the 'Create new profile' button twice before it actually give me the new blank profile screen).

    I can't add no background, no slider, no circuit, no nothing.

    I kinda can add a widget (or at least the widget kinda appears in the profile), but I can't modify any settings for this widget.

    I tried Chrome, FireFox, Internet Explorer, Edge, they all have the same issue.

     

    Edit:
    For now I copied an existing profile which had the controls I need.
    In this copied profile I am able to add controls; so the issue seems to be with creating a profile...


    This post was edited by Corné Van Den Bosch at November 4, 2020 10:49 AM CET
    • 323 posts
    October 22, 2020 12:18 PM CEST
    bernard gress said:

    Is does not seem possible to make my SBrick profiles (on https://designer.sbrick.com/?profile=51620) public. It says "Creation of public profiles not allowed in the current beta phase."

    When will this be possible?

    How can anyone publish any Lego or Technic design based on SBrick if they can't publish their profiles?

     

     

    Hi, do you create and shell designs? Please contact me via email at info@sbrick.com, then we discuss this topic towards.

    • 1 posts
    September 10, 2020 5:11 PM CEST

    Is does not seem possible to make my SBrick profiles (on https://designer.sbrick.com/?profile=51620) public. It says "Creation of public profiles not allowed in the current beta phase."

    When will this be possible?

    How can anyone publish any Lego or Technic design based on SBrick if they can't publish their profiles?


    This post was edited by bernard gress at September 10, 2020 8:56 PM CEST
    • 2 posts
    July 10, 2020 5:06 PM CEST
    Lénárd Pásztor said:
    I think the servo motor can't do this. The servo has 14 fixed position only. Have you checked the servo, is it on the center? 

    Yes, the servo is centered. 

    • 323 posts
    July 10, 2020 11:08 AM CEST
    Harrison said:

    hey. does anyone know how to have it so that when you press a button, it sends that to 2 ports so that they blink on and off???

    Hi,

     

    You can create a sequence for that in the profile designer.

    • 323 posts
    July 10, 2020 11:08 AM CEST
    Ben Zhang said:

    Hi, I was having a problem with my car steering. It always goes toward the right a little bit. I checked my lego steering gear, it is centered, the wheel is centered too. So I was trying to see if there's any offset setting in Sbrick I can use to offset my steering, but unfortunately I couldn't find any. The only hope I found is in the profile design where I can set the slide Zero point (or reset point) to a certain value not at center so my car will drive straight, that actually works great but the problem is the value is not refined enough, I can only go 0.1 the minimum, where I need is maybe 0.01 step. So now my car actually goes toward the left a little bit after i built my own profile. Is it possible to set the step to 0.01 instead of 0.1? I think it's limited to the step control chip inside Sbrick. thx

     

    I think the servo motor can't do this. The servo has 14 fixed position only. Have you checked the servo, is it on the center? 

    • 1 posts
    July 9, 2020 2:23 AM CEST

    hey. does anyone know how to have it so that when you press a button, it sends that to 2 ports so that they blink on and off???

    • 2 posts
    July 4, 2020 9:31 PM CEST

    Hi, I was having a problem with my car steering. It always goes toward the right a little bit. I checked my lego steering gear, it is centered, the wheel is centered too. So I was trying to see if there's any offset setting in Sbrick I can use to offset my steering, but unfortunately I couldn't find any. The only hope I found is in the profile design where I can set the slide Zero point (or reset point) to a certain value not at center so my car will drive straight, that actually works great but the problem is the value is not refined enough, I can only go 0.1 the minimum, where I need is maybe 0.01 step. So now my car actually goes toward the left a little bit after i built my own profile. Is it possible to set the step to 0.01 instead of 0.1? I think it's limited to the step control chip inside Sbrick. thx

    • 38 posts
    July 2, 2020 10:27 PM CEST
    Great for all of us that everyone is doing his job!
    "social.sbrick.comprofile" is repaired and does not appear anymore. It happened as I clicked at the picture of me in the right upside corner. Now I am redirected from profile-designer to social.sbrick.com as before. Thanks to the supporter.
    Unfortunately my android tablet is broken and I am trying to install SBrick app at the moment which is expectedly difficult as I still use android 4.4.x  confused.png
    Lénárd Pásztor said:
    Lothar Weigl said:
    What is wrong with this link?: "Server-IP-Adresse von social.sbrick.comprofile"
    Where is the link? social.sbrick.comprofile not seems a valid link.
    How can I add a close button?
    the close button is always on the profile, you can't remove or add another.
    Is anyone still alive out there or everybody on the way to the hospital?
    We are alive, fortunately. :)

    Lothar Weigl said:

    UPDATE:  I cannot chance the background? The big "+" in the left down corner is not working correctly? Some buttons have the same description?

    Please, remember we pay a lot of money for SBrick and we expect you to do your job properly and not always give us junk code to test it for you!

    Lothar Weigl said:

    Tamás Fábián said:

    Hello everyone,

    I've just updated the Profile Designer. The update fixed a bug that caused the lines between the nodes of a sequence not to be drawn correctly. We tested the new version with Chrome, Firefox and Edge, and the sequence editor behaves much better now.

    You can try to edit the sequences in your profiles again.

    I'm sorry for the inconvenience.

    Good Job, finally! 

    No reason to complain at the moment. Please, stay away from Profile-Designer from now on! (Remember the basic law of IT: "Never touch a running system.")

     

     

    • 323 posts
    July 1, 2020 12:28 PM CEST
    Lothar Weigl said:
    What is wrong with this link?: "Server-IP-Adresse von social.sbrick.comprofile"
    Where is the link? social.sbrick.comprofile not seems a valid link.
    How can I add a close button?
    the close button is always on the profile, you can't remove or add another.
    Is anyone still alive out there or everybody on the way to the hospital?
    We are alive, fortunately. :)

    Lothar Weigl said:

    UPDATE:  I cannot chance the background? The big "+" in the left down corner is not working correctly? Some buttons have the same description?

    Please, remember we pay a lot of money for SBrick and we expect you to do your job properly and not always give us junk code to test it for you!

    Lothar Weigl said:

    Tamás Fábián said:

    Hello everyone,

    I've just updated the Profile Designer. The update fixed a bug that caused the lines between the nodes of a sequence not to be drawn correctly. We tested the new version with Chrome, Firefox and Edge, and the sequence editor behaves much better now.

    You can try to edit the sequences in your profiles again.

    I'm sorry for the inconvenience.

    Good Job, finally! 

    No reason to complain at the moment. Please, stay away from Profile-Designer from now on! (Remember the basic law of IT: "Never touch a running system.")

     

    • 38 posts
    June 11, 2020 10:37 PM CEST
    What is wrong with this link?: "Server-IP-Adresse von social.sbrick.comprofile"
    How can I add a close button?
    Is anyone still alive out there or everybody on the way to the hospital?
    Lothar Weigl said:
    UPDATE:  I cannot chance the background? The big "+" in the left down corner is not working correctly? Some buttons have the same description?
    Please, remember we pay a lot of money for SBrick and we expect you to do your job properly and not always give us junk code to test it for you!
    Lothar Weigl said:
    Tamás Fábián said:

    Hello everyone,

    I've just updated the Profile Designer. The update fixed a bug that caused the lines between the nodes of a sequence not to be drawn correctly. We tested the new version with Chrome, Firefox and Edge, and the sequence editor behaves much better now.

    You can try to edit the sequences in your profiles again.

    I'm sorry for the inconvenience.

    Good Job, finally! 

    No reason to complain at the moment. Please, stay away from Profile-Designer from now on! (Remember the basic law of IT: "Never touch a running system.")

     

     

    • 38 posts
    June 9, 2020 10:05 PM CEST
    UPDATE:  I cannot chance the background? The big "+" in the left down corner is not working correctly? Some buttons have the same description?
    Please, remember we pay a lot of money for SBrick and we expect you to do your job properly and not always give us junk code to test it for you!
    Lothar Weigl said:
    Tamás Fábián said:

    Hello everyone,

    I've just updated the Profile Designer. The update fixed a bug that caused the lines between the nodes of a sequence not to be drawn correctly. We tested the new version with Chrome, Firefox and Edge, and the sequence editor behaves much better now.

    You can try to edit the sequences in your profiles again.

    I'm sorry for the inconvenience.

    Good Job, finally! 

    No reason to complain at the moment. Please, stay away from Profile-Designer from now on! (Remember the basic law of IT: "Never touch a running system.")

     


    This post was edited by Lothar Weigl at June 9, 2020 10:06 PM CEST
    • 38 posts
    June 8, 2020 11:47 PM CEST
    Tamás Fábián said:

    Hello everyone,

    I've just updated the Profile Designer. The update fixed a bug that caused the lines between the nodes of a sequence not to be drawn correctly. We tested the new version with Chrome, Firefox and Edge, and the sequence editor behaves much better now.

    You can try to edit the sequences in your profiles again.

    I'm sorry for the inconvenience.

    Good Job, finally! 

    No reason to complain at the moment. Please, stay away from Profile-Designer from now on! (Remember the basic law of IT: "Never touch a running system.")

    • 178 posts
    May 30, 2020 4:27 PM CEST

    Hello everyone,

    I've just updated the Profile Designer. The update fixed a bug that caused the lines between the nodes of a sequence not to be drawn correctly. We tested the new version with Chrome, Firefox and Edge, and the sequence editor behaves much better now.

    You can try to edit the sequences in your profiles again.

    I'm sorry for the inconvenience.

    • 323 posts
    May 28, 2020 11:44 AM CEST
    Lothar Weigl said:
    Sry, CHIEF! 
    The problem continous. :-(((
    Lénárd Pásztor said:

    Hi All,

     

    Now the sequence issue is fixed.

     

     

    Hi Lotar, If you create a new profile and create new sequences still not work?

    • 38 posts
    May 27, 2020 10:14 PM CEST
    Sry, CHIEF! 
    The problem continous. :-(((
    Lénárd Pásztor said:

    Hi All,

     

    Now the sequence issue is fixed.

     

    • 38 posts
    May 26, 2020 9:27 PM CEST
    GREAT NEWS! Thank you. 
    Unfortunately, I destroyed at least one profile in a rage. :-(((
    Lénárd Pásztor said:

    Hi All,

     

    Now the sequence issue is fixed.