Forums » Support

Back To Topics

Profile Designer

    • 33 posts
    February 27, 2016 7:37 PM CET

    Hi,

    Can you please let me know, how to fix the following issue:

    I have created a 16:9 ratio new profile in the designer (compatible ratio with an iPhone 4S).

    I have saved the profile as "private" (as the public option is not available yet).

    I have opened the app on the phone and I wanted to pick the recently created profile, but it did not show up anywhere: neither in the "All", nor in the "Favorites" menu.

    Cna you tell me, how much time does it take to populate a profile across the whole system?

     

    Btw.: how cna you classify a profile as "Favourite"?

    Thanks,

    Peter


    This post was edited by Peter Subert at February 27, 2016 7:40 PM CET
    • 310 posts
    February 23, 2016 1:28 PM CET

    [blockquote]Malcolm Plumb said: [blockquote]Balint Mezei said:

    [blockquote]Malcolm Plumb said: Total Confusion! Can some one explain how to actually use the Profiles in the designer, either created and private or the public ones shown? How do I actually get these 'images'' to do anything? Some very basic help required please as I must be missing something.[/blockquote]

     

    Hello, 

     

    Here you can find some information, 

    https://social.sbrick.com/wiki/view/pageId/10/slug/user-guide-for-profile-designer

    And a tutorial is also appear when you start a new profile. 

    If you still have any question, after visit these pages, please let us know, and send a mail, on info@sbrick.com

    Best regards, 
    Balint Mezei - SBrick Team 

    [/blockquote] Unable to send an email for further help to this email address. Classified as spam and error message returned. Please advise on how to contact you directly. [/blockquote]

     

    All right, try this one, please, balint.mezei@sbrick.com 

    • 3 posts
    February 23, 2016 12:17 PM CET
    [blockquote]Balint Mezei said:

    [blockquote]Malcolm Plumb said: Total Confusion! Can some one explain how to actually use the Profiles in the designer, either created and private or the public ones shown? How do I actually get these 'images'' to do anything? Some very basic help required please as I must be missing something.[/blockquote]

     

    Hello, 

     

    Here you can find some information, 

    https://social.sbrick.com/wiki/view/pageId/10/slug/user-guide-for-profile-designer

    And a tutorial is also appear when you start a new profile. 

    If you still have any question, after visit these pages, please let us know, and send a mail, on info@sbrick.com

    Best regards, 
    Balint Mezei - SBrick Team 

    [/blockquote] Unable to send an email for further help to this email address. Classified as spam and error message returned. Please advise on how to contact you directly.
    • 3 posts
    February 23, 2016 11:47 AM CET
    I managed to follow the instructions with out a problem and I think a profile has been created correctly .
    This was pretty straight forward.

    It's how I actually do anything with the profile that is stuck here that is the problem.
    I seem to have three profiles that are all the same when designer is opened but can't do anything with them.
    Couldn't find any information either..
    This post was edited by Malcolm Plumb at February 23, 2016 11:48 AM CET
    • 310 posts
    February 23, 2016 11:25 AM CET

    [blockquote]Malcolm Plumb said: Total Confusion! Can some one explain how to actually use the Profiles in the designer, either created and private or the public ones shown? How do I actually get these 'images'' to do anything? Some very basic help required please as I must be missing something.[/blockquote]

     

    Hello, 

     

    Here you can find some information, 

    https://social.sbrick.com/wiki/view/pageId/10/slug/user-guide-for-profile-designer

    And a tutorial is also appear when you start a new profile. 

    If you still have any question, after visit these pages, please let us know, and send a mail, on info@sbrick.com

    Best regards, 
    Balint Mezei - SBrick Team 

    • 3 posts
    February 23, 2016 12:26 AM CET
    Total Confusion!

    Can some one explain how to actually use the Profiles in the designer, either created and private or the public ones shown?
    How do I actually get these 'images'' to do anything?

    Some very basic help required please as I must be missing something.
    • 310 posts
    February 15, 2016 8:12 PM CET

    [blockquote]Johan vd Pluijm said:

    [blockquote]Denis H said:

    Profile designer is working, but the page is very SLOW (or the server)...i have the message time to time that the page can't load (prompt with the wait or close window)...if i click wait eventually the page load..... Once i enter in the design part i made a profile and try to save, but the orange SAVING... message stay forever...the profile don't save, because i press the "Home" button and says all my work will be lost, because is not saved.

    I'm using Google Chrome.......testing with Internet Explorer and is worst.

     

    Screenshot:

    https://social.sbrick.com/albums/photo/view/album_id/170/photo_id/585

    https://social.sbrick.com/albums/photo/view/album_id/170/photo_id/586

     

     

     

    [/blockquote]

    It isnt very fast indeed, but how is your own internet connection?

    [/blockquote]

     

    Others have not reported any problems like this before. For us, it works. 
    If you still have this problem, please contact us on, info@sbrick.com, and we will try to help you. 

     

    • 9 posts
    February 15, 2016 10:59 AM CET

    [blockquote]Denis H said:

    Profile designer is working, but the page is very SLOW (or the server)...i have the message time to time that the page can't load (prompt with the wait or close window)...if i click wait eventually the page load..... Once i enter in the design part i made a profile and try to save, but the orange SAVING... message stay forever...the profile don't save, because i press the "Home" button and says all my work will be lost, because is not saved.

    I'm using Google Chrome.......testing with Internet Explorer and is worst.

     

    Screenshot:

    https://social.sbrick.com/albums/photo/view/album_id/170/photo_id/585

    https://social.sbrick.com/albums/photo/view/album_id/170/photo_id/586

     

     

     

    [/blockquote]

    It isnt very fast indeed, but how is your own internet connection?

    • 310 posts
    February 15, 2016 10:40 AM CET

    [blockquote]Peter Subert said:

    Hello guys,

    How can I share and make my profiles available for the public? The new designer still disables the "Public" button and it says, it is not possible to share profiles in the beta version. The bottom of the page displays though, it is the Version 1.0.9final.

    May I have missed something?

    Thanks,

    Peter

    [/blockquote]

     

     

    Hello Peter,

    No, you haven't missed anything. Unfortunately this function is not available yet. It is under testing. 
    We will give you more information as soon as possible. 

    Best regards, 

    • 33 posts
    February 15, 2016 5:53 AM CET

    Hello guys,

    How can I share and make my profiles available for the public? The new designer still disables the "Public" button and it says, it is not possible to share profiles in the beta version. The bottom of the page displays though, it is the Version 1.0.9final.

    May I have missed something?

    Thanks,

    Peter

  • February 14, 2016 5:17 PM CET

    [blockquote]Balint Mezei said:

    [/blockquote]

    Hi! 

    The sequence feature is at the moment available only on android operating system. Our developers working on the IOS version.
    Hopefully it will be ready in a couple of weeks.

    [/blockquote]

     

    Hi Balint,

    Thank you for your reply, now I know. I'm looking forward for the update :-)

    • 310 posts
    February 14, 2016 2:48 PM CET

    [blockquote]Hendrikjan Krocké said:

    Hey Guys,

    My S-brick is working fine on IOS but when I use a sequence button in the Profile Designer the App crashes when I try to start the profile.

    Does anyone have an idea why?

    Thanks !

    [/blockquote]

    Hi! 

    The sequence feature is at the moment available only on android operating system. Our developers working on the IOS version.
    Hopefully it will be ready in a couple of weeks.

  • February 13, 2016 9:05 PM CET

    Hey Guys,

    My S-brick is working fine on IOS but when I use a sequence button in the Profile Designer the App crashes when I try to start the profile.

    Does anyone have an idea why?

    Thanks !


    This post was edited by Hendrikjan Krocké at February 13, 2016 9:28 PM CET
    • 143 posts
    February 5, 2016 2:00 PM CET

    [blockquote]Eduard Surovin said:

    [blockquote]Zsolt Szrapkó said:

    Hey everyone,

    A new minor version is out, with lot of bugfixes, and some features too.

    ...

    [/blockquote]

    Hi, thank you!

    I am testing it out now,

    Bug:

    * Changing Clinometer control name set channel names to same as control name. Expected - follow scheme "$name$ pitch" / "$name$ roll" in the same manner as Joystick control does for X and Y.

    * Sequence Repeat not visible in "Numeric" tab. Expected: when repeat is On 1 in numeric, when Off 0 in numeric, as other controls.

    Suggestion:

    * Add SHIFT + Arrow keys to rotate controls. E.g. Shirt + Right add 1 to rotation, Shift + Left sub 1 from rotation

    [/blockquote]

    The bugs are fixed. And your suggestion is an excelent solution, I going to implement it. :)

    • 33 posts
    February 4, 2016 4:27 AM CET

    Hey Guys,

    This new profile designer is Da bomb!

    I am eager to re-create some of my old profiles and share the news with my customer base. Kudos to the team for the repetitive functionality and for the "klinometer".

    You are all a big bag of chips:-)

    Peter

     

    • 16 posts
    February 3, 2016 7:27 PM CET

    [blockquote]Zsolt Szrapkó said:

    Hey everyone,

    A new minor version is out, with lot of bugfixes, and some features too.

    ...

    [/blockquote]

    Hi, thank you!

    I am testing it out now,

    Bug:

    * Changing Clinometer control name set channel names to same as control name. Expected - follow scheme "$name$ pitch" / "$name$ roll" in the same manner as Joystick control does for X and Y.

    * Sequence Repeat not visible in "Numeric" tab. Expected: when repeat is On 1 in numeric, when Off 0 in numeric, as other controls.

    Suggestion:

    * Add SHIFT + Arrow keys to rotate controls. E.g. Shirt + Right add 1 to rotation, Shift + Left sub 1 from rotation

    • 3 posts
    February 3, 2016 2:34 PM CET

    That's interesting idea. I have to try it. But in my opinion, simple activation of sequence button should energize the channel in chosen direction. 

    • 1 posts
    February 3, 2016 12:57 PM CET

    Hi, I had the same problem with sequence button. I solved it by adding normal button. 1) Need press normal button (for example, LED turn on), then 2) press sequence button (my LED start to doing sequence). After there steps you can press again normal button (i didn't see any effect) and when you need to stop sequence I just press sequence button.  I think that sequence work in cases if you gave energy to the channel before.

     

    P.S. I'm using SBrick v2.0 Update 1 on android 5.0.1 and SBrick firmware v4.8.

    I have other problem - I can't to connect more than 4 Sbrick to one profile (I can to add for example 5 Sbrick and set all ports, but when I try to start playng, application can find only 4 Sbrick (one disconected)

    • 3 posts
    February 3, 2016 11:31 AM CET

    My profile number is 7032. There are two sequence buttons. one with value 1 for 1.5s, second with value -1 for 1.5s. What is different between profile version? Mine is 1.9, but other profiles have numbers 2.0 and up. 

     

    • 143 posts
    February 2, 2016 10:22 PM CET

    [blockquote]maciek k said:

    Hi,

    I try to create a simple sequence : full speed at chanel 1 for 2s (to control gearbox). but when I create a sequence button in Profiel Designer and put my data on it (level 1, time 2s), I can't achieve requested result. I'm using SBrick v2.0 Update 1 on android 5.0.2 and SBrick firmware v4.8. 

    Thx for any help

    [/blockquote]

    Please post your profile's ID, and after that I can see how do you try to achive what you want.

    • 3 posts
    February 2, 2016 9:29 PM CET

    Hi,

    I try to create a simple sequence : full speed at chanel 1 for 2s (to control gearbox). but when I create a sequence button in Profiel Designer and put my data on it (level 1, time 2s), I can't achieve requested result. I'm using SBrick v2.0 Update 1 on android 5.0.2 and SBrick firmware v4.8. 

    Thx for any help

    • 143 posts
    February 2, 2016 5:12 PM CET

    Hey everyone,

    A new minor version is out, with lot of bugfixes, and some features too.

    Fixes:
    - Fixed the bug, where the controls are being replaced with each other after a control element deletion. That was the problem on Eduard profile's too. Sadly, these profiles are broken, and they must be rebuilt to work properly.
    - There was an error when the TAB key pressed.
    - Resource change on the clinometer and the sequence control now working.

    Features:
    - You can now use some keyboard buttons to work with if you have a selected element on the workspace, and the settings panel is closed:
      ARROW keys: you can move the selected control over the workspace
      TAB key: selects the next control on the workspace.
      ENTER key: opens the selected controls settings panel
      ESC key: it closes the control settings panel
      BACKSPACE / DELETE key: removes the selected control element.

    It's not a new feature, it was available in the previous version too, but I forgot to mention. Since the 1.0final, you can see all the public profiles if you select the option from the dropdown menu. You can't modify these profiles, but you can make a copy for yourself.


    This post was edited by Zsolt Szrapkó at February 2, 2016 5:12 PM CET
    • 16 posts
    January 31, 2016 9:27 PM CET
    [blockquote]Paweł Kulfan said:

    Just one more small thing: In old version of app, when you started it without bluetooth enabled, it was possible to turn it wihout exiting the app. Now, you need to go to the bluetooth settings and enable it manually. It would be more convenient, if this way was possible in the new version :)

    [/blockquote] Hello, are you sure about this? I use 2.0.1, but I remember same in 2.0.0 When I start the app with bluetooth off it stops loading with words Please enable the bluetooth! and I pull down a "shelf" from the top of the screen, where I have BT fast switch. I turn it on, and the app continues to load. The app hangs with black screen if I turn BT off during usage, but that's not top priority imo. I have Sams Note 3 with Sams "launcher" or what, so may be it depends on "launcher" and " homescreen" or whatever it is in Android.
    • 3 posts
    January 31, 2016 1:27 PM CET

    Just one more small thing: In old version of app, when you started it without bluetooth enabled, it was possible to turn it wihout exiting the app. Now, you need to go to the bluetooth settings and enable it manually. It would be more convenient, if this way was possible in the new version :)

    • 99 posts
    January 29, 2016 1:05 AM CET

    Just a few words about this new version of the Profile Designer : great job, guys :)

    Didn't try the gyro yet, but I sure will test it asap!